•   
  • 1
  • 134
  • 135
  • 136(current)
  • 137
  • 138
  • 146
  •   
  Thread Closed
OpenELEC Testbuilds for RaspberryPi (Kodi 17.0)
(2016-04-05, 08:02)Milhouse Wrote:
(2016-04-04, 21:40)niwa2 Wrote: And another thing I noticed with the updated confluence skin:
The transparencys now work again (thank you guys for that by the way). But they work a little bit too well. The message boxes that you acknowledge with an OK-Button are fully transparent now. You can only see the text and the button. This should also be in the logs: when the first movie did not play I got a transparent message that at least one file could not be played.

Can you provide a screenshot, or a way to reproduce? The yes/no/cancel dialogs I've seen are all appearing correctly in Confluence 3.0.7 with #0404. Make sure you've updated to Confluence 3.0.7 as 3.0.6 had broken/missing textures.

Yesterday evening I could only see 3.0.6 in the default repo.
I switched to this one which fixed the black areas on the home screen. And all the other visual anomalies except for the message boxes.
The confirmation message when I switched to the confluence skin was already completely transparent, with only text and the yes and no buttons visible.
@popcornmix
sorry for the noise again, I found the guilty,
it was libarmmem.so (bavison/arm-mem) which slipped in from pi2/pi1 builds,
removing ld.so.preload and rebooting fixed ALL the issues,
guess ffmpeg3 or something else does not like it any more.
(2016-04-05, 19:42)asavah Wrote: it was libarmmem.so (bavison/arm-mem) which slipped in from pi2/pi1 builds,
removing ld.so.preload and rebooting fixed ALL the issues,
guess ffmpeg3 or something else does not like it any more.

Can you just confirm what problem libarmem caused?
Are you saying it caused the skips you are seeing with live streams on Pi3, or something else?
Is your build based on raspbian, openelec, or something else?
It would be surprising if it did as libarmmem should be faster than the default libc version.
(2016-04-05, 19:30)niwa2 Wrote:
(2016-04-05, 08:02)Milhouse Wrote:
(2016-04-04, 21:40)niwa2 Wrote: And another thing I noticed with the updated confluence skin:
The transparencys now work again (thank you guys for that by the way). But they work a little bit too well. The message boxes that you acknowledge with an OK-Button are fully transparent now. You can only see the text and the button. This should also be in the logs: when the first movie did not play I got a transparent message that at least one file could not be played.

Can you provide a screenshot, or a way to reproduce? The yes/no/cancel dialogs I've seen are all appearing correctly in Confluence 3.0.7 with #0404. Make sure you've updated to Confluence 3.0.7 as 3.0.6 had broken/missing textures.

Yesterday evening I could only see 3.0.6 in the default repo.
I switched to this one which fixed the black areas on the home screen. And all the other visual anomalies except for the message boxes.
The confirmation message when I switched to the confluence skin was already completely transparent, with only text and the yes and no buttons visible.

ok confluence just updated to 3.0.7 and everything is good now.
Also the 3D icon is back with 0404
@popcornmix
libarmmem was causing INSANE amount of skips with live streams, like hundreds of skips in a few seconds,
Skips are still present atm, even with local media, I'm watching a movie from local file - mkv/1080p/h264 - 19k skips in 1h 30m,
it's not as bad as with armmem but still not as good as before,
iI've seen commits to newclock5 branch and firmware, building as I write this, will report back.
(2016-04-05, 22:45)asavah Wrote: libarmmem was causing INSANE amount of skips with live streams, like hundreds of skips in a few seconds,

I'd like you to double and triple check that. I'm using libarmmem in my dev environment and it's used on these OE builds
Also can you confirm what your build is? Is it your own OpenELEC build?
@popcornmix
https://github.com/popcornmix/xbmc/commi...31bf8956ad

Yay,thanks!!!
Good stuff, no skips on any kind of media, live or local.
SD live tv stream running for 15m with mmal, sync and deinterlacing - 2 skips, which is awesome.

Quote:I'd like you to double and triple check that.
Yes, please.
I've re-enabled libarmmem.so and rebooted - no skips, when I first disabled it the amount of skips decreased by order of magnitude (placebo effect?),
I was using it for ages on all the pis, never caused any inconvenience.

Quote:Also can you confirm what your build is? Is it your own OpenELEC build?
It's my own homergrown thing, the concept is the same as OpenELEC - minimal OS with all the necessary bits for Kodi.
Provided I use bleeding edge sources for some components the thingy is surprisingly stable.
I follow closely your newclock5 branch for Kodi, rpf git for kernel and firmware.
I also shamelessly borrow patches, scripts and tricks from OpenELEC, debian, arch and buildroot.
(2016-04-06, 00:40)asavah Wrote: It's my own homergrown thing, the concept is the same as OpenELEC - minimal OS with all the necessary bits for Kodi.
Provided I use bleeding edge sources for some components the thingy is surprisingly stable.
I follow closely your newclock5 branch for Kodi, rpf git for kernel and firmware.
I also shamelessly borrow patches, scripts and tricks from OpenELEC, debian, arch and buildroot.

Do you do this to get some feature not supported by OE (and other distros)?
Or do you just enjoy producing you own build?
New OpenELEC.tv Krypton build #0405: RPi / RPi2
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 4.4.6 #1 Tue Apr 5 22:11:00 BST 2016 armv6l GNU/Linux

# vcgencmd version
Apr  4 2016 19:13:34
Copyright (c) 2012 Broadcom
version dc0f91d43331e85db96be118c927c77011b9fff2 (clean) (release)

# lsb_release
OpenELEC (Milhouse) - Version: devel-20160405221002-#0405-g0026734 [Build #0405]

# vcdbg log msg 2>&1 | grep DTOK
002468.251: Kernel trailer DTOK property says yes

# Kernel device tree status: Enabled

Based on tip of OpenELEC.tv master (0026734b, changelog) and tip of XBMC master (6368510e, changelog) with the following modifications:
  • Includes newclock5 patches
  • Excludes the OpenELEC linux-01-RPi_support patch in favour of sourcing these and possibly more recent patches directly from kernel branch rpi-4.4.y
  • Default setting for "Show RSS Feed" changed to disabled (new installs only) [patch details]
  • Disabled "Total Duration" in Confluence (see build #0221 for details)
  • Includes latest bcm2835-driver master (c0655009, ahead +11)
  • Includes latest kodi-platform master (92583ef9, ahead +2)
  • Includes latest libcec master (6d68d212)
  • Includes latest libnfs master (3c26ce1e, ahead +13)
  • Includes latest p8-platform master (041a8c6c, ahead +1)
  • Includes latest addons: adsp.basic (5cf12e83, +7), adsp.biquad.filters (af575f3d, +7), adsp.freesurround (6dc533be, +8), asplib (da66f517, +13), inputstream.mpd (6bd24f3f), peripheral.joystick (76b7c40a, +48), pvr.argustv (974820ab, +25), pvr.demo (e74822f2, +21), pvr.dvblink (82c7b4d5, +20), pvr.dvbviewer (6ab861fa, +33), pvr.filmon (0d8dd5bd, +27), pvr.hdhomerun (fd9daf4a, +32), pvr.hts (0f88a357, +67), pvr.iptvsimple (b741cac7, +27), pvr.mediaportal.tvserver (96f415e3, +52), pvr.mythtv (f8d25fda, +36), pvr.nextpvr (d445c5ad, +27), pvr.njoy (b9b0ae43, +19), pvr.pctv (f1880484, +25), pvr.stalker (14a7c70d, +28), pvr.vbox (e70146d8, +27), pvr.vdr.vnsi (b64e7b4c, +43), pvr.vuplus (d8c6f9ba, +23), pvr.wmc (898e2dad, +33)
  • Includes commits from service.openelec.settings/, ahead +1 (OpenELEC)
  • Exclude [env] kodi-999.42-KEY_EPG.patch: Added upstream
  • Exclude [env] package.mk: dcadec: Drop (not needed anymore)
  • Include [env] e7cbe9cb: xf86-video-intel: explicitely disable TearFree and TripleBuffer
  • Include [env] ed774729: Intel: Implement Passthrough-Range
  • Include [env] 3a6268c9: VAAPI: Enable EGL
  • Include [env] 6be9ebe7: libva / libva-driver-intel: bump to 1.7.0
  • Include [env] 98c65e6a: Kodi: Use Limited Range by default
  • Include [env] 20965d0a: mesa: update to 11.2.0-rc4
  • Include [env] patch: xf86-video-intel: bump to 3fafabe
  • Include [env] patch: Clean Kodi view cache on startup
  • Include [env] patch: Fix OE settings button after Estuary update
  • Include [env] patch: HACK: Disable multiple PVR addons during migration. Always enable inputstream.*
  • Include [env] patch: Add extra headers needed by 3D BD MVC
  • Include [env] patch: Add support for dynamic device tree overlays
  • Include [env] patch: Set default volume steps to 20
  • Include [env] patch: Enable game controllers in manifest, add repository.kodi.game
  • Include [env] patch: Bump libbluray - include MVC support
  • Include [env] patch: Enable other binary addons
  • Include [env] patch: Reinstate version check service add-on - avoid black screens on x86?
  • Include [env] patch: Update inputstream.mpd settings
  • Include [env] patch: Install dtoverlay userland
  • Include [env] patch: Enable pvr addons, disable pvr updates
  • Include [env] patch: Add experimental splash video for RPi
  • Include [env] patch: Binary-Addons: Package inputstream.mpd
  • Include [env] patch: kodi: peripheral.joystick binary addon
  • Include [env] PR:4500: kodi: update to 17.0
  • Include [env] PR:4537: [scripts] Add PKG_SOURCE_NAME for non-standard package tarballs
  • Include [env] PR:4661: stripping changes
  • Revert [env] 46b9b7b3: rtmpdump (Reason: use newclock5 bump)
  • Include [pkg] PR:8645: [video] Add season/TV show artwork to episodes/seasons even if they have their own fanart.
  • Include [pkg] PR:8723: Implement filecache retry logic
  • Include [pkg] PR:8824: videodb: fix smart playlists not honoring "Show empty TV shows" setting.
  • Include [pkg] PR:8922: [guiinfo] extend ranges for listitem properties
  • Include [pkg] PR:9334: [chg] decrease volume steps to 20
  • Include [pkg] PR:9538: [Peripherals] m_bNeedsPolling broken for busses where it is set outsi?
  • Revert [pkg] e9a6d59f: VideoPlayer: inputstream, fix cp error (Reason: inputstream.mpd needs update) (kodi)
  • Revert [pkg] PR:9531: VideoPlayer: add method for requesting desired video resolution to demuxer (Reason: inputstream.mpd needs update)
Build Highlights:
  1. NOTE: DVD playback remains temporarily disabled
  2. New firmware:
    popcornmix Wrote:Firmware/kernel update to avoid using io_is_busy, and instead support changing the sdhost clock on the fly.

    This means minor sdcard activity won't keep us in turbo mode (possibly the issue that was reported in thread a couple of days back).

    Eventually you should no longer set the io_is_busy flag in OE/LE, but for now kernel will ignore the setting, so no change needed now.

    Keep an eye out for sdcard corruption, performance regressions and how long we spend in turbo/non-turbo.
    See previous build for relevant kernel commits.
Build Details:
  1. Firmware (Apr 4):
    • arm_loader: Add SET_SDHOST_CLOCK mailbox property
  2. XBMC:
    • [Builtins/Cec] add missing registrations (PR:9535, 1 commit, 1 file changed)
    • small syntax typo (PR:9554, 1 commit, 1 file changed)
    • VideoPlayer: set speed on demuxer when speed of player is changed (PR:9555, 1 commit, 1 file changed)
    • remove some unused/duplicate context menus (PR:9548, 4 commits, 8 files changed)
    • videoinfotag: fix typo introduced in e6e2d0ace5cfe6191b8f7727ced1747854254ce4 (PR:9558, 1 commit, 1 file changed)
    • [coverity] Some cleanup/fixes (PR:9512, 14 commits, 23 files changed)
  3. newclock5:
    • New commits in this build:
      • MMALRenderer: return earlier when frames are already submitted frame is skipped (a224e0d2)
  4. kernel 4.4.y:
    • New commits in this build:
      • config: Enabled IPV6_SUBTREES (ed825c0f)
      • add smsc95xx packetsize module_param (3cea4c3f)
      • reboot: Use power off rather than busy spinning when halt is requested (3ce05d6e)
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
I noticed after today's update that "Audio offset" is not working. The adjustment works I can change the numbers or move the slider but it has no effect on audio delay during the playback. I really make use of it when using small multi channel headphone amp. rather then full blown receiver for headphones.

It started from #0404 - audio offset not working
#0403 is working fine.

Thanks for all the updates, commitment to the project and 3D ISO playback Smile
This project is amazing. Taking not the best platform on the market, but with dedicated SW making it a deal braker.
I'm having a weird issue, I don't know if it is specific to these alpha builds but I have just plugged a third HDD into my pi and it recognises the names of all 3 HDDs but it seems to think two of the HDDs are the same. You can see in this image that openelec can see 3 HDDs but if I select the top two ones it will take me to the same place despite being separate drives with different content on them. Anyone have any ideas how to fix?

Never mind, I fixed it. I just renamed both drives to completely different things, apparently adding a "1" on to the end of the name isn't enough for kodi to see there is a difference.
Sorry if this is already posted, but I tried reading this whole thread and it's now over 130 pages and CEC is too short for the search to allow!

I found that with 403 (not tried 404 or 405 yet) that KODi would completely and utterly freeze dead when I did this:

1) Open video settings menu on my projector
2) Make some changes
3) Close video settings menu

This would freeze KODI regardless if it was running a video or just idle. Sorry no log file as debug logging was off and I haven't had time to recreate since.
If this isn't a know issue I'm happy to get a log file for it.

Disabling CEC fixed it.

Oddly enough, I can't image why the projector would be sending anything on CEC after changing color / brightness settings!

NB: Any chance of a summary page of know / in progress issues for this build? I doubt many people have time to read 136 pages!
(2016-04-05, 16:58)toppot Wrote:
(2016-04-05, 16:29)popcornmix Wrote:
(2016-04-05, 14:17)toppot Wrote: I could start disabling add-ons one at a time... But with a 1 hour wait that is probably not the smartest idea.....

Looking at the debug log (wiki) after one hour may be useful.
You can rename .kodi (e.g. to .kodi_back) and reboot. That will sanity check if a clean install has the one hour issue.

This one..
16:39:41 6367.685059 T:1962188800 NOTICE: SpawnThread - fatal error creating thread
16:40:04 6390.732422 T:1718612896 ERROR: Skin Helper Service --> ERROR in LibraryMonitor ! --> can't start new thread
16:40:04 6390.732910 T:1718612896 ERROR: Traceback (most recent call last):
16:40:04 6390.733398 T:1718612896 ERROR: File "/storage/.kodi/addons/script.skin.helper.service/resources/lib/ListItemMonitor.py", line 209, in run
16:40:04 6390.740234 T:1718612896 ERROR: thread.start_new_thread(self.setPVRThumbs, (True,))
16:40:04 6390.741211 T:1718612896 ERROR: error: can't start new thread


Soo, that seems obvious. The update/creation of pvr thumps.... Not sure I understand exactly why it should make a mess that the thread creation failed... It is on the other hand obvious that my setting "not to update guide data during playback" could be the reason I only experience this after some idling....

Then the question arises... How to fix? Is it the pvh.hts, the Rapier skin or perhaps the Skin helper that is the culprit...

hmm, not much wiser....
One one occasion there was a memory leak - on another the above mentioned... But looking at logs I am not finding anything conclusive...
Log file

It is difficult to find in the log - since it happens after 1 hour, but it does take "some" time to show the full effect... But around 11.30 some kodi.bin processes
have upped from %user around 2-4, during 10 min. to around 30-40....

But I dont see anything suspicious... Anybody?? This is really killing me, since the first hour it is more or less perfect.. (and the daily driver in the living room - not good for WAF)

BTW: Looking at the event log... Does anybody know what this "Alarm Clock set" isHuh

[Image: wZ8TOBH.png]
Alarm clock - I think it's Leopolds dev update addon, it will check for a new version every 3 hours.

For the one hour problem, have you tried a stock/clean system - no add-ons, only Estuary skin... At least it might help narrow down if this is add-on/skin related, or a core issue.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
  •   
  • 1
  • 134
  • 135
  • 136(current)
  • 137
  • 138
  • 146
  •   
  Thread Closed
 
Thread Rating:
  • 6 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
OpenELEC Testbuilds for RaspberryPi (Kodi 17.0)56
This forum uses Lukasz Tkacz MyBB addons.