•   
  • 1
  • 63
  • 64
  • 65(current)
  • 66
  • 67
  • 91
  •   
v16 Android pass-through test thread. EXPERIMENTAL!!!
(2016-02-09, 19:54)danjames92 Wrote:
(2016-02-09, 17:39)wweich Wrote: The 30th is RC2 (as already stated 5 posts above).
There is a newer version on the mirrors. but don't know if it is RC3 or how it improves on the 30th build:
http://mirrors.kodi.tv/test-builds/andro...bi-v7a.apk

On the mirrors, there is also a "martijn-shield" build, don't know what that's about though:
http://mirrors.kodi.tv/test-builds/andro...bi-v7a.apk

martijn is just a test build for checking channel configs for V17.

this builds is for hd audio also with rc3 ?
(2016-02-11, 00:42)busta.rhymes Wrote: I dont think that incorrect lip sync is anything that can be seen in the debug log, maybe im wrong. Its just that as soon as i think everything is lipsynct when i put on another movie or tv show it can be off again.
Even if not by much. i must say i am absolutly crazy with this. i need my lip sync to be 100% so 25ms + or - make a total difference. Anybody else stugling with things like this?

I had similar problems with the Jan 21 (mislabeled as Jan 31) build that I believe was based off of RC1... I upgraded to RC2 (without passthrough), and am still using that with great success, but still keeping an eye on this passthrough thread...
(2016-02-11, 02:03)psuKinger Wrote:
(2016-02-11, 00:42)busta.rhymes Wrote: I dont think that incorrect lip sync is anything that can be seen in the debug log, maybe im wrong. Its just that as soon as i think everything is lipsynct when i put on another movie or tv show it can be off again.
Even if not by much. i must say i am absolutly crazy with this. i need my lip sync to be 100% so 25ms + or - make a total difference. Anybody else stugling with things like this?

I had similar problems with the Jan 21 (mislabeled as Jan 31) build that I believe was based off of RC1... I upgraded to RC2 (without passthrough), and am still using that with great success, but still keeping an eye on this passthrough thread...

Ok, good to hear that others had the same issue, ill try to get a hold of rc 2 and go back to that. See if that solves my problems.
Situation on my side.

TV Sony W755 + audio Denon AVR1705 - connected by optic cable.

Kodi 15.2 - when passthrough option is enabled playing DTS movie TV is generating very loud stertorous sound (like short circuit on speaker) which is not possible to mute, even when volume level is on minimum or even fully mute - this sound is very loud. Not possible to watch anything because of that, audio system is switching to DTS but because I'm afraid of speakers in my TV I had to switch movie off instantly. No problem with picture smoothness at all.

Kodi 16 rc3 - the same as above with audio, had no time to check picture smoothness.

Kodi 16 passthrough build 30.01.2016 - when passthrough option is enabled playing DTS movie no problem with audio described above, TV is generating some quiet noise in DTS movies (buzzing) but it's possible to hear original audio from the movie and it's possible to fully mute. Audio system is switching to DTS correctly, no issues with sound at all. Unfortunately on some add-ons picture smoothness is quite bad, like very quick slideshow.
iksik2 - if you're connecting via optical then you won't get a HD stream, you need HDMI. So just turn off pass through and all your problems will be solved Smile


Just installed RC3 and very pleased to report...

- Audio sync issue fixed , I can ff, skip and it doesn't fall out of sync Smile

- flac 5.1's are now working wonderfully.

Only thing on my wish list now is Wav DTS-CD's playing at normal speed Smile I'd be very happy to help in anyway I can with the testing of any related fixes.
WAV DTS 44.1 khz is broken beyond repair ... it works on AMLogic devices and on old android device, that don't need to use this new PT api, though amlogic at least resamples to 48 khz under the hood (*). I don't see anything that kodi can do about that. Never the less we are in contact with google engineers and exactly this problem 44.1 khz dts / wav on v23 API (v22 shield).

* speeding up the samples.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
jusnogood - thank you for feedback. Unfortunately if pass through is not enable all DTS materials are working as a Dolby for me. It's how my Denon recognizing DTS movies on Auto mode when pass through is not enable. When pass through is enable then it switch to DTS mode with no problem.
(2016-02-11, 01:17)dimosx Wrote:
(2016-02-09, 19:54)danjames92 Wrote:
(2016-02-09, 17:39)wweich Wrote: The 30th is RC2 (as already stated 5 posts above).
There is a newer version on the mirrors. but don't know if it is RC3 or how it improves on the 30th build:
http://mirrors.kodi.tv/test-builds/andro...bi-v7a.apk

On the mirrors, there is also a "martijn-shield" build, don't know what that's about though:
http://mirrors.kodi.tv/test-builds/andro...bi-v7a.apk

martijn is just a test build for checking channel configs for V17.

this builds is for hd audio also with rc3 ?

If you want reliable PT with refresh rate switching, use the 8th adddroidPT V16 test-build.
Mac Mini (2.7GHz, Late 2012, Windows 10, Kodi DSPlayer) | SATV 16GB | Panasonic TX-P50GT50B | Yamaha RX-V675 | Q Acoustics 2010i (FL, FR, Left S, Right S), Q2000ci Center, Q2070si Sub
(2016-02-11, 12:27)iksik2 Wrote: jusnogood - thank you for feedback. Unfortunately if pass through is not enable all DTS materials are working as a Dolby for me. It's how my Denon recognizing DTS movies on Auto mode when pass through is not enable. When pass through is enable then it switch to DTS mode with no problem.

That's very odd, My old denon3803 used to be able to recognise DTS no trouble.

So guessing something in the chain is converting DTS to dd PCM. Perhaps your tv as it doesn't look like its DTS compatible from the specs I've read.
Most likely "AC3 Transcode" is enabled ... I don't know of any device other than kodi force to do so, that will decode DTS to PCM and reencode it to Dolby voluntarily.

A simple Debug Log could solve all this mistery ... so how about providing one?
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Are there release notes for these test builds? I see a 2.11.2016 test build in the arm test build directory, but I don't know if it's rc3 or audio pass through
(2016-02-11, 14:14)danjames92 Wrote: If you want reliable PT with refresh rate switching, use the 8th adddroidPT V16 test-build.

I wish. Unfortunately it doesn't include the PVR clients for some reason.
(2016-02-12, 06:45)onlinespending Wrote:
(2016-02-11, 14:14)danjames92 Wrote: If you want reliable PT with refresh rate switching, use the 8th adddroidPT V16 test-build.

I wish. Unfortunately it doesn't include the PVR clients for some reason.

Then use the 30th and be happy you have PT at all.
Mac Mini (2.7GHz, Late 2012, Windows 10, Kodi DSPlayer) | SATV 16GB | Panasonic TX-P50GT50B | Yamaha RX-V675 | Q Acoustics 2010i (FL, FR, Left S, Right S), Q2000ci Center, Q2070si Sub
(2016-02-12, 00:03)fritsch Wrote: Most likely "AC3 Transcode" is enabled ... I don't know of any device other than kodi force to do so, that will decode DTS to PCM and reencode it to Dolby voluntarily.

A simple Debug Log could solve all this mistery ... so how about providing one?
Hello, a little bit more information, right now to be honest I'm not sure if I've posted my question in proper tread.

First of all, log with pass through enable:
http://pastebin.com/fuFsFRXV
AC3 Transcode enable or disable - no changes at all.
It seems, that when switching on movie with DTS then TV speaker is going automatically to the highest possible volume (100) - this is causing that loud sound I described appears (even if TV is on mute or quiet it's going to the max volume rapidly with no message). It's also not possible to understand anything in TV speakers. My Denon is switching to DTS with no issues, no problem with volume level, sound is clear. These are movies 2 and 3 in my log.

When Kodi is starting movie with Dolby or just stereo, it's not changing volume level in TV. Possible to understand everything in TV speakers, my Denon switch to Dolby with no issues on Auto mode. This is movie no 1 in my log file.

When pass through is disable no issues with TV sound - playing DTS and regular movies just fine (of course in stereo mode). Possible to understand everything in TV speaker and no issues with volume. Just my Denon do not switch to DTS nor Dolby in Automatic mode. And log:
http://xbmclogs.com/pakrhxpel

I'll be really grateful for your support on this.
Quote:17:22:57 T:18446744072360438672 NOTICE: Kodi compiled Feb 4 2016 by GCC 4.8.0 for Android ARM 32-bit API level 17 (API level 17)

This API has _no_ in words _zero_ support for passthrough. Everything that works is passthrough sent via PCM, which means: 100% volume and send out the DATA with 16 bit encoding and hope that the AVR accepts that.

In your case it does not -> just disable passthrough completely.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
  •   
  • 1
  • 63
  • 64
  • 65(current)
  • 66
  • 67
  • 91
  •   



Logout Mark Read Team Forum Stats Members Help
Android pass-through test thread. EXPERIMENTAL!!!11
This forum uses Lukasz Tkacz MyBB addons.