• 1(current)
  • 2
  • 3
  • 4
  • 5
  • 27
  •   
[RELEASE] FilmAffinity (Spanish) scraper
#1
Hello guys.

In last build, is included a new Spanish scraper by Jurrabi. This scraper uses http://www.culturalianet.com
I tried this, and I found this web page hasn’t enough information. I decided then making a new scraper using http://www.filmaffinity.com web page. This scrapper supports all of this:

- Title
- Plot
- Outline (when available for the movie)
- Year
- Director
- Country and original version title (used mpaa tagline for this)
- Credits
- Genre
- Nominations, Oscars, and other prices (used mpaa field for this)
- Rating
- Votes
- Runtime
- Actor name

I think that it could be useful adding it to next releases.
Where can I post the xml file and the gif file?


Best Regards.

HectorziN (From Spain)
Reply
#2
submit a patch on SF.

https://sourceforge.net/tracker/?group_i...tid=581840
For python coding questions first see http://mirrors.xbmc.org/docs/python-docs/
Reply
#3
http://hectorzin.dynalias.com/FilmAffinity.zip
Regards

HectorziN
Reply
#4
I don't know how submit a patch. I have posted here a link to download. Guys, try to test it and evaluate. I think that it is very good. I haven't found a movie that dont' work with this scraper.

The only problem I have found, and I don't know how to solve it, is that don't work when the search string contains ñ, á, é, í, ó and ú. you mast search using n, a, e, i, o and u.

If anybody knows how to fix, please, tell me.

I am waiting your comments.
HectorziN
Reply
#5
sounds like encoding issues to me. make sure you properly specify utf vs not in your returned xml's.
Reply
#6
seems to be working fine. i'll hold off a couple of days to see if you nail that issue, then i'll commit to svn.

cheers

spiff
Reply
#7
the problem is that xbmc transforms ñ to ñ
In culturalianet.com, a search to ñ works, but filmaffinity.com needs to receive %F1.

The problem is that is xbmc who send ñ to the parer, then the parser cannot do anything with this.... This is what I think is happening.

Here is the log

INFO: Get URL: http://www.filmaffinity.com/es/search.ph...type=title

if you paste this url into internet explorer it won't find anything, but if you paste http://www.filmaffinity.com/es/search.ph...type=title then it will work. How can this be fixed?

Thanks
HectorziN
Reply
#8
we need some way for the scraper to say that it wants iso not utf chars. will have a crack at it later.
Reply
#9
OK, thanks, I'll wait for the new scraper functionallity
HectorziN
Reply
#10
Any progressHuh
is there a new definition of scraper languaje to explicit if dthe search using utf or iso?

Thanks a lot.

Also, anyone has test this scrapper? what do you think?
HectorziN
Reply
#11
Hello spiff.

it will be abailable anything to select utf or iso when searching?
if not. I think that we could include the filmaffinity scrapper anyway. what do you thing?

Regards
HectorziN
Reply
#12
oh my. this was an old one biting meSmile

had forgotten all about this. i suggest we stick it in svn as is, then i'll look into a fix when i have the time
Reply
#13
how can I stick it in svn?
thanks!
HectorziN
Reply
#14
submit it as a patch on sf.

i will do the stickingSmile
Reply
#15
Sorry, I submited it, but assigned to nobody, I should mismatch this field...
I suppouse I should submitted it to you.

I have attach the scrapper itself
HectorziN
Reply
  • 1(current)
  • 2
  • 3
  • 4
  • 5
  • 27
  •   
 
Thread Rating:
  • 2 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
[RELEASE] FilmAffinity (Spanish) scraper52