•   
  • 1
  • 2
  • 3
  • 4(current)
  • 5
  • 6
  • 50
  •   
[APPLE TV 4] pre-alpha builds CORE TESTING
#46
(2016-01-03, 14:08)klaasvs31 Wrote: There is a bug when using the Kodi remote (by joethefox) used on an iPhone. When trying to start a movie from the file browser in the app, Kodi crashes back to the main screen. This also happens in the official release of MrMC, but has been solved in test build 1.1.1

When trying the same procedure on the OS X build, the movie starts without any problems, so I believe it's the apple tv build.

If it was in MrMC and was fixed then we will get the fix once MrMC releases the code...
AppleTV4/iPhone/iPod/iPad: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for Kodi: NFS (wiki)
HowTo configure avahi (zeroconf): Avahi_Zeroconf (wiki)
READ THE IOS FAQ!: iOS FAQ (wiki)
Reply
#47
(2016-01-03, 06:07)DanTheMan827 Wrote: Is there any place in the code that would control what color space FFMPEG is decoding at?

I have updated the first post with a new tvos testbuild. I think i have fixed the color space (it was in our shaders where video level was forced by accident for GLES video rendering). Could you verify that it fixes the issue? (i have also enabled the limited color range setting in settings->system->video in that test build so you can switch back and forth - it only has an effect when video is playing though).
AppleTV4/iPhone/iPod/iPad: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for Kodi: NFS (wiki)
HowTo configure avahi (zeroconf): Avahi_Zeroconf (wiki)
READ THE IOS FAQ!: iOS FAQ (wiki)
Reply
#48
I noticed that the "black level" issue is striked-out, it means fixed.

Is the fix in the latest build or I have to change manually the settings as per post #40?
Reply
#49
read the post just before yours? ^^
AppleTV4/iPhone/iPod/iPad: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for Kodi: NFS (wiki)
HowTo configure avahi (zeroconf): Avahi_Zeroconf (wiki)
READ THE IOS FAQ!: iOS FAQ (wiki)
Reply
#50
(2016-01-03, 17:22)Memphiz Wrote: read the post just before yours? ^^

to be honest with you I did not understand if the solution is to use your last build of today in combination with the change of values in guisettings (post #40) or if your last build is enough as fix.

At the moment I just upgraded to your last build and at first I did not notice a big difference, but I may need to play a few videos before giving the last response.
Reply
#51
Changing contrast and brightness is only a workaround which should not be needed with my latest build. For seeing the difference i added the setting which can be flipped during playback with the ios remote app for example so you see the difference.

So to be clear. The last build has the fix ( at least i think so ).

AppleTV 4 should be set to auto in its video settings ...
AppleTV4/iPhone/iPod/iPad: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for Kodi: NFS (wiki)
HowTo configure avahi (zeroconf): Avahi_Zeroconf (wiki)
READ THE IOS FAQ!: iOS FAQ (wiki)
Reply
#52
(2016-01-03, 18:02)Memphiz Wrote: AppleTV 4 should be set to auto in its video settings ...

you mean.. "use limited colour range..." should be enabled ??

SORRY. I THINK I UNDERSTOOD:
Use limited color range ENABLED
Apple TV video settings to hdmi AUTO
Reply
#53
Can definitely tell the difference from previous builds to the 1/3 build. That's something I've been waiting for and noticed it immediately fixed

Thanks
Reply
#54
(2016-01-03, 16:56)Memphiz Wrote:
(2016-01-03, 06:07)DanTheMan827 Wrote: Is there any place in the code that would control what color space FFMPEG is decoding at?

I have updated the first post with a new tvos testbuild. I think i have fixed the color space (it was in our shaders where video level was forced by accident for GLES video rendering). Could you verify that it fixes the issue? (i have also enabled the limited color range setting in settings->system->video in that test build so you can switch back and forth - it only has an effect when video is playing though).

This fixed the issue. I update my local branch from your remote yab branch. I turned HDMI Resolution to "Auto" on apple tv and re-compiled Kodi. Installed on Apple TV and issue is now gone.

Thanks Memphiz.
Reply
#55
(2016-01-03, 18:13)sasagr Wrote:
(2016-01-03, 18:02)Memphiz Wrote: AppleTV 4 should be set to auto in its video settings ...

you mean.. "use limited colour range..." should be enabled ??

SORRY. I THINK I UNDERSTOOD:
Use limited color range ENABLED
Apple TV video settings to hdmi AUTO

you should disable limited range - limited range makes blacks brighter... man i didn't think that i made this to confusing - either you see too bright blacks or you don't Wink
AppleTV4/iPhone/iPod/iPad: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for Kodi: NFS (wiki)
HowTo configure avahi (zeroconf): Avahi_Zeroconf (wiki)
READ THE IOS FAQ!: iOS FAQ (wiki)
Reply
#56
(2016-01-03, 19:07)Memphiz Wrote:
(2016-01-03, 18:13)sasagr Wrote:
(2016-01-03, 18:02)Memphiz Wrote: AppleTV 4 should be set to auto in its video settings ...

you mean.. "use limited colour range..." should be enabled ??

SORRY. I THINK I UNDERSTOOD:
Use limited color range ENABLED
Apple TV video settings to hdmi AUTO

you should disable limited range - limited range makes blacks brighter... man i didn't think that i made this to confusing - either you see too bright blacks or you don't Wink

Followed your last instructions and saw the difference.
Much better now. Thanks
Reply
#57
Bug: if you hit the tv button while a video is playing (as an accident for example) and then go right back into Kodi the screensaver will then be enabled with a playing video

I'm pretty sure MrMC would also have the same problem
Install Kodi on iOS without a jailbreak: iOS App Signer — donations are gratefully accepted
Reply
#58
(2016-01-03, 16:56)Memphiz Wrote: I have updated the first post with a new tvos testbuild.

Thanks for all your great work with this, its appreciated Smile

The first post link does not work, do you have another mirror please?

http://z.os6.org/xbmc/test-builds/darwin...b-tvos.deb


Update: must have been a glitch... after 15mins and 8 attempts, it is now downloading, thanks again
Reply
#59
I have the same issue as simonk83 with the tv show scanning.
Kodi always crashes on another show, not the same.

Code:
Jan  4 10:07:48 Apple-TV Kodi[181] <Warning>: Debug Print: CSMBFile::Open - opened smb://NAS/Medien/Serien/Revenge/Season 04/Revenge S04E04 Meteor 720p HDTV-thumb.jpg, fd=10001
Jan  4 10:07:48 Apple-TV mediaserverd[26] <Notice>: '' (pid = 181) setting DiscoveryMode = DiscoveryMode_None, currentDiscoveryMode = DiscoveryMode_None
Jan  4 10:07:48 Apple-TV mediaserverd[26] <Notice>: '' (pid = 181) setting DiscoveryMode = DiscoveryMode_None, currentDiscoveryMode = DiscoveryMode_None
Jan  4 10:07:48 Apple-TV diagnosticd[71] <Error>: error evaluating process info - pid: 181, puniqueid: 181
Jan  4 10:07:48 Apple-TV com.apple.xpc.launchd[1] (UIKitApplication:com.timeless.Kodi[0x603][181]) <Notice>: Service exited due to signal: Bus error: 10
Jan  4 10:07:48 Apple-TV mediaserverd[26] <Notice>: 'FigPlayer - 31' (pid = 31) setting DiscoveryMode = DiscoveryMode_None, currentDiscoveryMode = DiscoveryMode_None
Jan  4 10:07:48 Apple-TV PineBoard[46] <Warning>: Application 'UIKitApplication:com.timeless.Kodi[0x603]' crashed.
Jan  4 10:07:48 Apple-TV UserEventAgent[23] <Warning>: 1190864391008: id=com.timeless.Kodi pid=181, state=0
Jan  4 10:07:48 Apple-TV PineBoard[46] <Notice>: #T:[0x16e1bb000] #Notice #SYSTEM : PBServiceProviderRegistry: clearing endpoints {com.timeless.Kodi}
Jan  4 10:07:48 Apple-TV PineBoard[46] <Notice>: #T:[Main] #Notice #PBAppLaunchLog : Process Manager launching com.apple.HeadBoard, from: com.timeless.Kodi, foreground: com.apple.PineBoard, focused: com.timeless.Kodi, switcherActive: NO
Jan  4 10:07:48 Apple-TV ReportCrash[182] <Notice>: Formulating report for corpse[181] Kodi
Jan  4 10:07:49 Apple-TV PineBoard[46] <Notice>: #T:[Main] #Notice #PBAppLaunchLog : Configure for Launch Running App
Jan  4 10:07:49 Apple-TV PineBoard[46] <Notice>: #T:[Main] #Notice #PBAppLaunchLog : Transition Controller from: com.timeless.Kodi, to: com.apple.HeadBoard, switcher: NO, app running: YES
Jan  4 10:07:49 Apple-TV ReportCrash[182] <Warning>: saved type '109_Kodi' report (4 of max 25) as /var/mobile/Library/Logs/CrashReporter/Kodi_2016-01-04-100748_Apple-TV.ips
Jan  4 10:07:49 Apple-TV PineBoard[46] <Error>: #T:[Main] #Error #SYSTEM : Unable to get short BSD proc info for 181: No such process


(2016-01-03, 09:22)simonk83 Wrote: Every build so far has crashed when scanning my TV shows.

Here's the logs (second one is xmbc.old):

http://xbmclogs.com/pd9ryfjpn
http://xbmclogs.com/pa2f2pdpf

I'm not 100% sure but it seems to crash more often when processing a show with a lot of content (Family Guy for example).
Reply
#60
(2016-01-04, 11:38)timeless Wrote: I have the same issue as simonk83 with the tv show scanning.
Kodi always crashes on another show, not the same.
Can you or simonk83 try without mysql? Also syslog is less useful than actual kodi logs, plus it's much cleaner if you just post links to the logs we can look through, so can one of you guys try to replicate without mysql and post logs if it crashes still? Thanks!
Reply
  •   
  • 1
  • 2
  • 3
  • 4(current)
  • 5
  • 6
  • 50
  •   
 
Thread Rating:
  • 7 Vote(s) - 4.86 Average



Logout Mark Read Team Forum Stats Members Help
[APPLE TV 4] pre-alpha builds CORE TESTING4.867