• 1
  • 172
  • 173
  • 174
  • 175(current)
  • 176
Release Kanzi: Amazon Alexa skill for Kodi
(2021-02-07, 15:26)Forkapicture Wrote:
(2021-01-17, 18:20)vedovivo Wrote: ...
when i lunch function lexigram generate-function kanzi i get
   → Configuration file is not valid. Please update it with the correct information.

Same here. This project seems to be dead. Would love to get it working. Deployed with 2 different Machines many times with the same result. Don't think it's actually the Config file.
Both Kanzi and Kodi Connect skills are working fine here. Make sure to follow the instructions (sorry, i know it’s a dumb reply but my setup is almost 2 years old and has been working since without any new intervention on my side)

Ive uploaded a video on YouTube in jan 2020 that demonstrate both skills. (In french)

Kodi & Alexa demo
I am completely stuck at the self host page. I've created the docker container and it runs fine but I need some help setting up the reverse proxy. I'm kind of clueless where to put the files and how to get them to run etc. Using lambda i get an error deploying skill

This is my error when deploying:

 Error: Command failed: /usr/lib/node_modules/lexigram-cli/dist/../node_modules/.bin/ask deploy -t skill
Invalid json: /root/.ask/cli_config

edit: got it deployed next issue. alexa saying there is a problem with the skills response

Last edit: got it working fine.
I don't suppose anyone can help me. 
I think my issue is a double nat as I have a really weird ISP where I live.
I've ran traceroutes to confirm this and no matter what I do I cannot get around it. I can view kodi on a web browser on my LAN but not on WAN.

Is there any hope for me? They're most unhelpful and refuse to open ports for me.
I am looking to move to Kodi for my video and music collection. Does this add on work with the most recent versions of Kodi?
Hello Folks,
I just have installed the Kanzi skill on AWS Lambda (I also have created an S3 bucket).
I can successfully logon to my Kodi installation on my Fire TV Cube via internet with myFritz!-network-address on port 8080 in FireFox browser,
the logon screen appears and I can logon with id Kodi and password. This works fine. I installed Kanzi as per the Lexigram documentation
on AWS Lambda, I ran all Lexigram commands with success, did upload of zip-file and deployed kanzi. After successfull deployment I can see
the kanzi skill appears in my phone's Alexa app under "development". So everything looks fine. However, when I issue a command to Alexa
on my Fire TV Cube, like "Alexa tell Kodi to play armageddon", then it obviously does not contact Kodi at all, but directs me to the film "Armageddon"
on Amazon prime. Also the command "Alexa tell Kodi open movies" does not interact with Kodi. My impression is, there is no interaction at all with
Kodi. I am using the skill with german language setting in the codi.config.
When I logon to theAmazon  Alexa console I see the skill kanzi in my account. When I edit the kanzi skill and look into invocation name I can see
that the invocation name is "kodi" only and there is a red error statement saying that an invocation name needs to be minimum 2 words.
I changed invocation to "call kodi" and rebuilt the skill from the developer console. However, no change, no interaction between Alexa and
my Kodi implementation on the Fire TV Cube. When I test the skill within the alexa deleoper page and enter a command "call kodi play armageddon"
then I get the prompt "call k.o.d.i play armageddon" so I thought that Alexa for whatever reason has a problem with the invocation name "Kodi"
which it replaces by "k.o.d.i". I re-deployed the skill using option "1" for "Kanzi" as invocation. However, this also gives no interaction with Kodi...

On AWS Lambda, i created the kanzi skill using Python 3.9 and option ARM64 and Alexa Skills Kit trigger.

Can anyone point me in a direction where to search how to fix the problem?
Any suggestions are highly appreciated.
Thanks in advance,
I am trying to setup a local version in docker using the linuxserver/docker-kanzi image. So for this pulled the image built and uploaded the skill to amazon all went as expected. I already have a reverse proxy setup running, hosting a few services like nextcloud, homeassistan, hasska skill for homeassistant and so on. When everi try to use kanzi i get A 500 ERROR in the alexa app and alexa shouts at me 'There was a problem with the requested skill's response' if i look in the docker logs i get the following errors and im unsure where to go next

my system clock was a bit slow adjusted the time and boom
Kanzi on docker.  Can't get past this step: "docker exec -itw /config kanzi lexigram login --no-browser true" When I paste the resulting url back into the browser I get an Amazon account login (url beings with "https://na.account.amazon.com/ap") page, I enter my amazon credentials, and then this response from "https://s3.amazonaws.com/ask-cli/response_parser.html..."
<Message>Access Denied</Message>

Yes, I have a developer account which I can log into using "https://developer.amazon.com".  The "funny" thing is that this error is relatively new.  I have tried the docker kanzi deployment successfully prior,  but got sidetracked elsewhere.

I have the exact same error on new installation.

I am using latest Kodi on a Windows 11 pc with the Alexa application.

I have an Amazon Developer account
hello, iam using a coreelec khadas vim3 device with Amlogic A311D chipset and Kodi 19.4.

how can I use Kanzi+lexigram?

I mean, i cant simply use the commands from the official linux tutorial because its a other platform.

first I install Node Version Manager with:
curl -o- https://raw.githubusercontent.com/nvm-sh...install.sh | bash


then i check with:
command -v nvm
but i receive nothing, even after rebooting the box.

i don't think you can really i believe coreelec / libreelec are pretty closed linux distros. but you can install docker as an addon then run a docker container for kanzi though try https://hub.docker.com/r/linuxserver/kanzi i run kanzi self hosted on my server inside of docker i also have nextcloud running on that so i store the cache there to
I have a Problem with "lexigram login" i get the error "Der Befehl "C:\Users\Raimund" ist entweder falsch geschrieben oder konnte nicht gefunden werden.". ("The command "C:\Users\Raimund" is either misspelled or could not be found.")
I think it's the spaces in the name of the userfolder. Is there a "simple" solution for an amateur?


PS: Its on Windows :-)

PPS: Found a Solution with DOS shorts
Quote:i don't think you can really i believe coreelec / libreelec are pretty closed linux distros. but you can install docker as an addon then run a docker container for kanzi though try https://hub.docker.com/r/linuxserver/kanzi i run kanzi self hosted on my server inside of docker i also have nextcloud running on that so i store the cache there to

Offtopic: ok, do you know how to open the docker webui? there is nothing on port 8080, 9090,.... is docker installed in kodi headless? I would prefer webgui for docker
not used docker inside kodi. can you not ssh in to the box and use the command line, or install something like portainer to give you a web management page for the docker engine
I tried now docker with linuxserver/kanzi.
but every time i am receiving a bad request by giving it the key.
user: default
on the amazon IAM console its the same name: default
I tried it many times, tried the hidden key, renew the keys, made new user with other names, nothing. bad request. why?


yes I copied the displayed link..... Alexa Skills Kit Tools are added

now iam receiving there only this
  • 1
  • 172
  • 173
  • 174
  • 175(current)
  • 176

Logout Mark Read Team Forum Stats Members Help
Kanzi: Amazon Alexa skill for Kodi15
This forum uses Lukasz Tkacz MyBB addons.