Skin MOD - Help needed to disable startup splash and replace with video.

  Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
brokentechie Offline
Junior Member
Posts: 24
Joined: Jun 2015
Reputation: 0
Post: #1
Hi,

I have tried the advanced.xml to disable the splash screen but no dice! I wish to play a startup video instead - can anyone help me please?

TY
find quote
Tgxcorporation Offline
Skilled Skinner
Posts: 1,091
Joined: May 2012
Reputation: 42
Location: Italy
Post: #2
Settings > Skin Settings > Startup > Startup Screen Type set to Video and select the path to your video.

Tgx
find quote
brokentechie Offline
Junior Member
Posts: 24
Joined: Jun 2015
Reputation: 0
Post: #3
Thank you! Didn't know if I had to disable the splash, then add the relevant scripting into the startup.xml Smile
find quote
Bama350z Offline
Junior Member
Posts: 8
Joined: Sep 2014
Reputation: 0
Post: #4
I have tried this. I am on Jarvis and when I follow the instructions I still get the splash screen. My intro video is also stuttering about halfway through. Any thoughts? Thanks!
find quote
addisonwalker Offline
Junior Member
Posts: 17
Joined: May 2017
Reputation: 0
Post: #5
Similar issue. Kodi screen starts first then nebula then my video intro. I have set the time to 0 and the time only seems to control the nebula screen intro. At 0 it pops up then goes away and starts video. Video runs fine. Any thoughts on completely disabling the kodi and nebula screan?
find quote
addisonwalker Offline
Junior Member
Posts: 17
Joined: May 2017
Reputation: 0
Post: #6
(2016-01-05 20:00)brokentechie Wrote:  Thank you! Didn't know if I had to disable the splash, then add the relevant scripting into the startup.xml Smile

Are you having the same issues that I am?
find quote
brokentechie Offline
Junior Member
Posts: 24
Joined: Jun 2015
Reputation: 0
Post: #7
Yes. I don't think you can disable the splash screen. I sacked off using nebula for this reason

Sent from my SM-G935F (typie typie)
find quote
comonucrows Offline
Junior Member
Posts: 30
Joined: Aug 2016
Reputation: 1
Post: #8
I simply just renamed my splash png to splash2 . By doing this, it will stop the splash png from showing.

You can disable the splash, it's just you need to go to the correct xml.....(which could be startup xml) and hide or delete the script.
find quote
Tgxcorporation Offline
Skilled Skinner
Posts: 1,091
Joined: May 2012
Reputation: 42
Location: Italy
Post: #9
In the latest revision i've added a new option to disable the default startup logo. Using this option together with 0 seconds as startup delay, lets you start the skin directly to a custom video without delay.

Video stuttering simply occurs because your device is low powered. In fact you have to remember that during the playback of your custom video, the cpu of your device is busy initializing Kodi and on low powered devices, video stuttering may occur.

Tgx
find quote
addisonwalker Offline
Junior Member
Posts: 17
Joined: May 2017
Reputation: 0
Post: #10
(2017-05-24 19:09)Tgxcorporation Wrote:  In the latest revision i've added a new option to disable the default startup logo. Using this option together with 0 seconds as startup delay, lets you start the skin directly to a custom video without delay.

Video stuttering simply occurs because your device is low powered. In fact you have to remember that during the playback of your custom video, the cpu of your device is busy initializing Kodi and on low powered devices, video stuttering may occur.

Tgx

Tgx - Thanks for all of your hard work developing this skin. I am running Krypton 17.1 and have done your recommended steps. I still get the kodi splash, Nebula then my video. I have a good android box and have no problem with my 5 sec intro video. Even when I set it to 0, I still get the full kodi 17.1, Nebula flash (less than a second) then mine. It's not a huge deal, just something that I'd like to change. I only use for my family's personal use. The intro was made by my daughter. We actually use Kodi as it was intended. I know this isn't the correct forum topic, however, id love to be able to add auto completion to your skin. Is there an update that will include this or could you share how I could make this compatible. Again thank you for all you do. We love your skin!
(This post was last modified: 2017-05-25 01:59 by addisonwalker.)
find quote
Tgxcorporation Offline
Skilled Skinner
Posts: 1,091
Joined: May 2012
Reputation: 42
Location: Italy
Post: #11
This won't work with the latest official skin release.
It will work with the Krypton version on Github :

https://github.com/Tgxcorporation/skin.n...rom-GitHub

I'll try to include autocompletion for the next official release.

Tgx
find quote