New Official Apt Repository
#1
All,

Having recently posted to tell you all that I'd got http://apt.tvheadend.org back on-line supporting a more comprehensive suite of builds. I've now decided to follow dreamcat4 and move the official hosting to bintray (I needed a bit of time to investigate it and understand that it's a much better solution).

So the existing auto-build system that feeds http://apt.tvheadend.org has now been altered to post stuff to a new "official" bintray location.

It's my strong recommendation that people downloading packages for Ubuntu / Debian use the new repository as apt.tvheadend.org may eventually stop serving content (though no intention to do that any time soon).

For more details please see https://tvheadend.org/projects/tvheadend...Repository

Adam
Reply
#2
I usually download the latest source code from github every few weeks or so and compile it myself. Obviously using pre-built Debian packages is a lot easier, so I'd like to try that. Just one question.

Do these packages contain the transcoding functions? They were the reason I compile tvheadend myself, but I never re-checked if that's still needed. Angel
Reply
#3
Not at the moment, I'm trying to sort that out though. Hopefully tomorrow.

Adam
Reply
#4
Hello Adam.

I have imported the GPG signing key and added the new bintray repository as instructed on https://tvheadend.org/projects/tvheadend...Repository, but an error is returned:

W: Failed to fetch http://dl.bintray.com/tvheadend/deb/dist...ty/Release Unable to find expected entry 'release/source/Sources' in Release file (Wrong sources.list entry or malformed file)

I tried to add the "release" repository:

sudo apt-add-repository "http://dl.bintray.com/tvheadend/deb release"
Reply
#5
@willemd I believe the latest "unstable" builds should now include libav support (using static ffmpeg lib).

@dnairb I've just tried it myself (on my laptop, which is running trusty) and it worked fine for me. Maybe some transient error? That file appears to download ok for me.
Reply
#6
Thanks Adam. It works OK now. Maybe it was a transient error of some sort.
Reply
#7
Let me know if you have any other problems.

I don't know if there is an issue with how they handle the updates, possibly there is a small window during the update process in which it "might" fail. Though looking at the temporary files that get created I would expect it to be a very small window.

Adma
Reply
#8
(2016-01-09, 15:42)adamsutton Wrote: @willemd I believe the latest "unstable" builds should now include libav support (using static ffmpeg lib).

Seems to be OK!

I'm running a Debian "testing" (i.e. codename "stretch") server, using the wheezy repository. So far, so good!
Reply
#9
It seems the autobuild thingy has stopped working. Last update was January 27th?
Reply
#10
Yes I noticed yesterday Sad unfortunately I've not had time to sort it out, will try and take a look at the weekend.

Basically it needs an overhaul / simplification to remove some of the horrible complexity inherited from the original way I set it up.

Adam
Reply
#11
After my Debian installation had it's apt-get updated, I get the following error when I try to update the package lists ('apt-get update').

Code:
W: Failed to fetch http://dl.bintray.com/tvheadend/deb/dists/jessie/Release  No Hash entry in Release file /var/lib/apt/lists/dl.bintray.com_tvheadend_deb_dists_jessie_Release, which is considered strong enough for security purposes
E: Some index files failed to download. They have been ignored, or old ones used instead.

I believe apt-get has been updated to allow only stronger encryption, and the server is not yet adjusted?

Is this something I can resolve myself or is it server related? (I'm guessing the latter.)


Edit: It seems to be fixed!
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
New Official Apt Repository00