Windows 10 - Kodi refresh rate change switching to wrong resolution
#31
I am very sorry that i own a 4k TV. Never thought that i make so much trouble. Maybe i throw it away and buy and old Full HD device Wink

And of course is your HTPC not switching to 4k on a 1080p HD TV.
Don't get me wrong, but your comment is useless.

Have you confirmations that other graphics cards (nvidia gtx 950) work?
Reply
#32
No confirmations. Windows 10 driver quality changes by release, which is sad - but we learned from Windows 10 :-(
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
#33
Thanks for your reply!
Then it makes no sense to buy an nvidia gtx 950.

You are right...that's sad...
Reply
#34
there is a simple fix for this using the DSplayer.

disable kodi refresh rate changer.

go to the madVR settings device -> "your device" -> display modes -> "list all display modes madVR may switch to:" and use this : 1080p23, 1080p24, 1080p50, 1080p59, 1080p60

if it still switches to 4096x2160 than your receiver should be the reason. and there are "workaround" for this too.

EDIT: i'm using a 960 with an UHD screen on windows 10 and i don't have issues.
Reply
#35
(2016-01-20, 08:44)huhn Wrote: there is a simple fix for this using the DSplayer.

disable kodi refresh rate changer.

go to the madVR settings device -> "your device" -> display modes -> "list all display modes madVR may switch to:" and use this : 1080p23, 1080p24, 1080p50, 1080p59, 1080p60

if it still switches to 4096x2160 than your receiver should be the reason. and there are "workaround" for this too.

EDIT: i'm using a 960 with an UHD screen on windows 10 and i don't have issues.

Thank you very much for your info. I will give it a try the next days.

One more question: have you tried the 960 with the dsplayer build and madVR or also with the official jarvis builds?
Reply
#36
(2016-01-21, 01:16)mo74 Wrote: Thank you very much for your info. I will give it a try the next days.

One more question: have you tried the 960 with the dsplayer build and madVR or also with the official jarvis builds?

doesn't matter if you setup your PC correct.

i only use kodi dsplayer for testing.

and with UHD to 1080p you can easily get in troubles. but everything is fine as long as you use 1080p only. and it looks like kodi can't handle DPI settings from windows.
Reply
#37
I bought yesterday a Samsung UE48JU7000 and I have been experiencing exactly the same problems explained in the first post while trying to work with 1920x1080 and Kodi auto TV refresh rate switch, specially when trying to change to 1080/24p

My device is a Tronsmart Ara X5 (integrated Intel GPU). I have been trying different things, and finally I have been able to fix it. These are the steps I have followed

* Download CRU 1.2.6 and run it.
* In "Detailed resolution" area, I had
3840x2160 @ 60.000 Hz (594.00 MHz) [+/+]
1920x1080 @ 60.000 Hz (148.50 MHz) [+/+]
Name: SAMSUNG
* I have selected the second one (1920x1080) and moved to the first position (using the up-arrow icon button), remaining the "Detailed resolution" section as:
1920x1080 @ 60.000 Hz (148.50 MHz) [+/+]
3840x2160 @ 60.000 Hz (594.00 MHz) [+/+]
Name: SAMSUNG
* Then, without changing anything else, OK and restart the system.

With this it seems that now the recommended screen resolution for the Windows is 1920x1080 instead of 3840x2160, and the GPU/TV doesn't make a mess while trying to change the refresh rate while in 1920x1080 mode.

That's all folks! I hope it can helps.
Reply
#38
Thumbs Up 
(2016-02-03, 22:38)xxDaViDxx Wrote: I bought yesterday a Samsung UE48JU7000 and I have been experiencing exactly the same problems explained in the first post while trying to work with 1920x1080 and Kodi auto TV refresh rate switch, specially when trying to change to 1080/24p

My device is a Tronsmart Ara X5 (integrated Intel GPU). I have been trying different things, and finally I have been able to fix it. These are the steps I have followed

* Download CRU 1.2.6 and run it.
* In "Detailed resolution" area, I had
3840x2160 @ 60.000 Hz (594.00 MHz) [+/+]
1920x1080 @ 60.000 Hz (148.50 MHz) [+/+]
Name: SAMSUNG
* I have selected the second one (1920x1080) and moved to the first position (using the up-arrow icon button), remaining the "Detailed resolution" section as:
1920x1080 @ 60.000 Hz (148.50 MHz) [+/+]
3840x2160 @ 60.000 Hz (594.00 MHz) [+/+]
Name: SAMSUNG
* Then, without changing anything else, OK and restart the system.

With this it seems that now the recommended screen resolution for the Windows is 1920x1080 instead of 3840x2160, and the GPU/TV doesn't make a mess while trying to change the refresh rate while in 1920x1080 mode.

That's all folks! I hope it can helps.

That seems to have done the trick on mine thanks very much for sharing your solution to this most annoying of problems.
Reply
#39
Wow great!! Thank you very much for your post !!
Reply
#40
Hi all,

I am experiencing the same issue with my Vizio D65u-D2 TV and Nvidia Geforce GTX 770. I have tried the steps mentioned using the CRU utility, however this doesn't seem to have the desired effect with the Nvidia drivers. All resolutions higher than 1080p get entirely disabled/removed. Any ideas what might be happening here?
Reply
#41
Tip for Nvidia users - use the custom resolution settings in the Nvidia control panel instead. CRU didn't seem to work.

My problem was that my display didn't support 1080p@25hz for the 25fps source material, and so Kodi was switching to the nearest resolution for which my display reported supporting 25hz (the wrong resolution for 1080p content). So I added a custom resolution of 50hz (display wouldn't do 1080p@25hz at all) and set Kodi to use this refresh rate for 25fps content in advancedsettings.xml.

Code:
<video>
  <adjustrefreshrate>
    <override>
      <fps>25.000</fps>
      <refresh>50.000</refresh>
    </override>
  </adjustrefreshrate>
</video>

Hope this helps someone.
Reply
#42
(2016-01-14, 22:23)afedchin Wrote: Seems something goes wrong in GPU drivers because Kodi selects resolution properly
Quote:20:41:08 T:6100 DEBUG: CRenderSystemDX::SetFullScreenInternal - Current display mode is: [email protected]
20:41:08 T:6100 DEBUG: CRenderSystemDX::SetFullScreenInternal - Found matched mode: [email protected]
20:41:08 T:6100 DEBUG: CRenderSystemDX::SetFullScreenInternal - Switching mode to [email protected].

Well, i´m on a AMD rig with A88 chipset and A10 APU and getting the exact same lines in the log.
Kodi would like to switch refreshrate to 24.000hz but it ends up @23.976 giving me droped Frames.

What´s crazy too: If i stop playback and return to kodi, kodi would like to set the refreshrate to 60hz. But the same Problem Returns and it ends up @59.940hz.

So in this thread is someone with Íntel VGA, another one with NViDia VGA and me with AMD VGA.
Should it still be a Driver Problem?
Ryzen5 2400g @gigabyte AorusM
Marantz AV7702/MM8003 Combo
Philips 55PFL8007k/12
Sony VW-270ES
Reply
#43
It is still driver problem but have you try latest Kodi Beta?
Reply
#44
Haven't tried v17 yet. I'm came from helix 14.2 to Jarvis 16.1 and recognised strange refresh rate changes when starting kodi or playing movies, and frame skipping on 24.000hz content which wasn't there using helix. Cause I upgraded from win7 to win10 the same time, I don't know if it's an windows or kodi problem.
What has changed in newest beta? Could it be the Microsoft PnP monitor driver causing this problem? Don't think three different gpu drivers from different manufacturers causing the same problem?!
Ryzen5 2400g @gigabyte AorusM
Marantz AV7702/MM8003 Combo
Philips 55PFL8007k/12
Sony VW-270ES
Reply
#45
Seems like you could add me to the list of people who have issue with refresh rate switching...

@afedchin: I am already on krypton nightly

http://forum.kodi.tv/showthread.php?tid=290779
Moanbag is in da place!
Reply

Logout Mark Read Team Forum Stats Members Help
Windows 10 - Kodi refresh rate change switching to wrong resolution0
This forum uses Lukasz Tkacz MyBB addons.