Thread Rating:
  • 0 Vote(s) - 0 Average
libCEC latest update on Ubuntu broke Kodi 17 CEC support
#1
Exclamation 
As of latest Ubuntu libCEC driver upgrade to version 3.1.0.1~trusty Kodi 17 Alpha 1 will stop working with CEC support. Solution until developers fix this issue is to force downgrade on ubuntu to driver 3.0.1-1~trusty.

In case you dont know how to do this below you will find sollution:
apt-get install --reinstall libcec3=3.0.1-1~trusty

Enjoy
Reply
#2
I have the same problem and i solve with your solution.

Ubuntu 14.04 with kodi 15.2 and Pulse height HDMI CEC-Adapter

Thanks again
Reply
#3
Your welcome. I am glad at least someone doesnt have to strugle finding sollution.

Anyhow here is how you can solvew this for any debian distribution (not just Ubuntu 14.04)

Get available version from apt cache:
apt-cache showpkg libcec

you will get something like this:
Reverse Depends:
libcec3:i386,libcec 2.2
libcec3:i386,libcec 2.2
libcec:i386,libcec
libcec3,libcec 2.2
libcec3,libcec 2.2
libcec3:i386,libcec 2.2
libcec3:i386,libcec 2.2
libcec2:i386,libcec 1.6
libcec2:i386,libcec 1.6
libcec:i386,libcec
libcec3,libcec 2.2
libcec3,libcec 2.2
libcec2,libcec 1.6
libcec2,libcec 1.6
Dependencies:
3.1.0.1~trusty - libcec3 (5 3.1.0.1~trusty) libcec:i386 (0 (null))
3.0.1-1~trusty - libcec3 (5 3.0.1-1~trusty) libcec:i386 (0 (null))
Provides:
3.1.0.1~trusty -
3.0.1-1~trusty -

Reverse Provides:
libcec3 3.0.1-1~trusty
libcec3 3.1.0.1~trusty
libcec2 2.2.0-2~trusty

check the version in bold trext

than just add wanted version after equal sign (=) in this command:
apt-get install --reinstall libcec3=add wanted version here

Enjoy
Reply
#4
I wrote 2 lines to the Pulse-eight website giving my debug log from kodi. And they sayd that is a kodi bug that load libcec 3.0 instead libcec 3.

That's my log:


16:26:12 T:139952490837952 DEBUG: LoadMappings - loaded node "Motorola Nyxboard Hybrid"
16:26:12 T:139952490837952 DEBUG: LoadMappings - loaded node "CEC Adapter"
16:26:12 T:139952490837952 DEBUG: LoadMappings - loaded node "Pulse-Eight CEC Adapter"
16:26:12 T:139952490837952 DEBUG: LoadMappings - loaded node "iMON HID device"
16:26:12 T:139952490837952 DEBUG: CPeripheralBusUSB - initialised udev monitor
16:26:12 T:139952490837952 DEBUG: SECTION:LoadDLL(libcec.so.3.0)
16:26:12 T:139952490837952 DEBUG: Loading: libcec.so.3.0
16:26:12 T:139952490837952 ERROR: Unable to load libcec.so.3.0, reason: libcec.so.3.0: cannot open shared object file: No such file or directory
16:26:12 T:139952490837952 DEBUG: Dll libcec.so.3.0 was not found in path
16:26:12 T:139952490837952 ERROR: Initialise - failed to initialise bus cec
16:26:12 T:139952490837952 DEBUG: GetMappingForDevice - device (2548:1002) mapped to Pulse-Eight CEC Adapter (type = cec)
16:26:12 T:139951993607936 NOTICE: Thread PeripBusUSBUdev start, auto delete: false
16:26:12 T:139952490837952 DEBUG: SECTION:LoadDLL(libcurl.so.4)
16:26:12 T:139952490837952 DEBUG: Loading: libcurl.so.4
Reply
#5
Its actualy not a bug. By the time they compiled kodi, there was no 3.1 version of libcec yet. I believe they will add/fix the correct version in future releases. Until than we will be forced to help each other with workarounds Wink
Reply
#6
Thank you very much
now CEC works again for me
ASUS E45M1-I Deluxe with 8GB RAM
Digital Devices Twin Tuner TV Karte DVB-S2
Lubuntu 16.04.3
KODI 17.5
Tvheadend 4.2.4-9
Reply
#7
just had the same problem with my pulse-eight Adapter when installing updates to Lubuntu, now working great with your solution.... thanks for posting your fix Smile
Reply
#8
I just update to kodi 16 Jarvis and still have this problem...
Reply
#9
Thanks I ran into this problem after upgrading to Jarvis. Thanks so much for posting a solution, it worked great for me!
Reply
#10
(2016-03-15, 16:29)lakram Wrote: Thanks I ran into this problem after upgrading to Jarvis.  Thanks so much for posting a solution, it worked great for me!

Hello everyone,

I used Ubuntu 14.04 with libcec3 3.0.1-1~trusty and the Pulse8 adapter worked well.

I now upgraded to Ubuntu 16.04 and the latest Kodi, and the adapter doesn't work anymore.

I have libcec4:

[email protected]:~$ sudo apt-cache showpkg libcec4
Package: libcec4
Versions: 
4.0.1.1~xenial (/var/lib/apt/lists/ppa.launchpad.net_team-xbmc_ppa_ubuntu_dists_xenial_main_binary-amd64_Packages) (/var/lib/dpkg/status)
 Description Language: 
                 File: /var/lib/apt/lists/ppa.launchpad.net_team-xbmc_ppa_ubuntu_dists_xenial_main_binary-amd64_Packages
                  MD5: d85ac50faaa9cffaa720cc9a95318e05
 Description Language: 
                 File: /var/lib/apt/lists/ppa.launchpad.net_team-xbmc_ppa_ubuntu_dists_xenial_main_binary-i386_Packages
                  MD5: d85ac50faaa9cffaa720cc9a95318e05
 Description Language: en
                 File: /var/lib/apt/lists/ppa.launchpad.net_team-xbmc_ppa_ubuntu_dists_xenial_main_i18n_Translation-en
                  MD5: d85ac50faaa9cffaa720cc9a95318e05


Reverse Depends: 
  libcec,libcec4 4.0.1.1~xenial
  libcec4:i386,libcec4 4.0.1.1~xenial
  libcec4:i386,libcec4 4.0.1.1~xenial
  libcec4-dev,libcec4 4.0.1.1~xenial
  python-libcec,libcec4 4.0.1.1~xenial
  kodi,libcec4
  cec-utils,libcec4 4.0.1.1~xenial

I also installed libcec3 to see if it works, however, I can't install the same version 3.0.1-1~trusty as in trusty, only 3.0.3~xenial.

I tried to remove libcec4, but I can't remove it without removing kodi too.

How can you work with the Pulse8 adapter and Kodi with Ubuntu 16.04 and the lastet Kodi version?
It seems that Kodi is using libcec4. How can I tell Kodi to use libcec3 instead?


Thanks.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
libCEC latest update on Ubuntu broke Kodi 17 CEC support00