Windows - HOW TO - Set up madVR for Kodi DSPlayer & External Players

  Thread Rating:
  • 3 Vote(s) - 4.67 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
Warner306 Offline
Posting Freak
Posts: 2,704
Joined: Feb 2014
Reputation: 92
Location: Canada
Post: #301
(2017-04-13 11:31)crestron Wrote:  I use the displaycal to build the 3dlut file,
Can be "convert HDR to SDR content by using an external 3DLUT" application,
Can not be "process HDR content by using an external 3DLUT" application,
Tip is "input and output format wrong", do not know where the problem?
how do it?

Try posting here: http://www.avsforum.com/forum/139-displa...llcms.html.

I'm not an expert on 3D LUTs.
find quote
Tyrindor2 Offline
Member
Posts: 69
Joined: May 2016
Reputation: 0
Post: #302
What's the best way to exit MPC-HC and go back to Kodi? I don't have a remote setup yet so I've just been right clicking (which causes screen to flicker due to go back to 60hz), then clicking exit. Is it better if I get a bluetooth adapter and pair my Harmony Elite to it?
(This post was last modified: 2017-04-14 17:05 by Tyrindor2.)
find quote
Moccafix Offline
Junior Member
Posts: 10
Joined: Apr 2017
Reputation: 0
Post: #303
Hello,

I installed Kodi 17 with dsplayer and madvr. The First Time i Played a file the System tray Icon from madvr occured and i was Able to configure. But now One Hour later the Icon Dosen't appear and i am not sure Kodi is Using the dsplayer. But in dsplayer Settings i enabled "use as the default Media Player". How Can i Check which Player is Used and why the madvr Icon doesnt appear? Video renderer i have madvr still used.

Can someone help me? Thanks!
find quote
Warner306 Offline
Posting Freak
Posts: 2,704
Joined: Feb 2014
Reputation: 92
Location: Canada
Post: #304
(2017-04-14 17:05)Tyrindor2 Wrote:  What's the best way to exit MPC-HC and go back to Kodi? I don't have a remote setup yet so I've just been right clicking (which causes screen to flicker due to go back to 60hz), then clicking exit. Is it better if I get a bluetooth adapter and pair my Harmony Elite to it?

Get an eHome IR receiver and program stop and exit to be the same key.

More here and here.
find quote
Warner306 Offline
Posting Freak
Posts: 2,704
Joined: Feb 2014
Reputation: 92
Location: Canada
Post: #305
(2017-04-14 17:38)Moccafix Wrote:  Hello,

I installed Kodi 17 with dsplayer and madvr. The First Time i Played a file the System tray Icon from madvr occured and i was Able to configure. But now One Hour later the Icon Dosen't appear and i am not sure Kodi is Using the dsplayer. But in dsplayer Settings i enabled "use as the default Media Player". How Can i Check which Player is Used and why the madvr Icon doesnt appear? Video renderer i have madvr still used.

Can someone help me? Thanks!

Press "O" during playback and observe if LAV Filters is being used.

Also, ensure you've chosen the madshi Video Renderer under DSPlayer settings.
(This post was last modified: 2017-04-14 19:24 by Warner306.)
find quote
Tyrindor2 Offline
Member
Posts: 69
Joined: May 2016
Reputation: 0
Post: #306
After doing this, my Kodi crashes when I attempt to exit it. I made a post here before I was sure of what was causing it: http://forum.kodi.tv/showthread.php?tid=312301

I believe the cause is: FATAL: CExternalPlayer::Process: Failed to restart AudioEngine after return from external player.

Pretty sure I followed the instructions to the dot. Everything is being bitstreamed via my Titan X to my Denon receiver.

My playercorefactory rules:
<playercorefactory>
<players>
<player name="MPC-HC" type="ExternalPlayer" audio="false" video="true">
<filename>C:\Program Files\MPC-HC\mpc-hc64.exe</filename>
<args>"{1}" /fullscreen /close</args>
<hidexbmc>false</hidexbmc>
<hideconsole>false</hideconsole>
<warpcursor>none</warpcursor>
<playcountminimumtime>600</playcountminimumtime>
</player>
</players>
<rules action="prepend">
<rule filetypes="mkv|avi|divx|ogm|mp4|mov|m4v|flv|m2v|mpeg|mpg|mts|m2ts|vob|bdmv|iso" player="MPC-HC">
<rule protocols="http|https" player="MPC-HC"/>
<rule protocols="daap|rtv|rtsp|rtmp|rtmpe|rtsp|mms|rtp|pvr" player="VideoPlayer"/>
</rule>
</rules>
</playercorefactory>
(This post was last modified: 2017-04-14 20:25 by Tyrindor2.)
find quote
Warner306 Offline
Posting Freak
Posts: 2,704
Joined: Feb 2014
Reputation: 92
Location: Canada
Post: #307
(2017-04-14 20:23)Tyrindor2 Wrote:  After doing this, my Kodi crashes when I attempt to exit it. I made a post here before I was sure of what was causing it: http://forum.kodi.tv/showthread.php?tid=312301

I believe the cause is: FATAL: CExternalPlayer::Process: Failed to restart AudioEngine after return from external player.

Pretty sure I followed the instructions to the dot. Everything is being bitstreamed via my Titan X to my Denon receiver.

My playercorefactory rules:
<playercorefactory>
<players>
<player name="MPC-HC" type="ExternalPlayer" audio="false" video="true">
<filename>C:\Program Files\MPC-HC\mpc-hc64.exe</filename>
<args>"{1}" /fullscreen /close</args>
<hidexbmc>false</hidexbmc>
<hideconsole>false</hideconsole>
<warpcursor>none</warpcursor>
<playcountminimumtime>600</playcountminimumtime>
</player>
</players>
<rules action="prepend">
<rule filetypes="mkv|avi|divx|ogm|mp4|mov|m4v|flv|m2v|mpeg|mpg|mts|m2ts|vob|bdmv|iso" player="MPC-HC">
<rule protocols="http|https" player="MPC-HC"/>
<rule protocols="daap|rtv|rtsp|rtmp|rtmpe|rtsp|mms|rtp|pvr" player="VideoPlayer"/>
</rule>
</rules>
</playercorefactory>

There's always DSPlayer...
find quote
Moccafix Offline
Junior Member
Posts: 10
Joined: Apr 2017
Reputation: 0
Post: #308
(2017-04-14 19:20)Warner306 Wrote:  
(2017-04-14 17:38)Moccafix Wrote:  Hello,

I installed Kodi 17 with dsplayer and madvr. The First Time i Played a file the System tray Icon from madvr occured and i was Able to configure. But now One Hour later the Icon Dosen't appear and i am not sure Kodi is Using the dsplayer. But in dsplayer Settings i enabled "use as the default Media Player". How Can i Check which Player is Used and why the madvr Icon doesnt appear? Video renderer i have madvr still used.

Can someone help me? Thanks!

Press "O" during playback and observe if LAV Filters is being used.

Also, ensure you've chosen the madshi Video Renderer under DSPlayer settings.

Under Video Decoder is "ff-h264-d3dd11va (hw). Here has to be lav? How Can i get it? Under Video renderer mashdi is enabled.
find quote
Moccafix Offline
Junior Member
Posts: 10
Joined: Apr 2017
Reputation: 0
Post: #309
(2017-04-14 19:20)Warner306 Wrote:  
(2017-04-14 17:38)Moccafix Wrote:  Hello,

I installed Kodi 17 with dsplayer and madvr. The First Time i Played a file the System tray Icon from madvr occured and i was Able to configure. But now One Hour later the Icon Dosen't appear and i am not sure Kodi is Using the dsplayer. But in dsplayer Settings i enabled "use as the default Media Player". How Can i Check which Player is Used and why the madvr Icon doesnt appear? Video renderer i have madvr still used.

Can someone help me? Thanks!

Press "O" during playback and observe if LAV Filters is being used.

Also, ensure you've chosen the madshi Video Renderer under DSPlayer settings.

Under Video Decoder is "ff-h264-d3dd11va (hw). Here has to be lav? How Can i get it? Under Video renderer mashdi is enabled.
find quote
Warner306 Offline
Posting Freak
Posts: 2,704
Joined: Feb 2014
Reputation: 92
Location: Canada
Post: #310
(2017-04-14 21:35)Moccafix Wrote:  
(2017-04-14 19:20)Warner306 Wrote:  
(2017-04-14 17:38)Moccafix Wrote:  Hello,

I installed Kodi 17 with dsplayer and madvr. The First Time i Played a file the System tray Icon from madvr occured and i was Able to configure. But now One Hour later the Icon Dosen't appear and i am not sure Kodi is Using the dsplayer. But in dsplayer Settings i enabled "use as the default Media Player". How Can i Check which Player is Used and why the madvr Icon doesnt appear? Video renderer i have madvr still used.

Can someone help me? Thanks!

Press "O" during playback and observe if LAV Filters is being used.

Also, ensure you've chosen the madshi Video Renderer under DSPlayer settings.

Under Video Decoder is "ff-h264-d3dd11va (hw). Here has to be lav? How Can i get it? Under Video renderer mashdi is enabled.

Don't know. Are you sure all settings match the set up guide? You are using VideoPlayer.
(This post was last modified: 2017-04-14 21:53 by Warner306.)
find quote
Tyrindor2 Offline
Member
Posts: 69
Joined: May 2016
Reputation: 0
Post: #311
(2017-04-14 21:03)Warner306 Wrote:  
(2017-04-14 20:23)Tyrindor2 Wrote:  After doing this, my Kodi crashes when I attempt to exit it. I made a post here before I was sure of what was causing it: http://forum.kodi.tv/showthread.php?tid=312301

I believe the cause is: FATAL: CExternalPlayer::Process: Failed to restart AudioEngine after return from external player.

Pretty sure I followed the instructions to the dot. Everything is being bitstreamed via my Titan X to my Denon receiver.

My playercorefactory rules:
<playercorefactory>
<players>
<player name="MPC-HC" type="ExternalPlayer" audio="false" video="true">
<filename>C:\Program Files\MPC-HC\mpc-hc64.exe</filename>
<args>"{1}" /fullscreen /close</args>
<hidexbmc>false</hidexbmc>
<hideconsole>false</hideconsole>
<warpcursor>none</warpcursor>
<playcountminimumtime>600</playcountminimumtime>
</player>
</players>
<rules action="prepend">
<rule filetypes="mkv|avi|divx|ogm|mp4|mov|m4v|flv|m2v|mpeg|mpg|mts|m2ts|vob|bdmv|iso" player="MPC-HC">
<rule protocols="http|https" player="MPC-HC"/>
<rule protocols="daap|rtv|rtsp|rtmp|rtmpe|rtsp|mms|rtp|pvr" player="VideoPlayer"/>
</rule>
</rules>
</playercorefactory>

There's always DSPlayer...

I was tempted to try that until i heard the author is done making it and it's running 17.0 instead of 17.1. Don't really want to rely on dead software.
find quote
Warner306 Offline
Posting Freak
Posts: 2,704
Joined: Feb 2014
Reputation: 92
Location: Canada
Post: #312
(2017-04-14 21:35)Moccafix Wrote:  
(2017-04-14 19:20)Warner306 Wrote:  
(2017-04-14 17:38)Moccafix Wrote:  Hello,

I installed Kodi 17 with dsplayer and madvr. The First Time i Played a file the System tray Icon from madvr occured and i was Able to configure. But now One Hour later the Icon Dosen't appear and i am not sure Kodi is Using the dsplayer. But in dsplayer Settings i enabled "use as the default Media Player". How Can i Check which Player is Used and why the madvr Icon doesnt appear? Video renderer i have madvr still used.

Can someone help me? Thanks!

Press "O" during playback and observe if LAV Filters is being used.

Also, ensure you've chosen the madshi Video Renderer under DSPlayer settings.

Under Video Decoder is "ff-h264-d3dd11va (hw). Here has to be lav? How Can i get it? Under Video renderer mashdi is enabled.

Try Jarvis 16.1. This is what I'm using: http://forum.kodi.tv/showthread.php?tid=...pid2327445.
find quote
gotham_x Offline
Fan
Posts: 407
Joined: Jun 2014
Reputation: 2
Location: The City of Darkness _@_Italy_@_
Post: #313
This is mine playercorefactory :

PHP Code:
<playercorefactory>
    <
players>
        <
player name="MPC-HC" type="ExternalPlayer" audio="false" video="true">
            <
filename>C:\Program Files\MPC-HC\MPC-HC64.exe</filename>
            <
args>"{1}" /fullscreen /close</args>
            <
hidexbmc>false</hidexbmc>
            <
hideconsole>false</hideconsole>
            <
warpcursor>none</warpcursor>
            <
playcountminimumtime>1140</playcountminimumtime>
        </
player>
        <
player name="MPC-BE" type="ExternalPlayer" audio="false" video="true">
            <
filename>C:\Program Files (x86)\MPC-BE\MPC-BE.exe</filename>
            <
args>"{1}" /fullscreen /close</args>
            <
hidexbmc>false</hidexbmc>
            <
hideconsole>false</hideconsole>
            <
warpcursor>none</warpcursor>
            <
playcountminimumtime>1140</playcountminimumtime>
        </
player>
        <
player name="PotPlayer" type="ExternalPlayer" audio="false" video="true">
            <
filename>C:\Program Files (x86)\DAUM\PotPlayer\PotPlayerMini.exe</filename>
            <
args>"{1}"</args>
            <
hidexbmc>false</hidexbmc>
            <
hideconsole>false</hideconsole>
            <
warpcursor>none</warpcursor>
            <
playcountminimumtime>1140</playcountminimumtime>
        </
player>
    </
players>
    </
playercorefactory


I have Added this rule , I would like to PotPlayer as player main


PHP Code:
<rules action="prepend">
        <
rule video="true" player="PotPlayerMini.exe">
            <
rule internetstream="true" player="DVDPlayer" /></rule>
    </
rules

but not It works , the player main is always DVDPlayer , some suggestion ?
(This post was last modified: 2017-04-25 20:45 by gotham_x.)
find quote
Warner306 Offline
Posting Freak
Posts: 2,704
Joined: Feb 2014
Reputation: 92
Location: Canada
Post: #314
(2017-04-25 20:42)gotham_x Wrote:  This is mine playercorefactory :

PHP Code:
<playercorefactory>
    <
players>
        <
player name="MPC-HC" type="ExternalPlayer" audio="false" video="true">
            <
filename>C:\Program Files\MPC-HC\MPC-HC64.exe</filename>
            <
args>"{1}" /fullscreen /close</args>
            <
hidexbmc>false</hidexbmc>
            <
hideconsole>false</hideconsole>
            <
warpcursor>none</warpcursor>
            <
playcountminimumtime>1140</playcountminimumtime>
        </
player>
        <
player name="MPC-BE" type="ExternalPlayer" audio="false" video="true">
            <
filename>C:\Program Files (x86)\MPC-BE\MPC-BE.exe</filename>
            <
args>"{1}" /fullscreen /close</args>
            <
hidexbmc>false</hidexbmc>
            <
hideconsole>false</hideconsole>
            <
warpcursor>none</warpcursor>
            <
playcountminimumtime>1140</playcountminimumtime>
        </
player>
        <
player name="PotPlayer" type="ExternalPlayer" audio="false" video="true">
            <
filename>C:\Program Files (x86)\DAUM\PotPlayer\PotPlayerMini.exe</filename>
            <
args>"{1}"</args>
            <
hidexbmc>false</hidexbmc>
            <
hideconsole>false</hideconsole>
            <
warpcursor>none</warpcursor>
            <
playcountminimumtime>1140</playcountminimumtime>
        </
player>
    </
players>
    </
playercorefactory


I have Added this rule , I would like to PotPlayer as player main


PHP Code:
<rules action="prepend">
        <
rule video="true" player="PotPlayerMini.exe">
            <
rule internetstream="true" player="DVDPlayer" /></rule>
    </
rules

but not It works , the player main is always DVDPlayer , some suggestion ?

Try changing the second rule. The player should say "PotPlayer" not "PotPlayerMini.exe." Also, you didn't mention if you are using 16.1 or 17.1. The default player in 17.1 is "VideoPlayer."
find quote
gotham_x Offline
Fan
Posts: 407
Joined: Jun 2014
Reputation: 2
Location: The City of Darkness _@_Italy_@_
Post: #315
with your suggestion I opened my eyes "PotPlayer" not "PotPlayerMini.exe." Resolved to external player main and "VideoPlayer." not "DVDPlayer" as rightly done observe because I'm running Kodi v17.1 “Krypton”
thanks.
find quote
Post Reply