•   
  • 1
  • 33
  • 34
  • 35
  • 36(current)
  • 37
  •   
Win HOW TO - Set up madVR for Kodi DSPlayer & External Players
(2019-08-08, 04:15)HomeTheatreGuru Wrote:
(2019-08-08, 04:02)MANswers Wrote:
(2019-08-08, 01:50)HomeTheatreGuru Wrote: His max rendering stats are also above 41ms and as a result there are dropped frames everywhere. 73 just in the opening shot, I’d say the settings are off.

@warner

I have successfully adjusted my chain to 8-bit RGB Full in NVIDIA settings, full range in madVR and also on the display (black levels set to high). It just works.

In saying that, I am still perplexed as to why any form of hardware decoding results in visible banding on my setup. I have tried internal and external LAV filters in mpc BE but as soon as hardware decoding is enabled it produces very visible banding. This is on a 2080 Ti.

Any ideas? I don’t mind using my CPU for software decoding (9900K so plenty of headroom) but would love to know the reason for banding issues as described above. 

There is definately a jitter. I do feel that, you do make sense. Can you help me with fixing this? what do i need to do, is this issue similar to what Warner mentions, or more needs to be done?

For starters, have you entered your TV’s supported resolutions and framerates under madVR display mode settings? See relevant section in the first post for details.

Thanks for your replies.
Mine is a 4k Samsung TV
Where do I find the exact settings of my TV that I need to add to madvr?
Reply
How does this look now?

Image

I have changed the resolution on my tv to 29Hz, and i see overall there is a lag or slowness. I dont see option in my madvr display section to change this to 29 hz.
Posting screenshots, please suggest.
I have a Nvidia 1080TI graphic card.

Image

Image

Image

Image

Image

Let me know if you want me to post any specific section of the Nvidia control panel.
Reply
You’re trying to play a 24p source on a 30p display which is causing the stutter.

As Warner had previously pointed out, you appear to be downscaling the image from 2160p to 1080p (why?) and the third screenshot of your setup doesn’t have any refresh rates listed for 1080p. So there is no switching happening.

You could add these (same refresh rates as 2160p) or you could stop downscaling the image to a lower resolution and play back natively.

Either way, change your native refresh rate back to 60 so that menu navigation is smooth.
Kodi Matrix 19.0 HDR Edition - Aeon MQ8 2.9.0 - RTX 2080 Ti - i9 9900K - LG C7 OLED - Setup
Reply
(2019-08-08, 01:50)HomeTheatreGuru Wrote:
(2019-08-08, 00:34)Warner306 Wrote:
(2019-08-07, 19:27)MANswers Wrote: How do i remove the OSD text appearing here on the player.

Image
As giulianoprs said, Ctrl + J.

If you are using a 4K display, you are downscaling to 1080p in that image. You are also outputting at 59.94 Hz rather than 23.796 Hz (matching the video frame rate, 23.976 fps). 

His max rendering stats are also above 41ms and as a result there are dropped frames everywhere. 73 just in the opening shot, I’d say the settings are off.

@warner

I have successfully adjusted my chain to 8-bit RGB Full in NVIDIA settings, full range in madVR and also on the display (black levels set to high). It just works.

In saying that, I am still perplexed as to why any form of hardware decoding results in visible banding on my setup. I have tried internal and external LAV filters in mpc BE but as soon as hardware decoding is enabled it produces very visible banding. This is on a 2080 Ti.

Any ideas? I don’t mind using my CPU for software decoding (9900K so plenty of headroom) but would love to know the reason for banding issues as described above.

I should note this is only happening with HDR files. I read somewhere that DXVA is not compatible with HDR? 

Hmmm, are you on Windows 1903? It had some universal banding issues with media playback that should soon be fixed. Did you try using other color space settings or setting the output bit depth to 8-bits as opposed to 12-bits?

The RTX cards have been problematic with madVR so far. I don't think they have the best driver support. But I haven't heard of rampant banding besides that introduced by Windows 1903, which was apparently hotfixed by Microsoft recently.

Is the banding obvious when playing the Spears & Munsil quantization test videos provided in the bit depths section? I find those videos are the easiest to use to see obvious banding. Is your display known to have any issues with banding? Are you using PC mode as the assigned input?
Reply
(2019-08-08, 04:01)MANswers Wrote:
(2019-08-08, 00:34)Warner306 Wrote:
(2019-08-07, 19:27)MANswers Wrote: How do i remove the OSD text appearing here on the player.

Image
As giulianoprs said, Ctrl + J.

If you are using a 4K display, you are downscaling to 1080p in that image. You are also outputting at 59.94 Hz rather than 23.796 Hz (matching the video frame rate, 23.976 fps).   

Thanks for the tip. How do i go about fixing this? Where do i need to go to fix this? I am sorry I am kind of a noob in this. It be great if you can just post the name of the application and the screenshot of the section where i need to change.  

That is the point of posting a guide. See the section on how to configure the GPU and display for media playback at the end of the RGB output levels section and move on to display modes to get the refresh rates right. I would recommend outputting everything at 8-bits for simplicity until you get everything working correctly. The instructions are detailed enough to get you to the end.

Edit: I looked at your screenshots. It looks like the GPU failed to switch to the correct display mode. Try setting the Nvidia Control Panel to 3840x2160 at 60 Hz and 8-bit RGB. I think you may have the GPU set to 1920x1080. You'll have to trust me that both 8-bits and 10-bits will look identical when using madVR because of the dithering. If you want to switch to 12-bits, you will have to live with a 30 Hz desktop or attempt to get the 12-bit display modes (all refresh rates that are under 30 Hz) to save in the Nvidia Control Panel and be called up when a video is played.
Reply
(2019-08-08, 13:22)Warner306 Wrote:
(2019-08-08, 01:50)HomeTheatreGuru Wrote:
(2019-08-08, 00:34)Warner306 Wrote: As giulianoprs said, Ctrl + J.

If you are using a 4K display, you are downscaling to 1080p in that image. You are also outputting at 59.94 Hz rather than 23.796 Hz (matching the video frame rate, 23.976 fps). 

His max rendering stats are also above 41ms and as a result there are dropped frames everywhere. 73 just in the opening shot, I’d say the settings are off.

@warner

I have successfully adjusted my chain to 8-bit RGB Full in NVIDIA settings, full range in madVR and also on the display (black levels set to high). It just works.

In saying that, I am still perplexed as to why any form of hardware decoding results in visible banding on my setup. I have tried internal and external LAV filters in mpc BE but as soon as hardware decoding is enabled it produces very visible banding. This is on a 2080 Ti.

Any ideas? I don’t mind using my CPU for software decoding (9900K so plenty of headroom) but would love to know the reason for banding issues as described above.

I should note this is only happening with HDR files. I read somewhere that DXVA is not compatible with HDR? 

Hmmm, are you on Windows 1903? It had some universal banding issues with media playback that should soon be fixed. Did you try using other color space settings or setting the output bit depth to 8-bits as opposed to 12-bits?

The RTX cards have been problematic with madVR so far. I don't think they have the best driver support. But I haven't heard of rampant banding besides that introduced by Windows 1903, which was apparently hotfixed by Microsoft recently.

Is the banding obvious when playing the Spears & Munsil quantization test videos provided in the bit depths section? I find those videos are the easiest to use to see obvious banding. Is your display known to have any issues with banding? Are you using PC mode as the assigned input?

I am on Windows 1903, yes. Hadn’t heard about the universal banding issue before. That would affect all players then, yes?

Haven’t run any test files yet, only parts of actual movies. The opening shot of Dunkirk is a great example where software decoding produces perfect clarity while hardware decoding turns the sky into a blocky mess. The display is LG’s C7 OLED which I haven’t heard much about in terms of banding. Bit depth is 8-bits in NVIDIA settings and madVR. Not using PC mode because it forces 4:4:4 subsampling on my unit which kills HDR at 60hz due to bandwidth requirements.

It might just be RTX cards not playing nice.
Kodi Matrix 19.0 HDR Edition - Aeon MQ8 2.9.0 - RTX 2080 Ti - i9 9900K - LG C7 OLED - Setup
Reply
(2019-08-09, 04:35)HomeTheatreGuru Wrote:
(2019-08-08, 13:22)Warner306 Wrote:
(2019-08-08, 01:50)HomeTheatreGuru Wrote: His max rendering stats are also above 41ms and as a result there are dropped frames everywhere. 73 just in the opening shot, I’d say the settings are off.

@warner

I have successfully adjusted my chain to 8-bit RGB Full in NVIDIA settings, full range in madVR and also on the display (black levels set to high). It just works.

In saying that, I am still perplexed as to why any form of hardware decoding results in visible banding on my setup. I have tried internal and external LAV filters in mpc BE but as soon as hardware decoding is enabled it produces very visible banding. This is on a 2080 Ti.

Any ideas? I don’t mind using my CPU for software decoding (9900K so plenty of headroom) but would love to know the reason for banding issues as described above.

I should note this is only happening with HDR files. I read somewhere that DXVA is not compatible with HDR? 

Hmmm, are you on Windows 1903? It had some universal banding issues with media playback that should soon be fixed. Did you try using other color space settings or setting the output bit depth to 8-bits as opposed to 12-bits?

The RTX cards have been problematic with madVR so far. I don't think they have the best driver support. But I haven't heard of rampant banding besides that introduced by Windows 1903, which was apparently hotfixed by Microsoft recently.

Is the banding obvious when playing the Spears & Munsil quantization test videos provided in the bit depths section? I find those videos are the easiest to use to see obvious banding. Is your display known to have any issues with banding? Are you using PC mode as the assigned input? 

I am on Windows 1903, yes. Hadn’t heard about the universal banding issue before. That would affect all players then, yes?

Haven’t run any test files yet, only parts of actual movies. The opening shot of Dunkirk is a great example where software decoding produces perfect clarity while hardware decoding turns the sky into a blocky mess. The display is LG’s C7 OLED which I haven’t heard much about in terms of banding. Bit depth is 8-bits in NVIDIA settings and madVR. Not using PC mode because it forces 4:4:4 subsampling on my unit which kills HDR at 60hz due to bandwidth requirements.

It might just be RTX cards not playing nice. 

If you are using Windows 1903, it might be this bug:

https://hub.displaycal.net/forums/topic/...dows-1903/

I've heard this issue has been fixed, but I don't know what build you need to have the fix.

Try using these two test videos to test for banding. Read the attached Readme to understand how to interpret the results:

https://drive.google.com/file/d/1ngYwwG5...Hyo_e/view
Reply
(2019-08-08, 13:25)Warner306 Wrote:
(2019-08-08, 04:01)MANswers Wrote:
(2019-08-08, 00:34)Warner306 Wrote: As giulianoprs said, Ctrl + J.

If you are using a 4K display, you are downscaling to 1080p in that image. You are also outputting at 59.94 Hz rather than 23.796 Hz (matching the video frame rate, 23.976 fps).   

Thanks for the tip. How do i go about fixing this? Where do i need to go to fix this? I am sorry I am kind of a noob in this. It be great if you can just post the name of the application and the screenshot of the section where i need to change.   

That is the point of posting a guide. See the section on how to configure the GPU and display for media playback at the end of the RGB output levels section and move on to display modes to get the refresh rates right. I would recommend outputting everything at 8-bits for simplicity until you get everything working correctly. The instructions are detailed enough to get you to the end.

Edit: I looked at your screenshots. It looks like the GPU failed to switch to the correct display mode. Try setting the Nvidia Control Panel to 3840x2160 at 60 Hz and 8-bit RGB. I think you may have the GPU set to 1920x1080. You'll have to trust me that both 8-bits and 10-bits will look identical when using madVR because of the dithering. If you want to switch to 12-bits, you will have to live with a 30 Hz desktop or attempt to get the 12-bit display modes (all refresh rates that are under 30 Hz) to save in the Nvidia Control Panel and be called up when a video is played. 
Warner, your inbox is full, I am trying to send you some more screenshots, can you please empty up some old msgs please?
Reply
It should be clear now. The inbox isn't very big.
Reply
(2019-08-10, 02:40)Warner306 Wrote: It should be clear now. The inbox isn't very big.

I get the same error, says your inbox is full and that you cannot receive new msgs.
Reply
I think it is fine now. I also had to empty the trash bin.
Reply
Hi all,

I am setting up Kodi with madvr for use on my projector utilising a scope screen. I enable the 'move OSD' to active viewing area and it works fine for movies that are appropriately labeled as either 2:40:1 or 2:37:1 etc however i have some movies that are scope format but kodi Recognizes them as 1:78:1 and the OSD is at the bottom of the screen.

Is there a way i can edit the aspect ratio flags for these movies?

Cheers
Reply
Are you talking about the setting in DSPlayer or madVR? If it's madVR, you can add a filename tag and use a rule such as this:

if (fileName = "*customname*") or (ar > 1.9) "21:9"
else "16:9"

Otherwise, you should configure the Windows desktop for a scope resolution, add those resolutions to display modes in madVR, set up screen config and zoom control for fixed CIH and find a Kodi skin that looks right in the 21:9 format.
Reply
(2019-08-13, 20:42)Warner306 Wrote: Are you talking about the setting in DSPlayer or madVR? If it's madVR, you can add a filename tag and use a rule such as this:

if (fileName = "*customname*") or (ar > 1.9) "21:9"
else "16:9"

Otherwise, you should configure the Windows desktop for a scope resolution, add those resolutions to display modes in madVR, set up screen config and zoom control for fixed CIH and find a Kodi skin that looks right in the 21:9 format.
I am talking about the option is DsPlayer,

I dont really want to mucj around with custom resolutions etc i just want to be able to change the aspect ratio kodi identifies the movie as.

As i will be in a batcave enviroment having the osd go off the screen will be extremley annoying. It works great for the movies with the appropriate aspect ratio tags attached however the scope movies that have the 1:78:1 tag are going to be an issue.
Reply
If Kodi is the issue, the only option I can think of is exporting your video library, manually editing the exported NFO files and refreshing the library with the edited NFOs.
Reply
  •   
  • 1
  • 33
  • 34
  • 35
  • 36(current)
  • 37
  •   
 
Thread Rating:
  • 5 Vote(s) - 4 Average



Logout Mark Read Team Forum Stats Members Help
HOW TO - Set up madVR for Kodi DSPlayer & External Players45