Kodi IP is 169.254.x.x
#1
Kodi is showing my IP as 169.254.x.x and is not the same as the network IP in Network and Sharing Center

How to fix this?

Currently Kore is not detecting Kodi because of this reason.
Reply
#2
169.* Are imaginary addresses typically given when dhcp didn't work. You either need to fix your connectivity to your dhcp or configure your ip address in your operating system.
If I have helped you or increased your knowledge, click the 'thumbs up' button to give thanks :) (People with less than 20 posts won't see the "thumbs up" button.)
Reply
#3
Yeah your network is borked.
Reply
#4
(2016-02-09, 03:26)Derek Wrote: Yeah your network is borked.

How?

I have no issues with connecting to the internet.

My IPV4 is showing correctly as 192.168.x.x
IP is auto assigned.

DHCP is enable

The only problem is Kodi is showing it as 169.x.x.x
Reply
#5
(2016-02-09, 03:21)nickr Wrote: 169.* Are imaginary addresses typically given when dhcp didn't work. You either need to fix your connectivity to your dhcp or configure your ip address in your operating system.

Yes, I read it is when there is a problem with DHCP.

But I am getting correct LAN IP assigned in network and sharing center

It is Kodi that is not showing the same IP.
Reply
#6
The only time I ever see that is in people that are using shifty/illegal addons which break their install. Post a a debug log to confirm.
Reply
#7
Okay I solved this..

thanks for the replies.
Reply
#8
Heita: yeah sounds plausable or maybe if your linking ethernet and wifi to bridge connections or such like was that the case madmax2?
Reply
#9
(2016-02-09, 17:42)Derek Wrote: Heita: yeah sounds plausable or maybe if your linking ethernet and wifi to bridge connections or such like was that the case madmax2?

No it has nothing to do with illegal addons, or anything to do with DHCP etc..

There was a second adapter (TAP LAN adapter) installed by a VPN software, and for some reason Kodi won't get the proper LAN IP address if this adapter is enabled.

When I disabled the adapter it showed the correct IP.

==
Is there a way to keep the TAP Adapter enabled and still have Kodi show the correct IP?
Reply
#10
Can you share how you did solve it, just in case anyone else in the future has the same issue and may be looking for a solution?
| Banned add-ons (wiki) | Forum rules (wiki) | VPN policy (wiki) | First time user (wiki) | FAQs (wiki) | Troubleshooting (wiki) | Add-ons (wiki) | Free content (wiki) | Debug Log (wiki) | Free Movies/TV Shows |
Reply
#11
(2016-02-09, 23:21)madmax2 Wrote:
(2016-02-09, 17:42)Derek Wrote: Heita: yeah sounds plausable or maybe if your linking ethernet and wifi to bridge connections or such like was that the case madmax2?

No it has nothing to do with illegal addons, or anything to do with DHCP etc..

There was a second adapter (TAP LAN adapter) installed by a VPN software, and for some reason Kodi won't get the proper LAN IP address if this adapter is enabled.

When I disabled the adapter it showed the correct IP.

==
Is there a way to keep the TAP Adapter enabled and still have Kodi show the correct IP?
I'd contact your VPN provider with that question.
Nvidia ShieldTV+Leia 
Reply
#12
I didnt mention anything illegal, i said it could be todo with bridging connections or such like and as said its a VPN issue.

Not sure if theres a way to start xbmc with a specific IP ALTHO all ip's on your machine work via kodi whichever is displayed in the settings.

I have 4 ip's on my PC 3 local and one VPN and i can contact PC's on all the networks via Kodi, well at lease the 192.168.0.x, 192.168.1.x and 192.168.2.x; ive never had need to try the VPN network as there's no shares available just virtual machines.

Also the 192.168.0.x has an external real internet IP associated which im sure would be usable,
Reply
#13
(2016-02-10, 00:26)Derek Wrote: I didnt mention anything illegal, i said it could be todo with bridging connections or such like and as said its a VPN issue.

Not sure if theres a way to start xbmc with a specific IP ALTHO all ip's on your machine work via kodi whichever is displayed in the settings.

I have 4 ip's on my PC 3 local and one VPN and i can contact PC's on all the networks via Kodi, well at lease the 192.168.0.x, 192.168.1.x and 192.168.2.x; ive never had need to try the VPN network as there's no shares available just virtual machines.

Also the 192.168.0.x has an external real internet IP associated which im sure would be usable,


I meant what Helta said about illegal addons.

I occasionally used a VPN provider software which installed that extra Adapter, and kodi will not get the local IP address if that adapter is enabled.

Not sure how to get Kodi to work with that adapter enabled.

==
Sorry, I didn't know what you meant when you said ethernet and wifi to bridge connections..

But I just a flash of insight and just looked at my network adapters.
I decided to disable the TAP adapter and tested Kodi, and voila it showed correct IP.

===
Now how to enable both adapters and have Kodi use the LAN adapter IP address?

If any one can solve this then please update this thread.
Reply
#14
(2016-02-09, 23:24)DarrenHill Wrote: Can you share how you did solve it, just in case anyone else in the future has the same issue and may be looking for a solution?

Yes..

There was a second adapter (TAP LAN adapter) installed by a VPN software provider, and for some reason Kodi won't get the proper LAN IP address if this adapter is enabled.

When I disabled the adapter it showed the correct IP.

==
Is there a way to keep the TAP Adapter enabled and still have Kodi show the correct IP?

If anyone can find a solution to this, then please update this thread.
Reply
#15
But does it effect Kodi? It can have multiple IP's i believe as mine displays my ethernet 192.168.1.8 in the system tab but i can connect my wifi remote from android to the 192.168.0.8 address.

I can also connect shares from 192.168.1.x network and 192.168.2.x network so is it just a cosmetic thing?
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Kodi IP is 169.254.x.x00