• 1(current)
  • 2
  • 3
  • 4
  • 5
  • 123
  • Next 
 
Thread Rating:
  • 2 Vote(s) - 5 Average
Work in Progress - Ember Media Manager 1.4.8.0 ALPHA - Discussion Thread
#1
Please don't install Ember under "C:\Program Files", unless you know how to fix the access rights.

Please use this thread for discussions about self-compiled versions or official alpha releases.

Ember Media Manager 1.4.8.0 Alpha 23.3 x64 - 2017-03-07
Ember Media Manager 1.4.8.0 Alpha 23.3 x86 - 2017-03-07
Commits (Changelog): Link
Reply
#2
Hi,
I have been testing the Kodi sync option and for the most part it seems to be working fine. However, I have come across one issue when syncing movie sets with Kodi Helix 14.1. The sync option states that is was successful and there are no errors in either the EMM or Kodi logs but clearly something didn't work properly. The poster is a film strip and everything else appears as if there is no art. I tried the same process with Kodi Isengard 15 and everything worked as expected. Syncing movies works fine in both versions.
Using Tapatalk
Reply
#3
Should the "Tag Manager" be functioning? When I select it from the Tools menu it starts, however, where the Movie Ttitles should be there is only a selection box with a check mark, the titles are not there.
Using Tapatalk
Reply
#4
I have several movies that have an audio codec of A_TRUEHD which EMM does not handle. I added and entry to the "Audio & Video Codec Mapping" table to translate from "A_TRUEHD" to "truehd". In version 1.4.7.2 the reults are:

Audio Stream 1
- Codec: truehd
- Channels: 8
- Language: English

which provide the expected results. However, in the 1.4.8 Alpha the same table entry and re-scraping of the meta data results in:

Audio Stream 1
- Codec: truehd
- Channels: Object Based / 8
- Language: English

which results in the wrong display in EMM. The .NFO file updated by EMM contains;


<audio>
<channels>Object Based / 8</channels>
<codec>truehd</codec>
<language>eng</language>
<longlanguage>English</longlanguage>
</audio>


Both versions of EMM are reading the same .MKV file. It appears that since "Channels" is not numeric EMM is not recognizing this as an audio stream.

In addition, after playing the movie in Kodi it shows the following in the .NFO file

<audio>
<codec>truehd</codec>
<language>eng</language>
<channels>8</channels>
</audio>
Using Tapatalk
Reply
#5
(2016-02-10, 22:17)hslansky Wrote: I have several movies that have an audio codec of A_TRUEHD which EMM does not handle. I added and entry to the "Audio & Video Codec Mapping" table to translate from "A_TRUEHD" to "truehd". In version 1.4.7.2 the reults are:

Audio Stream 1
- Codec: truehd
- Channels: 8
- Language: English

which provide the expected results. However, in the 1.4.8 Alpha the same table entry and re-scraping of the meta data results in:

Audio Stream 1
- Codec: truehd
- Channels: Object Based / 8
- Language: English

which results in the wrong display in EMM. The .NFO file updated by EMM contains;


<audio>
<channels>Object Based / 8</channels>
<codec>truehd</codec>
<language>eng</language>
<longlanguage>English</longlanguage>
</audio>


Both versions of EMM are reading the same .MKV file. It appears that since "Channels" is not numeric EMM is not recognizing this as an audio stream.

In addition, after playing the movie in Kodi it shows the following in the .NFO file

<audio>
<codec>truehd</codec>
<language>eng</language>
<channels>8</channels>
</audio>

There might be a problem with the Regex we are using... can you do me a favor and scan the movie directly in Mediainfo and post the XML file here? Like I described here: http://forum.kodi.tv/showthread.php?tid=...pid2195593
Image
Reply
#6
(2016-02-11, 22:49)Cocotus Wrote:
(2016-02-10, 22:17)hslansky Wrote: I have several movies that have an audio codec of A_TRUEHD which EMM does not handle. I added and entry to the "Audio & Video Codec Mapping" table to translate from "A_TRUEHD" to "truehd". In version 1.4.7.2 the reults are:

Audio Stream 1
- Codec: truehd
- Channels: 8
- Language: English

which provide the expected results. However, in the 1.4.8 Alpha the same table entry and re-scraping of the meta data results in:

Audio Stream 1
- Codec: truehd
- Channels: Object Based / 8
- Language: English

which results in the wrong display in EMM. The .NFO file updated by EMM contains;


<audio>
<channels>Object Based / 8</channels>
<codec>truehd</codec>
<language>eng</language>
<longlanguage>English</longlanguage>
</audio>


Both versions of EMM are reading the same .MKV file. It appears that since "Channels" is not numeric EMM is not recognizing this as an audio stream.

In addition, after playing the movie in Kodi it shows the following in the .NFO file

<audio>
<codec>truehd</codec>
<language>eng</language>
<channels>8</channels>
</audio>

There might be a problem with the Regex we are using... can you do me a favor and scan the movie directly in Mediainfo and post the XML file here? Like I described here: http://forum.kodi.tv/showthread.php?tid=...pid2195593

Here is the output from MediaInfo 0.7.82. I am pretty sure that this movie has a Dolby Atmos sound track

Code:
<?xml version="1.0" encoding="UTF-8"?>
<Mediainfo
    version="0.1"
    ref="P:\HT Media Library\Blu Rays\The Hunger Games - Mockingjay Part 1 (2014)\The Hunger Games - Mockingjay Part 1 (2014).mkv">
<File>
<track type="General">
<UniqueID_String>315354862697928897916751264317182598851 (0xED3F23274280C36D6D9E5E914E885EC3)</UniqueID_String>
<CompleteName>P:\HT Media Library\Blu Rays\The Hunger Games - Mockingjay Part 1 (2014)\The Hunger Games - Mockingjay Part 1 (2014).mkv</CompleteName>
<Format>Matroska</Format>
<Format_Version>Version 2</Format_Version>
<FileSize_String>21.4 GiB</FileSize_String>
<Duration_String>2h 2mn</Duration_String>
<OverallBitRate_Mode_String>Variable</OverallBitRate_Mode_String>
<OverallBitRate_String>24.9 Mbps</OverallBitRate_String>
<Movie>The Hunger Games: Mockingjay - Part 1</Movie>
<Encoded_Date>UTC 2015-03-06 21:23:03</Encoded_Date>
<Encoded_Application_String>MakeMKV v1.9.1 win(x64-release)</Encoded_Application_String>
<Encoded_Library_String>libmakemkv v1.9.1 (1.3.0/1.4.1) win(x64-release)</Encoded_Library_String>
</track>

<track type="Video">
<ID_String>1</ID_String>
<Format>AVC</Format>
<Format_Info>Advanced Video Codec</Format_Info>
<Format_Profile>[email protected]</Format_Profile>
<Format_Settings_CABAC_String>Yes</Format_Settings_CABAC_String>
<Format_Settings_RefFrames_String>4 frames</Format_Settings_RefFrames_String>
<CodecID>V_MPEG4/ISO/AVC</CodecID>
<Duration_String>2h 2mn</Duration_String>
<BitRate_Mode_String>Variable</BitRate_Mode_String>
<BitRate_Maximum_String>35.8 Mbps</BitRate_Maximum_String>
<Width_String>1 920 pixels</Width_String>
<Height_String>1 080 pixels</Height_String>
<DisplayAspectRatio_String>16:9</DisplayAspectRatio_String>
<FrameRate_Mode_String>Constant</FrameRate_Mode_String>
<FrameRate_String>23.976 (24000/1001) fps</FrameRate_String>
<ColorSpace>YUV</ColorSpace>
<ChromaSubsampling>4:2:0</ChromaSubsampling>
<BitDepth_String>8 bits</BitDepth_String>
<ScanType_String>Progressive</ScanType_String>
<Language_String>English</Language_String>
<Default_String>No</Default_String>
<Forced_String>No</Forced_String>
</track>

<track type="Audio" typeorder="1">
<ID_String>2</ID_String>
<Format>Atmos / TrueHD</Format>
<CodecID>A_TRUEHD</CodecID>
<BitRate_Mode_String>Variable</BitRate_Mode_String>
<BitRate_Maximum_String>7 719 Kbps</BitRate_Maximum_String>
<Channel_s__String>Object Based / 8 channels</Channel_s__String>
<ChannelPositions>Object Based / Front: L C R, Side: L R, Back: L R, LFE</ChannelPositions>
<SamplingRate_String> / 48.0 KHz</SamplingRate_String>
<FrameRate_String>1 200.000 fps (40 spf)</FrameRate_String>
<BitDepth_String>24 bits</BitDepth_String>
<Compression_Mode_String>Lossless</Compression_Mode_String>
<Title>Surround 7.1</Title>
<Language_String>English</Language_String>
<Default_String>Yes</Default_String>
<Forced_String>No</Forced_String>
</track>

<track type="Audio" typeorder="2">
<ID_String>3</ID_String>
<Format>AC-3</Format>
<Format_Info>Audio Coding 3</Format_Info>
<Format_Settings_ModeExtension>CM (complete main)</Format_Settings_ModeExtension>
<Format_Settings_Endianness>Big</Format_Settings_Endianness>
<CodecID>A_AC3</CodecID>
<Duration_String>2h 2mn</Duration_String>
<BitRate_Mode_String>Constant</BitRate_Mode_String>
<BitRate_String>640 Kbps</BitRate_String>
<Channel_s__String>6 channels</Channel_s__String>
<ChannelPositions>Front: L C R, Side: L R, LFE</ChannelPositions>
<SamplingRate_String>48.0 KHz</SamplingRate_String>
<FrameRate_String>31.250 fps (1536 spf)</FrameRate_String>
<Compression_Mode_String>Lossy</Compression_Mode_String>
<StreamSize_String>562 MiB (3%)</StreamSize_String>
<Title>Surround 5.1</Title>
<Language_String>English</Language_String>
<Default_String>No</Default_String>
<Forced_String>No</Forced_String>
</track>

<track type="Audio" typeorder="3">
<ID_String>4</ID_String>
<Format>AC-3</Format>
<Format_Info>Audio Coding 3</Format_Info>
<Format_Profile>Dolby Digital</Format_Profile>
<Format_Settings_ModeExtension>CM (complete main)</Format_Settings_ModeExtension>
<Format_Settings_Endianness>Big</Format_Settings_Endianness>
<CodecID>A_AC3</CodecID>
<Duration_String>2h 2mn</Duration_String>
<BitRate_Mode_String>Constant</BitRate_Mode_String>
<BitRate_String>224 Kbps</BitRate_String>
<Channel_s__String>2 channels</Channel_s__String>
<ChannelPositions>Front: L R</ChannelPositions>
<SamplingRate_String>48.0 KHz</SamplingRate_String>
<FrameRate_String>31.250 fps (1536 spf)</FrameRate_String>
<Compression_Mode_String>Lossy</Compression_Mode_String>
<StreamSize_String>197 MiB (1%)</StreamSize_String>
<Title>Stereo</Title>
<Language_String>English</Language_String>
<Default_String>No</Default_String>
<Forced_String>No</Forced_String>
</track>

<track type="Audio" typeorder="4">
<ID_String>5</ID_String>
<Format>AC-3</Format>
<Format_Info>Audio Coding 3</Format_Info>
<Format_Profile>Dolby Digital</Format_Profile>
<Format_Settings_ModeExtension>CM (complete main)</Format_Settings_ModeExtension>
<Format_Settings_Endianness>Big</Format_Settings_Endianness>
<CodecID>A_AC3</CodecID>
<Duration_String>2h 2mn</Duration_String>
<BitRate_Mode_String>Constant</BitRate_Mode_String>
<BitRate_String>224 Kbps</BitRate_String>
<Channel_s__String>2 channels</Channel_s__String>
<ChannelPositions>Front: L R</ChannelPositions>
<SamplingRate_String>48.0 KHz</SamplingRate_String>
<FrameRate_String>31.250 fps (1536 spf)</FrameRate_String>
<Compression_Mode_String>Lossy</Compression_Mode_String>
<StreamSize_String>197 MiB (1%)</StreamSize_String>
<Title>Stereo</Title>
<Language_String>English</Language_String>
<Default_String>No</Default_String>
<Forced_String>No</Forced_String>
</track>

<track type="Audio" typeorder="5">
<ID_String>6</ID_String>
<Format>DTS</Format>
<Format_Info>Digital Theater Systems</Format_Info>
<Format_Settings_Mode>16</Format_Settings_Mode>
<Format_Settings_Endianness>Big</Format_Settings_Endianness>
<CodecID>A_DTS</CodecID>
<Duration_String>2h 2mn</Duration_String>
<BitRate_Mode_String>Constant</BitRate_Mode_String>
<BitRate_String>768 Kbps</BitRate_String>
<Channel_s__String>2 channels</Channel_s__String>
<ChannelPositions>Front: L R</ChannelPositions>
<SamplingRate_String>48.0 KHz</SamplingRate_String>
<FrameRate_String>93.750 fps (512 spf)</FrameRate_String>
<BitDepth_String>24 bits</BitDepth_String>
<Compression_Mode_String>Lossy</Compression_Mode_String>
<StreamSize_String>675 MiB (3%)</StreamSize_String>
<Title>Stereo</Title>
<Language_String>English</Language_String>
<Default_String>No</Default_String>
<Forced_String>No</Forced_String>
</track>

<track type="Audio" typeorder="6">
<ID_String>7</ID_String>
<Format>AC-3</Format>
<Format_Info>Audio Coding 3</Format_Info>
<Format_Profile>Dolby Digital</Format_Profile>
<Format_Settings_ModeExtension>CM (complete main)</Format_Settings_ModeExtension>
<Format_Settings_Endianness>Big</Format_Settings_Endianness>
<CodecID>A_AC3</CodecID>
<Duration_String>2h 2mn</Duration_String>
<BitRate_Mode_String>Constant</BitRate_Mode_String>
<BitRate_String>224 Kbps</BitRate_String>
<Channel_s__String>2 channels</Channel_s__String>
<ChannelPositions>Front: L R</ChannelPositions>
<SamplingRate_String>48.0 KHz</SamplingRate_String>
<FrameRate_String>31.250 fps (1536 spf)</FrameRate_String>
<Compression_Mode_String>Lossy</Compression_Mode_String>
<StreamSize_String>197 MiB (1%)</StreamSize_String>
<Title>Stereo</Title>
<Language_String>English</Language_String>
<Default_String>No</Default_String>
<Forced_String>No</Forced_String>
</track>

<track type="Text" typeorder="1">
<ID_String>8</ID_String>
<Format>PGS</Format>
<CodecID>S_HDMV/PGS</CodecID>
<CodecID_Info>Picture based subtitle format used on BDs/HD-DVDs</CodecID_Info>
<Language_String>English</Language_String>
<Default_String>No</Default_String>
<Forced_String>No</Forced_String>
</track>

<track type="Text" typeorder="2">
<ID_String>10</ID_String>
<Format>PGS</Format>
<CodecID>S_HDMV/PGS</CodecID>
<CodecID_Info>Picture based subtitle format used on BDs/HD-DVDs</CodecID_Info>
<Language_String>English</Language_String>
<Default_String>No</Default_String>
<Forced_String>No</Forced_String>
</track>

<track type="Menu">
<_00_00_00000>en:Chapter 01</_00_00_00000>
<_00_08_43648>en:Chapter 02</_00_08_43648>
<_00_15_02818>en:Chapter 03</_00_15_02818>
<_00_22_56083>en:Chapter 04</_00_22_56083>
<_00_29_52457>en:Chapter 05</_00_29_52457>
<_00_36_45745>en:Chapter 06</_00_36_45745>
<_00_42_34969>en:Chapter 07</_00_42_34969>
<_00_50_33989>en:Chapter 08</_00_50_33989>
<_00_56_31012>en:Chapter 09</_00_56_31012>
<_01_02_14897>en:Chapter 10</_01_02_14897>
<_01_09_27830>en:Chapter 11</_01_09_27830>
<_01_17_37069>en:Chapter 12</_01_17_37069>
<_01_25_10105>en:Chapter 13</_01_25_10105>
<_01_34_20946>en:Chapter 14</_01_34_20946>
<_01_41_33796>en:Chapter 15</_01_41_33796>
<_01_47_20100>en:Chapter 16</_01_47_20100>
</track>

</File>
</Mediainfo>
Using Tapatalk
Reply
#7
Thanks, that helped! For channels Ember read the "Channel_s" informatione of MediaInfo Output.
Now I noticed the strange Object based string is already returned by MediaInfo:

Quote:<Channel_s__String>Object Based / 8 channels</Channel_s__String>
<ChannelPositions>Object Based / Front: L C R, Side: L R, Back: L R, LFE</ChannelPositions>

We are expecting format "number / number" here I think. I will take a look at this this evening and report back Smile
Image
Reply
#8
Not sure if this mat be a translate problem but i noticed the movie sorting is shifting the word "die" to the back of the title in english as if it were the word "the"
eg die hard is showing as hard, die
Reply
#9
I had some questions related to the Kodi sync process. By definition sync would mean two way communication, so other than updating Kodi with the artwork in EMM what does the sync process do? What information is taken from Kodi and updated in EMM? What is the purpose of real-time sync?
Using Tapatalk
Reply
#10
(2016-02-12, 17:11)mockandholler Wrote: ...the movie sorting is shifting the word "die" to the back of the title in english as if it were the word "the"
eg die hard is showing as hard, die
Check "Sort Tokens to Ignore" in Settings - Movies - General. I expect you will find the token "die" in that list. It is the German word for "the".
If you remove that token from the list it should be fine.
Reply
#11
(2016-02-12, 17:44)hslansky Wrote: I had some questions related to the Kodi sync process. By definition sync would mean two way communication, so other than updating Kodi with the artwork in EMM what does the sync process do? What information is taken from Kodi and updated in EMM? What is the purpose of real-time sync?

Real-time sync means that an element will be synced automatically after each edit or rescrape. Whitout real-time sync you have to to that manually via context menu in Ember.
To only thing that will be synced from Kodi back to Ember is the playcount (watched state) and lastplayed, but only if you have set a host for playcount sync in settings.
Reply
#12
cool thanks
Reply
#13
Is there a way to restrict Movie Sets to sets that have a minimum of two movies in the set?
Reply
#14
(2016-02-14, 15:27)Monk Wrote: Is there a way to restrict Movie Sets to sets that have a minimum of two movies in the set?

You can within kodi

Image
HTPC
PC: Home Built
Processor: i7 6700k
GPU: GTX 980 ti
Ram: 16GB DDR4
XBMC: Kodi Jarvis
Skin: Aeon Badnox Beta


Reply
#15
"Error creating window handle" while scraping season fanart. Let me know what info you need to sort this bug.
Reply
  • 1(current)
  • 2
  • 3
  • 4
  • 5
  • 123
  • Next 



Ember Media Manager 1.4.8.0 ALPHA - Discussion Thread52