•   
  • 1
  • 146
  • 147
  • 148(current)
  • 149
  • 150
  • 163
  •   
WIP -  Ember Media Manager 1.4.8.0 ALPHA - Discussion Thread
Hello dan!

Do you have plans for the future to add a language identifier for renaming subs and add the language code?
Reply
Hello all, i was using EMM for years without problems, yesterday i was upgrading version 1.4.7.2 to 1.4.8 everything was ok with the upgrade, but when i enter to EMM settings are gone
i was looking in profile/default an saw 5 .emm files (database files i think)
and the last two files are Myvideos43.emm with 146,432 bytes and Myvideos43.emm_tmp 14,262,272 bytes so i think something went wrong upgrading database and thats why i have a smaller .emm file and bigger .emm_temp file
So, anyone know what can i do to fix this error? I also have a backup of the version 1.4.7.2 files, and tested and worked fine

thanks in advanced temuy
PSConfusedorry for me english still learning
Reply
(2018-03-07, 16:28)temuy Wrote: Hello all, i was using EMM for years without problems, yesterday i was upgrading version 1.4.7.2 to 1.4.8 everything was ok with the upgrade, but when i enter to EMM settings are gone
i was looking in profile/default an saw 5 .emm files (database files i think)
and the last two files are Myvideos43.emm with 146,432 bytes and Myvideos43.emm_tmp 14,262,272 bytes so i think something went wrong upgrading database and thats why i have a smaller .emm file and bigger .emm_temp file
So, anyone know what can i do to fix this error? I also have a backup of the version 1.4.7.2 files, and tested and worked fine

thanks in advanced temuy
PSConfusedorry for me english still learning
First, you should use the latest daily build: Link 

*.emm_tmp will be build while Ember tries to upgrade your database. If Ember get an error while upgrading, a new database will be created. That's the small MyVideos43.emm. To old one which Ember upgrades from is still there and has a lower number then 43.
Please delete MyVideos43.emm and also MyVideos43.emm_tmp, install the latest daily build and try it again. If the database upgrade on the first start also ends in an empty database then post the latest log (.\Ember Media Manager\Logs) on http://pastebin.com so I can look what's the problem in your old database.
German Ember Media Manager Support

Daily Builds - Link
Latest official Ember-MM version - Ember Media Manager 1.4.x
Reply
(2018-03-07, 17:07)DanCooper Wrote:
(2018-03-07, 16:28)temuy Wrote: Hello all, i was using EMM for years without problems, yesterday i was upgrading version 1.4.7.2 to 1.4.8 everything was ok with the upgrade, but when i enter to EMM settings are gone
i was looking in profile/default an saw 5 .emm files (database files i think)
and the last two files are Myvideos43.emm with 146,432 bytes and Myvideos43.emm_tmp 14,262,272 bytes so i think something went wrong upgrading database and thats why i have a smaller .emm file and bigger .emm_temp file
So, anyone know what can i do to fix this error? I also have a backup of the version 1.4.7.2 files, and tested and worked fine

thanks in advanced temuy
PSConfusedorry for me english still learning
First, you should use the latest daily build: Link 

*.emm_tmp will be build while Ember tries to upgrade your database. If Ember get an error while upgrading, a new database will be created. That's the small MyVideos43.emm. To old one which Ember upgrades from is still there and has a lower number then 43.
Please delete MyVideos43.emm and also MyVideos43.emm_tmp, install the latest daily build and try it again. If the database upgrade on the first start also ends in an empty database then post the latest log (.\Ember Media Manager\Logs) on http://pastebin.com so I can look what's the problem in your old database. 
 Thank you very much for your fast reply, i tried with the lastest build but same result, here is the complete log https://pastebin.com/rL8WTXw9 
I think the error is here with the moviesource table or something like that

2018-03-07 12:30:24.7910    EmberAPI.Database   EmberAPI.Database.bwPatchDB_DoWork  5   ERROR   "bwPatchDB_DoWork   Unable to open media database connection."  "EXCEPTION OCCURRED:System.Data.SQLite.SQLiteException (0x80004005): SQL logic error or missing database
  1. no such table: moviesource

Best Regards
temuy
Reply
(2018-03-07, 18:07)temuy Wrote:
(2018-03-07, 17:07)DanCooper Wrote:
(2018-03-07, 16:28)temuy Wrote: Hello all, i was using EMM for years without problems, yesterday i was upgrading version 1.4.7.2 to 1.4.8 everything was ok with the upgrade, but when i enter to EMM settings are gone
i was looking in profile/default an saw 5 .emm files (database files i think)
and the last two files are Myvideos43.emm with 146,432 bytes and Myvideos43.emm_tmp 14,262,272 bytes so i think something went wrong upgrading database and thats why i have a smaller .emm file and bigger .emm_temp file
So, anyone know what can i do to fix this error? I also have a backup of the version 1.4.7.2 files, and tested and worked fine

thanks in advanced temuy
PSConfusedorry for me english still learning
First, you should use the latest daily build: Link 

*.emm_tmp will be build while Ember tries to upgrade your database. If Ember get an error while upgrading, a new database will be created. That's the small MyVideos43.emm. To old one which Ember upgrades from is still there and has a lower number then 43.
Please delete MyVideos43.emm and also MyVideos43.emm_tmp, install the latest daily build and try it again. If the database upgrade on the first start also ends in an empty database then post the latest log (.\Ember Media Manager\Logs) on http://pastebin.com so I can look what's the problem in your old database.  
 Thank you very much for your fast reply, i tried with the lastest build but same result, here is the complete log https://pastebin.com/rL8WTXw9 
I think the error is here with the moviesource table or something like that

2018-03-07 12:30:24.7910    EmberAPI.Database   EmberAPI.Database.bwPatchDB_DoWork  5   ERROR   "bwPatchDB_DoWork   Unable to open media database connection."  "EXCEPTION OCCURRED:System.Data.SQLite.SQLiteException (0x80004005): SQL logic error or missing database
  1. no such table: moviesource

Best Regards
temuy 
Looks like a bug. Can you upload your MyVideo24.emm (I think that should be the latest version of your database) to Dropbox or something similar and send me a link per PN?
German Ember Media Manager Support

Daily Builds - Link
Latest official Ember-MM version - Ember Media Manager 1.4.x
Reply
(2018-03-07, 18:43)DanCooper Wrote:
(2018-03-07, 18:07)temuy Wrote:
(2018-03-07, 17:07)DanCooper Wrote: First, you should use the latest daily build: Link 

*.emm_tmp will be build while Ember tries to upgrade your database. If Ember get an error while upgrading, a new database will be created. That's the small MyVideos43.emm. To old one which Ember upgrades from is still there and has a lower number then 43.
Please delete MyVideos43.emm and also MyVideos43.emm_tmp, install the latest daily build and try it again. If the database upgrade on the first start also ends in an empty database then post the latest log (.\Ember Media Manager\Logs) on http://pastebin.com so I can look what's the problem in your old database.  
 Thank you very much for your fast reply, i tried with the lastest build but same result, here is the complete log https://pastebin.com/rL8WTXw9 
I think the error is here with the moviesource table or something like that

2018-03-07 12:30:24.7910    EmberAPI.Database   EmberAPI.Database.bwPatchDB_DoWork  5   ERROR   "bwPatchDB_DoWork   Unable to open media database connection."  "EXCEPTION OCCURRED:System.Data.SQLite.SQLiteException (0x80004005): SQL logic error or missing database
  1. no such table: moviesource

Best Regards
temuy  
Looks like a bug. Can you upload your MyVideo24.emm (I think that should be the latest version of your database) to Dropbox or something similar and send me a link per PN? 
 @DanCooper  He is a new user so he can't use PM or mail
Reply
(2018-03-07, 18:43)DanCooper Wrote:
(2018-03-07, 18:07)temuy Wrote:
(2018-03-07, 17:07)DanCooper Wrote: First, you should use the latest daily build: Link 

*.emm_tmp will be build while Ember tries to upgrade your database. If Ember get an error while upgrading, a new database will be created. That's the small MyVideos43.emm. To old one which Ember upgrades from is still there and has a lower number then 43.
Please delete MyVideos43.emm and also MyVideos43.emm_tmp, install the latest daily build and try it again. If the database upgrade on the first start also ends in an empty database then post the latest log (.\Ember Media Manager\Logs) on http://pastebin.com so I can look what's the problem in your old database.  
 Thank you very much for your fast reply, i tried with the lastest build but same result, here is the complete log https://pastebin.com/rL8WTXw9 
I think the error is here with the moviesource table or something like that

2018-03-07 12:30:24.7910    EmberAPI.Database   EmberAPI.Database.bwPatchDB_DoWork  5   ERROR   "bwPatchDB_DoWork   Unable to open media database connection."  "EXCEPTION OCCURRED:System.Data.SQLite.SQLiteException (0x80004005): SQL logic error or missing database
  1. no such table: moviesource

Best Regards
temuy   
Looks like a bug. Can you upload your MyVideo24.emm (I think that should be the latest version of your database) to Dropbox or something similar and send me a link per PN?  
Sure np

https://dropfile.to/oge2mve

Edit: didnt see the link was by PM, anyway in 23 hours the file will be delete
Reply
(2018-03-07, 19:09)temuy Wrote:
(2018-03-07, 18:43)DanCooper Wrote:
(2018-03-07, 18:07)temuy Wrote:  Thank you very much for your fast reply, i tried with the lastest build but same result, here is the complete log https://pastebin.com/rL8WTXw9 
I think the error is here with the moviesource table or something like that

2018-03-07 12:30:24.7910    EmberAPI.Database   EmberAPI.Database.bwPatchDB_DoWork  5   ERROR   "bwPatchDB_DoWork   Unable to open media database connection."  "EXCEPTION OCCURRED:System.Data.SQLite.SQLiteException (0x80004005): SQL logic error or missing database
  1. no such table: moviesource

Best Regards
temuy      
Looks like a bug. Can you upload your MyVideo24.emm (I think that should be the latest version of your database) to Dropbox or something similar and send me a link per PN?     
Sure np

https://dropfile.to/oge2mve

Edit: didnt see the link was by PM, anyway in 23 hours the file will be delete   
Ok, that was a little challenge..

The issue was that you've used the same name (MKV) for more than one movie source. That ended in duplicate entries while replacing the source name into source ID in the movie table.
Since many version is no longer possible to add multiple sources with the same name, but it looks like that it was possible in older versions.

I've fixed your old database and changed the source name of one source to "MKV-L" and fixed all entries from this source in the table "movie". The update of your "MyVideos24.emm" works now in my development environment.
Please rename your file "MyVideos24.emm" to something like "MyVideos24.emm_old", delete all never version if they are still there, copy this fixed DB back to your profiles folder and try another run.
German Ember Media Manager Support

Daily Builds - Link
Latest official Ember-MM version - Ember Media Manager 1.4.x
Reply
(2018-03-07, 20:44)DanCooper Wrote:
(2018-03-07, 19:09)temuy Wrote:
(2018-03-07, 18:43)DanCooper Wrote: Looks like a bug. Can you upload your MyVideo24.emm (I think that should be the latest version of your database) to Dropbox or something similar and send me a link per PN?    
Sure np

https://dropfile.to/oge2mve

Edit: didnt see the link was by PM, anyway in 23 hours the file will be delete    
Ok, that was a little challenge..

The issue was that you've used the same name (MKV) for more than one movie source. That ended in duplicate entries while replacing the source name into source ID in the movie table.
Since many version is no longer possible to add multiple sources with the same name, but it looks like that it was possible in older versions.

I've fixed your old database and changed the source name of one source to "MKV-L" and fixed all entries from this source in the table "movie". The update of your "MyVideos24.emm" works now in my development environment.
Please rename your file "MyVideos24.emm" to something like "MyVideos24.emm_old", delete all never version if they are still there, copy this fixed DB back to your profiles folder and try another run.  
 Oh very nice, the dropbox link point to a library.rar and  i cant find the database there, is that the right file?
Reply
(2018-03-07, 21:58)temuy Wrote:
(2018-03-07, 20:44)DanCooper Wrote:
(2018-03-07, 19:09)temuy Wrote: Sure np

https://dropfile.to/oge2mve

Edit: didnt see the link was by PM, anyway in 23 hours the file will be delete    
Ok, that was a little challenge..

The issue was that you've used the same name (MKV) for more than one movie source. That ended in duplicate entries while replacing the source name into source ID in the movie table.
Since many version is no longer possible to add multiple sources with the same name, but it looks like that it was possible in older versions.

I've fixed your old database and changed the source name of one source to "MKV-L" and fixed all entries from this source in the table "movie". The update of your "MyVideos24.emm" works now in my development environment.
Please rename your file "MyVideos24.emm" to something like "MyVideos24.emm_old", delete all never version if they are still there, copy this fixed DB back to your profiles folder and try another run.   
 Oh very nice, the dropbox link point to a library.rar and  i cant find the database there, is that the right file? 
 Yes, that was the wrong one. Link is now fixed.
German Ember Media Manager Support

Daily Builds - Link
Latest official Ember-MM version - Ember Media Manager 1.4.x
Reply
(2018-03-07, 22:01)DanCooper Wrote:
(2018-03-07, 21:58)temuy Wrote:
(2018-03-07, 20:44)DanCooper Wrote: Ok, that was a little challenge..

The issue was that you've used the same name (MKV) for more than one movie source. That ended in duplicate entries while replacing the source name into source ID in the movie table.
Since many version is no longer possible to add multiple sources with the same name, but it looks like that it was possible in older versions.

I've fixed your old database and changed the source name of one source to "MKV-L" and fixed all entries from this source in the table "movie". The update of your "MyVideos24.emm" works now in my development environment.
Please rename your file "MyVideos24.emm" to something like "MyVideos24.emm_old", delete all never version if they are still there, copy this fixed DB back to your profiles folder and try another run.   
 Oh very nice, the dropbox link point to a library.rar and  i cant find the database there, is that the right file?  
 Yes, that was the wrong one. Link is now fixed. 
 Yes that fix it, ty very much for your incredible suppport, i will make a small donation when i transfer some money to my paypal account
thanks one more time
Reply
Hi,
using the version 1.4.90.
When i use the renamer to rename a file that have the special character : in the IMDB name the program is replacing the : by a -
ex:
1.Asterix & Obelix: In Britain
2.Asterix.&.Obelix -.In.Britain.2012.1080P.H264

my settings for files pattern is : $T{.$Y}{.$R}{.$V}{.$S}{.$H}$X.$!

Help

Thanks

Steve
Reply
: is not a valid character for file name in windows, so it must be replaced by the renamer
Don't think it's a setting to what the replacement character to use, it default's to -
Reply
(2018-03-10, 01:02)slappy Wrote: Hi,
using the version 1.4.90.
When i use the renamer to rename a file that have the special character : in the IMDB name the program is replacing the : by a -
ex:
1.Asterix & Obelix: In Britain
2.Asterix.&.Obelix -.In.Britain.2012.1080P.H264

my settings for files pattern is : $T{.$Y}{.$R}{.$V}{.$S}{.$H}$X.$!

Help

Thanks

Steve
A ":" will always be replaced by a "SPACE-" because ":" is not allowed in a file name. It is always replaced if there are characters at the end that are invalid for file names or directories. But you can add "$?:??" to the pattern to replace a ":" by "nothing" before that final check has been run.
German Ember Media Manager Support

Daily Builds - Link
Latest official Ember-MM version - Ember Media Manager 1.4.x
Reply
Hi Dan,

I was using an older built(0f9b806) & everything was scraping perfectly, see picture:

Image

I now installed the latest build (93ce5d7), rescraped the movie & this is what I got:

Image

Is there a setting I need to change or where did things go wrong?
PS: I installed the old version again & it scraped fine again.
Your help is appreciated Huh
Kodi v17.6 “Krypton” (AEON MQ 7 Skin w/ Multi-Mod) running on Windows 10
Reply
  •   
  • 1
  • 146
  • 147
  • 148(current)
  • 149
  • 150
  • 163
  •   
 
Thread Rating:
  • 2 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
Ember Media Manager 1.4.8.0 ALPHA - Discussion Thread52