•   
  • 1
  • 35
  • 36
  • 37(current)
  • 38
  • 39
  • 175
  •   
WIP Ember Media Manager 1.4.8.0 ALPHA - Discussion Thread
(2016-07-07, 13:34)DanCooper Wrote:
(2016-07-05, 08:04)RavenFire Wrote: Is there a way to view debug logs?
I just added a new show, and now get an error scanning 'Input String was not in a correct format' right before the app shuts itself down.

This is all I find in the log directory:
Code:
01:48.5    EmberAPI.ModulesManager    EmberAPI.ModulesManager.RunGeneric    9    TRACE    [ModulesManager] [RunGeneric] [Start] <Sync_TVShow>    
01:48.5    EmberAPI.ModulesManager    EmberAPI.ModulesManager.RunGeneric    9    TRACE    [ModulesManager] [RunGeneric] Run generic module <Kodi>    
01:48.6    generic.Interface.Kodi.KodiInterface    generic.Interface.Kodi.KodiInterface+VB$StateMachine_74_GenericRunCallBack.MoveNext    9    WARN    [KodiInterface] [GenericRunCallBack]: Please Scrape In Ember First!    
01:48.7    Ember_Media_Manager.My.MyApplication    Ember_Media_Manager.My.MyApplication.MyApplication_UnhandledException    1    ERROR    Microsoft.VisualBasic    "EXCEPTION OCCURRED:System.FormatException: Input string was not in a correct format.
   at Microsoft.VisualBasic.CompilerServices.Conversions.ParseDouble(String Value, NumberFormatInfo NumberFormat)
   at Microsoft.VisualBasic.CompilerServices.Conversions.ToInteger(String Value)*   at Microsoft.VisualBasic.CompilerServices.Conversions.ParseDouble(String Value, NumberFormatInfo NumberFormat)
   at Microsoft.VisualBasic.CompilerServices.Conversions.ToInteger(String Value)"
03:10.1    Ember_Media_Manager.frmMain    Ember_Media_Manager.frmMain.frmMain_FormClosed    1    INFO    ====Ember Media Manager exiting====



We always need a full log to find such issues.


Okay, here's the full log on pastebin. Thanks!
http://pastebin.com/LxRRAJAL
Reply
Ok so a few things after building today's commit:

1. Still does not save specials, same as before. No season poster/landscape/banner, no episode thumbs.

2. I copied an already scraped show to a new folder and deleted everything except for episode files and did a new scrape. Everything scraped fine minus the specials. I opened an episode nfo to compare and this is what it shows:

Code:
<?xml version="1.0" encoding="utf-8"?>
<episodedetails>
  <title>Ash Vs Evil Dead S01E01</title>
  <season>1</season>
  <episode>1</episode>
  <dateadded>2016-07-08 08:13:32</dateadded>
</episodedetails>

So, checked all of the episode nfos and they are the same. I originally had the TVDB scraper as first, so I switched it with IMDB and the same result. Tried a different show and same results. If I scrape the show or episode I get the same results.

*EDIT* I disabled the expert settings and re-enabled regular kodi naming on the first tab, did a rescrape of the same show and the SAME results. Won't save specials at all. Plus nfos are the same, not scraping any information what so ever.
Reply
(2016-07-08, 17:32)Fail$tyle420 Wrote: Ok so a few things after building today's commit:

1. Still does not save specials, same as before. No season poster/landscape/banner, no episode thumbs.

2. I copied an already scraped show to a new folder and deleted everything except for episode files and did a new scrape. Everything scraped fine minus the specials. I opened an episode nfo to compare and this is what it shows:

Code:
<?xml version="1.0" encoding="utf-8"?>
<episodedetails>
  <title>Ash Vs Evil Dead S01E01</title>
  <season>1</season>
  <episode>1</episode>
  <dateadded>2016-07-08 08:13:32</dateadded>
</episodedetails>

So, checked all of the episode nfos and they are the same. I originally had the TMDB scraper as first, so I switched it with IMDB and the same result. Tried a different show and same results. If I scrape the show or episode I get the same results.

Hmmm... I've tested the new code today and it has worked with:
.\Game of Thrones\Season Specials\GoT - S00E01.mkv
and
.\Game of Thrones\Season 0\GoT - S00E01.mkv
and
.\Game of Thrones\Season 00\GoT - S00E01.mkv

Please upload your Settings.xml and a screenshot of your season specials folder. I'm away now but I can check your settings later today.
German Ember Media Manager Support

Daily Builds - Link
Latest official Ember-MM version - Ember Media Manager 1.4.x
Reply
(2016-07-08, 17:44)DanCooper Wrote:
(2016-07-08, 17:32)Fail$tyle420 Wrote: Ok so a few things after building today's commit:

1. Still does not save specials, same as before. No season poster/landscape/banner, no episode thumbs.

2. I copied an already scraped show to a new folder and deleted everything except for episode files and did a new scrape. Everything scraped fine minus the specials. I opened an episode nfo to compare and this is what it shows:

Code:
<?xml version="1.0" encoding="utf-8"?>
<episodedetails>
  <title>Ash Vs Evil Dead S01E01</title>
  <season>1</season>
  <episode>1</episode>
  <dateadded>2016-07-08 08:13:32</dateadded>
</episodedetails>

So, checked all of the episode nfos and they are the same. I originally had the TMDB scraper as first, so I switched it with IMDB and the same result. Tried a different show and same results. If I scrape the show or episode I get the same results.

Hmmm... I've tested the new code today and it has worked with:
.\Game of Thrones\Season Specials\GoT - S00E01.mkv
and
.\Game of Thrones\Season 0\GoT - S00E01.mkv
and
.\Game of Thrones\Season 00\GoT - S00E01.mkv

Please upload your Settings.xml and a screenshot of your season specials folder. I'm away now but I can check your settings later today.


All folders as follows:

TV Shows\Show\
Season 0\S00E01 - Title.extn
Season 01\S01E01 - Title.extn

With your testing, did it save the banner/landscape/poster Huh

I'm gonna do a brand new install and rescrape the show again. If I get the same results I will try Game of Thrones. I will also upload settings.xml file as well.
Reply
I just did a fresh install of 1.4.8.0 Alpha (coming from 1.3) and ran into this problem:
I created a few files named
Code:
Show-S01E01-480p.mkv
Show-S01E02-720p.mkv
Show-S01E03.mkv
Show-S01E04-480.mkv
Clicked "Update Library" and had these entries in the episode pane:
Code:
01 01  Show S01E01
01 02  Show S01E02
01 03  Show S01E03
01 04  Show S01E04
01 480 Show S01E480
01 480 Show S01E480
01 720 Show S01E720
EMM 1.3 contained code to specifically filter out the 480p 720p 1020p part of the filename, in order to prevent this. Is this no longer part of 1.4? Or is it done differently?

Regards,
myce
Reply
Ok, tried a brand new install of today's build and did everything again:

1. I tried game of thrones and Marvel's agent carter and it worked like you said. Downloaded the season poster/landscape/banner and episode thumbs. I tried Ash vs Evil Dead and I get the same results, NO specials information.

2. NONE of the episodes are saving information in the nfo files. They ALL appear like this:

Code:
<?xml version="1.0" encoding="utf-8"?>
<episodedetails>
  <title>Game Of Thrones S01E01</title>
  <runtime>61</runtime>
  <season>1</season>
  <episode>1</episode>
  <fileinfo>
    <streamdetails>
      <audio>
        <bitrate>192</bitrate>
        <channels>2</channels>
        <codec>AAC</codec>
        <language>eng</language>
        <longlanguage>English</longlanguage>
      </audio>
      <subtitle>
        <language>eng</language>
        <longlanguage>English</longlanguage>
        <type>Embedded</type>
      </subtitle>
      <subtitle>
        <language>dan</language>
        <longlanguage>Danish</longlanguage>
        <type>Embedded</type>
      </subtitle>
      <subtitle>
        <language>nld</language>
        <longlanguage>Dutch</longlanguage>
        <type>Embedded</type>
      </subtitle>
      <subtitle>
        <language>fin</language>
        <longlanguage>Finnish</longlanguage>
        <type>Embedded</type>
      </subtitle>
      <subtitle>
        <language>fra</language>
        <longlanguage>French</longlanguage>
        <type>Embedded</type>
      </subtitle>
      <subtitle>
        <language>nor</language>
        <longlanguage>Norwegian</longlanguage>
        <type>Embedded</type>
      </subtitle>
      <subtitle>
        <language>pol</language>
        <longlanguage>Polish</longlanguage>
        <type>Embedded</type>
      </subtitle>
      <subtitle>
        <language>por</language>
        <longlanguage>Portuguese</longlanguage>
        <type>Embedded</type>
      </subtitle>
      <subtitle>
        <language>spa</language>
        <longlanguage>Spanish</longlanguage>
        <type>Embedded</type>
      </subtitle>
      <subtitle>
        <language>spa</language>
        <longlanguage>Spanish</longlanguage>
        <type>Embedded</type>
      </subtitle>
      <subtitle>
        <language>swe</language>
        <longlanguage>Swedish</longlanguage>
        <type>Embedded</type>
      </subtitle>
      <video>
        <aspect>1.778</aspect>
        <bitrate>902</bitrate>
        <codec>hev1</codec>
        <durationinseconds>3697</durationinseconds>
        <height>1080</height>
        <width>1920</width>
        <filesize>538735366</filesize>
      </video>
    </streamdetails>
  </fileinfo>
  <dateadded>2016-07-08 09:19:31</dateadded>
</episodedetails>

No matter the scraper, I'm not getting any info.
Reply
(2016-07-08, 18:21)myce Wrote: I just did a fresh install of 1.4.8.0 Alpha (coming from 1.3) and ran into this problem:
I created a few files named
Code:
Show-S01E01-480p.mkv
Show-S01E02-720p.mkv
Show-S01E03.mkv
Show-S01E04-480.mkv
Clicked "Update Library" and had these entries in the episode pane:
Code:
01 01  Show S01E01
01 02  Show S01E02
01 03  Show S01E03
01 04  Show S01E04
01 480 Show S01E480
01 480 Show S01E480
01 720 Show S01E720
EMM 1.3 contained code to specifically filter out the 480p 720p 1020p part of the filename, in order to prevent this. Is this no longer part of 1.4? Or is it done differently?

Regards,
myce

I believe the option is located on the first tab of tv shows settings:

Build episode title instead of filtering. Try unchecking that option and let us know
Reply
(2016-07-08, 19:03)Fail$tyle420 Wrote: I believe the option is located on the first tab of tv shows settings:

Build episode title instead of filtering. Try unchecking that option and let us know

Not really an improvement. Not I got:
Code:
01 01  Showp
01 02  Showp
01 03  Show
01 04  Show
01 480 Showp
01 480 Show
01 720 Showp
Reply
(2016-07-08, 19:33)myce Wrote:
(2016-07-08, 19:03)Fail$tyle420 Wrote: I believe the option is located on the first tab of tv shows settings:

Build episode title instead of filtering. Try unchecking that option and let us know

Not really an improvement. Not I got:
Code:
01 01  Showp
01 02  Showp
01 03  Show
01 04  Show
01 480 Showp
01 480 Show
01 720 Showp

Worth a shot, sorry it didn't work out for you
Reply
(2016-07-08, 18:21)myce Wrote: I just did a fresh install of 1.4.8.0 Alpha (coming from 1.3) and ran into this problem:
I created a few files named
Code:
Show-S01E01-480p.mkv
Show-S01E02-720p.mkv
Show-S01E03.mkv
Show-S01E04-480.mkv
Clicked "Update Library" and had these entries in the episode pane:
Code:
01 01  Show S01E01
01 02  Show S01E02
01 03  Show S01E03
01 04  Show S01E04
01 480 Show S01E480
01 480 Show S01E480
01 720 Show S01E720
EMM 1.3 contained code to specifically filter out the 480p 720p 1020p part of the filename, in order to prevent this. Is this no longer part of 1.4? Or is it done differently?

Regards,
myce

We use the same regex for multi-episode like Kodi. S01E04-480 means season 1 episode 4 and episode 480.
If you have enabled an online scraper in Kodi, Kodi try to get the information for episode 480. In most case there is no episode 480 (or 720/1080/2160) and Kodi ignore it. But if you have enabled the "local info only" scraper, Kodi adds episode 480, even if no information for this episode is available in NFO.

So the best way is to rename the files properly, e.g. Show-S01E01 (480p).mkv or Show-S01E01.mkv.

But you also can preserve Ember to recognize the 480/720/1080/2160 as episode. Just change the TV Show Multi Part Maching regex in Settings=>TV Shows=>Files and Sources=> Regex (tab) to this one:
Code:
^[-_ex]+(?!(?:480|720|1080)(?:i|p))([0-9]+(?:(?:[a-i]|\.[1-9])(?![0-9]))?)

But Kodi still tries the wrong episodes to scrape or add it if you use the "local NFO only" scraper.
German Ember Media Manager Support

Daily Builds - Link
Latest official Ember-MM version - Ember Media Manager 1.4.x
Reply
(2016-07-08, 19:03)Fail$tyle420 Wrote: I believe the option is located on the first tab of tv shows settings:

Build episode title instead of filtering. Try unchecking that option and let us know

The filter is only to get a proper episode title from file name instead of "show name SxxExx". This has nothing to do with the episode numbers. This functions is only usefull for shows that can be scraped on any available scraper in Ember, e.g. home videos like "Holliday 2016 - My ugly family"
German Ember Media Manager Support

Daily Builds - Link
Latest official Ember-MM version - Ember Media Manager 1.4.x
Reply
(2016-07-08, 18:37)Fail$tyle420 Wrote: Ok, tried a brand new install of today's build and did everything again:

1. I tried game of thrones and Marvel's agent carter and it worked like you said. Downloaded the season poster/landscape/banner and episode thumbs. I tried Ash vs Evil Dead and I get the same results, NO specials information.

2. NONE of the episodes are saving information in the nfo files. They ALL appear like this:

Code:
<?xml version="1.0" encoding="utf-8"?>
<episodedetails>
  <title>Game Of Thrones S01E01</title>
  <runtime>61</runtime>
  <season>1</season>
  <episode>1</episode>
  <fileinfo>
    <streamdetails>
      <audio>
        <bitrate>192</bitrate>
        <channels>2</channels>
        <codec>AAC</codec>
        <language>eng</language>
        <longlanguage>English</longlanguage>
      </audio>
      <subtitle>
        <language>eng</language>
        <longlanguage>English</longlanguage>
        <type>Embedded</type>
      </subtitle>
      <subtitle>
        <language>dan</language>
        <longlanguage>Danish</longlanguage>
        <type>Embedded</type>
      </subtitle>
      <subtitle>
        <language>nld</language>
        <longlanguage>Dutch</longlanguage>
        <type>Embedded</type>
      </subtitle>
      <subtitle>
        <language>fin</language>
        <longlanguage>Finnish</longlanguage>
        <type>Embedded</type>
      </subtitle>
      <subtitle>
        <language>fra</language>
        <longlanguage>French</longlanguage>
        <type>Embedded</type>
      </subtitle>
      <subtitle>
        <language>nor</language>
        <longlanguage>Norwegian</longlanguage>
        <type>Embedded</type>
      </subtitle>
      <subtitle>
        <language>pol</language>
        <longlanguage>Polish</longlanguage>
        <type>Embedded</type>
      </subtitle>
      <subtitle>
        <language>por</language>
        <longlanguage>Portuguese</longlanguage>
        <type>Embedded</type>
      </subtitle>
      <subtitle>
        <language>spa</language>
        <longlanguage>Spanish</longlanguage>
        <type>Embedded</type>
      </subtitle>
      <subtitle>
        <language>spa</language>
        <longlanguage>Spanish</longlanguage>
        <type>Embedded</type>
      </subtitle>
      <subtitle>
        <language>swe</language>
        <longlanguage>Swedish</longlanguage>
        <type>Embedded</type>
      </subtitle>
      <video>
        <aspect>1.778</aspect>
        <bitrate>902</bitrate>
        <codec>hev1</codec>
        <durationinseconds>3697</durationinseconds>
        <height>1080</height>
        <width>1920</width>
        <filesize>538735366</filesize>
      </video>
    </streamdetails>
  </fileinfo>
  <dateadded>2016-07-08 09:19:31</dateadded>
</episodedetails>

No matter the scraper, I'm not getting any info.

I don't understand what's now working and what not. Please share a screenshot or post your exactly file name inclunding full path of a special episode.
German Ember Media Manager Support

Daily Builds - Link
Latest official Ember-MM version - Ember Media Manager 1.4.x
Reply
ALL specials are in "Season 00"

1. D:\Videos\TV Shows\Ash vs Evil Dead\ - No season00-landscape/season00-poster/season00-banner
2. D:\Videos\TV Shows\Ash vs Evil Dead\Season 00\S00E05 - Starz Ash vs Evil Dead.mkv -No thumbs

3. On a separate issue, NO info for episodes are being scraped, no matter what the scraper. tvshow.nfo scrapes just fine.

Settings:
https://www.dropbox.com/s/g5rbygde33homy...s.xml?dl=0
Reply
(2016-07-08, 23:06)Fail$tyle420 Wrote: ALL specials are in "Season 00"

1. D:\Videos\TV Shows\Ash vs Evil Dead\ - No season00-landscape/season00-poster/season00-banner
2. D:\Videos\TV Shows\Ash vs Evil Dead\Season 00\S00E05 - Starz Ash vs Evil Dead.mkv -No thumbs

3. On a separate issue, NO info for episodes are being scraped, no matter what the scraper. tvshow.nfo scrapes just fine.

Settings:
https://www.dropbox.com/s/g5rbygde33homy...s.xml?dl=0

1/2. There is no thumb on TVDB for s00e05 and TMDB has only listed season 1. Also TVDB, TMDB and Fanart.tv don't have ANY image for season 0 ;-)

3. Can't reproduce this issue. This is how my folders look after scraping this tv show with your settings:

Image

Image
German Ember Media Manager Support

Daily Builds - Link
Latest official Ember-MM version - Ember Media Manager 1.4.x
Reply
(2016-07-08, 22:27)DanCooper Wrote: But you also can preserve Ember to recognize the 480/720/1080/2160 as episode. Just change the TV Show Multi Part Maching regex in Settings=>TV Shows=>Files and Sources=> Regex (tab) to this one:
Code:
^[-_ex]+(?!(?:480|720|1080)(?:i|p))([0-9]+(?:(?:[a-i]|\.[1-9])(?![0-9]))?)
Hadn't seen the tab. Tongue
The changed regexp handles it nicely.
BTW:
Code:
^[-_ex]+(?!(?:480|720|1080)(?:i|p)|26[45])([0-9]+(?:(?:[a-i]|\.[1-9])(?![0-9]))?)
get rid of spurious episodes for -x264 and -x265 as well.
Reply
  •   
  • 1
  • 35
  • 36
  • 37(current)
  • 38
  • 39
  • 175
  •   
 
Thread Rating:
  • 2 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
Ember Media Manager 1.4.8.0 ALPHA - Discussion Thread52