•   
  • 1
  • 5
  • 6
  • 7(current)
  • 8
  • 9
  • 176
  •   
  Thread Closed
WIP Ember Media Manager 1.4.8.0 ALPHA - Discussion Thread
#91
(2016-03-04, 19:14)T-bird_se Wrote: Seen this in Set handling on empty Ember DB, sources is fully loaded from 1.4.7.2:
nfo for sets never load
TMDB scraper don't work, only results from fanart
Cosmetic bug (this is an old bug) in movie list, the year shows two times, like Dirty Harry (1971) (1971)

MovieSet NFO/images are not loaded automatically while movie update. I've tested it, but that slows down the scanning process to much. Use F5 or Tools => Reload all MovieSets. Also you have to manually add the MovieSet NFO file name in expert settings (<settitle>.nfo).

TMDB: Movie, tv show? Title?

Cosmetic bug: please upload a screenshot.
#92
i get this after installing when trying to open:

SQL logic error or missing database no such table moviesource


any insight on how i can fix this?
#93
(2016-03-06, 21:40)knives of ice Wrote: i get this after installing when trying to open:

SQL logic error or missing database no such table moviesource


any insight on how i can fix this?

Looks like you database is broken. Do you have manually renamed an old database to a new version number? What's the latest/highest number and what it the number before (.\Ember Media Manager\Settings\MyVideosXX.emm)? What says the Log file?
#94
(2016-03-06, 19:38)DanCooper Wrote:
(2016-03-05, 12:09)T-bird_se Wrote: Further testing and more about sets:
Empty DB in Kodi and let Ember sync
No set artworks shows in Kodi
Looking in Kodi DB and artwork paths is a mess, in first set only a image name without a path and for the rest they points to images in movie folder and not to movie artwork folder. Just like if you let Kodi run the update and don't run MSAA

Do you have set the MovieSet Artwork path for the host in Kodi Interface? Should be looking like smb://SERVER/SHARE.

EDIT: ... and moviesets are only synced if you sync it. There is no autosync while movie syncing.

I only had a standard unc path, adding smb: and now it works

(2016-03-06, 19:46)DanCooper Wrote:
(2016-03-04, 19:14)T-bird_se Wrote: Seen this in Set handling on empty Ember DB, sources is fully loaded from 1.4.7.2:
nfo for sets never load
TMDB scraper don't work, only results from fanart
Cosmetic bug (this is an old bug) in movie list, the year shows two times, like Dirty Harry (1971) (1971)

MovieSet NFO/images are not loaded automatically while movie update. I've tested it, but that slows down the scanning process to much. Use F5 or Tools => Reload all MovieSets. Also you have to manually add the MovieSet NFO file name in expert settings (<settitle>.nfo).

TMDB: Movie, tv show? Title?

Cosmetic bug: please upload a screenshot.

Adding it to expert settings works but why is it needed?
F5 doesn't do anything but reload all sets does

TMDB: It's in sets so on any movieset open edit sets and scrape folders or fanart, no result from TMBD only fanart.tv

Screenshot of cosmetic bug (it must be short movie names to see it)
https://www.dropbox.com/s/ctrt4hxj8c0h09...s.JPG?dl=0

Thanks for all help and your hard work
#95
(2016-03-06, 23:18)T-bird_se Wrote:
(2016-03-06, 19:38)DanCooper Wrote:
(2016-03-05, 12:09)T-bird_se Wrote: Further testing and more about sets:
Empty DB in Kodi and let Ember sync
No set artworks shows in Kodi
Looking in Kodi DB and artwork paths is a mess, in first set only a image name without a path and for the rest they points to images in movie folder and not to movie artwork folder. Just like if you let Kodi run the update and don't run MSAA

Do you have set the MovieSet Artwork path for the host in Kodi Interface? Should be looking like smb://SERVER/SHARE.

EDIT: ... and moviesets are only synced if you sync it. There is no autosync while movie syncing.

I only had a standard unc path, adding smb: and now it works

(2016-03-06, 19:46)DanCooper Wrote:
(2016-03-04, 19:14)T-bird_se Wrote: Seen this in Set handling on empty Ember DB, sources is fully loaded from 1.4.7.2:
nfo for sets never load
TMDB scraper don't work, only results from fanart
Cosmetic bug (this is an old bug) in movie list, the year shows two times, like Dirty Harry (1971) (1971)

MovieSet NFO/images are not loaded automatically while movie update. I've tested it, but that slows down the scanning process to much. Use F5 or Tools => Reload all MovieSets. Also you have to manually add the MovieSet NFO file name in expert settings (<settitle>.nfo).

TMDB: Movie, tv show? Title?

Cosmetic bug: please upload a screenshot.

Adding it to expert settings works but why is it needed?
F5 doesn't do anything but reload all sets does

TMDB: It's in sets so on any movieset open edit sets and scrape folders or fanart, no result from TMBD only fanart.tv

Screenshot of cosmetic bug (it must be short movie names to see it)
https://www.dropbox.com/s/ctrt4hxj8c0h09...s.JPG?dl=0

Thanks for all help and your hard work

We only list file names in default Kodi (Kodi Interface / MSAA) list that works out-of-the-stock. MovieSet NFO are not supportet, so we don't list it.
Now Kodi 16 supports overviews for MovieSets ind movie's NFO files, but that's not implementet in Ember atm (i hope comming soon).

TMDB: uups, copy-past bug :-) I've fixed it. I'll release an new alpha later today/tonight.

Cosmetic bug: We use ListTitle + Year for this list to show the same ordering like in media list. Now it think you have enable "Show year in List Title", that is the reason why it looks so bad. But i can add a check for that.
#96
Hi there,

I've been playing around with the alpha9 build and am so far loving it ! I have managed to get moviesets to update in kodi in real time when changed in EMM.

But I'm struggling to get normal movie artwork to sync in real time.

I have the 'sync in real time' option enable in the Kodi interface module (the check connection returns successful message), and I have the 'Kodi interface option' enabled in the movies --> files and sources --> kodi section.

I haven't enabled the extra images banner/clearart etc. as this was causing EMM to download <moviename>-banner etc files - all my artwork is named banner.jpg clearart.png (using expert settings)

I have tried reloading the individual movies after making an edit, and also choosing Tools --> Kodi Interface --> Update library but the artwork is not being refreshed in Kodi.

I'm running a raspberry Pi with Openelec/Isengard

Any help would be greatly appreciated.
Raspberry PI3 - LibreELEC 8.2.2 - Kodi 17.6 - Aeon MQ7 Krypton Mod 1.4.0.10
#97
(2016-03-07, 00:00)Esky Wrote: Hi there,

I've been playing around with the alpha9 build and am so far loving it ! I have managed to get moviesets to update in kodi in real time when changed in EMM.

But I'm struggling to get normal movie artwork to sync in real time.

I have the 'sync in real time' option enable in the Kodi interface module (the check connection returns successful message), and I have the 'Kodi interface option' enabled in the movies --> files and sources --> kodi section.

I haven't enabled the extra images banner/clearart etc. as this was causing EMM to download <moviename>-banner etc files - all my artwork is named banner.jpg clearart.png (using expert settings)

I have tried reloading the individual movies after making an edit, and also choosing Tools --> Kodi Interface --> Update library but the artwork is not being refreshed in Kodi.

I'm running a raspberry Pi with Openelec/Isengard

Any help would be greatly appreciated.

The Kodi Interface works with any file name, we only set the path of each image to the Kodi database. I suppose you have mapped the sources in the module Kodi Interface host settings, so it think you currently are showing the movie list in Kodi. If that's true, you have to leaf the movie list in Kodi and go back to the main menu. If you go back you should see the addition images. Kodi do only create a database call if you enter the list.

If that was'nt the issue you have to check the Ember log file if an ID was found while syncing.
#98
Alpha 10 is online.
#99
(2016-03-07, 00:09)DanCooper Wrote:
(2016-03-07, 00:00)Esky Wrote: Hi there,

I've been playing around with the alpha9 build and am so far loving it ! I have managed to get moviesets to update in kodi in real time when changed in EMM.

But I'm struggling to get normal movie artwork to sync in real time.

I have the 'sync in real time' option enable in the Kodi interface module (the check connection returns successful message), and I have the 'Kodi interface option' enabled in the movies --> files and sources --> kodi section.

I haven't enabled the extra images banner/clearart etc. as this was causing EMM to download <moviename>-banner etc files - all my artwork is named banner.jpg clearart.png (using expert settings)

I have tried reloading the individual movies after making an edit, and also choosing Tools --> Kodi Interface --> Update library but the artwork is not being refreshed in Kodi.

I'm running a raspberry Pi with Openelec/Isengard

Any help would be greatly appreciated.

The Kodi Interface works with any file name, we only set the path of each image to the Kodi database. I suppose you have mapped the sources in the module Kodi Interface host settings, so it think you currently are showing the movie list in Kodi. If that's true, you have to leaf the movie list in Kodi and go back to the main menu. If you go back you should see the addition images. Kodi do only create a database call if you enter the list.

If that was'nt the issue you have to check the Ember log file if an ID was found while syncing.

Hi Dan, thanks for your quick reply.

I believe I have the sources mapped correctly - I clicked the populate sources button and the correct type was selected for movies & TV Shows (The Kodi source field however is blank - is that correct ?)

Image

I have tried coming out to the main menu and back into my movie list, but the images are still not getting refreshed.

The following is the last few lines from the log after I changed an image for the movie '9'

Code:
2016-03-06 22:31:50.9795,EmberAPI.ModulesManager,EmberAPI.ModulesManager.ScrapeImage_Movie,1,TRACE,[ModulesManager] [ScrapeImage_Movie] [Done] Y:\Movies\9 (2009) 720p.BDRip\9 (2009) 720p.BDRip.x264.mp4,
2016-03-06 22:32:05.8138,EmberAPI.ModulesManager,EmberAPI.ModulesManager.RunGeneric,1,TRACE,[ModulesManager] [RunGeneric] [Start] <MediaPlayerStop_Video>,
2016-03-06 22:32:05.8138,EmberAPI.ModulesManager,EmberAPI.ModulesManager.RunGeneric,1,TRACE,[ModulesManager] [RunGeneric] Run generic module <VLC Player>,
2016-03-06 22:32:05.9113,EmberAPI.ModulesManager,EmberAPI.ModulesManager.RunGeneric,1,TRACE,[ModulesManager] [RunGeneric] [Start] <AfterEdit_Movie>,
2016-03-06 22:32:05.9113,EmberAPI.ModulesManager,EmberAPI.ModulesManager.RunGeneric,1,TRACE,[ModulesManager] [RunGeneric] Run generic module <Renamer>,
2016-03-06 22:32:05.9369,EmberAPI.ModulesManager,EmberAPI.ModulesManager.RunGeneric,1,TRACE,[ModulesManager] [RunGeneric] [Start] <OnNFOSave_Movie>,
2016-03-06 22:32:05.9369,EmberAPI.ModulesManager,EmberAPI.ModulesManager.RunGeneric,1,WARN,[ModulesManager] [RunGeneric] No generic modules defined <OnNFOSave_Movie>,
2016-03-06 22:32:36.8172,EmberAPI.ModulesManager,EmberAPI.ModulesManager.RunGeneric,1,TRACE,[ModulesManager] [RunGeneric] [Start] <OnTrailerSave_Movie>,
2016-03-06 22:32:36.8172,EmberAPI.ModulesManager,EmberAPI.ModulesManager.RunGeneric,1,WARN,[ModulesManager] [RunGeneric] No generic modules defined <OnTrailerSave_Movie>,
2016-03-06 22:32:48.9373,EmberAPI.ModulesManager,EmberAPI.ModulesManager.RunGeneric,1,TRACE,[ModulesManager] [RunGeneric] [Start] <Sync_Movie>,
2016-03-06 22:32:48.9373,EmberAPI.ModulesManager,EmberAPI.ModulesManager.RunGeneric,1,TRACE,[ModulesManager] [RunGeneric] Run generic module <Kodi>,
Raspberry PI3 - LibreELEC 8.2.2 - Kodi 17.6 - Aeon MQ7 Krypton Mod 1.4.0.10
(2016-03-07, 00:44)Esky Wrote:
(2016-03-07, 00:09)DanCooper Wrote:
(2016-03-07, 00:00)Esky Wrote: Hi there,

I've been playing around with the alpha9 build and am so far loving it ! I have managed to get moviesets to update in kodi in real time when changed in EMM.

But I'm struggling to get normal movie artwork to sync in real time.

I have the 'sync in real time' option enable in the Kodi interface module (the check connection returns successful message), and I have the 'Kodi interface option' enabled in the movies --> files and sources --> kodi section.

I haven't enabled the extra images banner/clearart etc. as this was causing EMM to download <moviename>-banner etc files - all my artwork is named banner.jpg clearart.png (using expert settings)

I have tried reloading the individual movies after making an edit, and also choosing Tools --> Kodi Interface --> Update library but the artwork is not being refreshed in Kodi.

I'm running a raspberry Pi with Openelec/Isengard

Any help would be greatly appreciated.

The Kodi Interface works with any file name, we only set the path of each image to the Kodi database. I suppose you have mapped the sources in the module Kodi Interface host settings, so it think you currently are showing the movie list in Kodi. If that's true, you have to leaf the movie list in Kodi and go back to the main menu. If you go back you should see the addition images. Kodi do only create a database call if you enter the list.

If that was'nt the issue you have to check the Ember log file if an ID was found while syncing.

Hi Dan, thanks for your quick reply.

I believe I have the sources mapped correctly - I clicked the populate sources button and the correct type was selected for movies & TV Shows (The Kodi source field however is blank - is that correct ?)

Image

I have tried coming out to the main menu and back into my movie list, but the images are still not getting refreshed.

The following is the last few lines from the log after I changed an image for the movie '9'

Code:
2016-03-06 22:31:50.9795,EmberAPI.ModulesManager,EmberAPI.ModulesManager.ScrapeImage_Movie,1,TRACE,[ModulesManager] [ScrapeImage_Movie] [Done] Y:\Movies\9 (2009) 720p.BDRip\9 (2009) 720p.BDRip.x264.mp4,
2016-03-06 22:32:05.8138,EmberAPI.ModulesManager,EmberAPI.ModulesManager.RunGeneric,1,TRACE,[ModulesManager] [RunGeneric] [Start] <MediaPlayerStop_Video>,
2016-03-06 22:32:05.8138,EmberAPI.ModulesManager,EmberAPI.ModulesManager.RunGeneric,1,TRACE,[ModulesManager] [RunGeneric] Run generic module <VLC Player>,
2016-03-06 22:32:05.9113,EmberAPI.ModulesManager,EmberAPI.ModulesManager.RunGeneric,1,TRACE,[ModulesManager] [RunGeneric] [Start] <AfterEdit_Movie>,
2016-03-06 22:32:05.9113,EmberAPI.ModulesManager,EmberAPI.ModulesManager.RunGeneric,1,TRACE,[ModulesManager] [RunGeneric] Run generic module <Renamer>,
2016-03-06 22:32:05.9369,EmberAPI.ModulesManager,EmberAPI.ModulesManager.RunGeneric,1,TRACE,[ModulesManager] [RunGeneric] [Start] <OnNFOSave_Movie>,
2016-03-06 22:32:05.9369,EmberAPI.ModulesManager,EmberAPI.ModulesManager.RunGeneric,1,WARN,[ModulesManager] [RunGeneric] No generic modules defined <OnNFOSave_Movie>,
2016-03-06 22:32:36.8172,EmberAPI.ModulesManager,EmberAPI.ModulesManager.RunGeneric,1,TRACE,[ModulesManager] [RunGeneric] [Start] <OnTrailerSave_Movie>,
2016-03-06 22:32:36.8172,EmberAPI.ModulesManager,EmberAPI.ModulesManager.RunGeneric,1,WARN,[ModulesManager] [RunGeneric] No generic modules defined <OnTrailerSave_Movie>,
2016-03-06 22:32:48.9373,EmberAPI.ModulesManager,EmberAPI.ModulesManager.RunGeneric,1,TRACE,[ModulesManager] [RunGeneric] [Start] <Sync_Movie>,
2016-03-06 22:32:48.9373,EmberAPI.ModulesManager,EmberAPI.ModulesManager.RunGeneric,1,TRACE,[ModulesManager] [RunGeneric] Run generic module <Kodi>,

No, sources are not mapped. You have to click on "Populate Sources" and map it like this:

Image
Ahhhh !!! I had clicked on those fields earlier (before clicking 'Populate Sources' and nothing happened) ... I was then clicking populate sources and didn't re-try the Kodi Sources bit again.

Thanks very much for you quick responses ... The images are now updating in real time, after they have been changed in EMM

Big Grin

Fantastic stuff !!
Raspberry PI3 - LibreELEC 8.2.2 - Kodi 17.6 - Aeon MQ7 Krypton Mod 1.4.0.10
(2016-03-07, 00:25)DanCooper Wrote: Alpha 10 is online.

Confirm that everything I reported is solved Smile

Thx again
I noticed that using the Kodi interface for TV shows, the default filename for logos is clearlogo.png instead of logo.png and for characterart is characterart.png instead of character.png (as used by artwork downloader - http://kodi.wiki/view/Add-on:Artwork_Dow...onventions )

I have tried using the expert settings, but doing a reload of TV Shows still does not pick up logos or characters. Any ideas?
Raspberry PI3 - LibreELEC 8.2.2 - Kodi 17.6 - Aeon MQ7 Krypton Mod 1.4.0.10
(2016-03-07, 22:40)Esky Wrote: I noticed that using the Kodi interface for TV shows, the default filename for logos is clearlogo.png instead of logo.png and for characterart is characterart.png instead of character.png (as used by artwork downloader - http://kodi.wiki/view/Add-on:Artwork_Dow...onventions )

I have tried using the expert settings, but doing a reload of TV Shows still does not pick up logos or characters. Any ideas?

Do you have tried to enable the default AD Settings in Ember? Settings => Movies/TV Shows => Files and Sources => File Names => Kodi Addons (tab)
(2016-03-07, 22:53)DanCooper Wrote:
(2016-03-07, 22:40)Esky Wrote: I noticed that using the Kodi interface for TV shows, the default filename for logos is clearlogo.png instead of logo.png and for characterart is characterart.png instead of character.png (as used by artwork downloader - http://kodi.wiki/view/Add-on:Artwork_Dow...onventions )

I have tried using the expert settings, but doing a reload of TV Shows still does not pick up logos or characters. Any ideas?

Do you have tried to enable the default AD Settings in Ember? Settings => Movies/TV Shows => Files and Sources => File Names => Kodi Addons (tab)

I have not enabled artwork downloader yet (as I didn't for movies and they are working fine)

For TV shows, all my other existing artwork is being recognised, poster.jpg, fanart.jpg, banner.jpg, landscape.jpg, clearart.png
It is only logo.png and character.png that is not being recognised. (Because EMM is defaulted to look for clearlogo.png and characterart.png ?)

I will try the artwork downloader option when EMM has finished it's current resync of my whole library !
Raspberry PI3 - LibreELEC 8.2.2 - Kodi 17.6 - Aeon MQ7 Krypton Mod 1.4.0.10
  •   
  • 1
  • 5
  • 6
  • 7(current)
  • 8
  • 9
  • 176
  •   
  Thread Closed
 
Thread Rating:
  • 2 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
Ember Media Manager 1.4.8.0 ALPHA - Discussion Thread52
This forum uses Lukasz Tkacz MyBB addons.