•   
  • 1
  • 167
  • 168
  • 169(current)
  • 170
  • 171
  • 176
  •   
  Thread Closed
WIP Ember Media Manager 1.4.8.0 ALPHA - Discussion Thread
hi all.

suddenly i cant search out my movies anymore.

it states that the database is locked. and then craches.

how can i solves this ??
Hi @DanCooper 

It's been a while...

I needed to do a major update of things like ratings, MPAA etc and have noticed a few differences between what is being scrapped and what is on imdb.com.  For example, I tried to update all my Top 250s and EMM returned that all the ones that were originally in the top 250 are no longer on that list (returned blank), e.g. 2001 a space odyssey.  It also said that film had a rating of 8 (when refreshed/re-scrapped) yet when I check on IMDB (moments later) it states it has a rating of 8.3 and is #89 in the top 250, instead of now blank in EMM.

I decided to try a full re scrape of a movie instead of single field.  Stupidly I took one of my "foreign" language films to do this: Hauru no ugoku shiro, aka Howl's Moving Castle, rating in IMDB currently 8.2 and #129 in top 50.  The full re-scrape changed the name to English in both "title" and "original title" and made the rating 8.4 and taking out the old top 250 ranking altogether.

I have had a really good look around the settings, as I was playing with them, but cannot see any that would cause these issues.  I also seemed to recall, maybe in a prior version, there was a setting to force the title to be that of the original title; am I making that up?
(2019-09-08, 03:19)Hairy Hippy Wrote: Hi @DanCooper 

It's been a while...

I needed to do a major update of things like ratings, MPAA etc and have noticed a few differences between what is being scrapped and what is on imdb.com.  For example, I tried to update all my Top 250s and EMM returned that all the ones that were originally in the top 250 are no longer on that list (returned blank), e.g. 2001 a space odyssey.  It also said that film had a rating of 8 (when refreshed/re-scrapped) yet when I check on IMDB (moments later) it states it has a rating of 8.3 and is #89 in the top 250, instead of now blank in EMM.

I decided to try a full re scrape of a movie instead of single field.  Stupidly I took one of my "foreign" language films to do this: Hauru no ugoku shiro, aka Howl's Moving Castle, rating in IMDB currently 8.2 and #129 in top 50.  The full re-scrape changed the name to English in both "title" and "original title" and made the rating 8.4 and taking out the old top 250 ranking altogether.

I have had a really good look around the settings, as I was playing with them, but cannot see any that would cause these issues.  I also seemed to recall, maybe in a prior version, there was a setting to force the title to be that of the original title; am I making that up?

@DanCooper  - Apologies, helps if I use the latest version... I was using 1.4.80, now using 1.4.90-alpha.git.99933648 from https://drive.google.com/drive/folders/0...GhoSkRVWG8, which I assume is the latest?

However, whilst I am here, could I suggest a "new" feature:   currently have full re-scan and single field; be great to be able to select which fields you would like to update (e.g. rating, top 250, trailer) all at once rather than having to do a full or single.
(2019-09-08, 04:13)Hairy Hippy Wrote:
(2019-09-08, 03:19)Hairy Hippy Wrote: Hi @DanCooper 

It's been a while...

I needed to do a major update of things like ratings, MPAA etc and have noticed a few differences between what is being scrapped and what is on imdb.com.  For example, I tried to update all my Top 250s and EMM returned that all the ones that were originally in the top 250 are no longer on that list (returned blank), e.g. 2001 a space odyssey.  It also said that film had a rating of 8 (when refreshed/re-scrapped) yet when I check on IMDB (moments later) it states it has a rating of 8.3 and is #89 in the top 250, instead of now blank in EMM.

I decided to try a full re scrape of a movie instead of single field.  Stupidly I took one of my "foreign" language films to do this: Hauru no ugoku shiro, aka Howl's Moving Castle, rating in IMDB currently 8.2 and #129 in top 50.  The full re-scrape changed the name to English in both "title" and "original title" and made the rating 8.4 and taking out the old top 250 ranking altogether.

I have had a really good look around the settings, as I was playing with them, but cannot see any that would cause these issues.  I also seemed to recall, maybe in a prior version, there was a setting to force the title to be that of the original title; am I making that up?

@DanCooper  - Apologies, helps if I use the latest version... I was using 1.4.80, now using 1.4.90-alpha.git.99933648 from https://drive.google.com/drive/folders/0...GhoSkRVWG8, which I assume is the latest?

However, whilst I am here, could I suggest a "new" feature:   currently have full re-scan and single field; be great to be able to select which fields you would like to update (e.g. rating, top 250, trailer) all at once rather than having to do a full or single. 

There is a way of doing that, see this post: 2742973 (post)

I don't know if there still is a bug with TV series that you also have to have something selected from the TV show level (like update the Status) or it won't work. But it should work with movies just fine.
Hello
I would like to print a list but not only movie titles but also audio and video formats can be downloaded Is this possible?
(2019-09-08, 13:29)Boulder Wrote:
(2019-09-08, 04:13)Hairy Hippy Wrote:
(2019-09-08, 03:19)Hairy Hippy Wrote: Hi @DanCooper 

It's been a while...

I needed to do a major update of things like ratings, MPAA etc and have noticed a few differences between what is being scrapped and what is on imdb.com.  For example, I tried to update all my Top 250s and EMM returned that all the ones that were originally in the top 250 are no longer on that list (returned blank), e.g. 2001 a space odyssey.  It also said that film had a rating of 8 (when refreshed/re-scrapped) yet when I check on IMDB (moments later) it states it has a rating of 8.3 and is #89 in the top 250, instead of now blank in EMM.

I decided to try a full re scrape of a movie instead of single field.  Stupidly I took one of my "foreign" language films to do this: Hauru no ugoku shiro, aka Howl's Moving Castle, rating in IMDB currently 8.2 and #129 in top 50.  The full re-scrape changed the name to English in both "title" and "original title" and made the rating 8.4 and taking out the old top 250 ranking altogether.

I have had a really good look around the settings, as I was playing with them, but cannot see any that would cause these issues.  I also seemed to recall, maybe in a prior version, there was a setting to force the title to be that of the original title; am I making that up?

@DanCooper  - Apologies, helps if I use the latest version... I was using 1.4.80, now using 1.4.90-alpha.git.99933648 from https://drive.google.com/drive/folders/0...GhoSkRVWG8, which I assume is the latest?

However, whilst I am here, could I suggest a "new" feature:   currently have full re-scan and single field; be great to be able to select which fields you would like to update (e.g. rating, top 250, trailer) all at once rather than having to do a full or single.  

There is a way of doing that, see this post: 2742973 (post)

I don't know if there still is a bug with TV series that you also have to have something selected from the TV show level (like update the Status) or it won't work. But it should work with movies just fine. 
Excellent!!!  Thank you so much.
Can you added view size of movie?
Wink 
Good morning, evening, night!

Exist any way to add a feature to visualize the movie size in ember? (sorry for my english)

Thank you!
Ember Media Manager BETA 1.4.90-alpha.git.99933648 2018-12-09

LOG

When I run "Update TV Shows Only" it adds the 3 series back without error. However, the 3 episodes listed below are not scrapped. If I "(Re)Scrape Show" then I get the error.

I have not changed anything in Ember. Up until today these latest episodes the series scrapped without error. Other series episodes scrap fine with "Update TV Shows Only".

1) When I attempt to "(Re)Scrape Show" for either of these series I get this error.
- Shark Tank s11e07 (720p Web h264 DD 5.1 subs).mkv
- Stargate Atlantis s01e20 - The Siege (2) (720p BDMux DTS 5.1 subs).mkv
- Legacies (2018)\Season 2\Legacies s02e05 - Screw Endgame (WEBDL-720p x264 DDP 5.1 subs).mkv

"End of Central Directory record could not be found"

Here's what I've done to try and fix the errors following these steps:
- Deleted Stargate Atlantis series in Ember
- Deleted Shark Tank series in Ember
- Deleted Legacies in Ember
- Cleared All Caches
- Closed Ember
- Clean Database
- Closed Ember
- Updated TV Shows Only


2) When "(Re)Scrape Show" this series, this episode is causing this error even though the file is there. Deleting the actors.xml file makes no difference.
- "Could not find the file "C:\program files (x86)\Ember Media Manager BETA\Temp\Shows\extraction\actors.xml"

3) Why am I getting getting all the skipped alerts related to extrafanart and .actors directories? They were created by Ember.

4) BTW is "Sanner" misspelled?
2019-11-15 07:19:49.5684,EmberAPI.Scanner,EmberAPI.Scanner.ScanForFiles_TV,8,INFO,"[Sanner]
HTPC: Dell Optiplex 7040 Small Form Factor i7-6700 quad-core, 3.4GHz, 16GB
NAS: Synology DS1813+ and DX513, RAID 6 (29TB usable space)
My Media Center | www.CaptainKen.us | www.YouTube.com/KenInGilbert
(2019-11-16, 04:14)CaptainKen Wrote: Ember Media Manager BETA 1.4.90-alpha.git.99933648 2018-12-09

LOG

When I run "Update TV Shows Only" it adds the 3 series back without error. However, the 3 episodes listed below are not scrapped. If I "(Re)Scrape Show" then I get the error.

I have not changed anything in Ember. Up until today these latest episodes the series scrapped without error. Other series episodes scrap fine with "Update TV Shows Only".

1) When I attempt to "(Re)Scrape Show" for either of these series I get this error.
- Shark Tank s11e07 (720p Web h264 DD 5.1 subs).mkv
- Stargate Atlantis s01e20 - The Siege (2) (720p BDMux DTS 5.1 subs).mkv
- Legacies (2018)\Season 2\Legacies s02e05 - Screw Endgame (WEBDL-720p x264 DDP 5.1 subs).mkv

"End of Central Directory record could not be found"

Here's what I've done to try and fix the errors following these steps:
- Deleted Stargate Atlantis series in Ember
- Deleted Shark Tank series in Ember
- Deleted Legacies in Ember
- Cleared All Caches
- Closed Ember
- Clean Database
- Closed Ember
- Updated TV Shows Only


2) When "(Re)Scrape Show" this series, this episode is causing this error even though the file is there. Deleting the actors.xml file makes no difference.
- "Could not find the file "C:\program files (x86)\Ember Media Manager BETA\Temp\Shows\extraction\actors.xml"

3) Why am I getting getting all the skipped alerts related to extrafanart and .actors directories? They were created by Ember.

4) BTW is "Sanner" misspelled?
2019-11-15 07:19:49.5684,EmberAPI.Scanner,EmberAPI.Scanner.ScanForFiles_TV,8,INFO,"[Sanner]

TheTVDB API broken after new website launched yesterday.

Yesterday
TheTVDB API response broken zip file (https://thetvdb.com/api/***/series/254123/all/en.zip) which cannot be opened.

Today
TheTVDB API fix the broken zip file issue, but these is another issue.
The filename inside the zip file is changed that make Ember cannot find the series xml file.

en.zip
|-- actors.xml
|-- banners.xml
|-- en.zip.xml

Ember needs en.xml, but TheTVDB API added .zip started from yesterday.
Don't know that it is permanent change or bug. Sad

Hope TheTVDB or Ember developer (if it is permanently) can fix it. 
No workaround solution except edit Ember source code and compile it yourself.
Thank you @skyeia for replying with the details.

Sounds like API change will affect even the devs, so hopefully they'll provide a new Ember alpha build.

When I download the file name is "en.zip.zip" should I rename it to "en.zip"?
HTPC: Dell Optiplex 7040 Small Form Factor i7-6700 quad-core, 3.4GHz, 16GB
NAS: Synology DS1813+ and DX513, RAID 6 (29TB usable space)
My Media Center | www.CaptainKen.us | www.YouTube.com/KenInGilbert
Well this morning tried 1.4.90 Movies work but TV Shows still not updating with TVDB any work around ?
One HTPC Windows 7 pro 64x running WMC with 2 HDhomeRun on Comcast 6 tuners with MCEbuddy
WD MyCloud 24TB over Netgear network | 6500 movies and 40,000+ TV Show episodes
(2019-11-21, 14:52)Rickt1962 Wrote: Well this morning tried 1.4.90 Movies work but TV Shows still not updating with TVDB any work around ?

Well found a work around that works go to Edit/Settings go to TV shows under general tab on Left check mark scrapers - data move down to scarpers - IMDB and TMDB and UNCHECK TVDB then move down to Scarpers - Images check FanartTV and TMDB and UNCHECK TVDB go back and rescan everything works for me now Smile
One HTPC Windows 7 pro 64x running WMC with 2 HDhomeRun on Comcast 6 tuners with MCEbuddy
WD MyCloud 24TB over Netgear network | 6500 movies and 40,000+ TV Show episodes
(2019-11-21, 15:07)Rickt1962 Wrote:
(2019-11-21, 14:52)Rickt1962 Wrote: Well this morning tried 1.4.90 Movies work but TV Shows still not updating with TVDB any work around ?

Well found a work around that works go to Edit/Settings go to TV shows under general tab on Left check mark scrapers - data move down to scarpers - IMDB and TMDB and UNCHECK TVDB then move down to Scarpers - Images check FanartTV and TMDB and UNCHECK TVDB go back and rescan everything works for me now Smile 
Thats not really a workaround... I mean, the TVDb API is broken and you disable the TVDb scraper and uses another scraper sounds like a logical step ;-) But I know what you mean, maybe I should have mentioned that Big Grin
Congratulations!
TheTVDB fixed the naming issue.

But another bad news, they removed all xml header (<?xml version="1.0" encoding="UTF-8"?>)  of the xml files extacted from zip.
The API response is different before their shitty update, it broken the backward compatibility of API and broken the library that Ember is using.
And it seems that they are not treat it as bug and going fix it (Hope I was wrong).


TheTVDB Temporary Workaround (Use at Your Own Risk)
  1. Download the modified TVDB.dll
    • <TVDB.dll (20191129)Latest
      • Attempt to fix <displayepisode>4096</displayepisode> issue (Details)
      • Do not save incorrect <displayseason> and <displayepisode> to new scraped episode. (NEW SCRAPED episode only)
      • Note: As I am not clearly understand the usage of <displayepisode> and<displayepisode>, please try the previous version if these is any side effect.
    • <TVDB.dll (20191125)>
  2. Save it to the same directory with Ember Media Manager.exe
    Code:
    Ember Media Manager
      |-- Ember Media Manager.exe
      |-- TVDB.dll
  3. That's all

2019-11-25 19:15 GMT :
Season poster scraping is still not work.
It is another gift (bug) from their shitty update, their API* does not return any season poster.
* banners.xml from https://thetvdb.com/api/{API}/series/300472/all/en.zip
  •   
  • 1
  • 167
  • 168
  • 169(current)
  • 170
  • 171
  • 176
  •   
  Thread Closed
 
Thread Rating:
  • 2 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
Ember Media Manager 1.4.8.0 ALPHA - Discussion Thread52
This forum uses Lukasz Tkacz MyBB addons.