[iOS App Signer] No signing certificates found

  Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
3HMB Offline
Junior Member
Posts: 3
Joined: Mar 2016
Reputation: 0
Post: #46
Update on my last post. I decided to get it a other try at home on my VM and this time it work. Just like DanTheMan and Shinobi Wan suggested. Thank you all for the great info.
(This post was last modified: 2016-03-03 15:51 by 3HMB.)
find quote
ajmi982 Offline
Junior Member
Posts: 5
Joined: Jan 2016
Reputation: 0
Post: #47
how can we protect all of our add ons and settings if we have to completely remove Kodi and reinstall with the new signature?
find quote
DanTheMan827 Offline
Team-Kodi Member
Posts: 576
Joined: Jul 2012
Reputation: 27
Location: Wausau, WI - USA
Post: #48
In the devices window you can select Kodi and then click the gear and select download container

Then remove and re-install kodi and do the same but select replace container and select the container you just backed up

Although... the white screen for some may be due to configuration of Kodi (Addons, messed up database, etc)

Install Kodi on iOS without a jailbreak: iOS App Signer
Donations are gratefully accepted
find quote
spiritwarrior Offline
Junior Member
Posts: 1
Joined: Mar 2016
Reputation: 0
Post: #49
Dan thanks for all you do here.

I've tried everything suggested herein, but I'm still getting the following error message when I launch iOS App Signer:
"No codesigning certificates found! You won't be able to successfully sign anything."

I've deleted the Apple Worldwide Developer certificates in keychain and downloaded and installed the new ones that expire in 2023 (in both Login and System areas of Keychain); I've deleted my Xcode account and reinstalled it, including the deletion of the Provisioning Profiles; I've also "Force Trusted" my iOS Developer ID in Keychain; and of course I did all of the above with the r17 version of iOS App Signer.

I WISH I could get to the solid white screen like these others - at least that would be progress!
Thanks for any help you guys can provide.
find quote
aston23 Offline
Junior Member
Posts: 3
Joined: Jan 2016
Reputation: 0
Post: #50
Dan you are the best!!
I have also tried everything and still get WHITE SCREEN.
i still have four older kodi's install in my Atv4 and working great but when i install ...303 i get the white screen....
Should i delete the older kodi's to work this???what should i do??
thanks great work here!!
find quote
aston23 Offline
Junior Member
Posts: 3
Joined: Jan 2016
Reputation: 0
Post: #51
(2016-03-07 09:15)aston23 Wrote:  Dan you are the best!!
I have also tried everything and still get WHITE SCREEN.
i still have four older kodi's install in my Atv4 and working great but when i install ...303 i get the white screen....
Should i delete the older kodi's to work this???what should i do??
thanks great work here!!

I finaly made it!!!!
My mystake was that i had always connected my atv4 with my mac via usb and i could not reset my Provisioning Profiles...
find quote
chrisjohnson83 Offline
Member
Posts: 70
Joined: Nov 2011
Reputation: 0
Post: #52
Hey DantheMan. You helped me a few months back, things have been going flawless. Now i bought a 2nd apple tv for the bedroom. Just keep getting the same error over & over and over valid provisioning for this executable was not found. I have tried 2 different apple developer accounts. Have tried removing provisioning profiles in the library folder. Replaced the certification that expired & removed the old one but just keep getting same thing over & over. Any other suggestions? please & thanks
find quote
chrisjohnson83 Offline
Member
Posts: 70
Joined: Nov 2011
Reputation: 0
Post: #53
could it be that the latest iOS signer is the problem? i have the latest version & i remember having a similar problem when having the old version where it says invalid provisioning for this executable.
find quote
activate Offline
Fan
Posts: 629
Joined: Feb 2011
Reputation: 2
Post: #54
(2016-03-12 23:02)chrisjohnson83 Wrote:  Hey DantheMan. You helped me a few months back, things have been going flawless. Now i bought a 2nd apple tv for the bedroom. Just keep getting the same error over & over and over valid provisioning for this executable was not found. I have tried 2 different apple developer accounts. Have tried removing provisioning profiles in the library folder. Replaced the certification that expired & removed the old one but just keep getting same thing over & over. Any other suggestions? please & thanks

Had this issue too. What I did was right clicked the device in Xcode and uploaded the provisional profile to it. Seemed to have fixed it for me.

Macmini Server 2011 i7 Quad Core, OS 10.8.2, Amp Onkyo TX-SR308 USB WD drives 3x2TB TV Samsung Plasma 720p EyeTV Integration
There are only 10 kinds of people in this world, those who understand binary, and those who don't.



find quote
dereklad Offline
Junior Member
Posts: 31
Joined: Jan 2012
Reputation: 0
Location: Birmingham uk
Post: #55
Trusting that certificate worked for me thanks dan.kodi is back on my appletv after the the update removed it..

Mac mini 2010
Appletv 4
Ps4
Iphone6
find quote
dereklad Offline
Junior Member
Posts: 31
Joined: Jan 2012
Reputation: 0
Location: Birmingham uk
Post: #56
Strange it worked perfect for my atv4 thanks,but fails for iphone 6.cant find profile..

Mac mini 2010
Appletv 4
Ps4
Iphone6
find quote
teezer_91776 Offline
Junior Member
Posts: 3
Joined: Mar 2016
Reputation: 0
Post: #57
I am having App installation failed.

I previoulsy was able to get Kodi installed on my AppleTV4 but little did I know AppleTV auto updated, and now Kodi is missing. I do not have the original Xcode data. So what I did was try and re-install it, now all I get is the App installation failed "A valid provisioning profile for this executable was not found"

Been struggling to get this to install for the last day and a half with no success.

I just tried to uninstall Xcode and deleted all the data file. Now I am getting "An App ID with identifer '.com.Tony.AppleTV' is not available. Please enter a different string." error.
(This post was last modified: 2016-03-31 02:52 by teezer_91776.)
find quote
Memphiz Offline
Kodi MVP
Posts: 16,020
Joined: Feb 2011
Reputation: 225
Location: germany
Post: #58
stop double posting please - one spot is enough...

AppleTV4/iPhone/iPod/iPad: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for Kodi: NFS (wiki)
HowTo configure avahi (zeroconf): Avahi_Zeroconf (wiki)
READ THE IOS FAQ!: iOS FAQ (wiki)
find quote
jingle_k0di.tv Offline
Junior Member
Posts: 1
Joined: Apr 2016
Reputation: 0
Post: #59
Same Problem. You need The lastest version of App Signer(18). The other is invalid since mid february.

Sorry 4 my bad english.?
find quote
ATVwaffles Offline
Junior Member
Posts: 35
Joined: Oct 2011
Reputation: 0
Post: #60
So my troubles have started up since swapping my Apple TV 4 since the remote stopped pairing

When I try with new dev free account it says no devices need to add it in dev portal

When I try old Apple ID my main one I used to sign kodi On my other existing box it says to use a unique bundle or it can't fix it

I've tried product > target > the device

I've tried always trust in keychain access for both Apple Ids. Signed out and signed in.

Removed wwdc cert and re added it and trusted it.

What is going on?

Also get that it doesn't match up. Every error possible :/
(This post was last modified: 2016-04-16 23:58 by ATVwaffles.)
find quote