Req Option to disable Long Press
#1
If you have a menu button on your remote you probably don't need long press, but now you have to press "OK" multiple times instead of holding it down.

Option to disable it and go back to how it was before Jarvis would be nice
Reply
#2
There is an option. I'll show an example keymap in a moment.
Reply
#3
Code:
<keymap>
  <global>
    <keyboard>
      <return mod="longpress"></return>
      <enter mod="longpress"></enter>
    </keyboard>
  </global>
</keymap>

Save that as something.xml as a plain text file and put it in userdata (wiki) in the keymaps folder. That will remove the select long press actions.
Reply
#4
If we use a custom remote.xml we can just copy/paste your <keyboard>...</keyboard> tag section under our keymap's <global> tag section, right?
Reply
#5
That will work. You can even load them as separate maps and they will all be applied. Whichever is easier for you.
Reply
#6
(2016-02-22, 05:01)Ned Scott Wrote:
Code:
<keymap>
  <global>
    <keyboard>
      <return mod="longpress"></return>
      <enter mod="longpress"></enter>
    </keyboard>
  </global>
</keymap>

Save that as something.xml as a plain text file and put it in userdata (wiki) in the keymaps folder. That will remove the select long press actions.

Thank you
Reply
#7
This only 1/2 worked for me. It disabled enter but no return. I copied and pasted it into a file called longpress.xml and placed it in the specified folder.
Reply
#8
(2016-05-30, 22:20)bobbyburns Wrote: This only 1/2 worked for me. It disabled enter but no return. I copied and pasted it into a file called longpress.xml and placed it in the specified folder.

Can you get us a debug log (wiki) of Kodi starting up?
Reply
#9
I'll get on it. I have ALS so everything is hard.
Reply
#10
I cleared the data on kodi and copied the keymap above into longpress.xml. The long press on the return button still goes strait home.

http://pastebin.com/n8jxmMSJ
Reply
#11
(2016-06-01, 16:51)bobbyburns Wrote: I cleared the data on kodi and copied the keymap above into longpress.xml. The long press on the return button still goes strait home.

http://pastebin.com/n8jxmMSJ

Very strange. I'm not sure why it wouldn't work in that situation. Your log shows your keymap being loaded and doesn't mention any errors (no other conflicting maps that are loaded later, no syntax errors, etc), and the fact that it works for enter leads me to believe that you've done everything correctly on your end.

I'll try disabling it on my Fire TV and see if I can get it to work on that specific device. Maybe there's something weird with the remote itself, but that's a wild guess at this point.
Reply
#12
I might have to go back to 15.2 thanks for the help.
I'll try it on my sheild pro.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Option to disable Long Press00
This forum uses Lukasz Tkacz MyBB addons.