•  Previous
  • 1
  • 2
  • 3(current)
  • 4
  • 5
  • 14
  • Next 
 
Thread Rating:
  • 1 Vote(s) - 5 Average
Kodi 17 - Xperience1080 6.x
#31
Thanks for your issue report.

(2016-09-17, 06:40)bbqbob Wrote: Another small issue.

Under Settings -> Skin - Advanced, the second option is missing the text. There is a option under "Enable Kiosk Mode", but no text. I think it is supposed to be about Play playlist upon start.

This is already fixed in master.

(2016-09-17, 05:42)bbqbob Wrote: Using Kodi 17 Beta 1, latest zip from this thread, Windows 7, Intel i5 wiith 4600 graphics.

I have seen the following issues with the skin:

1) video settings do not look or operate correctly

when playing a movie, the video settings do not work correctly. In prior versions, there was a white square in the bar that showed the zoom amount. The left and right buttons on the remote adjusted the zoom amount.

In this version, the white spot in the bar is missing so there isn't a graphic depiction of the amount. Also, you have to use the up and down arrows on the remote to adjust zoom. Given the bar is left to right, this seems unnatural.

The same thing happens to pixel ratio, and probably the other settings.

Also fixed in master.

(2016-09-17, 05:42)bbqbob Wrote: 2) selecting a movie on the home screen spot light is messed up.

My root menu has a rotating list of movies shown. If you press "Ok" on the remote, it takes you to the information screen of the movie, but this is shown in a semi-transparent way over the home screen. The movie information page seems to work, but it is hard to use when half mixed with the home menu.

Will need a closer look at this. ATM I can't reproduce the issue.
Reply
#32
I grabbed the zip from the first page again. I can confirm that the missing text in settings, and the trouble with the video settings are fixed. Thanks!

I am still having the same issue with the Home Windows widgets. All of the widgets (Spotlight, New Movies, Ongoing TV, New TV) have the same problem. I also noticed that when I press OK on the remote or Enter on the Keyboard on the widget that the fanart for the movie is displayed behind both the movie info and the home screen even though I have Use Fanart turned off. If get to the movie info screen from the normal method (choosing Movies from the home screen), then the Use Fanart setting works as expected.

I have Settings->Media->Videos->Default Selection set to "Show Information". You will need to have this setting to see the problem. If I set this to Play, then pressing Ok on the video shown in the Home Window widget will properly play the video without issue.

This Kodi installation done on a system with Kodi 16 (and 15) previously on it. I did not manually erase the Kodi scripts and addons after uninstallation of the prior version.

I also have installed the Estuary MOD skin on this installation.

I keep playing with the settings to see if there a setting that changes the behavior as I don't understand why you can't reproduce it as it happens all of the time to my setup.
Reply
#33
Minor issue:

Under Settings -> Media -> Library, the following menu items appear twice:
Hide Progress of library updates
Clean Library
Export Library
Import Library
Reply
#34
I uninstalled Kodi, and erased everything in the Kodi directory under .../Roaming/Kodi except for the userdata directory. I don't really want to erase my database of movies. So, there may still be some setting that is causing my problem with the Homw Window widgets. After re-installation, the problem is still the same.
Reply
#35
@bbqbod I'm working on the "open video info from home screen" issue. will push a fix in next few days.
Reply
#36
We switched over to a new Github repository https://github.com/xperience1080/skin.xperience1080.

I've updated all main threads to include the new URL.
Reply
#37
I am testing XP1080 on new Kodi Krypton Beta.
So far things seem to function really well.
Will report any issues when I find some.

Another thing:
in Estuary Mod the Skinners added a function to show "NextUp" popup in Live-TV.
https://github.com/sualfred/skin.fTVfred...eea37dbb81
I would LOVE to see that on my all favourite skin of all time! Wink

If you wouldnt implement, could someone advice me where to add these modification, i would do the work, and upload my result afterwards if wanted / allowed Smile

BTW: Thank you xhaggi for continuing development for Krypton. I was actually afraid I couldn't use the new kodi version with xp1080! Smile

Greetings

Hendrik
Reply
#38
(2016-09-17, 20:43)bbqbob Wrote: I am still having the same issue with the Home Windows widgets. All of the widgets (Spotlight, New Movies, Ongoing TV, New TV) have the same problem. I also noticed that when I press OK on the remote or Enter on the Keyboard on the widget that the fanart for the movie is displayed behind both the movie info and the home screen even though I have Use Fanart turned off. If get to the movie info screen from the normal method (choosing Movies from the home screen), then the Use Fanart setting works as expected.

Now the video info dialog works fine on top of the home screen. I've updated it in our Github repository.

Also, I've finally pushed support for the context menu stuff introduced in Krypton. You are now be able to open the context menu for every widget item.
There is one limitation caused by the skin and how it handles the widgets. You need to use your 'info' button not your 'contextmenu' button to get the contextmenu for the currently visible item of the widget.
Widgets that does not support a context menu are 'PVR' and 'Pictures'.
Reply
#39
(2016-09-20, 15:46)xhaggi Wrote: Now the video info dialog works fine on top of the home screen. I've updated it in our Github repository.

Also, I've finally pushed support for the context menu stuff introduced in Krypton. You are now be able to open the context menu for every widget item.
There is one limitation caused by the skin and how it handles the widgets. You need to use your 'info' button not your 'contextmenu' button to get the contextmenu for the currently visible item of the widget.
Widgets that does not support a context menu are 'PVR' and 'Pictures'.

Thanks! Big Grin I downloaded the update and I can confirm that the video info screen works properly when called from a home widget. However, when the video info screen invoked this way, the video fanart is always displayed despite that the "Enable Fanart" setting is turned off.

The duplicated settings in the Media section of the settings (see post 33) still exist.

I am not sure that I understand your note on the context menu. Pressing "i" or long pressing "Ok" didn't seem to do anything when focus is on a home screen widget (New Movies, New TV, Ongoing TV, ...). I didn't see any change in this regard from the prior versions of the skin.
Reply
#40
(2016-09-21, 06:41)bbqbob Wrote: Thanks! Big Grin I downloaded the update and I can confirm that the video info screen works properly when called from a home widget. However, when the video info screen invoked this way, the video fanart is always displayed despite that the "Enable Fanart" setting is turned off.

Will take a look at this again.

(2016-09-21, 06:41)bbqbob Wrote: The duplicated settings in the Media section of the settings (see post 33) still exist.

Caused by the missing settings group label + separator in Xpierence1080. The first settings are for video the second for music.
Will take a look at this too.

(2016-09-21, 06:41)bbqbob Wrote: I am not sure that I understand your note on the context menu. Pressing "i" or long pressing "Ok" didn't seem to do anything when focus is on a home screen widget (New Movies, New TV, Ongoing TV, ...). I didn't see any change in this regard from the prior versions of the skin.

You should see the context menu on top of the widget item.

Image
Reply
#41
The missing settings group label + separator image is fixed in master.

Image
Reply
#42
(2016-09-21, 06:41)bbqbob Wrote: However, when the video info screen invoked this way, the video fanart is always displayed despite that the "Enable Fanart" setting is turned off.

Fixed in master.
Reply
#43
(2016-05-31, 01:09)3000 Wrote: 4. Make it possible to add customized home categories - like “Games” OR anything anyone would want to add

thank you

An option we all would like to have. Indeed the hole skin could be more customisable.
Reply
#44
Thanks again!

I can confirm the media settings now have headers (so the settings do not appear redundant). Also, the showing fanart from a widget works fine. And, pressing "i" or "ctrl-d" on a keyboard shows the context menu.

My problem with the context menu is related to my remote, and not the skin. The "i" key on my Media Center remote does not map to "i" (information) on the keyboard. I had this set up before, but in clearing things out during the update to Kodi 17 Beta, I must have deleted the setting. Right now, I can't remember how I did it before. I don't think it is skin related though.

I see that this thread is marked "unstable", but this skin is working really well on Kodi 17 Beta. In fact, I think my setup is more robust and stable now than with Kodi 16. Thank you to everyone who worked on Kodi 17 and this skin!!
Reply
#45
(2016-09-21, 17:37)chisys Wrote:
(2016-05-31, 01:09)3000 Wrote: 4. Make it possible to add customized home categories - like “Games” OR anything anyone would want to add

thank you

An option we all would like to have. Indeed the hole skin could be more customisable.

Sorry but I've to say no for more customizations and the game category.
As more customizations and categories we add as more time is needed to maintain all the stuff.

(2016-09-22, 00:55)bbqbob Wrote: Thanks again!

I can confirm the media settings now have headers (so the settings do not appear redundant). Also, the showing fanart from a widget works fine. And, pressing "i" or "ctrl-d" on a keyboard shows the context menu.

My problem with the context menu is related to my remote, and not the skin. The "i" key on my Media Center remote does not map to "i" (information) on the keyboard. I had this set up before, but in clearing things out during the update to Kodi 17 Beta, I must have deleted the setting. Right now, I can't remember how I did it before. I don't think it is skin related though.

I see that this thread is marked "unstable", but this skin is working really well on Kodi 17 Beta. In fact, I think my setup is more robust and stable now than with Kodi 16. Thank you to everyone who worked on Kodi 17 and this skin!!

Thank you for testing it. I'll remove the unstable marker after the next release on the official Kodi repository.
ATM there are some glitches in the classic home, if you move between the categories.
Reply
  •  Previous
  • 1
  • 2
  • 3(current)
  • 4
  • 5
  • 14
  • Next 



Xperience1080 6.x51