v16 TVHeadend not working after Kodi Upgrade
#1
Hello all,

I was upgrading my Kodibuntu with Kodi 15.2 to 16.0. During the installation process I also upgraded TVHeadend to the latest version 4.0.8-16. I also configured a new account to access the backend interface. What is working now:

I'm able to access the backend with my newly configured credentials

What is not working:

- I'm not able to see the button "TV" in Kodi; the PVR client is configured properly
- the folder "/home/hts" is empty
- I cannot see any logfiles or any log entries in kodi.log

I tried to reconfigure TVHeadend with my browser but "nothing" works, that means, I cannot see any channels, Satellites, Services, Muxes etc. Everything is empty.

Can somebody please help me?
Thanks,
Kirschi
Reply
#2
Did you also upgrade pvr.hts? Major version updates to Kodi require new versions of the PVR addons. In linux, these addons are not supplied with Kodi.
Reply
#3
(2016-03-07, 10:35)kirschi Wrote: During the installation process I also upgraded TVHeadend to the latest version 4.0.8-16.
.
.
.
I tried to reconfigure TVHeadend with my browser but "nothing" works, that means, I cannot see any channels, Satellites, Services, Muxes etc. Everything is empty.

There is a large difference between the configuration of TVHeadend 3.x and 4.x. The configuration guide for 4.x can be found here: http://docs.tvheadend.org/
Reply
#4
(2016-03-07, 19:12)dnairb Wrote:
(2016-03-07, 10:35)kirschi Wrote: During the installation process I also upgraded TVHeadend to the latest version 4.0.8-16.
.
.
.
I tried to reconfigure TVHeadend with my browser but "nothing" works, that means, I cannot see any channels, Satellites, Services, Muxes etc. Everything is empty.

There is a large difference between the configuration of TVHeadend 3.x and 4.x. The configuration guide for 4.x can be found here: http://docs.tvheadend.org/

Thanks for the link. I followed the instructions and I can see a list of muxes but no services.

Bild "muxesuar24.jpg" anzeigen.
Bild "servicesznqk0.jpg" anzeigen.
Reply
#5
You probably still need to scan the muxes for services (channels).

Under the tab DVB Inputs/Networks you can select the networks (for you that's Astra 19.2 I guess), and then click 'Force scan'.

Although normally I guess tvheadend should scan when you add the network, somehow all muxes are still in 'pending' in your screenshot. So, try the 'force scan' button.
Reply
#6
And make sure your tuner is enabled, and associated with the "Astra" network

Image

Image
Reply
#7
Thanks Prof Yaffle! The tuner was not associated with the network.
Reply



Logout Mark Read Team Forum Stats Members Help
TVHeadend not working after Kodi Upgrade0
This forum uses Lukasz Tkacz MyBB addons.