•   
  • 1
  • 115
  • 116
  • 117
  • 118
  • 119(current)
Beta Spotify for Kodi
no way for me. installed last release from ldsz (1.2.3) but i cannot connect, keeps saying "Please connect this device with the Spotify App on your phone to Login or enter your credentials in the Settings dialog"
here's the log:

https://paste.kodi.tv/tohaqofoxi.kodi
Reply
(2021-05-20, 12:59)Acromion1754 Wrote: no way for me. installed last release from ldsz (1.2.3) but i cannot connect, keeps saying "Please connect this device with the Spotify App on your phone to Login or enter your credentials in the Settings dialog"
here's the log:

https://paste.kodi.tv/tohaqofoxi.kodi
Unfortunately me too. I've got "No credentials have been set or the login failed. Please enter your credentials in the addon settings.". Tried with both username and e-mail as "Username" in settings dialog.
Reply
OK, it's not working because I'm trying on Amlogic device without web browser. On W10 it's opening browser, authorize and working fine.
Also tried to swap cache with generated token from Windows to Amlogic (CoreELEC) but it's not working.
I guess since there are no working web browser on CoreELEC / Amlogic devices this addon wouldn't work.
Reply
Does anyone else have the issue where on certain tracks it will stop playing around the 2 min 44 second mark and then skip to the next song?

It appears to happen on everty 4th or 5th song, and it's always the same songs that this happens on and always at around the 2:44 mark.

I have reinstalled the app (cleared settings, deleted the addon directory), same problem.

I am playing locally off the device running Kodi. This is using Kodi 19.1 on Ubuntu, and ldsz 1.2.3, but this also happened with Kodi 19.0

On another machine I have librelec Kodi 18.9 running, and it seems to be ok, ie it can play these 'problem' tracks. So I'm not sure if the common factor is Kodi 19.
Reply
(2021-05-31, 23:42)ChickenLicken Wrote: Does anyone else have the issue where on certain tracks it will stop playing around the 2 min 44 second mark and then skip to the next song?

It appears to happen on everty 4th or 5th song, and it's always the same songs that this happens on and always at around the 2:44 mark.

I have reinstalled the app (cleared settings, deleted the addon directory), same problem.

I am playing locally off the device running Kodi. This is using Kodi 19.1 on Ubuntu, and ldsz 1.2.3, but this also happened with Kodi 19.0

On another machine I have librelec Kodi 18.9 running, and it seems to be ok, ie it can play these 'problem' tracks. So I'm not sure if the common factor is Kodi 19.
no i spoke too soon, kodi 18.9 has this problem too, although it cuts out at a slightly different time (2:35)

very frustrating problem
Reply
(2018-10-14, 04:48)ray2301 Wrote:
(2018-03-15, 16:06)adixor Wrote: Hi all

(new here)

I have installed the latest version today (1.1.46) on RPI3 + OSMC + Kodi latest (17.6) but unfortunately I have encountered the dreaded 2.40 min problem (play stops after 2.40, CPU goes very high for few seconds then system skips to next song and everything happens again in a loop Smile ).

I have tried to debug it more and saw that basically the spotty-muslhf process seems to die after getting the first part of the song (seen as <defunct> in ps axufw) and once kodi wants to buffer some more data (around minute 2:20-2:30) multiple such pspotty-muslhf processes get spawned FOR THE SAME TRACK and they consume A LOT OF CPU. Due to that apparently the curl cannot get the data anymore (a tcpdump shows TCP Window 0 messages as the system cannot cope with the curl transfer) and then.. well everything dies and we start again with the next song.

I was able to find a workaround though! apparently on RPI the kodi cache is around 20MB (which I understand means it consumes 60MB of RAM, don't ask me why, ask https://kodi.wiki/view/Video_cache).
I modified that value to be 80MB (which I guess will consume 240MB but I  did NOT yet see that, memory consumption is the same) but it works, play does not stop anymore! Well,. maybe for songs more than 10minutes it will, but I don't listen much to those.

Here's my /home/osmc/.kodi/userdata/advancedsettings.xml if you want to try:

[email protected]:~/.kodi/userdata$ cat advancedsettings.xml
<?xml version="1.0" encoding="utf-8"?>
<advancedsettings>
        <network>
                <autodetectpingtime>30</autodetectpingtime>
                <curlclienttimeout>10</curlclienttimeout>
                <curllowspeedtime>3</curllowspeedtime>
                <curlretries>3</curlretries>
                <disableipv6>true</disableipv6>
<!--            <cachemembuffersize>0</cachemembuffersize> -->
        </network>
        <cache>
                <buffermode>1</buffermode>
                 <memorysize>80971520</memorysize>
                 <readfactor>10</readfactor>
        </cache>
</advancedsettings>



I have also modified some of the CURL variables above (default timeout was 5, def speedtime was 1 (I also saw messages related to this when the issue happens), curlretries was 2). Anyway, not sure about the CURL variables and I don't think they are related, I think it's related with the memorysize value which was about 20000000. Try it, maybe it will work for you.

If that is indeed the cause (cannot test now more on this),  then the exact 2:40 timemark might be caused by the default kodi value for the buffer on RPI systems. I mean not caused but that may be a factor, the issue still seems to be related with spotty-muslhf doing something wrong somewhere but it's a binary, not much I can investigate there. The multiple <defunct> spotty-muslhf children of kodi.bin do not look good though...

Curious if that helps anyone.

adixor
 Thank you!!!! I was trying everyting for days! This solves the audio cut-off problem on windows 10 x64, kodi 17, confirmed with spotify version 1.1.44 and finaly it works fine with the latest 1.1.58.
I went back to 17 after trying to solve this problem on Leia. I wonder if it would work on Leia. Now I'm scared to try xD

Trawling through this forum I realised i have this 2.40 min issue too, as above.

This fix works! Thank you x1000!!!!

This is on my RPi4 8GB running Libreelec 9.2.6 (Kodi 18.9) with Spotify version 1.1.58

What's interesting though is that I had this same issue on my Linux Ubuntu 20.04 version with both Kodi 18.9, Kodi 19.0 and 19.1 using both 1.1.58 and the release from ldsz, so I'm pretty sure this is not a RPi specific issue.

What I don't understand is how everyone does not have this issue by default on a fresh install?

Anyway, still testing it, I am 10 songs into my playlist and it hasn't missed a beat, fingers crossed.

Kudos to Marcelveldt, this is by far my fav addon on Kodi
Reply
Hi,
Having a lot of issues getting this to work - consistently.
I'm on Ubuntu 20.04 x86_64
Firstly can't login - the web page never opens to authentication.
So use the spotify app on my phone to provide the authentication token - annoying, but a work around.
But then the songs won't start playing.
Kodi log here. https://hastebin.com/honaviwupa
But if I wait long enough, they might start playing a single song - then fails again part way through the song

Hope someone can point me in the right direction.

Thanks, Neeto
Reply
Hi I am on latest Raspbian on RPI 4 4GB. Having Kodi 18.7, Spotify addon 1.1.58. 
When I play song via spottify connect from android mobile It will play either two songs and the second is stuck on android phone spotify on 00:00 duration while on Spotify addon the song is playing and the third one is not played at all. Or the plugin plays only first song while you see on android phone that the duration of the song is going over the end till the infinity.

Anyone have suggestions how to solve this please?
Reply
(2021-06-24, 09:49)neeto33 Wrote: Hi,
Having a lot of issues getting this to work - consistently.
I'm on Ubuntu 20.04 x86_64
Firstly can't login - the web page never opens to authentication.
So use the spotify app on my phone to provide the authentication token - annoying, but a work around.
But then the songs won't start playing.
Kodi log here. https://hastebin.com/honaviwupa
But if I wait long enough, they might start playing a single song - then fails again part way through the song

Hope someone can point me in the right direction.

Thanks, Neeto

How do i use the spotify app to provice a token? and how do i put it in the kodi spotify add-on? (using 1.2.3 lszd)
Thanks!
Reply
Hello everyone, my premium account on Spotify was blocked due to illegal use. Apart from the Kodi add-on, there was no use outside of the app. So take care...

Hello again Uwe, thank you for your answer and for your invoice number. We have now canceled your blocked premium subscription on July 27th, 21st.
We cannot give you any more information than what you have already received, but we can tell you the following again: Spotify is a streaming service and music can only be listened to within the app. This also includes offline listening with a premium account. Any attempt to circumvent this, or otherwise make the content available for use outside the app is prohibited.

Should we carry out a music transfer for you (about when we will know and verify your new account) or should we just continue to help you close the old account. We are happy to hear from you again. If there is still something we can do for you, you can write to us at any time. Best regards ..... Spotify Customer Support
KODI 19 - AEON MQ8 for MATRIX MOD
5 Clients Win10 Pro - WinServer 2016 Essentials - DVBViewer / MediaServer - 2 x DD Duoflex C2/T2 - Duoflex CI - Deltacam 2.0 Twin - Unitymedia HD/Sky
Reply
One question:

How working the addon? With regular or Highspeed streaming? Spotify now control allways, if someone streaming with highspeed (most downloader for mp3 use this) and cancel the account. 

Maybe someone knows it. Thanks

Uwe
KODI 19 - AEON MQ8 for MATRIX MOD
5 Clients Win10 Pro - WinServer 2016 Essentials - DVBViewer / MediaServer - 2 x DD Duoflex C2/T2 - Duoflex CI - Deltacam 2.0 Twin - Unitymedia HD/Sky
Reply
  •   
  • 1
  • 115
  • 116
  • 117
  • 118
  • 119(current)



Logout Mark Read Team Forum Stats Members Help
Spotify for Kodi17
This forum uses Lukasz Tkacz MyBB addons.