•   
  • 1
  • 75
  • 76
  • 77(current)
  • 78
  • 79
  • 111
  •   
Beta Spotify for Kodi
(2017-06-30, 10:11)kneegrow Wrote: Using the plugin on kodi on libreelec i get an error that says control not avaliable or something..

Great bug report. Maybe provide the exact problem description and/or a kodi logfile ?
Reply
Just tried this addon on my shield. Looks great but rarely get a song to play. Does seem to work if I connect it to my phone though.
Reply
I'm continuing to have issues getting this working well. Other people clearly have it working, so I suspect there's something in my specific setup. My reading of the logs suggests it's most likely a timeout issue - perhaps my 3G internet connection has more latency than is assumed in the settings.

BACKGROUND
My setup is a linux quad core mobile chipset, running kodi, and I upgraded to latest spotify plugin this morning. I have pulseaudio running (installed so the native Spotify client would work, but I had the same behaviour with native alsa audio).

The native spotify client does play, with spotify connect as well. So whilst my setup is probably the cause of the problem, whatever it is is an interaction with Kodi and the Spotify addon, not just a problem with Spotify entirely.

ISSUE
My spotify connect won't play at all in kodi, although the logs suggest the commands are coming through. Running librespot directly I can see the files downloading, although I get no audio (presumably due to configuration of librespot and audio).

Playing songs from the playlist within the plugin fails the first time on a song, but when playing a song already cached plays fine. Kodi log shows a timeout error. Once the first song plays in the playlist the next song doesn't play, even if that song has been previously played and is therefore cached.

LOGS AND DETAIL
When calling directly from librespot, it seems to stream fine, although I'm getting no audio, no doubt due to the alsa settings. As can be seen librespot is busily downloading the track, and presumably trying to play it to the alsa sink:
https://pastebin.com/Uqp5Mb7u

When calling from within Kodi for spotify connect, it just doesn't play anything, although it clearly is trying to:
https://pastebin.com/ReQVHAky

Second time calling from spotify connect, file already downloaded/cached, still no playing. I'd hoped perhaps once the file was downloaded it might play, same as it does when playing from the UI, but no joy, so potentially a different issue than when playing from playlist:
https://pastebin.com/e6DJt5TY

First time when picking a track directly from playlist in the UI, doesn't work:
https://pastebin.com/4KdTZwx9

Second time calling from playlist, file already cached. Works and plays audio:
https://pastebin.com/Hf1VML6E

However, it doesn't go to the next track in the playlist, and nothing that looks relevant in the log. When I selected that track directly, I got the following error:
https://pastebin.com/MCD1KtLd
This one crashed Kodi entirely, and may be a different issue.

Finally, I also noticed the Kodi UI hangs sometimes when trying to start a track - so something is perhaps blocking the UI. I'm not sure if that is maybe contributing.

Any thoughts or diagnostic paths I should follow would be gratefully received.
Reply
I've created a ticket for the multi user switching that crashes https://github.com/marcelveldt/plugin.au.../issues/33
Reply
(2017-06-30, 23:16)marcelveldt Wrote:
(2017-06-28, 09:47)manfeed Wrote: Hi, this addon is amazing, thanks for your work! I have noticed that when I open an album from an artist and I hit C one of the options is Scan item to library; when I select it the album gets added to my library, just as if it was a local one what is nice, but if I try to play those songs from the library it's impossible... is it an issue or am I doing something wrong?

Actually it's Kodi itself that is showing that entry in the context menu but apparently it doesn't accept the http location to be added to the local library. It's a shame because it would have been cool if the Spotify library was synced up to the Kodi library.

Right, sorry if I caused any confusion. My eyes seem to be getting worse. And yes, would be awesome to be able to add albums or songs to kodi's library from streaming addons like this one to unify the libraries. Right now I have four libraries in kodi if you want: Local, Spotify, Google Music and Amazon Prime Music butthey are not connected in any way.

But Marcel, it was possible to add albums to kodi's library once with this addon, content was even correctly scraped, playback from the library failed though:

2374095 (post)
Reply
Hey marcelveldt, just wanted to say thank you so much for this addon and all your work!

The new features (especially "Spotify Connect") are great! This really is a huge improvement and makes using Spotify so much more fun and easy!

Thank you.
Reply
I used to be able to use the plugin with no problems.

Now I am getting this :


17:45:22.259 T:140216470464832 ERROR: CCurlFile::FillBuffer - Failed: Timeout was reached(28)
17:45:22.259 T:140216470464832 ERROR: CCurlFile::Open failed with code 0 for http://localhost:52308/track/6N7gPTru90HYLRUIVDQ185/270
17:45:22.260 T:140216470464832 ERROR: Open - failed to open source <http://localhost:52308/track/6N7gPTru90HYLRUIVDQ185/270>
17:45:22.260 T:140216470464832 ERROR: Init: Error opening file http://localhost:52308/track/6N7gPTru90HYLRUIVDQ185/270
17:45:22.260 T:140216470464832 ERROR: CAudioDecoder: Unable to Init Codec while loading file http://localhost:52308/track/6N7gPTru90HYLRUIVDQ185/270
17:45:22.260 T:140216470464832 WARNING: PAPlayer::QueueNextFileEx - Failed to create the decoder
17:45:22.260 T:140216470464832 ERROR: Playlist Player: skipping unplayable item: 0, path [http://localhost:52308/track/6N7gPTru90HYLRUIVDQ185/270]
17:45:23.318 T:140214768895744 NOTICE: plugin.audio.spotify --> playback stopped
17:45:23.398 T:140213804316416 NOTICE: plugin.audio.spotify --> Connect player requested playback of track 6N7gPTru90HYLRUIVDQ185
17:45:23.952 T:140213804316416 NOTICE: plugin.audio.spotify --> Pause requested by connect player

I am on the latest version. ( 1.1.30 )

Any ideas?

Update : Adjusting the settings to "Play through Kodi" seems to have fixed the problem.

I have pulse audio installed. I suspect that is the issue.

Update : Adjusting that settings worked for one song only. Reverting to version 1.1.25 seems to have made it functional.
Reply
Hi, thanks for your great work.

I'm trying to use the new feature spotify connect :

In kodi I can see my spotify devices (android smartphones) and I can connect them, they are tagged as [active] but in tha android app, I never see the Kodi peripheral...

If i click another time on the device [Active], the playback on the phone just pause.

Am I missing something ?
Reply
I have tried this add-on in its early days but since it needed a browser which a Raspberry PI runing OSMC does not have, I never got very far.

Now It seems the requirement for the browser has gone away and I can logon to my Spottify account using the 1.1.30 version of the package.

But unfortunately I cannot play any music, nothing happens when i hit a particular song in my playlist.

(unfortunately i am to dumb to know where the kodi log is to be found so I cannot show any specifics).

I have tried OSMC from April, May and June this year, and May try earlyer versions to see If I can find a pre Krypton version where things might work.

Anybody know of this problem and what version i need to revert to?

At some poing SpotImc stopped working since the interface in Kodi changed, are we under the same restrictions here og will the library be updated to work with current OSMC versions ?

My Raspberry Pi works as media centre for my living room being connected to the TV and Amplifyer so my tweenage kids can play all their music loudly when I am not at home.
I am very happy this project is progressing, I have missed by Spotify to provide the feed for .their frenzy :-)

Greetings from Denmark
Reply
@WolfJespersen: I don't have a lot of answers for you, as mine is only intermittently working, but it sounds like mine works more than yours, so worth a try.

On a raspberry pi your logs would be in ~/.kodi/temp/kodi.log. ~ is your home directory, so if your username on the pi was paul, then it would be in /home/paul/.kodi/temp/kodi.log.

You can get more logging information by turning on debug logging within Kodi, which you do in the kodi settings menu, under logging. You can google for instructions for that.

I believe the Spotify plugin has some settings, including one that tells it whether you want Kodi to do the playback, or for it to do the playback itself. I haven't had to adjust that myself, but it sounds like that is the most likely source of your trouble if it looks like it's playing on screen but you have no sound. Worth a try anyway.
Reply
@iskonje: I have seen mention that it is important that Kodi is set to broadcast - I'm trying to recall the name of the option, but it's upnp or avahi or one of those. It has been mentioned in this thread, if it isn't turned on then the plugin won't broadcast to other spotify devices, but presumably can see those other devices itself. That sounds like the cause of your problem to me, but as noted just above I'm not overly familiar and mostly came here today to see if my issue had an answer. :-)
Reply
Guys, long replies with this & that does not help much.

Here is a useful reminder from the first post of this thread:

If you have an issue, please report as much details as you can;
- Hardware
- OS
- Kodi version
- Addon version
- If possible: a kodi log grabbed after discovering an issue
Sony VPL-HW55ES + Stewart Firehawk 182cm, nVidia Shield, LibreElec + 5 * Intel NUC, Vu+ Uno4k & T90+8lnb, 28Tb Thecus N7510 NAS, Denon AVR-X1100W, AMX+ 3*Ipad, 3*KefQ1, 4*KefQ2DS, Elac S12EQ
Reply
Hello Marcel et all.

I made another attempt at getting Spotify for Kodi ver. 1.1.30 to work on Raspberry PI running OSMC, today I tried OSMC january-2017, based on Kodi 16.1.

I made a logfile of my attempt at playing several music numbers which can be found here: https://paste.ubuntu.com/25013656/

Only configuration i made was to install the Spotify plugin and set my loginname and password, everything else is default.

I selected the Confluence skin since that's the one I am used to and installed the logfile upload plug in.

It logged onto Spotify OK and accessed my playlists no problem, but when hitting one of the songs nothing happens.
No visual reaction, no error message, nothing.

Hopefully the log shows a bit more but I dont know enough of Kodi to interpret it.

Great that you are working on Spotify for Kodi, I really hope you can get everything working, even though you are attempting to support such a varied platform, from PC¨s with windows to Raspberry Pi's like mine.
Full Steam Ahead Big Grin
Reply
Hello Marcel,

perhaps you could help me with the following problem within Spotify:

19:14:45.648 T:1937765360 WARNING: CreateLoader - unsupported protocol(activatewindow(10502,"plugin) in activatewindow(10502,"plugin://plugin.audio.spotify/?action=browse_playlists&ownerid=xxxxx",return).tbn
19:14:49.822 T:1709175792 ERROR: GetDirectory - Error getting
19:15:17.063 T:1725953008 ERROR: Previous line repeats 3 times.
19:15:17.063 T:1725953008 NOTICE: plugin.audio.spotify --> playback stopped

- Hardware: RaspberryPi 2
- OS: OSMC - Kodi 17 17.1-RC1
- Addon version: 1.0.30

The result is, that i can open spotify choose my plalist and when i want to start a title the screen shows, that a totally different title starts but without any real (music) signal output and when i try to choose another title again the same different title seems to be started but again without any result.

Thanks for your help
Reply
(2017-07-02, 17:22)jNk20 Wrote: Hey marcelveldt, just wanted to say thank you so much for this addon and all your work!

The new features (especially "Spotify Connect") are great! This really is a huge improvement and makes using Spotify so much more fun and easy!

Thank you.

I cannot agree more! Thanks Marcel for this awesomeness. I actually could return the Music Box (Spotify player) which I just ordered. Laugh

I experience some hiccups (not responding or slow when using spotify on my phone remotely), but sure it will get stable over time.
Reply
  •   
  • 1
  • 75
  • 76
  • 77(current)
  • 78
  • 79
  • 111
  •   
 
Thread Rating:
  • 17 Vote(s) - 4.65 Average



Logout Mark Read Team Forum Stats Members Help
Spotify for Kodi4.6517