•   
  • 1
  • 78
  • 79
  • 80(current)
  • 81
  • 82
  • 112
  •   
Beta Spotify for Kodi
(2017-07-09, 13:06)marcelveldt Wrote:
(2017-07-06, 18:18)rollcry Wrote: Hello Marcel,

perhaps you could help me with the following problem within Spotify:

19:14:45.648 T:1937765360 WARNING: CreateLoader - unsupported protocol(activatewindow(10502,"plugin) in activatewindow(10502,"plugin://plugin.audio.spotify/?action=browse_playlists&ownerid=xxxxx",return).tbn
19:14:49.822 T:1709175792 ERROR: GetDirectory - Error getting
19:15:17.063 T:1725953008 ERROR: Previous line repeats 3 times.
19:15:17.063 T:1725953008 NOTICE: plugin.audio.spotify --> playback stopped

- Hardware: RaspberryPi 2
- OS: OSMC - Kodi 17 17.1-RC1
- Addon version: 1.0.30

The result is, that i can open spotify choose my plalist and when i want to start a title the screen shows, that a totally different title starts but without any real (music) signal output and when i try to choose another title again the same different title seems to be started but again without any result.

Thanks for your help

In the main screen when you enter the add-on you can set the playback device. Please (re)set it to your local machine.
Also, in the add-on settings try to play with the setting to enable playback through Kodi or directly to the sound card.

Hello Marcel,

unfortunately your proposes have not been succesful. Instead I downgraded to 1.0.22 and now everything seems to work fine.

Thanks for your great work.
Reply
(2017-07-09, 04:05)jurialmunkey Wrote: Btw, for those with playback problems, the old version that runs on libspotify still works for the time being. Spotify is going to disable the libspotify api sometime this year, that is why marcelveldt has been working on this new version that uses librespot. But in the meantime, it still works pretty well. I'm currently using it until the issues in 1.1.30 are fixed. I keep a zip file of it on hand and then I test out the new versions and if I have problems I report them in this thread and then roll back to the old version so that I still have something that works.
I use the version supplied by eddiewould which added radio support from this post:
2573352 (post)
Link to zip: https://github.com/flakey-bit/plugin.aud.../radio.zip

Of the new version using librespot, I've had much more success on LibreElec using version 1.1.24
https://github.com/marcelveldt/repositor...1.1.24.zip

Thanks for this. It worked. I have a NUC running LibreELEC and this great addon just wasn't playing any of the tracks.
OSMC Vero 4K, Intel NUC Celeron 847, Raspberry Pi3 LibreELEC. Amazon Fire TV
Sony 5.1 Surround sound
Panasonic 50EX750B
Reply
ugh...

All I did was get a new phone... now it barely works and constantly tries to play the last song I played on my phone. Then fails.

who knows androidHuh??
Reply
Hi,

This plugin has stopped working for me,

I can log in, but cannot see any songs or any of my playlists.

here is my Debug Log if it helps : http://paste.ubuntu.com/25075331/

Br
Patric
Reply
Hi, I had to downgrade the addon due to the following problem. When I choose a song, it will be played on the last device that has spotify open. To clarify, when I choose a song on my Kodi (RPi) my phone suddenly starts to play the song, and I can't switch to play it local on the RPi. The settings of the spotify connect says that it will be played locally, however I haven't managed to play a single song locally on the RPi. The downgraded version just works fine like it used too. I understand the problems and difficulties currently since spotify want to shutdown libspotify. This post is purely for feedback and further help for the addon.

INFO:
- RPi 3
- LibreElec 7.0.3
- Kodi 16.1
- Addon 1.0.30

Kind regards
Reply
(2017-07-12, 15:55)Dystant Wrote: Hi, I had to downgrade the addon due to the following problem. When I choose a song, it will be played on the last device that has spotify open. To clarify, when I choose a song on my Kodi (RPi) my phone suddenly starts to play the song, and I can't switch to play it local on the RPi. The settings of the spotify connect says that it will be played locally, however I haven't managed to play a single song locally on the RPi. The downgraded version just works fine like it used too. I understand the problems and difficulties currently since spotify want to shutdown libspotify. This post is purely for feedback and further help for the addon.

It's the default behaviour of Spotify that playback starts on the last device used. That device is set as the playback device.
When you open the add-on, right away in the first screen click on playback device and select your Pi to change the playback device.
Reply
(LibreElec Krypton, RasPi 3, addon v1.1.30)
Here's a log taken while Spotify was refusing to play anything. This happens with both 'output directly to sound card' and 'use kodi player' and with audio cache both enabled and disabled: https://paste.ubuntu.com/25073632/
Reply
(2017-07-13, 06:46)theycallmecheese Wrote: (LibreElec Krypton, RasPi 3, addon v1.1.30)
Here's a log taken while Spotify was refusing to play anything. This happens with both 'output directly to sound card' and 'use kodi player' and with audio cache both enabled and disabled: https://paste.ubuntu.com/25073632/

Thanks, can you please test again with version 1.0.31 ?
I've reverted the code to the point where playback was working the best according to reports here.

The lockups still happen every now and than but I'm close to pinpointing the issue to discuss with the Kodi devs.
Version 1.0.31 is back to the point where the playback is handled by Kodi so no more direct output to the sound card and the audio is sent in chunks to the Kodi player to get it playing faster.

My own test results with version 1.0.31 is that it's working pretty well now with only an occasional lockup of the Kodi player.
Spotify Connect control is still a bit flakey though if you try to control the playback from the Kodi OSD. From a remote device it seems to work ok.

I'd like to hear some test reports of people testing with version 1.0.31 to confirm this is indeed working better (remember, still not perfect but we're getting there).
Reply
For me, on 1.0.31, it's not working. It's not working in a different way than before, to the extent that's helpful. The behaviour is that it boots up fine, connects fine, shows playlists etc. When selecting a song it blocks the UI briefly (5-10 seconds) and nothing plays.

(without debug logging)
https://pastebin.com/KmRwj7fE

(with debug logging)
https://pastebin.com/caXXSafa

INFO:
- Debian Linux on intel
- Kodi 17.3 x64
- Addon 1.0.31
Reply
I'd like to revert as well.

Do you have a link to the 1.0.xx releases? I only see the 1.1.xx releases on github. Hope I'm not missing something obvious. lol
Reply
(2017-07-14, 02:00)booker88 Wrote: I'd like to revert as well.
Do you have a link to the 1.0.xx releases? I only see the 1.1.xx releases on github. Hope I'm not missing something obvious. lol

I think marcelveldt just mistyped in the post just above. He was referring to the most recent 1.1.31 (not 1.0.31) release that has reverted back the most recent changes - so just update normally.

Also if you want to revert to the old libspotify version, I linked a zip of a forked version that has song radio support in this post:
2614739 (post)
Reply
@marcelveldt - still getting heaps of tracks being skipped on 1.1.31 on LibreElec8. First track I played on an album stuttered and skipped a bit, then second track played completely, then after that every track was slowly skipped.

Nothing much being output to the log other than this being repeated for each skipped track:
Code:
13:13:30.008 T:140081785382656  NOTICE: plugin.audio.spotify --> start streaming of track 0g89QcYabnaRUUPgFOLKZ9
13:13:32.008 T:140081785382656  NOTICE: plugin.audio.spotify --> end of stream for track 0g89QcYabnaRUUPgFOLKZ9
13:13:42.006 T:140081743419136  NOTICE: plugin.audio.spotify --> []
13:14:20.379 T:140081521985280   ERROR: CCurlFile::FillBuffer - Failed: Timeout was reached(28)
13:14:20.379 T:140081521985280 WARNING: CCurlFile::FillBuffer - Reconnect, (re)try 1
13:14:20.383 T:140081521985280   ERROR: CCurlFile::FillBuffer - Failed: Requested range was not delivered by the server(33)

Also, as a side note. The "plugin.audio.spotify --> Userdetails" part of the log is outputting some details that really don't belong in a log - namely birthdate and email address. This really should be automatically censored to prevent people unwittingly uploading these details online.


EDIT: Now that the album has finished skipping slowly through the tracks, I also got this at the end of the log:
Code:
13:16:56.444 T:140082832992000   ERROR: EXCEPTION: XBMC is not playing any file
13:17:09.730 T:140081904822016   ERROR: Previous line repeats 26 times.
13:17:09.730 T:140081904822016  NOTICE: plugin.audio.spotify --> []
Reply
Here's with Debug logging turned on:
https://pastebin.com/J8iQVH0R

I started playing a song with debug logging turned on at 13:19:58.001
Reply
(LibreElec Krypton, RasPi 3, addon v1.1.30)
Tracks play again pretty reliably with 1.1.31 but eventually begin to stutter and then stop playing after a while. This log was taken while the playback was stuttering.
https://paste.ubuntu.com/25087040/

EDIT: whoa wait it auto updated to 1.1.32 while i was making this post
Reply
I have placed the old 1.0.26 version on the repo so you can install that on your "production" machines.
In the meanwhile I've contacted one of the Kodi devs about the lockup issue I'm running into with the new implementation.
The old implementation had that same issue but it only happened sometimes.
Reply
  •   
  • 1
  • 78
  • 79
  • 80(current)
  • 81
  • 82
  • 112
  •   
 
Thread Rating:
  • 17 Vote(s) - 4.65 Average



Logout Mark Read Team Forum Stats Members Help
Spotify for Kodi4.6517
This forum uses Lukasz Tkacz MyBB addons.