WIP -  Why Doesn't My Repo Work?
#1
Sad 
Trying to create a repository for my add-ons, but not having much success.

I've put together some add-ons on my laptop running Ubuntu, and created the addon.xml, addons.xml, and addons.xml.md5 files on the same system. I created some folders on Github and uploaded the files using the 'Upload files' button, and the first time, it worked ok. But when I added a fourth add-on to Github, and updated addons.xml and addons.xml.md5 files, it stopped working. At first, nothing showed up when I tried to access the repository in Kodi. But after deleting the addons.db file and doing a force refresh, all 4 add-ons were there - but icons weren't showing up, and clicking on any of the add-ons either produced no results, or a message indicating the add-on was installed successfully when actually nothing was installed.

I'm no stranger to using the command line, but a while back I almost killed the ESPN3 add-on by attempting a pull request using the CLI. For that reason, I decided I'd be better off trying a gui interface for git. I removed all the files I had previously uploaded to Github, created a new repository, and tried using SourceTree on my Macbook to upload everything. Everything seemed to work ok, but when I tested the newly created repo on my laptop and HTPC, I get the same results as before.

I've created and re-created the xml and md5 files over and over, but I'm just going around in circles. I've spent a couple of days searching and reading various threads here and different tutorials for creating repositories, trying different ideas, but I'm not getting anywhere. I've looked at other repositories and it looks like I've got things put together the right way, but I'm stumped and my eyes are tired. I need someone to download my repo (link removed since it didn't work) and look it over and see if there's something there that I'm not seeing.

Any help would be greatly appreciated.

EDIT: Debug log on pastebin.
Kodi Jarvis (16.1) on ThinkPad T400 Lubuntu 16.04.4 | Kodi Krypton (17.6) on HTPC Lubuntu 16.04 | My Add-ons | My Repo
Reply
#2
ive been trying set up a repo from a youtube guide i went round in circles trying to make it work

i eventually fixed it be downgrading kodi to isengard 15.2 and it worked first time

this is how i got here looking for jarvis repo support
Reply
#3
@MetalChris:

I visited your github repo and clicked on addons.xml.md5 and saw that this:

Code:
8d71f2a5c4f35f8dacc4d3ee9ff21c1b addons.xml

As far as I know, the md5 file should only have the hash, should not have ' addons.xml' in there.

Must be something in your addons_xml_generator.py doing that.

In your debug log, icons and fanart is failing to load. I think it's because of the url being used.

Code:
https://github.com/MetalChris/repository.metalchris/blob/master/addons/plugin.video.animalist/icon.png

Instead of 'blob', shouldn't it be 'raw' ?

Code:
https://github.com/MetalChris/repository.metalchris/raw/master/addons/plugin.video.animalist/icon.png
Get Best of NHK, NRATV, DigitalRev TV and XiveTv add-ons via my repository. Enjoy!
Reply
#4
With some help from @Lunatixz and @misty01, I think I'm pretty close to having a working repo. Smile

This most recent attempt seems to work as expected with all of my newer add-ons. There is some sort of conflict occurring with some of the early versions of my older add-ons. I had attempted to make each add-on it's own, self contained repository, and the added repo info (different hosts) in the individual addon.xml files seems to prevent these add-ons from updating. I've since removed the repo info from all addon.xml files, and bumped the add-on versions. In most cases, uninstalling existing older versions, exiting Kodi, then deleting the addons.db file allows for installing these older add-ons from the new repo after restarting Kodi. In a few cases this did not work, but uninstalling, restarting Kodi, and manually installing the add-ons from .zip file did.

This is not perfect, but definitely closer to where I'd like to be. If a few people would download the newest version of my repo, give it a test drive, and provide some feedback, it would be greatly appreciated.
Kodi Jarvis (16.1) on ThinkPad T400 Lubuntu 16.04.4 | Kodi Krypton (17.6) on HTPC Lubuntu 16.04 | My Add-ons | My Repo
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Why Doesn't My Repo Work?00