Linux Fixed? Cannot play any video file
#1
Could anyone please help with this error? I can play music, but not any movies. For any movie that I try to play, the screen turns blank. When I return to the console, I see this error message:

Code:
libpng warning: iCCP: known incorrect sRGB profile
mmal: mmal_component_create_core: could not find component 'vc.ril.video_render'
mmal: mmal_component_create_core: could not find component 'vc.ril.video_decode'
mmal: mmal_component_create_core: could not find component 'vc.ril.video_render'
kodi.bin: RBP.cpp:308: virtual bool CMMALRenderer::Configure(unsigned int, unsigned int, unsigned int, float, unsigned int, ERenderFormat, unsigned int, insigned int): Assertion 'm_bConfigured' failed.
/usr/local/bin/kodi: line 165:  1118 Aborted        "$LIBDIR/${bin_name}/${bin_name}.bin" $SAVED_ARGS
Crash report available at /home/username/kodi_crashlog-20160326_130407.log

Click here for the crash log.

I tried this, but it did not help (LD_LIBRARY_PATH=/opt/vc/lib/ /usr/local/lib/kodi/kodi.bin). Ldd did not show any problems finding libraries initially, anyway.

Quote:http://forum.kodi.tv/showthread.php?tid=261019
LD_LIBRARY_PATH=/opt/vc/lib/ /usr/local/lib/kodi/kodi.bin

I found this, as well:

Quote:https://www.raspberrypi.org/forums/viewt...4&p=934983
If you're using Gentoo and using the pi2, don't use the default raspberrypi-userland in portage. It's quite old.

However, I am using media-libs/raspberrypi-userland-0_pre20160305-r1, which I would expect to be reasonably up-to-date. I will try 9999, but I am not sure whether it will help.

I tried increasing G.P.U. memory to 256MB, but this did not help.

Gentoo Linux
Raspberry Pi 3
Kodi 16.0
Reply
#2
The original post was for errors after I built Kodi from source. I tried 17, 16.0, and 15.2, all with the same or very similar errors.

After a bit of tweaking, I am running 16.0 with this error repeating when I try to play any video:

Code:
mmal: mmal_component_create_core: could not find component 'vc.ril.video_render'

Omxplayer works fine, though; I can play movies with this.

I am honestly not sure whether this is related, but I found this article and am rebuilding without the --as-needed LDFLAG; by default, it looks like --as-needed is enabled on my computer.
Reply
#3
I installed kodi with LDFLAGS="-Wl,-O1", but it still did not play movies. However, after compiling and installing raspberrypi-userland with LDFLAGS="-Wl,-O1", I can play movies now. It looks like the --as-needed LDFLAG was causing problems in this situation.
Reply
#4
here is a bug at github that i filed: https://github.com/raspberrypi/userland/...-204394592 they claim this is kodi issue and not raspberrypi-userland issue which makes sense.

from what i understand, the problem is kodi being built with --as-needed as it removes unused library mmal_vc_client and hence causes the components not being initialized. when --as-needed is disabled, the library is linked and components are initialized. at the link there is proposed solution:

pellwell Wrote:On the VPU the way I got round this was to put some key function like a constructor (or a reference to it) in a .init.* section - see interface/vchi/vchi_autoservice.h for an example; this works because the linker always includes things in .init and .init.*. I don't know if that technique works with the GNU linker, but it might be worth a try.
Reply



Logout Mark Read Team Forum Stats Members Help
Fixed? Cannot play any video file0
This forum uses Lukasz Tkacz MyBB addons.