•   
  • 1
  • 102
  • 103
  • 104(current)
  • 105
  • 106
  • 231
  •   
Win Intel HTPCs/NUCs & Kodi-native 3D MVC Playback
I don't know about the previous generations but on my LG OLED E6 from 2016 'Real Cinema' is automatically activated when I playback 24p content and greyed out in the settings menu. Real Cinema switches the display to 120Hz so that basically every frame is displayed five times. (120/5=24)

Also make sure that the Kodi player settings switch the panel on start/stop of the movie, otherwise it will use your regular desktop settings which might be 60Hz. FWIW my TV also automatically turns 3D mode on and off on playback start/stop.
Intel NUC5i5RYH
Reply
(2016-09-16, 16:25)ppoulos Wrote:
(2016-09-16, 15:03)p750mmx Wrote: No no, I only want to know if you have any settings active like Real Cinema and/or Trumotion.

I have Real Cinema turned off (except when viewing my DirecTV DVR which is 1080i resolution). Trumotion is set to USER with a De-Judder setting of 2, and a De-Blur setting of 9.
OK, thanks for sharing that. I changed the Trumotion settings from USER to OFF because with my TV Provider is give sometimes a strange stutter when watching live TV. Its look like some frames are being skipped, sometimes, not frequently, but enough to irritate me. It mostly happens when watching Formula 1 or with other fast images on display. With the setting switched off is doesn't occur at all. I don't see a really big difference while using Kodi with the setting on or off, so I let it off all the time.

Edit: auto 3D start when starting a 3D movie is solved. Just re-installed the latest driver.
Kodi 18.2 RC [MVC build] Shuttle DH270 [Kaby Lake i3-7300/HD630 graphics] Windows 10 - 1903 [3840x2160/60Hz]
4k video trough HDMI 2.0a port direct to LG Oled 55EF950V (with 2018 panel) HDR [success] HD audio through HDMI 1.4 port direct to NR1606 receiver
Kodi [4k/60Hz success] [i3D 4k success] HDR done by Kodi [no support]
Reply
New MVC build posted. Thank you @afedchin. See post #1 for download link.

Anyone know where I can see what improvements/changes are in this build?
[H]i-[d]eft [M]edia [K]een [V]ideosaurus
My Family Room Theater
Reply
This is what i found, don't know if that apply to the new release.

Quote:This fixes several issues with ffmpeg build for windows:

Fixed build ffmpeg via MSVC toolchain
Fixed build hanging if ffmpeg build failed.
Added liblzma to dependencies which adds lzma support to ffmpeg.
Bump gnutls version which speed up build

Nice to see a new update from @afedchinCool
MY CURRENT MEDIA PLAYER | MY HOME THEATER
MINIX NEO U9-H LIBREELEC v18 Leia | EGREAT A10 | NVIDIA SHIELD
SAMSUNG QLED QN75Q7 | Sony 43 Android TV HDR
XBOX ONE X UHD BLU-RAY | PS4 PRO 4K w/PSVR
NAKAMICHI PRO 7.1.4 DTS:X/ATMOS 
Reply
Hoping to see the following fixes personally that weren't working in July 14 build:
  • TrueHD/ATMOS fixed (was an issue in master used at the time)
  • DD+ passthrough fixed (has been an issue in master for ages)
  • Auto-switching for 3D SBS and TAB (unsure about July 14 build, but doesn't work w/June 30 I've been using)
  • 3D auto flip-eyes (Hasn't this been broken for a while?)
Anyway, will test later today and report back.
[H]i-[d]eft [M]edia [K]een [V]ideosaurus
My Family Room Theater
Reply
(2016-05-12, 19:38)Statikk Wrote: Build Info: Kodi MVC WIP 20160512

Debug Logs:
Everest MVC MKV (created with MakeMKV) http://xbmclogs.com/pwejnrriq
Finding Nemo MVC MKV (created with MakeMKV) http://xbmclogs.com/p3xiwhe3s

Ok I was able to do a quick test of the same movies and add some new logs. It definitely seems like the problem is less severe. I have a much better chance of successfully skipping a chapter now. When chapter skipping fails it seems like it is much less likely that CPU spikes to 100%. Last time it seemed to spike everytime.

If CPU usage does not spike to 100% then you can usually skip to the next chapter. Going back to the previous chapter (that failed when skipping forward to it) always fails though. Sometimes I will skip through a whole movie and there will be a handful of chapters that always fail everytime I skip forward/backward to them. Then I stop the movie and restart it and I am able to skip to those chapters every time but a new handful of other chapters will fail.

If CPU does spike to 100% then all attempts to chapter skip after that will fail and CPU will stay at 100% until I stop the movie.

In Nemo after a chapter skip I noticed that sync was off and I tried to seek forward a little to adjust. That also failed.

Thanks for working on this afedchin and feel free to message me if you would like me to try anything in proticular.


(2016-05-12, 04:51)Statikk Wrote: An update to yesterday's post:

Build Info: Kodi MVC WIP 20160505

Hardware: Intel NUC DN2820FYKH with Intel Celeron N2830 CPU, Windows 10 Professional 64bit, Intel® HD Graphics driver-version 10.18.10.4338

Debug Logs:
Everest MVC MKV (created with MakeMKV) http://xbmclogs.com/peqvzgcof
Finding Nemo MVC MKV (created with MakeMKV) http://xbmclogs.com/pfwepqi3s

Description: When skipping in MVC MKV files with TrueHD/ATMOS sound about about 85% of the time CPU usage increases to 100% and remains there while video slows to a halt.

Screenshots: Screenshots taken during video playback were blank. If helpful I can snap a pic/video with my phone.

How to reproduce: Play an MVC MKV file with TrueHD/ATMOS sound and chapter skip.


Finding Nemo seems to have slightly better chances of a successful chapter skip for whatever reason. There seems to be no problem with DTS-MA. I have tried disabling bitstreaming of TrueHD.


(2016-05-11, 08:32)Statikk Wrote: Can anyone confirm a problem with the 5-05 build playing 3D MVC MKVs with TrueHD/Atmos soundtracks? An ISO of the same movie plays fine but when converted into MVC MKV I'm not able to FF/RW or chapter skip without losing audio> video slows> video freezes. When doing a chapter skip the video actually progresses to the new chapter but the play timer starts back at 0:00> audio loss> slow video> video freeze. I have tested quite a few movies now (Everest, Finding Nemo, Minions, In the Heart of the Sea) and have also tried turning off TrueHD Capable Receiver. I also tried switching off 3D while playing which seemed to have no effect.

Statikk is this fixed with latest build? I have the same nuc...
Reply
Between this and the updated Intel driver things are really looking good.... hoping to see skylake reduce in price once next batch of NUCs hit and buy as an early Christmas present from me to me.
Reply
This build (9/19) has issues (did clean install):
  • 3D ISO's no longer play; no picture (display goes into 3D mode, but all I see is the OSD in 3D w/a blank screen behind; no video, audio only) Sad
  • 3D MVC MKV's do play in 3D mode, but the picture doesn't look completely right (click 'OK' key bring up the OSD and you'll see what I mean; kind of a weird shimmering effect)
  • 3D SBS and TAB mkv's (named properly) still don't play in 3D mode (3D mode isn't automatically engaged; you need to manually choose 'hardware based' in 3D mode via OSD to get proper 3D)

These do work now, likely as pulled from master:
  • TrueHD/ATMOS, broken with last build (July 14), working fine again
  • DD+ 5.1/7.1 bitstreaming now works! (finally!) Smile

As 3D ISO's don't work, I'm back to June 30 build Sad. Will keep fingers crossed next build gets it right Angel.
[H]i-[d]eft [M]edia [K]een [V]ideosaurus
My Family Room Theater
Reply
Same here was that a clean install.
Reply
Yes.
[H]i-[d]eft [M]edia [K]een [V]ideosaurus
My Family Room Theater
Reply
He probly left something out pretty sure he will update. Thanks afedchin for still working on this.
Reply
Well I have not tested this, however the fact that there was an update (broken or not) in the ffmpeg toolchain relieves me that the MVC fork lives outside of just merging with mainstream builds. Thank you and hope for further improvement.
Reply
Anyone tried the delay after change of refresh rate to see if it works or not yet?
Reply
(2016-09-21, 01:01)hdmkv Wrote: This build (9/19) has issues (did clean install):
  • 3D ISO's no longer play; no picture (display goes into 3D mode, but all I see is the OSD in 3D w/a blank screen behind; no video, audio only) Sad
  • 3D MVC MKV's do play in 3D mode, but the picture doesn't look completely right (click 'OK' key bring up the OSD and you'll see what I mean; kind of a weird shimmering effect)
  • 3D SBS and TAB mkv's (named properly) still don't play in 3D mode (3D mode isn't automatically engaged; you need to manually choose 'hardware based' in 3D mode via OSD to get proper 3D)

These do work now, likely as pulled from master:
  • TrueHD/ATMOS, broken with last build (July 14), working fine again
  • DD+ 5.1/7.1 bitstreaming now works! (finally!) Smile
    [/list

    As 3D ISO's don't work, I'm back to June 30 build Sad. Will keep fingers crossed next build gets it right Angel.

I can confirm as well. Here the 3D MVC also doesn't work.
Reply
There is a new build. I won't have a chance to test tonight though. Sad


Sept 22 EXE
Sept 22 PDB
Main: Intel NUC DN2820FYKH with Intel Celeron N2830 CPU, Windows 10 Professional 64bit, Intel® HD Graphics driver-version 10.18.10.4338. Running afedchin's Windows MVC 3D test build.
Secondary: Amazon Fire TV Gen 1
Reply
  •   
  • 1
  • 102
  • 103
  • 104(current)
  • 105
  • 106
  • 231
  •   
 
Thread Rating:
  • 10 Vote(s) - 4.3 Average



Logout Mark Read Team Forum Stats Members Help
Intel HTPCs/NUCs & Kodi-native 3D MVC Playback4.310
This forum uses Lukasz Tkacz MyBB addons.