•   
  • 1
  • 65
  • 66
  • 67(current)
  • 68
  • 69
  • 231
  •   
Win Intel HTPCs/NUCs & Kodi-native 3D MVC Playback
(2016-05-13, 23:06)movie78 Wrote: Dell Inspiron Micro Desktop N3050

Dell Inspiron Micro Desktop N3050 selling for $129...

Actually looks like $80 shipped?? Would be a fantastic deal!!
[H]i-[d]eft [M]edia [K]een [V]ideosaurus
My Family Room Theater
Reply
Received my Skull Canyon tonight, Windows 10 installed, Kodi installed and successfully tested running a 3D Bluray. Just a quick test but more to come. Had an issue where it displayed as over/under for some reason but bringing up the Samsung 3D menu fixed that. Not sure why.

However I am having an issue with audio. Have the sound device (HDMI) configured as 7.1 but it will only output stereo to the Denon AVR-6200. This is using the sound test (other channels other than left/right produce no sound and the Denon still shows stereo). When running KODI I get no sound. Looks like a driver issue or something else? Anyone have any thoughts?

I'd like to get this working so I can fully test with both 3D and HD audio passthrough. So close! Smile

Thanks!
Reply
Did you make sure to configure your audio options as shown in the screenshots from the first post?
Main: Intel NUC DN2820FYKH with Intel Celeron N2830 CPU, Windows 10 Professional 64bit, Intel® HD Graphics driver-version 10.18.10.4338. Running afedchin's Windows MVC 3D test build.
Secondary: Amazon Fire TV Gen 1
Reply
(2016-05-14, 06:33)santiagodraco Wrote: Received my Skull Canyon tonight, Windows 10 installed, Kodi installed and successfully tested running a 3D Bluray. Just a quick test but more to come. Had an issue where it displayed as over/under for some reason but bringing up the Samsung 3D menu fixed that. Not sure why.

However I am having an issue with audio. Have the sound device (HDMI) configured as 7.1 but it will only output stereo to the Denon AVR-6200. This is using the sound test (other channels other than left/right produce no sound and the Denon still shows stereo). When running KODI I get no sound. Looks like a driver issue or something else? Anyone have any thoughts?

I'd like to get this working so I can fully test with both 3D and HD audio passthrough. So close! Smile

Thanks!

Windows Audio

Make sure you select WASAPI for the Audio Output.
MY CURRENT MEDIA PLAYER | MY HOME THEATER
MINIX NEO U9-H LIBREELEC v18 Leia | EGREAT A10 | NVIDIA SHIELD
SAMSUNG QLED QN75Q7 | Sony 43 Android TV HDR
XBOX ONE X UHD BLU-RAY | PS4 PRO 4K w/PSVR
NAKAMICHI PRO 7.1.4 DTS:X/ATMOS 
Reply
(2016-05-14, 06:33)santiagodraco Wrote: Received my Skull Canyon tonight, Windows 10 installed, Kodi installed and successfully tested running a 3D Bluray. Just a quick test but more to come. Had an issue where it displayed as over/under for some reason but bringing up the Samsung 3D menu fixed that. Not sure why.

However I am having an issue with audio. Have the sound device (HDMI) configured as 7.1 but it will only output stereo to the Denon AVR-6200. This is using the sound test (other channels other than left/right produce no sound and the Denon still shows stereo). When running KODI I get no sound. Looks like a driver issue or something else? Anyone have any thoughts?

I'd like to get this working so I can fully test with both 3D and HD audio passthrough. So close! Smile

Thanks!

this is very odd that 3D Bluray worked for you , because in the intel specifications :
http://ark.intel.com/products/89187/Inte...-NUC6i7KYK

don't mention this essential spec : Intel InTru 3D Technology

Did you see excellent quality Picture in 3D Bluray ?
Reply
(2016-05-14, 06:33)santiagodraco Wrote: Received my Skull Canyon tonight, Windows 10 installed, Kodi installed and successfully tested running a 3D Bluray. Just a quick test but more to come. Had an issue where it displayed as over/under for some reason but bringing up the Samsung 3D menu fixed that. Not sure why.

I don't have that NUC, but same issue if I have my Windows set to anything besides 1080p on my 4K TV, so maybe it's the same for you?

(2016-05-14, 06:33)santiagodraco Wrote: However I am having an issue with audio. Have the sound device (HDMI) configured as 7.1 but it will only output stereo to the Denon AVR-6200. This is using the sound test (other channels other than left/right produce no sound and the Denon still shows stereo). When running KODI I get no sound. Looks like a driver issue or something else? Anyone have any thoughts?

I'd like to get this working so I can fully test with both 3D and HD audio passthrough. So close! Smile

I'm guessing you made sure the WASAPI device was selected and not the DirectSound device? That's the first thing I'd check. Maybe put up a log. Also check the sound settings in Windows and make sure you have it set to 7.1. Also in those settings you can see what the installed driver supports. Look here for what I'm talking about: windows_audio (wiki)
Denon X6500H 7.1.4 -> LG OLED65C6P
Main: Odroid N2 CoreELEC
Other Devices: Apple TV 4K, RPi 4, NVIDIA Shield Pro (2017)
Retired devices: Zidoo X9S, Xiaomi Mi Box, All other RPi’s
Reply
@santiagodraco, I'd love to hear how 10-bit 4K performs on Skull Canyon, assuming you have a 10-bit 4K display.
[H]i-[d]eft [M]edia [K]een [V]ideosaurus
My Family Room Theater
Reply
A few updates (and some responses to questions above).

Regarding the audio issue (stereo only, no audio in Kodi):
1. Over HDMI I only get stereo audio. Windows audio settings are set correctly. If using mini-displayport to HDMI adapter I get full 7.1 with passthrough. IE eveything works with Displayport but NOT HDMI.
2. Kodi works and passes through HD audio great with Displayport.
3. Displayport is not a solution for me as it only gives 30hz and not 60hz. This could be an adapter issue but remains to be seen as I have not found one that states 60hz at 4k.
4. I've reinstalled graphics drivers to no avail. I have not yet tried a different HDMI adapter, will try that today.
5. WASAPI was selected. Note that I mentioned the audio issue is in Windows itself (and Kodi by extension).
6. 4k and 1080p both have the issue.

Regarding Kodi/3D:
1. Quality is excellent.
2. 3D movies start in over/under, not sure why. Driving me nuts. Once I hit the 3D button for the Samsung display it corrects.
3. HDMKV: how can I verify that I am running in 10bit 4k on the NUC? I don't see anywhere to enable 10bit vs 8. My hardware supports it (Denon 6200 and Samsung 8500).
Reply
(2016-05-14, 16:06)santiagodraco Wrote: A few updates (and some responses to questions above).

Regarding the audio issue (stereo only, no audio in Kodi):
1. Over HDMI I only get stereo audio. Windows audio settings are set correctly. If using mini-displayport to HDMI adapter I get full 7.1 with passthrough. IE eveything works with Displayport but NOT HDMI.
2. Kodi works and passes through HD audio great with Displayport.
3. Displayport is not a solution for me as it only gives 30hz and not 60hz. This could be an adapter issue but remains to be seen as I have not found one that states 60hz at 4k.
4. I've reinstalled graphics drivers to no avail. I have not yet tried a different HDMI adapter, will try that today.
5. WASAPI was selected. Note that I mentioned the audio issue is in Windows itself (and Kodi by extension).
6. 4k and 1080p both have the issue.

Regarding Kodi/3D:
1. Quality is excellent.
2. 3D movies start in over/under, not sure why. Driving me nuts. Once I hit the 3D button for the Samsung display it corrects.
3. HDMKV: how can I verify that I am running in 10bit 4k on the NUC? I don't see anywhere to enable 10bit vs 8. My hardware supports it (Denon 6200 and Samsung 8500).

Thanks for full review ,
about the " 3D MOVIES START IN OVER/UNDER" you use kodi + MVC Build from here? or you used Cyberlink - Powerdvd or other external software that do that ?
about the Hdmi port do you think it is from Hardware problem or only driver problem ?

Thanks in advance.
Reply
(2016-05-14, 16:11)Neighbour Wrote: Thanks for full review ,
about the " 3D MOVIES START IN OVER/UNDER" you use kodi + MVC Build from here? or you used Cyberlink - Powerdvd or other external software that do that ?
about the Hdmi port do you think it is from Hardware problem or only driver problem ?

Thanks in advance.

I'm using the latest MVC build. No PowerDVD Smile Just native Kodi. Once I select 3D from the TV menu (it detects the Over/Under) it works great. Not sure yet why Kodi is sending it as Over/under but it's definitely working as 3D (in 4k no less) so it's decoding from the Blu-ray. I'm thinking it's a Kodi issue as it's Kodi sending it as over/under when it should be mvc. I'm not an expert so not sure....

I don't have enough info yet to know if the hdmi audio issue is hardware or drivers. I know it works over mini-displayport but that doesn't really mean a whole lot. Could be a bios/firmware problem, or hardware... or who knows. Frustrating and I won't be able to check with intel support until Monday.
Reply
Just an update on the performance of the Intel NUC5i5RYH with the latest MVC Build,(KodiSetup-20160512), There has been no change or improvement in the Audio Sync Issues playing 3D MVC mkv files - audio syncing issues occur with chapter skipping. With past releases the out-of sync audio can be corrected by fast forwarding or reversing for a few seconds, but with the latest release this fix no longer works. Also turning on and off 3D with this latest release is also affected. For past releases I have inserted a delay of 0.5 seconds after change of refresh rate to fix the problem peculiar to my LG OLED. This delay is not working with the latest release, and when 3D is turned off it is then back on again despite setting the disabling of 3D mode of the user interface.

But as an unexpected benefit for the Intel NUC5i5RYH, 4K/24 or 30 Hz movies and TV Shows (at least in H.264 format) playback fine, but unfortunately 1080p videos have a green vertical bar at each end sometimes during playback when 4K screen resolutions are enabled..
NUC: NUC5i5RYH (Intel Core i5-5250U, Intel HD Graphics 6000)
RAM: 16 GB Crucial DDR3-1600
SSD: 250GB Samsung 850 EVO M.2 SSD
OS: Windows 10 Home version
Display: LG 65EF9500 OLED
AVR: Pioneer Elite SC-99
Reply
(2016-05-14, 16:23)santiagodraco Wrote:
(2016-05-14, 16:11)Neighbour Wrote: Thanks for full review ,
about the " 3D MOVIES START IN OVER/UNDER" you use kodi + MVC Build from here? or you used Cyberlink - Powerdvd or other external software that do that ?
about the Hdmi port do you think it is from Hardware problem or only driver problem ?

Thanks in advance.

I'm using the latest MVC build. No PowerDVD Smile Just native Kodi. Once I select 3D from the TV menu (it detects the Over/Under) it works great. Not sure yet why Kodi is sending it as Over/under but it's definitely working as 3D (in 4k no less) so it's decoding from the Blu-ray. I'm thinking it's a Kodi issue as it's Kodi sending it as over/under when it should be mvc. I'm not an expert so not sure....

I don't have enough info yet to know if the hdmi audio issue is hardware or drivers. I know it works over mini-displayport but that doesn't really mean a whole lot. Could be a bios/firmware problem, or hardware... or who knows. Frustrating and I won't be able to check with intel support until Monday.

Thanks,

Do you install kodi 16.1 from here http://mirrors.kodi.tv/releases/win32/ko...Jarvis.exe and after that you install this 3D MVC version from here ( KodiSetup-20160512) http://mirrors.kodi.tv/test-builds/win32...vc_wip.exe ?

I understand from you that the kodi send over/under from tv , try to change 3D setting to Auto in kodi setting .

how much bucks Nuc Scull Canyon cost to you? and from overall experience you suggest that ?

Thanks.
Reply
@Neighbour

What hardware did you buy?
MY CURRENT MEDIA PLAYER | MY HOME THEATER
MINIX NEO U9-H LIBREELEC v18 Leia | EGREAT A10 | NVIDIA SHIELD
SAMSUNG QLED QN75Q7 | Sony 43 Android TV HDR
XBOX ONE X UHD BLU-RAY | PS4 PRO 4K w/PSVR
NAKAMICHI PRO 7.1.4 DTS:X/ATMOS 
Reply
on the skylake i3 HEVC is good with 8bit up to 50 mb/s bitrate give or take.. with 10bit its only possible to keep up with low bitrate stuff like the encodes found around the net.. anything @ 24hz over 20 mb/s isnt watchable and near 50 mb/s is depressing to watch its so choppy. 60hz content at 10 bit crashes kodi occasionally for me. i would suspect the i7 suffers from similar results and at best if it can handle it better the CPU is going to be in overdrive mode and working at near 100%
Main System - HTPC - Intel I3 6300 - Asrock z170 - 16 GB DDR4 - 128gb SSD - 65" UHD HDR Sony Android TV - Pioneer VSX 1130-K - 7.2.2 speakers
Other devices currently in use - 55" 3D UHD LG TV - 2 Fire TV's - Nexus Player - MiniMX s905 - Voyo Vmac Mini
Ubuntu Server - 12 TB NAS - MYSQL - Torrent Box
Reply
(2016-05-14, 16:23)santiagodraco Wrote: I'm using the latest MVC build. No PowerDVD Smile Just native Kodi. Once I select 3D from the TV menu (it detects the Over/Under) it works great. Not sure yet why Kodi is sending it as Over/under but it's definitely working as 3D (in 4k no less) so it's decoding from the Blu-ray. I'm thinking it's a Kodi issue as it's Kodi sending it as over/under when it should be mvc. I'm not an expert so not sure....

I don't have enough info yet to know if the hdmi audio issue is hardware or drivers. I know it works over mini-displayport but that doesn't really mean a whole lot. Could be a bios/firmware problem, or hardware... or who knows. Frustrating and I won't be able to check with intel support until Monday.

Your Videos are playing in over under mode because there is no frame packed 4k format, set Kodi to [email protected] to fix that.

you could ask @Koying , @noggin, or @wesk05 about MVC over under at 4k resolutions vs 1080p frame packed, i dont know if theres a difference or not in regards to quality but they probably do.

Personally i run kodi at 1080p, 3D works great, when i play any 4K content Kodi just knows to switch to 2160p and then back when playback stops


Your audio issue is strange, can you try to disable the display port via the bios or possibly in Device Manager, also: Do you have multiple WASAPI devices you can select in Kodi?
Main System - HTPC - Intel I3 6300 - Asrock z170 - 16 GB DDR4 - 128gb SSD - 65" UHD HDR Sony Android TV - Pioneer VSX 1130-K - 7.2.2 speakers
Other devices currently in use - 55" 3D UHD LG TV - 2 Fire TV's - Nexus Player - MiniMX s905 - Voyo Vmac Mini
Ubuntu Server - 12 TB NAS - MYSQL - Torrent Box
Reply
  •   
  • 1
  • 65
  • 66
  • 67(current)
  • 68
  • 69
  • 231
  •   
 
Thread Rating:
  • 10 Vote(s) - 4.3 Average



Logout Mark Read Team Forum Stats Members Help
Intel HTPCs/NUCs & Kodi-native 3D MVC Playback4.310
This forum uses Lukasz Tkacz MyBB addons.