•   
  • 1
  • 67
  • 68
  • 69(current)
  • 70
  • 71
  • 231
  •   
Win Intel HTPCs/NUCs & Kodi-native 3D MVC Playback
(2016-05-14, 20:59)timstephens24 Wrote:
(2016-05-14, 16:06)santiagodraco Wrote: A few updates (and some responses to questions above).

Regarding the audio issue (stereo only, no audio in Kodi):

Probably an HDMI cable issue, I had a few when I upgraded to 4k. [email protected] needs a 18Gbps cable, and most of the older ones are around 10Gbps.

Edit: I had to return 4 cables that didn't work right too, but they were amazon cheap ones. When I found good ones they were good.

(2016-05-14, 16:06)santiagodraco Wrote: 2. 3D movies start in over/under, not sure why. Driving me nuts. Once I hit the 3D button for the Samsung display it corrects.

Pretty sure it's like I said, your display needs to be at 1080p and not 4k.

Right on the 4k vs 1080p. That resolved the 3D issue.

As for the audio issue over HDMI that still remains after trying several different HDMI cables. Will see about ordering one that is specifically rated at 18Gbps and see what happens.
Reply
Just tested the theory about the HDMI cable being the issue with multi-channel audio. Changed the resolution to 1080p and... same problem. So it doesn't look like the cable is the issue.

Will see what Intel has to say Monday.

Other than the HDMI audio problem so far the box is great. Would have liked to have 10bit but I can live without. I did playback the Sony Camp SDR clip at 4k and it ran great!
Reply
(2016-05-15, 00:55)santiagodraco Wrote: Just tested the theory about the HDMI cable being the issue with multi-channel audio. Changed the resolution to 1080p and... same problem. So it doesn't look like the cable is the issue.

Will see what Intel has to say Monday.

Other than the HDMI audio problem so far the box is great. Would have liked to have 10bit but I can live without. I did playback the Sony Camp SDR clip at 4k and it ran great!

can you take a debug log, it could shed some light as to whats happening.

Log_file/Easy (wiki)
Main System - HTPC - Intel I3 6300 - Asrock z170 - 16 GB DDR4 - 128gb SSD - 65" UHD HDR Sony Android TV - Pioneer VSX 1130-K - 7.2.2 speakers
Other devices currently in use - 55" 3D UHD LG TV - 2 Fire TV's - Nexus Player - MiniMX s905 - Voyo Vmac Mini
Ubuntu Server - 12 TB NAS - MYSQL - Torrent Box
Reply
(2016-05-15, 01:05)dukester Wrote:
(2016-05-15, 00:55)santiagodraco Wrote: Just tested the theory about the HDMI cable being the issue with multi-channel audio. Changed the resolution to 1080p and... same problem. So it doesn't look like the cable is the issue.

Will see what Intel has to say Monday.

Other than the HDMI audio problem so far the box is great. Would have liked to have 10bit but I can live without. I did playback the Sony Camp SDR clip at 4k and it ran great!

can you take a debug log, it could shed some light as to whats happening.

Log_file/Easy (wiki)

Not sure a log will help as it's happening in Windows natively without running Kodi. Unless you think Kodi's like might help?
Reply
(2016-05-15, 01:08)santiagodraco Wrote:
(2016-05-15, 01:05)dukester Wrote:
(2016-05-15, 00:55)santiagodraco Wrote: Just tested the theory about the HDMI cable being the issue with multi-channel audio. Changed the resolution to 1080p and... same problem. So it doesn't look like the cable is the issue.

Will see what Intel has to say Monday.

Other than the HDMI audio problem so far the box is great. Would have liked to have 10bit but I can live without. I did playback the Sony Camp SDR clip at 4k and it ran great!

can you take a debug log, it could shed some light as to whats happening.

Log_file/Easy (wiki)

Not sure a log will help as it's happening in Windows natively without running Kodi. Unless you think Kodi's like might help?

it can show alot about the devices and what capabilities they are shown as supporting.

so while its not a for sure thing its a good start for a place to troubleshoot at least.
Main System - HTPC - Intel I3 6300 - Asrock z170 - 16 GB DDR4 - 128gb SSD - 65" UHD HDR Sony Android TV - Pioneer VSX 1130-K - 7.2.2 speakers
Other devices currently in use - 55" 3D UHD LG TV - 2 Fire TV's - Nexus Player - MiniMX s905 - Voyo Vmac Mini
Ubuntu Server - 12 TB NAS - MYSQL - Torrent Box
Reply
Gotcha.

Uploaded a log. We'll see how it goes. http://goo.gl/lKH6ri

Just as a matter of future reference:

1. Played several Blu-rays (2D and 3D) with Directsound enabled (not WASAPI) by mistake. However what's interesting is that multi-channel audio worked via Kodi (while not working in Windows). 3D playback was jittery (no 3D). Running 1080p. Weird since it worked previously at 4k.
2. Played a few at the end of the session with WASAPI enabled along with all passthrough options on. No audio (except for one in stereo). Passthrough a no go. 3D playback was broken as well.

So for this log run in 1080p had broken 3D and HD audio/passthrough. Under 4k before everything worked except audio.

Weirdness. Smile
Reply
(2016-05-14, 22:27)movie78 Wrote: @Neighbour

What have you bought or what are you going to buy?

I have bought "Lenovo stick 300 " and not yet arrived . The black dot is that not can play passthrough HD audio.
I try to figure out which device can give me from all the worlds : 3D MVC + HD Audio .
My setup : 65 inch LG 850UF + Denon 1200 + Tannoy TFX 5.1 .

I don't know If I take Nuc or Stick that support 3D MVC + HD Audio .

Thanks for help.
(2016-05-14, 22:50)timstephens24 Wrote:
(2016-05-14, 21:59)Neighbour Wrote: if the Nuc or other machine will be native rate 4K on 4K 3D TV , I need to down resolution to FULL HD on 60HZ that I can play 3D ISO ?

Yes, to properly play (at least from my experience with my NUC) 3D movies, ISO or MKV, you need the resolution of Windows and Kodi to be 1080p (you can set the Hz to whatever you want, Kodi will change it if it's required). It's in the very first picture in the settings that are on post #1.

Thanks , that mean if I buy the new Nuc that support 4K I also need to down the resolution to full hd that mean not really need the new Nuc.

Do you have this nuc : http://www.amazon.com/Intel-D54250WYK1-i...Power+Cord

and which SSD and Ram you add to him ?
with that Nuc you get everything works fine ( 3D MVC + KODI + DTS-HD/DOLBY-HD/ATMOS/DTS-X ) ? ( I have 65 4k passive 3d like yours )

Thanks.
Reply
(2016-05-15, 01:24)santiagodraco Wrote: Gotcha.

Uploaded a log. We'll see how it goes. http://goo.gl/lKH6ri

Just as a matter of future reference:

1. Played several Blu-rays (2D and 3D) with Directsound enabled (not WASAPI) by mistake. However what's interesting is that multi-channel audio worked via Kodi (while not working in Windows). 3D playback was jittery (no 3D). Running 1080p. Weird since it worked previously at 4k.
2. Played a few at the end of the session with WASAPI enabled along with all passthrough options on. No audio (except for one in stereo). Passthrough a no go. 3D playback was broken as well.

So for this log run in 1080p had broken 3D and HD audio/passthrough. Under 4k before everything worked except audio.

Weirdness. Smile


try setting both audio options to "WASAPI HDMI - DENON-AVRHD (Intel® Display Audio)" or the similar setting you have, neither should be on DirectSound, change your channels from 2.0 to 7.1 and then enable pass-through and select all the available modes except DD+ as its currently broken, if it still doesnt work correctly, we can still see if you get 7.1 LPCM by disabling pass-through and replaying the same videos.
Main System - HTPC - Intel I3 6300 - Asrock z170 - 16 GB DDR4 - 128gb SSD - 65" UHD HDR Sony Android TV - Pioneer VSX 1130-K - 7.2.2 speakers
Other devices currently in use - 55" 3D UHD LG TV - 2 Fire TV's - Nexus Player - MiniMX s905 - Voyo Vmac Mini
Ubuntu Server - 12 TB NAS - MYSQL - Torrent Box
Reply
(2016-05-15, 02:04)Neighbour Wrote: Do you have this nuc : http://www.amazon.com/Intel-D54250WYK1-i...Power+Cord

and which SSD and Ram you add to him ?
with that Nuc you get everything works fine ( 3D MVC + KODI + DTS-HD/DOLBY-HD/ATMOS/DTS-X ) ? ( I have 65 4k passive 3d like yours )

Yeah, I have that NUC and everything on your list works. As for the SSD I have three and don't know what they are specifically, just get any mSATA (get at least 64GB for Windows, prob just go for a 128GB) and you'll be fine, same with the RAM, and you don't need much, 8GB of DDR3 will work perfectly fine and could even still be overkill.
Denon X6500H 7.1.4 -> LG OLED65C6P
Main: Odroid N2 CoreELEC
Other Devices: Apple TV 4K, RPi 4, NVIDIA Shield Pro (2017)
Retired devices: Zidoo X9S, Xiaomi Mi Box, All other RPi’s
Reply
Just an FYI for everyone: the 5-12 build does not install any of the encoder/decoder/dsp/pvr/screensaver/inputstream components. It's just Kodi and the runtimes. Most people will probably want to stick with 5-05 and below.
Main: Intel NUC DN2820FYKH with Intel Celeron N2830 CPU, Windows 10 Professional 64bit, Intel® HD Graphics driver-version 10.18.10.4338. Running afedchin's Windows MVC 3D test build.
Secondary: Amazon Fire TV Gen 1
Reply
(2016-05-15, 03:56)timstephens24 Wrote:
(2016-05-15, 02:04)Neighbour Wrote: Do you have this nuc : http://www.amazon.com/Intel-D54250WYK1-i...Power+Cord

and which SSD and Ram you add to him ?
with that Nuc you get everything works fine ( 3D MVC + KODI + DTS-HD/DOLBY-HD/ATMOS/DTS-X ) ? ( I have 65 4k passive 3d like yours )

Yeah, I have that NUC and everything on your list works. As for the SSD I have three and don't know what they are specifically, just get any mSATA (get at least 64GB for Windows, prob just go for a 128GB) and you'll be fine, same with the RAM, and you don't need much, 8GB of DDR3 will work perfectly fine and could even still be overkill.

Thanks,
This type of SSD will work to me ? : http://www.amazon.com/Crucial-128GB-mSAT...00IRRDI34/

and for mini HDMI to HDMI , which Cable you suggest?

and the type of HDMI is HDMI 1.4A , and HDMI 1.4B support 60hz for 3D , it isn't necessary for that ?

Thanks.
Reply
That drive is way too much, go for this one instead. For the cable just find the cheapest one you can.
Denon X6500H 7.1.4 -> LG OLED65C6P
Main: Odroid N2 CoreELEC
Other Devices: Apple TV 4K, RPi 4, NVIDIA Shield Pro (2017)
Retired devices: Zidoo X9S, Xiaomi Mi Box, All other RPi’s
Reply
(2016-05-15, 03:35)dukester Wrote:
(2016-05-15, 01:24)santiagodraco Wrote: Gotcha.

Uploaded a log. We'll see how it goes. http://goo.gl/lKH6ri

Just as a matter of future reference:

1. Played several Blu-rays (2D and 3D) with Directsound enabled (not WASAPI) by mistake. However what's interesting is that multi-channel audio worked via Kodi (while not working in Windows). 3D playback was jittery (no 3D). Running 1080p. Weird since it worked previously at 4k.
2. Played a few at the end of the session with WASAPI enabled along with all passthrough options on. No audio (except for one in stereo). Passthrough a no go. 3D playback was broken as well.

So for this log run in 1080p had broken 3D and HD audio/passthrough. Under 4k before everything worked except audio.

Weirdness. Smile


try setting both audio options to "WASAPI HDMI - DENON-AVRHD (Intel® Display Audio)" or the similar setting you have, neither should be on DirectSound, change your channels from 2.0 to 7.1 and then enable pass-through and select all the available modes except DD+ as its currently broken, if it still doesnt work correctly, we can still see if you get 7.1 LPCM by disabling pass-through and replaying the same videos.

As I mentioned in my post I ran it both ways. The DirectSound runs were by accident (due to connection changes).

In any case I'm returning the Skull Canyon. Considering the price and the problems... it's not worth it. Without HDMI audio functioning (and I'm convinced at this point that the issue is with the hardware/firmware or drivers) I can't justify the purchase. I only gain one thing from the device (assuming it worked properly) and that is Blu-Ray 3D and 4k 60hz.

I'll stick with my Nvidia Shield TV for now as my main box (which is, frankly, far superior to the Skull Canyon NUC) which does 10bit, 4k 60hz and gaming much better than the SC NUC. Not to mention it's less than half the price.

I'm going to keep an eye out for mATX motherboards over the next several months for one that supports 4k 60hz and mvc. I will then upgrade my current HTPC (which is running an i7 2700 and nvidia 740 in a Moncaso half height case). This current HTPC also works great, supports 4k, does 3D Blu-ray using PDVD externally and supports full power on/off using a Simrec PCS2.

So the adventure continues. Thanks to everyone who has provided feedback/advice on the testing of the Skull Canyon NUC. Hoping to complete the HTPC picture this year with upcoming hardware but for now sticking with the current config. Now back to playing with my HTC Vive Smile
Reply
Skull Canyon just came out, so will take a little time for issues to be fixed. Likely audio driver for HD audio as you suspect.

Re: "10bit, 4k 60hz", I'd take a look at HiMedia Q10 Pro, or upcoming Q5 Pro. I find Q10 Pro's 4K performance better than Shield's.
[H]i-[d]eft [M]edia [K]een [V]ideosaurus
My Family Room Theater
Reply
(2016-05-13, 16:02)hdmkv Wrote: Kodi's default Estuary skin UI changed between the builds, so if you're doing a restore from previous Kodi backup to new build, this happens. I ended up starting fresh, re-adding shares, etc.
I was using Estuary Mod and switching back to the reg. Estuary fixed the issue, I'm now able to access all menus but Gawwd do I miss Aeon Nox Sad

I was using it earlier on a different build but it was more a hack so I was having issues with Library update, watch status and all...
Box 1: Vero 4K
Box 2: Intel NUC D34010WYK (Windows afedchin's Krypton MVC Build)
Box 3: ChromeBOX
RIP schimi2k | I miss you buddy :(
Reply
  •   
  • 1
  • 67
  • 68
  • 69(current)
  • 70
  • 71
  • 231
  •   
 
Thread Rating:
  • 10 Vote(s) - 4.3 Average



Logout Mark Read Team Forum Stats Members Help
Intel HTPCs/NUCs & Kodi-native 3D MVC Playback4.310
This forum uses Lukasz Tkacz MyBB addons.