Win Intel HTPCs/NUCs & Kodi-native 3D MVC Playback
(2016-05-14, 16:06)santiagodraco Wrote: A few updates (and some responses to questions above).

Regarding the audio issue (stereo only, no audio in Kodi):
1. Over HDMI I only get stereo audio. Windows audio settings are set correctly. If using mini-displayport to HDMI adapter I get full 7.1 with passthrough. IE eveything works with Displayport but NOT HDMI.
2. Kodi works and passes through HD audio great with Displayport.
3. Displayport is not a solution for me as it only gives 30hz and not 60hz. This could be an adapter issue but remains to be seen as I have not found one that states 60hz at 4k.
4. I've reinstalled graphics drivers to no avail. I have not yet tried a different HDMI adapter, will try that today.
5. WASAPI was selected. Note that I mentioned the audio issue is in Windows itself (and Kodi by extension).
6. 4k and 1080p both have the issue.

Regarding Kodi/3D:
1. Quality is excellent.
2. 3D movies start in over/under, not sure why. Driving me nuts. Once I hit the 3D button for the Samsung display it corrects.
3. HDMKV: how can I verify that I am running in 10bit 4k on the NUC? I don't see anywhere to enable 10bit vs 8. My hardware supports it (Denon 6200 and Samsung 8500).

(2016-05-19, 20:58)ciscostud Wrote:
(2016-05-19, 02:36)hifihedgehog Wrote:
(2016-05-18, 18:41)ciscostud Wrote: I am having the EXACT same problem with the Intel Skull Canyon NUC on Windows 10 that both of you describe above. I just received mine yesterday. You may or may not be happy to know that this problem with HDMI 5.1 or multichannel passthrough is effecting both my Yamaha 5600 sound bar and Yamaha 5100 AV Pre-Amp. So it is not just a Denon problem. It is a Yamaha problem too. I hear this may not be happening under Linux. It sounds to me like it is a Windows Driver Issue (Intel Display Audio?). I am also running the latest drivers with the Intel Driver Update Utility. I called this in also to Intel Support and they opened a case with the phone number above.

Cool! I have both a thread on the Intel support forums and a Reddit thread on the Intel NUC subreddit, linked below. Below also is a family member's Amazon review of the product. I will post a link to the fix at Reddit and the Intel support forums as soon as it comes.
https://www.reddit.com/r/intelnuc/commen...work_over/
https://communities.intel.com/thread/102165
http://www.amazon.com/review/R1I49QUJ7M4...6&store=pc

I see Intel on their forum is suggesting you try the display port with an adapter on their new Skull Canyon NUC for 5.1 passthrough. It very well could work, but this is a work around and not a fix. It needs to work on HDMI!!

See the topmost quoted comment. Displayport to HDMI has no problem outputting multichannel surround sound. The problem is the native HDMI port does not support multichannel surround sound. You are so right. A workaround is not a fix. They need to fix this $650 investment. Its HDMI sound is a mess.
Reply
 
Thread Rating:
  • 10 Vote(s) - 4.3 Average


Messages In This Thread
What about xvYCC / x.v.Color - by ma9ick - 2016-04-15, 14:01
RE: Intel HTPC/NUC's w/reliable Kodi-native 3D MVC Playback - by hifihedgehog - 2016-05-20, 00:07
June 30 download link broken? - by CooperCGN - 2016-08-02, 08:18