•   
  • 1
  • 83
  • 84
  • 85(current)
  • 86
  • 87
  • 232
  •   
Win Intel HTPCs/NUCs & Kodi-native 3D MVC Playback
(2016-06-18, 06:16)movie78 Wrote:
(2016-06-18, 00:29)Charger Hellcat Wrote: Oh ok, I'll give that a try.

Cool slideshow and info in that first post. How do you get the dtsx logo? Is that new?

Use this Skin Estuary MOD


If you movie contain ATMOS or DTS:X track add

Files naming :

Your filenames must contains :

Quote:3D for 3D flag like : Batman 3D.mkv / Batman - 3D.mkv / Batman.3D.mkv

atmos for ATMOS audio flag like : Batman (1996) Atmos.mkv / Batman (1996) - Atmos.mkv / Batman (1996).Atmos.mkv

dtsx / dts-x for DTS-X audio flag like : Batman (1996) DTS-X.mkv / Batman (1996).dts-x.mkv / Batman (1996) dtsx.mkv etc..

I have on 3D ISO some titles with Atmos and when I scan all the folder it not separate to MOVIES and ATMOS on the main menu but only Movies on the main menu.
how to fix that ?

Thanks.
Reply
Examples of 3D ATMOS and DTS:X naming

Quote:Terminator Genisys.3D.atmos
Mad Max Fury Road.3D.atmos
Gods Of Egypt.3D.dtsx
MY CURRENT MEDIA PLAYER | MY HOME THEATER
MINIX NEO U9-H LIBREELEC v18 Leia | EGREAT A10 | NVIDIA SHIELD | SAMSUNG QLED QN75Q7 | Sony 43 Android TV HDR
XBOX ONE X UHD BLU-RAY | PS4 PRO 4K w/PSVR | NAKAMICHI PRO 7.1.4 DTS:X/ATMOS 
Reply
(2016-06-18, 12:06)Neighbour Wrote:
(2016-06-18, 06:16)movie78 Wrote:
(2016-06-18, 00:29)Charger Hellcat Wrote: Oh ok, I'll give that a try.

Cool slideshow and info in that first post. How do you get the dtsx logo? Is that new?

Use this Skin Estuary MOD


If you movie contain ATMOS or DTS:X track add

Files naming :

Your filenames must contains :

Quote:3D for 3D flag like : Batman 3D.mkv / Batman - 3D.mkv / Batman.3D.mkv

atmos for ATMOS audio flag like : Batman (1996) Atmos.mkv / Batman (1996) - Atmos.mkv / Batman (1996).Atmos.mkv

dtsx / dts-x for DTS-X audio flag like : Batman (1996) DTS-X.mkv / Batman (1996).dts-x.mkv / Batman (1996) dtsx.mkv etc..

I have on 3D ISO some titles with Atmos and when I scan all the folder it not separate to MOVIES and ATMOS on the main menu but only Movies on the main menu.
how to fix that ?

Thanks.


Seriously?

Video_library_tags (wiki)

Basic_playlists (wiki)

Smart_playlists (wiki)

I'd suggest you read the smart playlist wiki in particular. Then please go and find an appropriate thread for your chosen skin if you need guidance on how to customize it to your liking........

Your queries are not 3D MVC playback related.
Reply
(2016-06-18, 12:06)Neighbour Wrote: I have on 3D ISO some titles with Atmos and when I scan all the folder it not separate to MOVIES and ATMOS on the main menu but only Movies on the main menu.
how to fix that ?

Thanks.

Here ill save your brain from any thinking at all. make 3 files named 2d.xsp, 3d.xsp, and atmos.xsp with the contents below, place them in your "playlists" folder in Kodi DIR and then add all 3 playlists to menu items, personally i make the default "movies" menu item into 2D playlist.


2D.xsp

Code:
<?xml version="1.0" encoding="UTF-8" standalone="yes" ?>
<smartplaylist type="movies">
    <name>2D</name>
    <match>all</match>
    <rule field="filename" operator="doesnotcontain">
        <value>3D</value>
    </rule>
</smartplaylist>

3D.xsp

Code:
<?xml version="1.0" encoding="UTF-8" standalone="yes" ?>
<smartplaylist type="movies">
    <name>3D</name>
    <match>all</match>
    <rule field="filename" operator="contains">
        <value>3D</value>
    </rule>
</smartplaylist>

Atmos.xsp

Code:
<?xml version="1.0" encoding="UTF-8" standalone="yes" ?>
<smartplaylist type="movies">
    <name>Atmos</name>
    <match>all</match>
    <rule field="filename" operator="contains">
        <value>atmos</value>
    </rule>
</smartplaylist>
Main System - HTPC - Intel I3 6300 - Asrock z170 - 16 GB DDR4 - 128gb SSD - 65" UHD HDR Sony Android TV - Pioneer VSX 1130-K - 7.2.2 speakers
Other devices currently in use - 55" 3D UHD LG TV - 2 Fire TV's - Nexus Player - MiniMX s905 - Voyo Vmac Mini
Ubuntu Server - 12 TB NAS - MYSQL - Torrent Box
Reply
Thanks for all your helping ...
Reply
Set up my new Nuc and other than sorting the install stick it was a breeze.

For some reason on my display settings I don't have:
1920 x 1080 3D (recommended)
as in the first slide show pic in the first post. Any ideas why?

I'm on Windows 10 pro, fully updated all drivers installed.
Reply
(2016-06-21, 17:35)T800 Wrote: Set up my new Nuc and other than sorting the install stick it was a breeze.

For some reason on my display settings I don't have:
1920 x 1080 3D (recommended)
as in the first slide show pic in the first post. Any ideas why?

I'm on Windows 10 pro, fully updated all drivers installed.

Check your HDMI connect (AVR)
Video Drivers
MY CURRENT MEDIA PLAYER | MY HOME THEATER
MINIX NEO U9-H LIBREELEC v18 Leia | EGREAT A10 | NVIDIA SHIELD | SAMSUNG QLED QN75Q7 | Sony 43 Android TV HDR
XBOX ONE X UHD BLU-RAY | PS4 PRO 4K w/PSVR | NAKAMICHI PRO 7.1.4 DTS:X/ATMOS 
Reply
Hi!

On my journey to the 3D MVC I've come close to the very end. I've spent hours and hours searching every possible bit of info for my case and I've tested those things. Sadly no success, yet.

1. Hardware:
Intel C2D E8400, Nvidia 610 GT, 1.4 HDMI all the way through to the Benq W1350 video projector.

2. Software:
Today had clean install Windows 10 pro, tested latest Kodi Jarvis 16.1 and then switched to the latest Kodi MVC build (20160608-4d90005-msdk_mvc_wip) from here http://forum.kodi.tv/showthread.php?tid=...ked+nvidia
+ Nvidia drivers 368.39
+ latest WDDM 2.0 for Windows 10
+ (libmfx32) for Nvidia users

3. Settings
I've followed the steps exactly from here "Windows - Intel HTPC/NUC's w/reliable Kodi-native 3D MVC Playback" -thread. Have done all those "Adjust display refresh rate", "Decode stereo stream 3D" etc. options. Of course I ignored the Intel gpu steps and did those on Nvidia Control panel (1920x1080 (3D) 60hz resolution and enabled 3D vision there).

4. And this results to...?
In Kodi I have tried Martian MVC I made with DVDFab and Frozen.iso (straight blu-ray rip, mounting the iso and then looking the right scene.800.mpls from the bluray folder in kodi so movie starts at once). Upon launching, Benq takes it's time and then comes 24p 1920x2205 resolution, frame packing automatically activated. Only problem is that there is no 3D-effect (screen is typically red for this DLP-projector and with glasses it looks fine, just no 3D). I look up into the video options and I see 2(!!) h.264 video streams which of I could choose from. So I think MVC is very close??, but not... :-)

5. Brazen1's succeed on this.
Among many other threads I've read this "Windows 3D MVC Bluray test builds" http://forum.kodi.tv/showthread.php?tid=...ght=nvidia
There brazen1 points out how he managed to work things out with 4/1 build ONLY, sadly I haven't figured out how to get that and try it myself.
I thought I could just pm and ask him politely, but that option was disabled for me, maybe because I'm so new.
So if you, brazen1, see this post, could you offer your helping hand, please? (;


Easiest way would be to smash that "HTPC" and buy new Intel-build, but I'm just too eager to get this working with this. And those succeeds I've read keep me trying!
On a side note I've managed to get this MVC work with PowerDVD with mounted iso. Picture quality was better than in FSBS (never get that to work --> so it showed as normal HSBS) and HSBS rips. PowerDVD was kinda laggy (trial problem?), it wasn't even near as smooth as XBMC.

In the end, I've tried and I'm willing to admit my defeat. Just asking if there is any hope?

Thanks!
Reply
Hello all. Need a little noob help here. I have an intel i3 nuc with Jarvis 16.1. I have it working great with Silvo Nox skin, but I have about 30 mkv 3d mvc movies that I would love to test and watch with this build. Is there any way to have both versions of Kodi on my nuc? Thank you for your help.
Reply
(2016-06-22, 02:16)Phoenix74 Wrote: Hello all. Need a little noob help here. I have an intel i3 nuc with Jarvis 16.1. I have it working great with Silvo Nox skin, but I have about 30 mkv 3d mvc movies that I would love to test and watch with this build. Is there any way to have both versions of Kodi on my nuc? Thank you for your help.

Even though I haven't been successful getting 3D via Kodi yet I do have two builds on mine.
I'm running 16.1 as normal and I've got the MVC build located in Documents running in portable mode so I can use both.
Reply
Or you could do what I do. I have the MVC build for Windows on my SSD and I also have LibreELEC installed on a flash drive which I use for everything but the 3D movies. It's as easy as unplugging the flash drive when I want to watch something in 3D.
I only want to deal with Windows when I really have to Tongue
Box 1: Vero 4K
Box 2: Intel NUC D34010WYK (Windows afedchin's Krypton MVC Build)
Box 3: ChromeBOX
RIP schimi2k | I miss you buddy :(
Reply
(2016-06-21, 17:56)movie78 Wrote:
(2016-06-21, 17:35)T800 Wrote: Set up my new Nuc and other than sorting the install stick it was a breeze.

For some reason on my display settings I don't have:
1920 x 1080 3D (recommended)
as in the first slide show pic in the first post. Any ideas why?

I'm on Windows 10 pro, fully updated all drivers installed.

Check your HDMI connect (AVR)
Video Drivers

I changed my driver (latest one) for 15.40.22.4424 and now 3D is available, thanks.
Reply
(2016-06-21, 23:38)Timpppa Wrote: Hi!

On my journey to the 3D MVC I've come close to the very end. I've spent hours and hours searching every possible bit of info for my case and I've tested those things. Sadly no success, yet.

1. Hardware:
Intel C2D E8400, Nvidia 610 GT, 1.4 HDMI all the way through to the Benq W1350 video projector.

2. Software:
Today had clean install Windows 10 pro, tested latest Kodi Jarvis 16.1 and then switched to the latest Kodi MVC build (20160608-4d90005-msdk_mvc_wip) from here http://forum.kodi.tv/showthread.php?tid=...ked+nvidia
+ Nvidia drivers 368.39
+ latest WDDM 2.0 for Windows 10
+ (libmfx32) for Nvidia users

3. Settings
I've followed the steps exactly from here "Windows - Intel HTPC/NUC's w/reliable Kodi-native 3D MVC Playback" -thread. Have done all those "Adjust display refresh rate", "Decode stereo stream 3D" etc. options. Of course I ignored the Intel gpu steps and did those on Nvidia Control panel (1920x1080 (3D) 60hz resolution and enabled 3D vision there).

4. And this results to...?
In Kodi I have tried Martian MVC I made with DVDFab and Frozen.iso (straight blu-ray rip, mounting the iso and then looking the right scene.800.mpls from the bluray folder in kodi so movie starts at once). Upon launching, Benq takes it's time and then comes 24p 1920x2205 resolution, frame packing automatically activated. Only problem is that there is no 3D-effect (screen is typically red for this DLP-projector and with glasses it looks fine, just no 3D). I look up into the video options and I see 2(!!) h.264 video streams which of I could choose from. So I think MVC is very close??, but not... :-)

5. Brazen1's succeed on this.
Among many other threads I've read this "Windows 3D MVC Bluray test builds" http://forum.kodi.tv/showthread.php?tid=...ght=nvidia
There brazen1 points out how he managed to work things out with 4/1 build ONLY, sadly I haven't figured out how to get that and try it myself.
I thought I could just pm and ask him politely, but that option was disabled for me, maybe because I'm so new.
So if you, brazen1, see this post, could you offer your helping hand, please? (;


Easiest way would be to smash that "HTPC" and buy new Intel-build, but I'm just too eager to get this working with this. And those succeeds I've read keep me trying!
On a side note I've managed to get this MVC work with PowerDVD with mounted iso. Picture quality was better than in FSBS (never get that to work --> so it showed as normal HSBS) and HSBS rips. PowerDVD was kinda laggy (trial problem?), it wasn't even near as smooth as XBMC.

In the end, I've tried and I'm willing to admit my defeat. Just asking if there is any hope?

Thanks!

You do not need to use the earlier build. I'm using latest 6/8 build with no problems. After the original thread was closed, the Nvidia quirks were addressed in the following release and have worked well since.

You do not need libmfx32. That is intended for non Intel users, mainly AMD.

Be certain your folder/file have .3D in the naming. Don't forget the period (dot).

Download Intel_Media_SDK_2016.msi from Intel website. You will need to register with them to gain access to the download. Once installed, check Intel Media SDK 2016 is 1.7 (Intel_Media_SDK_2016.0.1) info in programs folder.

Remember, to run the stereoscopic setup in Nvidia control panel and always enable stereoscopic. The main quirk, when 24Hz matched refresh rate is switched, Nvidia enables 3D for 2D titles, has been addressed. When Kodi starts, 3D is disabled globally (system wide) allowing 2D 24Hz titles to render correctly. When a 3D title is selected, Kodi will enable 3D globally and turn it back off when finished. When exiting Kodi, 3D will again be enabled globally.

Some BD menus still not working as of yet so using this build with seamless PDVD for occasions when menu is desired. There is no difference in audio/video quality. This is the final hurdle that will overcome any need for an external player. Been using full frame packed MVC iso's and MVC mkv's, some interpolated to 60Hz rips, HEVC low bitrate as well. The build(s) handling most everything thrown at them.

Some titles require eye flip adjustment and is not automated. Most of you are using mkv. Fwiw, you can run your title through mkvtoolnix and select left eye first for your right eye first titles to correct. It only takes a few minutes.
HOW TO - Kodi 2D - 3D - UHD (4k) HDR Guide Internal & External Players
W10/1909 MPC-BE\HC PDVD19 DVDFab3&5 KODI 19 PotPlayer 960-4GB/RGB 4:4:4/Desktop=60Hz/Video=Matched Refresh rates 8/12bit/Samsung 82" Q90R
Reply
Auto flip-eyes doesn't appear to be functioning w/the latest (June 8) build, at least for ISO's. But, didn't know you could set left-eye first via MKVToolNix... I may just mount my right-eye first ISO's, demux, set left-eye first, then mux back into ISO.
[H]i-[d]eft [M]edia [K]een [V]ideosaurus
My Family Room Theater
Reply
(2016-06-22, 18:19)hdmkv Wrote: Auto flip-eyes doesn't appear to be functioning w/the latest (June 8) build, at least for ISO's. But, didn't know you could set left-eye first via MKVToolNix... I may just mount my right-eye first ISO's, demux, set left-eye first, then mux back into ISO.

That's is a good idea, but what ATMOS/TRUEHD ?
TsMuxer doesn't support that.
MY CURRENT MEDIA PLAYER | MY HOME THEATER
MINIX NEO U9-H LIBREELEC v18 Leia | EGREAT A10 | NVIDIA SHIELD | SAMSUNG QLED QN75Q7 | Sony 43 Android TV HDR
XBOX ONE X UHD BLU-RAY | PS4 PRO 4K w/PSVR | NAKAMICHI PRO 7.1.4 DTS:X/ATMOS 
Reply
  •   
  • 1
  • 83
  • 84
  • 85(current)
  • 86
  • 87
  • 232
  •   
 
Thread Rating:
  • 10 Vote(s) - 4.3 Average



Logout Mark Read Team Forum Stats Members Help
Intel HTPCs/NUCs & Kodi-native 3D MVC Playback4.310
This forum uses Lukasz Tkacz MyBB addons.