Win Intel HTPCs/NUCs & Kodi-native 3D MVC Playback
(2017-05-26, 19:34)Chris_77 Wrote: Hey guys,
I purchased a BEELINK BT3-II, which has the Atom-based CPU Z8350. Since the CPU is just an update on the Z8300, which is used in the original BEELINK BT3 - which had some good reviews here-, I was hoping for uncomplicated 3D-ISO Playback & dts-MA decoded to LPCM 7.1.
While 2d-Playback is good, I have not been able to play any 3d-ISO file with KODI :-( Tried it with own untouched ISOs as well as the ISO-samples from KODI-WIKI: It will always switch my TV into 3D-mode, but then I get like for 1-2 seconds a black full screen and then I am back in the KODI UI with the menus showing in 3D and the movie soundtrack playing in the background, but no 3D movie ! When stopping playback KODI is unusable: it either does not react at all or menus are that sluggish that I have to quit and restart it.
I am on WIN10-64bit off a clean install with all latest patches and driver updates installed(but also tried some older graphics drivers, but did not help). Using the KODI build linked on page 1 of this thread and followed EXACTLY all steps described in the tutorial also on page 1 with the exception that I didnt set WASAPI as audio device in KODI since BT3 does not support audio passthrough for HD-audio.
My conclusion so far is that either

a. I am doing something substantially wrong...

OR

b. Z8350-chipset does not support 3d-Iso playback as its predecessor Z8300 does.

OR

c. The KODI build suggested on page 1 has serious 3D playback issues with Cherry Trail chipsets...

Any guess? Maybe anyone who got things working with a Z8350-device?
Thanks!!!
Regards
Chris

Hey Chris,
Unfortunately I don't have any experience with that specific chipset, but I've read up on various 3D specific issues people have been reporting. Does your device output in 4K or only up to HD? I know some people with 4K capable hardware have only had luck at this time playing back with the resolution set to HD.

Is there another video port you can try connecting through (i.e. DisplayPort vs hdmi etc)? Sometimes if you have multiple video outputs, some use different controller chips that can wreck havoc with 3D playback.

You also might consider trying some of the older builds from last fall. In my case, an issue I have with the latest couple of builds actually doesn't occur in the older (circa October or so) builds. Worth a shot.

Also, are you running the latest Windows 10 creators update? If so, might be worth trying to get a hold of an older build as at this point I don't believe it's been verified to work with this fork of Kodi, and it did change some underlying video playback functionality.

If it's a newer device I'd also check for bios updates, just to be safe.

Wish I could be of more help. Best of luck!
Reply
 
Thread Rating:
  • 10 Vote(s) - 4.3 Average


Messages In This Thread
What about xvYCC / x.v.Color - by ma9ick - 2016-04-15, 14:01
June 30 download link broken? - by CooperCGN - 2016-08-02, 08:18
RE: Intel HTPC/NUC's w/reliable Kodi-native 3D MVC Playback - by filmgeek47 - 2017-05-28, 09:17