v16 PVR client addon TvHeadend do not work
#1
Photo 
Hi,

When I change my ISP I notes that I have problems with PVR client addon TvHeadend.

I was patient and I was waiting for updates with hope that someone will fix my problem.

Tvhendend Server is working great.With remote PC ( VLC) or Android client I can watch all TV Channels without any problems. Also if I disable kodi "PVR client addon TvHeadend" and enable add-on:"IPTV Simple Client" is working great.

Also with add-on "PVR client addon TvHeadend" recorded programs is playing well.

When I have addon PVR client TV hendend enable and I try to watch tv channals kodi show buffering... and that is it. No picture, nothing.

I try this on Raspberry Pi 1 Model B (osmc and openelec), Qnap, Android (smsung tab) and with all is the same error (kodi show buffering... and that is it)

info:
Server HTS Tvheadend 4.0.7

add-on PVR client TV hendend 2.2.14

KODI 16.0


Codec info from VLC player (PC):

Stream 0:
Type: Video
Original ID: 200
Resolution: 720x576
Codec: H264 - MPEG-4 AVC (part 10) (h264)
Decoded format: Planar 4:2:0 YUV full scale
Stream 1

Type: Audio:

Original ID: 300
Codec: MPEG AAC Audio (mp4a)
Channels: Stereo
Sample rate: 48000 Hz
AAC extension: SBR



kodi log from /home/osmc/.kodi/temp/

20:54:26 1698.360840 T:3024261680 NOTICE: DVDPlayer: Opening: pvr://channels/tv/Vsi programi/pvr.hts_731790469.pvr
20:54:26 1698.361206 T:3024261680 WARNING: CDVDMessageQueue(player):Tongueut MSGQ_NOT_INITIALIZED
20:54:26 1698.363037 T:2562192368 NOTICE: Creating InputStream
20:54:28 1699.618286 T:2562192368 NOTICE: Creating Demuxer
20:54:28 1699.634399 T:2562192368 ERROR: Get - failed to get stream
20:54:28 1699.634888 T:2562192368 WARNING: CDVDMessageQueue(audio):Tongueut MSGQ_NOT_INITIALIZED
20:54:28 1699.635010 T:2562192368 WARNING: CDVDMessageQueue(video):Tongueut MSGQ_NOT_INITIALIZED


Please help.
Reply
#2
You may need to rescan your muxes. Also, make sure your ip Kodi's using hasn't changed with the changing of your isp. Sounds like you have communication though.
Reply
#3
On the pi, if you are getting audio but no video it's because you need mpeg2 license for hardware decoding on Pi. TVheadend server has 3 streams: mpeg2, matroska, and pass-through (h264/mp4). You can play back recorded programs because they are saved pass-through (and Pi has no restrictions on hardware decode of mp4). Similarly for VLC streaming (see your codec info).

But TVheadend client uses htsp which seems to default to mpeg2. You can try to configure the backend to use pass-through stream (I dont know if this is actually possible). Alternatively, you can buy a mpeg2 license from raspberry pi company. It's about $4. They will send you your license as a configuration settting that you can add to your Pi config file with a text editor. You can also turn off hardware decode, but software on pi only works for lower resolution like SD. With HD signals, it'll slow to a crawl.

Edit: Quick search on tvheadends project page seems to suggest that recorded programs are stored as matroska files.
Reply



Logout Mark Read Team Forum Stats Members Help
PVR client addon TvHeadend do not work0
This forum uses Lukasz Tkacz MyBB addons.