•   
  • 1
  • 43
  • 44
  • 45
  • 46
  • 47(current)
Zap2xml for ATSC in OpenELEC
Hello and thank you so much for this addon.  The past few days, I have been receiving the following error below on my tvheadend server running osmc on a pi 2.  Was wondering if anyone else has been getting the same or might be able to shed some light on the issue.

2019-11-15 07:04:37.136 xmltv: /usr/bin/tv_grab_zap2epg: htsmsg_xml_deserialize error Unknown syntatic element:

Thank you in advance for your assistance.
Reply
(2019-11-15, 20:04)James62370 Wrote: htsmsg_xml_deserialize error Unknown syntatic elemen

Would help if you let us know zipcode and lineup - not seeing any issues on my end so it is likely lineup specific.  Usually an issue with a name of a service (station) - sometimes the station's use characters that our outside of the system's support. 

Also - if you know how to post the zap2epg.log file that would help.  Thanks!
Current Kodi addon projects: zap2epg, sd4tvh and tvh2kodi (tvh config from inside Kodi)
Testing ATSC single and dual tuners on RPi3 and the occasional s905 box
If you like my work you can buy me a coffee!
Reply
(2019-11-15, 21:02)edit4ever Wrote:
(2019-11-15, 20:04)James62370 Wrote: htsmsg_xml_deserialize error Unknown syntatic elemen

Would help if you let us know zipcode and lineup - not seeing any issues on my end so it is likely lineup specific.  Usually an issue with a name of a service (station) - sometimes the station's use characters that our outside of the system's support. 

Also - if you know how to post the zap2epg.log file that would help.  Thanks! 

Appreciate the quick response.  It just started happening the past 2 days.  When I manually run the grabber it works fine.  If it continues I will post the log and additional info.  Thanks again for your help and support!
Reply
on libreelec using Kodi 19 I am getting an incompatible error. I am not sure if you plan to upgrade or maybe this is something with dependencies and I just need to be patient.

Thanks
Reply
(2020-04-21, 06:25)hagertyoh Wrote: on libreelec using Kodi 19 I am getting an incompatible error. I am not sure if you plan to upgrade or maybe this is something with dependencies and I just need to be patient.

Thanks

Kodi 19 needs python 3 for addons - so I have to rewrite this in order to get it to work.  I may take a look since I have a bit more "free time" right now.  :-)  Then again - this will all not be necessary with ATSC 3.0 which is launching later this year...so I'm not sure it will be needed by the time Kodi 19 actually launches.
Current Kodi addon projects: zap2epg, sd4tvh and tvh2kodi (tvh config from inside Kodi)
Testing ATSC single and dual tuners on RPi3 and the occasional s905 box
If you like my work you can buy me a coffee!
Reply
(2020-04-21, 17:30)edit4ever Wrote:
(2020-04-21, 06:25)hagertyoh Wrote: on libreelec using Kodi 19 I am getting an incompatible error. I am not sure if you plan to upgrade or maybe this is something with dependencies and I just need to be patient.

Thanks

Kodi 19 needs python 3 for addons - so I have to rewrite this in order to get it to work.  I may take a look since I have a bit more "free time" right now.  :-)  Then again - this will all not be necessary with ATSC 3.0 which is launching later this year...so I'm not sure it will be needed by the time Kodi 19 actually launches.

Thanks for the reply. With that said you are probably correct.
Reply
Hello,

I'm running Kodi 18.6 Leia and TVHeadend frontend on multiple Nvidia Shields.  I am running TVHeadend backend on a QNAP NAS.

Is there a version of Zap2XML that will work on my version of Kodi and equipment?

Thanks.
Reply
(2020-05-10, 13:16)Dawgneck Wrote: Hello,

I'm running Kodi 18.6 Leia and TVHeadend frontend on multiple Nvidia Shields.  I am running TVHeadend backend on a QNAP NAS.

Is there a version of Zap2XML that will work on my version of Kodi and equipment?

Thanks.
Sorry, meant Zap2EPG, Not Zap2XML.
Reply
(2020-04-21, 17:30)edit4ever Wrote:
(2020-04-21, 06:25)hagertyoh Wrote: on libreelec using Kodi 19 I am getting an incompatible error. I am not sure if you plan to upgrade or maybe this is something with dependencies and I just need to be patient.

Thanks

Kodi 19 needs python 3 for addons - so I have to rewrite this in order to get it to work.  I may take a look since I have a bit more "free time" right now.  :-)  Then again - this will all not be necessary with ATSC 3.0 which is launching later this year...so I'm not sure it will be needed by the time Kodi 19 actually launches.

I think the ATSC 3.0 rollout is going to take some time (at least in my area).  And then people will need to upgrade their tuners.  My bet is Kodi 20 will be out before there is widespread adoption of ATSC 3.0.
Reply
@edit4ever  i see you published zap2epg version 2.0 with python 3.  you opening a new thread for feedback or continuing with this one?  Also thanks, for updating.  I had no alternative.
Reply
Hi All,

I'm new to EPGs and Zap2EPG and have been playing around with it. It works fine on the Kodi 18.7 I'm running on my Windows 10 PC.

But on my Android TV box running Kodi 18.9 I'm getting JSON file errors. Has anyone had this happen or know how to fix it?
I'm pretty sure I'm running 1.3.1 of Zap2EPG but am not sure why the log says it's running 0.7.4.

2021/02/23 13:40:46 Kodi settings version is: 2
2021/02/23 13:40:46 Running zap2epg-0.7.4 for zipcode: 14202 and lineup: TIMEZONE - Eastern
2021/02/23 13:40:46 Checking for old cache files...
2021/02/23 13:40:46 Downloading guide data for: 1614103200
2021/02/23 13:40:47 JSON file error for: 1614103200.json.gz - deleting file
2021/02/23 13:40:47 Downloading guide data for: 1614114000
2021/02/23 13:40:48 JSON file error for: 1614114000.json.gz - deleting file
2021/02/23 13:40:48 Downloading guide data for: 1614124800
2021/02/23 13:40:49 JSON file error for: 1614124800.json.gz - deleting file
2021/02/23 13:40:49 Downloading guide data for: 1614135600
2021/02/23 13:40:50 JSON file error for: 1614135600.json.gz - deleting file
2021/02/23 13:40:50 Downloading guide data for: 1614146400
2021/02/23 13:40:51 JSON file error for: 1614146400.json.gz - deleting file
2021/02/23 13:40:51 Downloading guide data for: 1614157200
2021/02/23 13:40:51 JSON file error for: 1614157200.json.gz - deleting file
2021/02/23 13:40:51 Downloading guide data for: 1614168000
2021/02/23 13:40:52 JSON file error for: 1614168000.json.gz - deleting file
2021/02/23 13:40:52 Downloading guide data for: 1614178800
2021/02/23 13:40:53 JSON file error for: 1614178800.json.gz - deleting file
2021/02/23 13:40:53 Creating xmltv.xml file...
Reply
(Yesterday, 05:09)KCfan2001 Wrote: 2021/02/23 13:40:46 Running zap2epg-0.7.4 for zipcode: 14202 and lineup: TIMEZONE - Eastern
@KCfan2001 There may have been a change in the generic lineup codes.  Can you access the settings.xml file that is in your userdata folder (same location as the zap2epg.py file) and let me know what is in the line:
<setting id="lineupcode">DFLTE</setting>
I'm interested to see if yours says:
<setting id="lineupcode">DFLTEC</setting>
Thanks!
---------------------
Just realized that's likely not the issue - I was looking at Canada lineups.  I'll be pushing a 2.0.1 version to fix a Kodi dialog error - so maybe you can try to update and see if that fixes it.  Of course - it depends on your Kodi version 18.9 seems like it may actually be a Kodi 19 beta??  zap2epg 1.3 runs on Python 2 and zap2epg 2.0 runs on Python 3.
Current Kodi addon projects: zap2epg, sd4tvh and tvh2kodi (tvh config from inside Kodi)
Testing ATSC single and dual tuners on RPi3 and the occasional s905 box
If you like my work you can buy me a coffee!
Reply
(2020-11-17, 23:39)hagertyoh Wrote: @edit4ever  i see you published zap2epg version 2.0 with python 3.  you opening a new thread for feedback or continuing with this one?  Also thanks, for updating.  I had no alternative.
Not sure - I'm not really working on this anymore - but I occasionally take a look.  I was hoping someone would take up the torch - or a better alternative would have have come along.
Current Kodi addon projects: zap2epg, sd4tvh and tvh2kodi (tvh config from inside Kodi)
Testing ATSC single and dual tuners on RPi3 and the occasional s905 box
If you like my work you can buy me a coffee!
Reply
Pushing a slight update to the zap2epg 2.0 / Kodi 19 version.  Fixes a dialog error and cleans up logging version numbers.

https://github.com/edit4ever/script.modu...tag/v2.0.1
Current Kodi addon projects: zap2epg, sd4tvh and tvh2kodi (tvh config from inside Kodi)
Testing ATSC single and dual tuners on RPi3 and the occasional s905 box
If you like my work you can buy me a coffee!
Reply
(Today, 00:45)edit4ever Wrote:
(Yesterday, 05:09)KCfan2001 Wrote: 2021/02/23 13:40:46 Running zap2epg-0.7.4 for zipcode: 14202 and lineup: TIMEZONE - Eastern
@KCfan2001 There may have been a change in the generic lineup codes.  Can you access the settings.xml file that is in your userdata folder (same location as the zap2epg.py file) and let me know what is in the line:
<setting id="lineupcode">DFLTE</setting>
I'm interested to see if yours says:
<setting id="lineupcode">DFLTEC</setting>
Thanks!
---------------------
Just realized that's likely not the issue - I was looking at Canada lineups.  I'll be pushing a 2.0.1 version to fix a Kodi dialog error - so maybe you can try to update and see if that fixes it.  Of course - it depends on your Kodi version 18.9 seems like it may actually be a Kodi 19 beta??  zap2epg 1.3 runs on Python 2 and zap2epg 2.0 runs on Python 3.

Hi - I'm pretty sure I'm on an actual Kodi 18.9 and not a Kodi 19 beta. I've been avoiding Kodi 19 in case some of my installed addons haven't been upgraded for Python 3 yet. If you've got any other suggestions for things to look for please let me know. Thanks!
Reply
  •   
  • 1
  • 43
  • 44
  • 45
  • 46
  • 47(current)



Logout Mark Read Team Forum Stats Members Help
Zap2xml for ATSC in OpenELEC4
This forum uses Lukasz Tkacz MyBB addons.