•  Previous
  • 1
  • 159
  • 160
  • 161(current)
  • 162
  • 163
  • 198
  • Next 
 
Thread Rating:
  • 12 Vote(s) - 4.33 Average
Release - YouTube Plug-in Thread
I must say you are the best. I finally went threw and set up the API and this is the best add on I have used. Laugh

Running on openelec 17

Thank you
Reply
(2017-06-03, 14:09)anxdpanic Wrote: ERROR: /mnt/home/profile/.kodi/addons/script.module.requests/lib/requests/packages/urllib3/connectionpool.py:843: InsecureRequestWarning: Unverified HTTPS request is being made. Adding certificate verification is strongly advised. See: https://urllib3.readthedocs.io/en/latest...l-warnings
InsecureRequestWarning)

Is a warning not an error, you can enable certificate verification in Settings - Advanced. This will not work on all systems, due to python versions.

I cannot reproduce either blank My Subscriptions, or Play from here issues. A full debug log (wiki) may help shed some light on it. Would also try Play from here with 'auto-play suggested' disabled to see if that helps(both work here).

For those with issues with cryptography/openssl errors on linux based installs, these are likely caused by something in your environment.

https://github.com/jdf76/plugin.video.youtube/issues/14 (pyOpenSSL 16.1.0 not working)
https://github.com/jdf76/plugin.video.youtube/issues/64 (pyOpenSSL 17.0.0 not working)

First thing I would try would be 'sudo pip install pyopenssl==16.2.0'

Ok... I've removed the pyOpenSSL as well and the Certificate warning has gone now. Thanks for that Smile


The Playlist issue is still the same though. Here's a debug log where I first try to play a whole playlist with 5.3.13 and then the same with 5.3.12.
https://pastebin.com/7wNzjL4K

Looks pretty much the same to me apart from the fact that 5.3.12 actually starts playing whereas 5.3.13 just seems to queue the videos and then stops doing anything more.
Reply
play from here is broken. I've reported it.

Jeff
Reply
What I have observed: It queues everything in the playlist and doesn't start.
When you navigate to the 'current playlist' and pick start on the first item, it will correctly play them.

So in my opinion, it is not fully broken as it does enqueue all entries following the selected entry. It only fails to start playing after queueing Smile
Using Kodi/OpenELEC on a Raspberry Pi3 rev1.2 with a Sony KDL-42W706B and an external audio receiver
Reply
Thank you @Elbereth

pip uninstall pyOpenSSL
That is the solution for the cryptography problems !!!

amazing, I did not uninstall it because I was thinking it is required for functioning.
Reply
I have an annoying problem. When I select a particular channel in subscriptions, some of the uploaded videos are missing. They do appear in My Subscriptions, just not when I select the channel itself. Any ideas why this might be the case?
Reply
(2017-06-06, 21:45)lordzerg Wrote: Thank you @Elbereth

pip uninstall pyOpenSSL
That is the solution for the cryptography problems !!!

amazing, I did not uninstall it because I was thinking it is required for functioning.

Just wanted to add... While this fixed tge cryptography issue it broke my Deluge daemon. So I had to reinstall pyOpenSSL and just live with the error for now :/
Reply
Okay, perhaps there is an earlier thread that addressed this, but I couldn't find it. I created the API key. I deleted the YouTube app on my Raspberry Pi 2, reinstalled it, and entered the API keys. When I go through the two-step registration, I get an error message saying that the credentials are not valid. Is there something remaining from the old YouTube app in the system that needs to be deleted? (And yes, I triple-checked that everything was correct on the three parts of the keys. When I go back to the pre-existing API keys, the app works...until those API's get overused.) Since other people are doing so well, there must be something else happening...

Update: Duuuhhhh! The problem was that I printed out the keys using my standard font, Times New Roman. In the middle of the Secret key, there were two lower-case L's followed by the number 1. In that font they both look nearly identical. I changed it to a weirder font and the difference was striking. I re-entered the Secret key, and now my YouTube plugin works perfectly...after a YEAR of trouble. Sorry, guys.
Reply
(2017-06-06, 21:45)lordzerg Wrote: Thank you @Elbereth

pip uninstall pyOpenSSL
That is the solution for the cryptography problems !!!

amazing, I did not uninstall it because I was thinking it is required for functioning.

Yeah, I know. Rather counterintuitive, isn't it? Smile
Reply
(2017-06-07, 08:34)bluezed Wrote:
(2017-06-06, 21:45)lordzerg Wrote: Thank you @Elbereth

pip uninstall pyOpenSSL
That is the solution for the cryptography problems !!!

amazing, I did not uninstall it because I was thinking it is required for functioning.

Just wanted to add... While this fixed tge cryptography issue it broke my Deluge daemon. So I had to reinstall pyOpenSSL and just live with the error for now :/

Use the transmission it is amazing
Reply
I have a question boys..... on "My subscription" using the currently estuary skin it's possibly to add a info about when the video it's been uploaded and released on youtube himself ?
...only on your "little world" can you lay down the law...
Reply
I'm really missing "recommended for you" functionality. Is there another way i can get this on Windows without using a browser?
Reply
New Alpha 5.4.0~alpha1

https://github.com/jdf76/plugin.video.yo.../tag/5.4.0
Reply
What a great addon!
Everything runs perfect on my side

Just a n00b question...

If I created a playlist and I wanted to play it automatically using kodi's xbmc.PlayMedia
would it be possible if I'd like the order to be randomized instead of having the same sequence all the time?


Thank you
Reply
(2017-06-15, 09:38)jdf76 Wrote: New Alpha 5.4.0~alpha1

https://github.com/jdf76/plugin.video.yo.../tag/5.4.0

OMG!! It's now possibly to create a "filtered" My Subscriction Smile I have on the pass ask if possibly to add this feature.....

But it's possibly to create a whitelist........ i thinks there's a better idea to create a "filtered" list and create a "My Subscription" channel whit some "hide" channel indicated and separated by "comma" like it's now for a whitelist. It's possible ?

If this is not possibly i thinks it's a good idea add, for example, a "context" function for add a channel directly on the "whitelist" directly from "My Subscription" or directly from search feature..... you thinks it's a good idea ?
...only on your "little world" can you lay down the law...
Reply
  •  Previous
  • 1
  • 159
  • 160
  • 161(current)
  • 162
  • 163
  • 198
  • Next 
 
Thread Rating:
  • 12 Vote(s) - 4.33 Average



Logout Mark Read Team Forum Stats Members Help
YouTube Plug-in Thread4.3312