“Kodi” is damaged and can’t be opened. You should move it to the Trash
#46
Hi! I had the same frustrating issue. Nothing from above did work for me but it was very helpful as it was pointing me into the right solution. I found a tip regarding gatekeeper that works: it was about SystemPolicy database where gatekeeper keep its stuff and it could become corrupted. You need to restore it with default values writing this in terminal (the first command is to make a backup):

mv /var/db/SystemPolicy /var/db/SystemPolicyOLD
cp /var/db/.SystemPolicy-default /var/db/SystemPolicy

(found here http://krypted.com/mac-security/restorin...-database/ )

It should work, but if you get a "permission denied" you can do it manually by digging into the var folder at the root level in your system, var is invisible so you can use this http://blog.tice.de/?content=invisibles_engl to switch invisible items to visible and vice verse

That works for me.
Reply
#47
I'm having the same issue... Would somebody be willing to use teamviewer to help me out? PM me please.. This is frustrating. I'm not tech savvy so all these terms Gatekeeper and userdata and shit is confusing tf out of me.
Reply
#48
When I initially downloaded Kodi (from the official site) it worked perfectly. But because of a wonky add-on I decided to uninstall and reinstall it. This is the 15th time I'm trying to reinstall and every time I do I get this message:

"Kodi" is damaged and can't be opened. You should move it to the Trash.
Google Chrome downloaded this file today at 8:10 PM from http://ftp.halifax.rwth-aachen.de

That last part is different every time. One time it said "mirror" something. What does all this mean and how do I fix it? I have a MacBook Pro and my operating system is MacOS Sierra.
Reply
#49
(2017-01-30, 17:06)CouchPie Wrote: There's no need to disable Gatekeeper. In cases were I got the "... is damaged" message for an application, I could fix it with an xattr change via Terminal.
For Kodi try: xattr -rc /Applications/Kodi.app (works from admin user account, otherwise use sudo but anyhow know what you are doing!)

This was the solution for me, Thanx!!!
I had this problem when being on 17.3, then going back to 16.1 and then back to 17.3 again (and at going back to 17.3 i had this issue about the damage-notice).
Reply
#50
FWIW, I had this exact problem with Kodi 17.3 installing under MacOS High Sierra (10.13.1). The initial install went fine, then when I scrapped it (the app + the UserData files), subsequent download/installs would not run: when I tried to start the newly-installed Kodi.app, I invariably got,

     "Kodi" is damaged and can't be opened. You should move it to the Trash."

The solution (though I'm not quite sure why) was indeed to run the following command from Terminal:


Code:
xattr -rc /Applications/Kodi.app


which resets the application file's extended attributes. Once I did this, the Kodi.app started and ran fine. Again, I'm not sure how or why this works (or indeed why Kodi installed once, but refused to install thereafter) but I'm glad it did!
Reply
#51
I am trying to install 17.6 and i have run into the same issue about moving the damaged kodi file to the trash.  the software was working just fine earlier this morning, but when i went to update to 17.6, thats went things went down hill

iMac (Retina 5K, 27-inch, Mid 2015)
Processor:  3.3 GHz Intel Core i5

i have done pretty much everything above, including moving back to 17.5 but still no luck.

thoughts?

thanks,

apostle
Reply
#52
(2017-11-19, 16:11)TheApostle Wrote: I am trying to install 17.6 and i have run into the same issue about moving the damaged kodi file to the trash.  the software was working just fine earlier this morning, but when i went to update to 17.6, thats went things went down hill

iMac (Retina 5K, 27-inch, Mid 2015)
Processor:  3.3 GHz Intel Core i5

i have done pretty much everything above, including moving back to 17.5 but still no luck.

thoughts?

thanks,

apostle
I installed the nightly build and everything seems to be working just fine.  I will install a build and see if i run into any issues.
Reply
#53
If by the second use of "build" you mean the kind that are on the banned addons (wiki) list then if you do install one thenany issues you run into are your own to solve. Such an install devalidates any support being asked to your device here.

Just as a word to the wise, see our piracy policy (wiki) for more details.
| Banned add-ons (wiki) | Forum rules (wiki) | First time user (wiki) | FAQs (wiki) | Troubleshooting (wiki) | Add-ons (wiki) | Free content (wiki) | Debug Log (wiki) | Free Movies/TV Shows |
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
“Kodi” is damaged and can’t be opened. You should move it to the Trash00