•   
  • 1
  • 43
  • 44
  • 45(current)
  • 46
  • 47
  • 218
  •   
  Thread Closed
v17 LibreELEC Testbuilds for RaspberryPi (Kodi 17.0)
New LibreELEC.tv Krypton build #0526: RPi / RPi2
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 4.6.0 #1 Thu May 26 21:06:53 BST 2016 armv6l GNU/Linux

# vcgencmd version
May 20 2016 19:05:21
Copyright (c) 2012 Broadcom
version faf071dd4885c5ac1a89483d35a5326e7f69495f (clean) (release)

# lsb_release
LibreELEC (Milhouse) - Version: devel-20160526210501-#0526-g454d0a5 [Build #0526]

# vcdbg log msg 2>&1 | grep DTOK
002477.246: Kernel trailer DTOK property says yes

# Kernel device tree status: Enabled

Based on tip of LibreELEC.tv master (454d0a54, changelog) and tip of XBMC master (c34d9e80, changelog) with the following modifications:
  • Includes newclock5 patches
  • Excludes the LibreELEC linux-01-RPi_support patch in favour of sourcing these and possibly more recent patches directly from kernel branch rpi-4.6.y
  • Includes latest bcm2835-driver master (3b98f743, ahead +10)
  • Includes latest kodi-platform master (c8188d82, ahead +4)
  • Includes latest libcec master (6d68d212)
  • Includes latest libnfs master (00d9ba15, ahead +19)
  • Includes latest p8-platform master (041a8c6c, ahead +1)
  • Includes latest addons: adsp.basic (2ae604e5, +8), adsp.biquad.filters (01236bbe, +7), adsp.freesurround (34f50406, +7), asplib (da66f517), inputstream.mpd (3ac19c39, +11), inputstream.smoothstream (32275717, +2), peripheral.joystick (83371862, +30), pvr.argustv (5f48dcec, +4), pvr.demo (0fa9e1d0, +4), pvr.dvblink (a92f1264, +5), pvr.dvbviewer (3d0bea9a, +4), pvr.filmon (8743511d, +4), pvr.hdhomerun (b5ce9309, +4), pvr.hts (acd1a6ac, +5), pvr.iptvsimple (7a5a43f8, +4), pvr.mediaportal.tvserver (172a273c, +4), pvr.mythtv (e2b60252, +8), pvr.nextpvr (150698b7, +4), pvr.njoy (b5d65655, +4), pvr.pctv (feed5990, +4), pvr.stalker (4244220f, +12), pvr.vbox (c6594819, +4), pvr.vdr.vnsi (5498a8c1, +7), pvr.vuplus (ea3b33f6, +4), pvr.wmc (77af8daf, +4)
  • Exclude [env] kodi-999.10-aarch64-support.patch: Merged upstream
  • Include [env] e7cbe9cb: xf86-video-intel: Explicitely disable TearFree and TripleBuffer
  • Include [env] ed774729: Intel: Implement Passthrough-Range
  • Include [env] 98c65e6a: Kodi: Use Limited Range by default
  • Include [env] patch: xf86-video-intel: bump to 3fafabe
  • Include [env] patch: Fix SIGTERM patch after PR9748
  • Include [env] patch: Fix cmake after PR9750
  • Include [env] patch: Add extra headers needed by 3D BD MVC
  • Include [env] patch: Disable -werror as libnfs won't build 32-bit without it
  • Include [env] patch: Bump libbluray - include MVC support
  • Include [env] patch: Add experimental splash video for RPi
  • Include [env] patch: HACK: Disable multiple PVR addons during migration. Always enable inputstream.*, os.* and peripheral.*
  • Include [env] patch: Enable pvr addons, disable pvr updates
  • Include [env] patch: Enable other binary addons
  • Include [env] PR:353: plymouth-lite: add bilinear interpolation patch
  • Include [env] PR:366: mysql: update to 5.7.12
  • Include [env] PR:381: splash: Select splash image based on native resolution
  • Include [env] PR:382: systemd: update to 230
  • Include [env] PR:388: xf86-video-nvidia: update to xf86-video-nvidia-361.42
  • Revert [env] 46b9b7b3: rtmpdump (Reason: use newclock5 bump)
  • Include [pkg] patch: [skin.estuary] Hide watched items on home (kodi-theme-Estuary)
  • Include [pkg] patch: drm/i915: Extend Fake HDMI live status to Valley View (linux)
  • Include [pkg] patch: drm/i915/psr: Try to program link training times correctly (HSW fix) (linux)
  • Include [pkg] patch: Revert "drm/i915: Exit cherryview_irq_handler() after one pass" (BSW fix) (linux)
  • Include [pkg] patch: CSC: Remove average logic when saving NV12 surface on IVB+ (VAAPI fix) (libva-intel-driver)
  • Include [pkg] PR:8645: [video] Add season/TV show artwork to episodes/seasons even if they have their own fanart.
  • Include [pkg] PR:8824: videodb: fix smart playlists not honoring "Show empty TV shows" setting.
  • Include [pkg] PR:8922: [guiinfo] extend ranges for listitem properties
  • Include [pkg] PR:9803: [PeripheralCecAdapter] fix playback stopping on screensaver deactivated
  • Include [pkg] PR:9847: [PVR] Feature: Make instant recording behavior configurable
Build Highlights:
  1. NOTE: DVD playback remains temporarily disabled
  2. Drop Roby77 vblank patch
Build Details:
  1. LibreELEC.tv:
    • nvidia: Enable USLEEP to reduce CPU load while rendering (PR:393, 1 commit, 1 file changed)
  2. XBMC:
    • [PVR] Fix deadlock in PVR channel window. (PR:9880, 1 commit, 5 files changed)
    • [cmake][Windows] Fix wrong output directory of add-on callback libraries for Windows (PR:9868, 1 commit, 1 file changed)
    • [guilib] remove deprecated controls (PR:9848, 5 commits, 21 files changed)
  3. newclock5:
    • New commits in this build:
      • Revert "RenderMan: Simplify late frame skipping code v2" (e7e9e273)
      • VideoPlayer: improve skipping frames (53db8e76)
    • Commits no longer in build:
      • [mmalcodec] Add back in preroll (81334fec)
      • Revert "[mmalcodec] Add back in preroll" (d2102b99)
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
I am new to the whole RPI concept, so this is very basic question:

I have got LibreELEC running, and downloaded the .tar, but I cannot find the "update" folder to copy it in.

Do you plug the SD card with the image in a Windows PC?

or in the RPI running Raspberrian?

or under OPENELEC itself?

or through a network?

Any clue would be appreciated.
Thx,
the update folder is hidden, I do it through ssh, and to get there you would put a period before update, ie: cd .update
(2016-05-27, 02:59)santope Wrote: I have got LibreELEC running, and downloaded the .tar, but I cannot find the "update" folder to copy it in.

1st. Enable display of hidden files and folders in LibreELEC

System > Settings > Appearance > File Lists > Show hidden files and directories

2nd. Have a USB Flash Drive with .tar file plugged into the Raspberry Pi and then go to "File Manager" to copy it into the ".update" folder

System > File Manager > storage > .update

then "Reboot" your Pi to auto start the update procedure.
(2016-05-26, 06:50)Milhouse Wrote:
(2016-05-26, 06:37)TheShoe Wrote: having issues setting the time. i have pool.ntp.org configured but the time is still incorrect. any ideas? this is libreelec build #0525
Has this started with #0525? If not which is the last build when the time is set correctly? Does it happen with LibreELEC 7.0.1?

You shouldn't need to set pool.ntp.org as that's already the default (0.pool.ntp.org, 1.pool.ntp.org, 2.pool.ntp.org, 3.pool.ntp.org). If the time isn't being set then you may not have an internet connection - are you sure it's not a local network issue (are you using WiFi or wired, DHCP or static? Is a local timeserver - such as your router - being used that isn't accurate)? Try resetting your router.

Well, I don't recall if it was correct in any LibreELEC version. It was correct in OpenELEC. I can try an older version pre-0525 and see it it corrects itself.

I removed pool.ntp.org but no difference.

The RPI2 definitely has an internet connection as I can ping external addresses by DNS name or IP address.

I'm using wired, DHCP, and the router is configured for pool.ntp.org, GMT-5 which is all correct.

I'll try rebooting the router. issuing "date" on the commandline shows same time as Kodi, so the RPI2 itself is picking up the wrong time. It's as if it's ignoring the GMT offset and showing GMT+0 (or UTC)
Is it just the time that is incorrect, and not also the date? Have you set the timezone correctly in Kodi?
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2016-05-27, 06:22)Milhouse Wrote: Is it just the time that is incorrect, and not also the date? Have you set the timezone correctly in Kodi?

oh good grief! this is a PEBCAK (Problem Exists Between Chair and Keyboard).

no i didn't. sorry for wasting your time (no pun intended). it's been a long week.

cheers and thanks for pointing out the obvious to me
(2016-05-25, 23:00)popcornmix Wrote:
(2016-05-25, 22:52)Milhouse Wrote: [*]RenderMan: Simplify late frame skipping code v2 (eaa440d9)
This is designed to improve the stall that occurs a few seconds after start of playback or seeking. Report if it helps.

This seems improved in the latest 2605 build, although still not 100% smooth at the start of 1080p birds.mkv

2505 felt like a regression: more dropped/skipped frames, IMHO 2605 is better.
(2016-05-27, 02:59)santope Wrote: I am new to the whole RPI concept, so this is very basic question:

or through a network?

Any clue would be appreciated.
Thx,

No need to copy anything, do it by terminal, and let the RPI download it:

Code:
ssh [email protected] (or ssh [email protected]*)
cd .update
wget http://milhouse.libreelec.tv/builds/master/RPi2/***.tar
reboot

This requires a linux/osx machine, but since Microsoft finally has seen the light, you can use a Bash shell in Windows 10 (soon) to run above commands:
https://blogs.windows.com/buildingapps/2...n-windows/
(2016-05-27, 06:45)TheShoe Wrote:
(2016-05-27, 06:22)Milhouse Wrote: Is it just the time that is incorrect, and not also the date? Have you set the timezone correctly in Kodi?

oh good grief! this is a PEBCAK (Problem Exists Between Chair and Keyboard).

no i didn't. sorry for wasting your time (no pun intended). it's been a long week.

cheers and thanks for pointing out the obvious to me

I've the same issue.. timezone is set correctly to Britain (UK) in Kodi, date is lagging and time is completely off...
It started lately, didn't notice when. Tried to change a timezone to something else, restart, waited a bit for ntp update... nothing... even when back to GMT timezone. Will try to go back few realeases to find out.
Connected via LAN to router, same setup for several years now, router is synced with ntp and aligned
Any idea?
(2016-05-27, 12:13)ElectricPim Wrote:
(2016-05-27, 02:59)santope Wrote: I am new to the whole RPI concept, so this is very basic question:

or through a network?

Any clue would be appreciated.
Thx,

No need to copy anything, do it by terminal, and let the RPI download it:

Code:
ssh [email protected] (or ssh [email protected]*)
cd .update
wget http://milhouse.libreelec.tv/builds/master/RPi2/***.tar
reboot

This requires a linux/osx machine, but since Microsoft finally has seen the light, you can use a Bash shell in Windows 10 (soon) to run above commands:
https://blogs.windows.com/buildingapps/2...n-windows/

Can you able to explain it little bit more for people like me who are not very tech savy.....
Thanks in advance
Hi,

i can't change the wireless settings because there isn't a save button. is this a bug ?

alexm.
(2016-05-27, 19:46)AlexMineiro Wrote: Hi,

i can't change the wireless settings because there isn't a save button. is this a bug ?

alexm.


I have the same problem.

build #0526

In Confluence also save button missing
[1x RPi3]#[ AV Receiver - Marantz NR1506 ]#[ TV Panasonic TX-50EXW784 ]#[ NAS @ OMV 4.1.xx (Arrakis) on Banana Pi ]#[ ODROID C2 + wrxtasy's LE 8.0 ]
(2016-05-27, 19:46)AlexMineiro Wrote: i can't change the wireless settings because there isn't a save button. is this a bug ?

Yes. Thanks for reporting.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2016-05-27, 06:22)Milhouse Wrote: Is it just the time that is incorrect, and not also the date? Have you set the timezone correctly in Kodi?

using the standard skin Estuaty. Pi3

i have the timeservers setup via the libreELEC settings
0.pool.ntp.org
1.pool.ntp.org.

When i turn on the PI it shows the wrong time. It shows the time that the image was updated? like i put the latest from 26 may it shows 26 may.

is it correct NTPdate isnt installed?
  •   
  • 1
  • 43
  • 44
  • 45(current)
  • 46
  • 47
  • 218
  •   
  Thread Closed
 
Thread Rating:
  • 19 Vote(s) - 4.63 Average



Logout Mark Read Team Forum Stats Members Help
LibreELEC Testbuilds for RaspberryPi (Kodi 17.0)4.6319