•   
  • 1
  • 54
  • 55
  • 56(current)
  • 57
  • 58
  • 218
  •   
  Thread Closed
v17 LibreELEC Testbuilds for RaspberryPi (Kodi 17.0)
(2016-06-10, 19:05)popcornmix Wrote:
(2016-06-10, 18:50)cojms1 Wrote: Recently I've been getting an issue with Live TV (pvr.hts) where the picture is very juddery. When I go into the video settings and turn Deinterlace settings from Auto to Off all seems fine.

I've gone back through the versions; #0604 is fine and #0605 exhibits the problem.

PR:9917 looks like the most likely possibility from #605. A little surprising though.
I could try temporarily reverting it to confirm it is the problem.

Thanks @popcornmix. Once reverted I can test and let you know how it goes.
(2016-06-10, 19:02)unclejoe01 Wrote:
(2016-06-10, 15:11)popcornmix Wrote: What do you have "When TV is switched off" set to (in system/input/peripherals/CEC)?

I don't have the option in system!

Ah - that's where it was on Jarvis. Try Interface Settings->Control->Peripherals/CEC Adapter
(2016-06-10, 19:05)popcornmix Wrote:
(2016-06-10, 18:50)cojms1 Wrote: Recently I've been getting an issue with Live TV (pvr.hts) where the picture is very juddery. When I go into the video settings and turn Deinterlace settings from Auto to Off all seems fine.

I've gone back through the versions; #0604 is fine and #0605 exhibits the problem.

PR:9917 looks like the most likely possibility from #605. A little surprising though.
I could try temporarily reverting it to confirm it is the problem.
I had reported the same here and here, but received no response...
[1x RPi3]#[ AV Receiver - Marantz NR1506 ]#[ TV Panasonic TX-50EXW784 ]#[ NAS @ OMV 4.1.xx (Arrakis) on Banana Pi ]#[ ODROID C2 + wrxtasy's LE 8.0 ]
(2016-06-10, 18:50)cojms1 Wrote: Recently I've been getting an issue with Live TV (pvr.hts) where the picture is very juddery. When I go into the video settings and turn Deinterlace settings from Auto to Off all seems fine.

I've gone back through the versions; #0604 is fine and #0605 exhibits the problem.

(2016-06-04, 11:07)Aux_ Wrote: In build #0603 there is a problem with deinterlacing? If in Video settings - Adjusting "Deinterlace video" = ON, the image stop all at 2sec. If put in Video settings "Deinterlace video" = Auto then there is no frezes.

in build #0602 all OK.

Doesn't look like the same issue. One started in #603 and one in #605.
(2016-06-10, 19:23)cojms1 Wrote:
(2016-06-10, 19:05)popcornmix Wrote:
(2016-06-10, 18:50)cojms1 Wrote: Recently I've been getting an issue with Live TV (pvr.hts) where the picture is very juddery. When I go into the video settings and turn Deinterlace settings from Auto to Off all seems fine.

I've gone back through the versions; #0604 is fine and #0605 exhibits the problem.

PR:9917 looks like the most likely possibility from #605. A little surprising though.
I could try temporarily reverting it to confirm it is the problem.

Thanks @popcornmix. Once reverted I can test and let you know how it goes.
Not sure if related, been away for a few days, updated to #0609 and noticed juddery picture with pvr.hts and live DVB-T HD tv channels (not SD, I have installed pi codec licences?) #0602 seems fine with #0603 juddering same as #0609

Not modified any settings in my usage case its like video frame type pause with audio continuing normally approx every two/three seconds

#0603 debug log
rPi3B+, SanDisk Ultra 8Gb SD, Milhouse kernel_5.x LE ​Testbuild (Kodi 19 Matrix) -> Onkyo TX-SR608 AV Receiver -> Philips 42" LCD TV
KVIM2 Pro, SanDisk Ultra 8Gb SD, kernel_5.x LE Testbuild (Kodi 19 Matrix) -> LG 27UD69-W 4K Monitor -> AudioEngine A2+ Speakers
I won't be able to test again until tomorrow. Tests earlier showed the results I mentioned in the previous post (#0604 seemed fine at first glance). Maybe it was just less pronounced though.
Smile 
I upgrade from #0604 to #0609 and this issue with Live-TV channel switch on 720p channel is fixed now
(2016-06-10, 20:42)cojms1 Wrote: I won't be able to test again until tomorrow. Tests earlier showed the results I mentioned in the previous post (#0604 seemed fine at first glance). Maybe it was just less pronounced though.

Managed to test again whilst watching the football. Watched some of 2nd half on #0604 without issue so I'll stand by the fact that my issue seemed to start with #0605.
(2016-06-10, 22:40)cojms1 Wrote: Managed to test again whilst watching the football. Watched some of 2nd half on #0604 without issue so I'll stand by the fact that my issue seemed to start with #0605.

Tonight's build reverts the most likely commit from #0605, so we'll see if that makes a difference.
New LibreELEC.tv Krypton build #0610: RPi / RPi2
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 4.6.2 #1 Fri Jun 10 21:06:31 BST 2016 armv6l GNU/Linux

# vcgencmd version
Jun  8 2016 16:12:00
Copyright (c) 2012 Broadcom
version 1c8638223821fe0ed16e20bd8e948b6cc037fa4a (clean) (release)

# lsb_release
LibreELEC (Milhouse) - Version: devel-20160610210525-#0610-gd03b16e [Build #0610]

# vcdbg log msg 2>&1 | grep DTOK
002475.137: Kernel trailer DTOK property says yes

# Kernel device tree status: Enabled

Based on tip of LibreELEC.tv master (d03b16ea, changelog) and tip of XBMC master (536fa3c3, changelog) with the following modifications:
  • Includes newclock5 patches
  • Excludes the LibreELEC linux-01-RPi_support patch in favour of sourcing these and possibly more recent patches directly from kernel branch rpi-4.6.y
  • Includes latest bcm2835-driver master (9cd62e61)
  • Includes latest kodi-platform master (c8188d82)
  • Includes latest libcec master (6d68d212)
  • Includes latest libnfs master (cdd1643c, ahead +28)
  • Includes latest p8-platform master (041a8c6c, ahead +1)
  • Includes latest addons: adsp.basic (2ae604e5), adsp.biquad.filters (01236bbe), adsp.freesurround (34f50406), asplib (da66f517), inputstream.mpd (3ac19c39, +15), inputstream.smoothstream (32275717), peripheral.joystick (2db8029e), pvr.argustv (5f48dcec), pvr.demo (0fa9e1d0), pvr.dvblink (a92f1264), pvr.dvbviewer (3d0bea9a), pvr.filmon (8743511d), pvr.hdhomerun (b5ce9309), pvr.hts (acd1a6ac), pvr.iptvsimple (7a5a43f8), pvr.mediaportal.tvserver (172a273c), pvr.mythtv (e2b60252), pvr.nextpvr (150698b7), pvr.njoy (b5d65655), pvr.pctv (feed5990), pvr.stalker (fb24eda2), pvr.vbox (c6594819), pvr.vdr.vnsi (5498a8c1), pvr.vuplus (ea3b33f6), pvr.wmc (77af8daf)
  • Include [env] e7cbe9cb: xf86-video-intel: Explicitely disable TearFree and TripleBuffer
  • Include [env] ed774729: Intel: Implement Passthrough-Range
  • Include [env] 98c65e6a: Kodi: Use Limited Range by default
  • Include [env] patch: xf86-video-intel: bump to 3fafabe
  • Include [env] patch: Add extra headers needed by 3D BD MVC
  • Include [env] patch: mesa: update to 12.0.0-rc1
  • Include [env] patch: Bump libbluray - include MVC support
  • Include [env] patch: HACK: Disable multiple PVR addons during migration. Always enable inputstream.*, os.* and peripheral.*
  • Include [env] patch: Add experimental splash video for RPi
  • Include [env] patch: Enable pvr addons, disable pvr updates
  • Include [env] patch: Enable other binary addons
  • Include [env] PR:408: Fix digital audio crackling when playing music on non Kodi based setups.
  • Include [env] PR:412: splash: Stop blanking splash too early in RPi boot sequence
  • Include [env] PR:431: Revert "Merge pull request #136 from lrusak/modesetting"
  • Include [env] PR:432: build: start using .libreelec-unpack
  • Include [env] PR:433: libreelec: use build project directory for ccache
  • Revert [env] 46b9b7b3: rtmpdump (Reason: use newclock5 bump)
  • Include [pkg] patch: drm/i915: Extend Fake HDMI live status to Valley View (linux)
  • Include [pkg] patch: [skin.estuary] Hide watched items on home (kodi-theme-Estuary)
  • Include [pkg] patch: CSC: Remove average logic when saving NV12 surface on IVB+ (VAAPI fix) (libva-intel-driver)
  • Include [pkg] PR:8645: [video] Add season/TV show artwork to episodes/seasons even if they have their own fanart.
  • Include [pkg] PR:8824: videodb: fix smart playlists not honoring "Show empty TV shows" setting.
  • Include [pkg] PR:8922: [guiinfo] extend ranges for listitem properties
  • Include [pkg] PR:9803: [PeripheralCecAdapter] fix playback stopping on screensaver deactivated
Build Highlights:
  1. Revert commit causing possible pvr.hts issue
  2. Several new kernel dma-related commits
Build Details:
  1. LibreELEC.tv:
    • samba: actually allow it to be disabled (PR:439, 1 commit, 2 files changed)
    • settings: bump to v0.8.1 (PR:440, 1 commit, 1 file changed)
    • linux: Update to 4.6.2 (PR:434, 4 commits, 33 files changed)
    • Add Custom config.txt copy to boot loader during update and version check (PR:389, 3 commits, 4 files changed)
    • Atom Baytrail and CherryTrail HDMI audio support (PR:417, 2 commits, 2 files changed)
  2. XBMC:
    • FFmpeg: Make usable from add-ons (PR:9827, 1 commit, 3 files changed)
    • fixed: tar depends on automake (PR:9938, 1 commit, 1 file changed)
    • reduce impact of touching VideoDatabase.h, PVRRecordings.h (PR:9937, 1 commit, 12 files changed)
  3. newclock5:
    • New commits in this build:
      • VideoPlayer: do not calc framerate in stalled state (178e2bb9)
      • Revert "VideoPlayer: set 10ms threshold for DISCONT error adjustments" (240c6f57)
  4. kernel 4.6.y:
    • New commits in this build:
      • Revert "bcm2835-dma: Fix up convert to DMA pool" (dd033124)
      • Revert "bcm2835-dma: Limit cyclic transfers on lite channels to 32k" (74565476)
      • Revert "dmaengine: bcm2835: Load driver early and support legacy API" (148d1698)
      • Revert "dmaengine: bcm2835: Add slave dma support" (08e56c0e)
      • dmaengine: bcm2835: remove unnecessary masking of dma channels (490c8874)
      • dmaengine: bcm2835: add additional defines for DMA-registers (ff186fbb)
      • dmaengine: bcm2835: move cyclic member from bcm2835_chan into bcm2835_desc (d4bd931f)
      • dmaengine: bcm2835: move controlblock chain generation into separate method (f73908f6)
      • dmaengine: bcm2835: limit max length based on channel type (5535fb2e)
      • dmaengine: bcm2835: add slave_sg support to bcm2835-dma (faaf5411)
      • dmaengine: bcm2835: add dma_memcopy support to bcm2835-dma (65019ea0)
      • dmaengine: bcm2835: use platform_get_irq_byname (8134418e)
      • dmaengine: bcm2835: Load driver early and support legacy API (bc60e5c0)
      • ARM: bcm270x: changed bcrm,dma-channel-mask to mask out the used channel (0d46bb04)
      • ARM: bcm2835: add interrupt-names and apply correct mapping (e10a8296)
      • ARM: bcm2835: make dma-channel-0 available for kms setups (28072edd)
      • dmaengine: bcm2835: Fix cyclic DMA period splitting (35128a8a)
      • dmaengine: bcm2835: Avoid splitting periods into very small chunks (5fc5ec29)
      • Merge pull request #1522 from DigitalDreamtimeLtd/rpi-4.6.y (47b63bd3)
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Fairly big change to I2S/DMA driver in this update. If you use I2S audio then please test and report.
Video settings, deinterlace video and deinterlace method Automatic works fine, no more video stops or freezes.

Thanks for the hard work guys!
[1x RPi3]#[ AV Receiver - Marantz NR1506 ]#[ TV Panasonic TX-50EXW784 ]#[ NAS @ OMV 4.1.xx (Arrakis) on Banana Pi ]#[ ODROID C2 + wrxtasy's LE 8.0 ]
I noticed an issue that is not present in stable 7.0.1 build:

During the first couple of seconds after the start of the video - there is a high number of skipped frames (usually around 30-70). The start of playback is much more smooth in Kodi 16. The issue seem to be limited to the files in TS, MPEG-PS and VOB containers. All MKVs I tested are ok.

Update: The problem is gone when "Sync Playback to Display" is enabled.

Tested on RPi3 connected with a LAN cable to an SMB shared folder on Win7 PC.
(2016-06-10, 23:00)popcornmix Wrote:
(2016-06-10, 22:40)cojms1 Wrote: Managed to test again whilst watching the football. Watched some of 2nd half on #0604 without issue so I'll stand by the fact that my issue seemed to start with #0605.

Tonight's build reverts the most likely commit from #0605, so we'll see if that makes a difference.

Unfortunately no difference here. I still need to set deinterlace to off to get a smooth picture.

Update 07:30 - I've gone back through with some further testing. It appears that it may be channel specific in my car. The football was on ITV last night and I didn't see a problem. However trying BBC One this morning I do see the issue on #0604. Based on that I went further back (testing BBC One each time) and it now appears that #0603 is where it started.

Apologies for the duff information earlier.
(2016-06-10, 20:16)popcornmix Wrote:
(2016-06-10, 18:50)cojms1 Wrote: Recently I've been getting an issue with Live TV (pvr.hts) where the picture is very juddery. When I go into the video settings and turn Deinterlace settings from Auto to Off all seems fine.

I've gone back through the versions; #0604 is fine and #0605 exhibits the problem.

(2016-06-04, 11:07)Aux_ Wrote: In build #0603 there is a problem with deinterlacing? If in Video settings - Adjusting "Deinterlace video" = ON, the image stop all at 2sec. If put in Video settings "Deinterlace video" = Auto then there is no frezes.

in build #0602 all OK.

Doesn't look like the same issue. One started in #603 and one in #605.
ref my previous post and debug log for #0603
#0610 pausing video freeze every two seconds is resolved if I set deinterleaved video to "off" with on and auto options, video freeze every couple of seconds still exists. (HD TV via DVB-T (Spain) & tvheadend installed on pi)
rPi3B+, SanDisk Ultra 8Gb SD, Milhouse kernel_5.x LE ​Testbuild (Kodi 19 Matrix) -> Onkyo TX-SR608 AV Receiver -> Philips 42" LCD TV
KVIM2 Pro, SanDisk Ultra 8Gb SD, kernel_5.x LE Testbuild (Kodi 19 Matrix) -> LG 27UD69-W 4K Monitor -> AudioEngine A2+ Speakers
  •   
  • 1
  • 54
  • 55
  • 56(current)
  • 57
  • 58
  • 218
  •   
  Thread Closed
 
Thread Rating:
  • 19 Vote(s) - 4.63 Average



Logout Mark Read Team Forum Stats Members Help
LibreELEC Testbuilds for RaspberryPi (Kodi 17.0)4.6319