•   
  • 1
  • 72
  • 73
  • 74(current)
  • 75
  • 76
  • 218
  •   
  Thread Closed
v17 LibreELEC Testbuilds for RaspberryPi (Kodi 17.0)
I've a similar problems with navigating DVD title menus since DVD playback was re-instated (I've tested several but not all builds - 0613,0617,0618).
Using home-created DVD images (mytharchive) which used to play fine before the change the title menu displays the background picture, but the overlay which shows the currently selected option doesn't seem to work (some builds didn't even display the background picture).

Pressing the 'select' key blind you can still start to play something (at least with #0618), but you don't know what it will be until it starts. I get similar title rendering problems using a laptop DVD drive and a shop-bought copy of 'The Box Trolls' which I grabbed to do a quick test.

Switching back to the #0224 OpenELEC test build my home created DVDs play fine and the shop-bought disk works as well.

Going back this far makes me appreciate all the effort put in since then, wow what an improvement in performance generally, but DVD playback was definitely far better in #0224. Certainly #0618 won't pass the 'family usage' test for DVDs yet :-(.
(2016-06-27, 01:00)smp1 Wrote: Build #0626 broke the DVD playback again. This time the navigation in DVD menus does not work on many titles I tested. The sample I posted here is a good example.

Yes, it looks like DVD menu navigation is a little broken. Doldi's Alan Parsons DVD works OK, but navigating the Eagles DVD is a problem (the selected menu item is not visible etc.) and the tracks are not playing.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2016-06-27, 00:59)igenena Wrote: HI Milhouse,

I am on Raspberry Pi3 , using libreelec K17 since #618 till #626, the addon PVR Stalker Client 2.5.0 Search function not working, the search function in the PVR does not allow for writing in any string, but rather is showing me external Directories of my RPI (a directory for an ext4 partition on my SD or if i add my USB HDDs, they show up as well).

Its pretty odd and tiring, i cant search up a channel or a program, within 2500 channels i have!

When i try from MAC OS, Kodi build 17 as well, the add on is behaving well, and indeed the search function works perfectly!

I opened a thread in Stalker client middleware forum, but i was told to open in PVR support as the search function might not be an add on function, but rather a Kodi's only. and that might be true, as on MAC the builds are from Kodi, while on RPi3 its the nightly we use here (Thanks to your excellent work).

PS: search anywhere else in Kodi works fine, only within the stalker client it doesnt.

You'll need to identify the first build when this problem started. Start with build #0430 and if that is OK, work forward (ie. install #0501 next) until you find the first build with the problem. If #0430 has the same problem, then work backwards until you find the first build without the problem - the preceding build being the one that introduced the problem.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
New LibreELEC.tv Krypton build #0627: RPi / RPi2
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 4.6.2 #1 Mon Jun 27 22:05:55 BST 2016 armv6l GNU/Linux

# vcgencmd version
Jun 27 2016 17:27:06
Copyright (c) 2012 Broadcom
version 1e7b8e2c9a7319f7b22869f1334c66e2cfc99f4a (clean) (release)

# lsb_release
LibreELEC (Milhouse) - Version: devel-20160627220447-#0627-gdf3c36b [Build #0627]

# vcdbg log msg 2>&1 | grep DTOK
002475.933: Kernel trailer DTOK property says yes

# Kernel device tree status: Enabled

Based on tip of LibreELEC.tv master (df3c36b5, changelog) and tip of XBMC master (1f9e2a2c, changelog) with the following modifications: Build Highlights:
  1. New firmware
  2. PR:10036: [PVR] Guide window: Fix timer icon issues (trac #16621)
Build Details:
  1. Firmware (Jun 27):
    • firmware: image_fx: Allow dimensions to be changed without triggering a size error
    • firmware: image_fx: Avoid setting the vpitch for YUVUV buffers
    • firmware: image_fx: Add YUVUV as supported type
    • firmware: image_fx: relax check on inout/output formats to support standalone deinterlace
    • firmware: h264_parse: Silently discard macroblocks with unsupported profile. See: link
    • userland: MMAL_VC_SHM: Explicitly lock buffer when requested. See: link
    • userland: khronos: Use vchiq_get_client_id to determine global PID. See: link
    • userland: various warning fixes
  2. LibreELEC.tv:
    • kodi-binary-addons: Update unofficial addons (PR:492, 3 commits, 8 files changed)
    • squeezelite: remove ir (PR:495, 2 commits, 3 files changed)
    • kodi-binary-addons: Fix update_binary-addons (PR:496, 2 commits, 4 files changed)
  3. XBMC:
    • ZeroconfMDNS.cpp: add header to fix compile with gcc 4.9 & uClibc (PR:10035, 1 commit, 1 file changed)
  4. pvr.hts:
    • Fix setting channel type & setting epg uid (PR:232, 3 commits, 3 files changed)
  5. pvr.stalker:
    • [debian] disable LTO (PR:66, 1 commit, 1 file changed)
  6. Additional commits/pull requests/changes not yet merged upstream:
    • Added: [pkg] PR:10036: [PVR] Guide window: Fix timer icon issues (trac #16621)
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2016-06-27, 01:00)smp1 Wrote: Build #0626 broke the DVD playback again. This time the navigation in DVD menus does not work on many titles I tested. The sample I posted here is a good example.
Same issue in #0627.
In build #0626 I've got this backtrace in dmesg:
https://p.6core.net/p/pqA6VVB9krnAluVWxAK7rW2z

I've cleared dmesg buffer before downloading build #0627 (nothing unusual in it), used wget to download the new build (so ~140 MB were written to disk) and before rebooting checked dmesg again.
Although it's the first time I see this backtrace, I tend to exclude this is new in #0626 - the ~recent (edit: in #0610 and #0611) DMA commits might be responsible. Or not.
i updated to #0627
but i tried to play a Xvid video and the quality was very bad all blocks in the video etc Which normally looks like its wrongly encoded but with 621 they played just fine.



Other problem is when i in the settings click on available versions the list is empty. While before i updated from 621 to 627 via this way.

627, 626 have both the video problem and that i cant update the version from the settings.

625 the video is ok again but still have that the version window is empty.
i also i updated to #0627 from a clean Libreelec installation.

The only issue i have, is the Onboard WiFi is not working fine. I miss a lot of Spots and can not write them in manuel. So i use again my wlan-dongle wich was not the intend any more....

Is there a workaround i mist?

i know there some hinds given in the Openelec forum but there was also said that it shut solved on your dev-builds.
(2016-06-28, 10:53)Little_Kitty Wrote: but i tried to play a Xvid video and the quality was very bad all blocks in the video etc Which normally looks like its wrongly encoded but with 621 they played just fine.

I've had a test. xvid is generally fine, but I suspect your video has GMC which can't be hardware decoded. Look for something like this in mediainfo:
Code:
Format settings, GMC                     : 3 warppoints

We should we automatically switching to software decode for GMC, but I suspect an fffmpeg change has stopped that working. I'll look into it.
(2016-06-28, 12:51)popcornmix Wrote:
(2016-06-28, 10:53)Little_Kitty Wrote: but i tried to play a Xvid video and the quality was very bad all blocks in the video etc Which normally looks like its wrongly encoded but with 621 they played just fine.

I've had a test. xvid is generally fine, but I suspect your video has GMC which can't be hardware decoded. Look for something like this in mediainfo:
Code:
Format settings, GMC                     : 3 warppoints

We should we automatically switching to software decode for GMC, but I suspect an fffmpeg change has stopped that working. I'll look into it.

Thank you.
it seems that something changed in FFmpeg 3.1 that makes the video go "bad" it still plays but a lot of artifacts.

It's true the video's i tried are quite old ( Anime ) But there arnt really any other version of these files which have better quality.
here is some info on the file not sure if you need it or can use it

Format : MPEG-4 Visual
Format profile : Advanced [email protected]
Format settings, BVOP : 2
Format settings, QPel : No
Format settings, GMC : 3 warppoints
Format settings, Matrix : Default (H.263)
Muxing mode : Packed bitstream
Codec ID : XVID
Codec ID/Hint : XviD
Duration : 24mn 49s
Bit rate : 823 Kbps
Width : 704 pixels
Height : 396 pixels
Display aspect ratio : 16:9
Frame rate : 23.976 (23976/1000) fps
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Scan type : Progressive
Compression mode : Lossy
Bits/(Pixel*Frame) : 0.123
Stream size : 146 MiB (86%)
Writing library : XviD 1.2.1 (UTC 2008-12-04)
Is anyone else having problems with scraping movies? Kodi doesn't seem to recognise new movies added to my movies folder and so I have to go and manually tell kodi to scrape the file.
(2016-06-28, 21:30)CAM STEW Wrote: Is anyone else having problems with scraping movies? Kodi doesn't seem to recognise new movies added to my movies folder and so I have to go and manually tell kodi to scrape the file.


Forgive my ignorance, but is it supposed to do it automatically? I have always done it manually.

Bill
New LibreELEC.tv Krypton build #0628: RPi / RPi2
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 4.6.3 #1 Tue Jun 28 21:06:29 BST 2016 armv6l GNU/Linux

# vcgencmd version
Jun 27 2016 17:27:06
Copyright (c) 2012 Broadcom
version 1e7b8e2c9a7319f7b22869f1334c66e2cfc99f4a (clean) (release)

# lsb_release
LibreELEC (Milhouse) - Version: devel-20160628210522-#0628-gc008283 [Build #0628]

# vcdbg log msg 2>&1 | grep DTOK
002470.762: Kernel trailer DTOK property says yes

# Kernel device tree status: Enabled

Based on tip of LibreELEC.tv master (c0082832, changelog) and tip of XBMC master (c6f500ac, changelog) with the following modifications: Build Highlights:
  1. New 4.6.3 kernel
  2. Fix for files with GMC warp-points
Build Details:
  1. LibreELEC.tv:
    • kodi-binary-addons: update to latest versions (PR:497, 1 commit, 4 files changed)
    • linux: Update to 4.6.3 + RPi firmware (PR:499, 4 commits, 32 files changed)
    • build: evaluate DEVTOOLS after $HOME options (PR:494, 1 commit, 1 file changed)
  2. XBMC:
    • [PVR] Guide window: Fix timer icon issues. Fixes #16621 (PR:10036, 3 commits, 6 files changed)
    • Revert "[addons] Preserve strings which are not string ids in enum lv… (PR:10040, 1 commit, 1 file changed)
  3. newclock5:
    • New commits in this build:
      • ffmpeg: hacky fix for files with GMC (ce0970ba)
      • mmalcodec: Clear flags before returning picture (e8583ac9)
      • mmalrenderer: Execute callbacks from main thread (e678bd25)
      • mmalcodec: Add interlace state to mmal video buffer (2ea8de97)
      • mmalrender: Improve logging for pool creation (a0e8061b)
      • mmalrender: Switch to user flag 3 for submitted pictures (6910a17e)
  4. kernel 4.6.y:
    • New commits in this build:
      • Add critical information for getting pi3-miniuart-bt overlay to work (065cd146)
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2016-06-28, 21:32)bill_orange Wrote:
(2016-06-28, 21:30)CAM STEW Wrote: Is anyone else having problems with scraping movies? Kodi doesn't seem to recognise new movies added to my movies folder and so I have to go and manually tell kodi to scrape the file.


Forgive my ignorance, but is it supposed to do it automatically? I have always done it manually.

Bill

Normally you can just tell kodi to scan for new media and it will go through all my drives and find any new file and scan it. However this isn't working for movies and instead I have to go into directory and find the file and then tell it to scan that file.
The DVD menu navigation issues are still there in #0628. The last good build is #0625.
  •   
  • 1
  • 72
  • 73
  • 74(current)
  • 75
  • 76
  • 218
  •   
  Thread Closed
 
Thread Rating:
  • 19 Vote(s) - 4.63 Average



Logout Mark Read Team Forum Stats Members Help
LibreELEC Testbuilds for RaspberryPi (Kodi 17.0)4.6319