•   
  • 1
  • 78
  • 79
  • 80(current)
  • 81
  • 82
  • 218
  •   
  Thread Closed
v17 LibreELEC Testbuilds for RaspberryPi (Kodi 17.0)
sure I know it was more a comment to why memphiz might have heard the audio/video so much out of sync, but I realize that should not matter.
I have always had sync video to display on, along with refresh rate, especially when you have a tv that does just about every refresh rate and the RPi can output perfect Hz to the decimal point, I certainly do not mind the tv delay..
was these 2 settings not combined in kodi below 17?
and then a sync display to video setting to let the audio drive the clock, perhaps that's why there is some confusion.

btw. I actually pulled my old pi out again after a longer android relationship (those things are not very versatile), so I was taken back again by the video quality, flexibility and open/libreELEC familiarity. a new gen should be on its way. android bye bye. lol. I always liked milhouse build's although I am on a halt, I miss tv from my provider who uses stalker middleware to much. but that will hopefully get fixed along the way. I still wonder if it is its ffmpeg limited livestreams issue you mentioned as its not rtmp, but it did start erroring out when opening the link in #701.

EDIT: peeking in the ffmpeg documentation hls should be supported as before and not have anything in common with the rtmp change.
strange I wonder what broke it then.
(2016-07-04, 16:10)tuxen Wrote: sure I know it was more a comment to why mephiz might have heard the audio/video so much out of sync, but I realize that should not matter.
I have always had sync video to display on, along with refresh rate, was these 2 settings not combined in kodi below 17?
and then a sync display to video setting to let the audio drive the clock, perhaps that's why there is some confusion.

The two settings have always been present and are independent. Big thread about them here:
219796 (thread)
(2016-07-04, 16:12)popcornmix Wrote:
(2016-07-04, 16:10)tuxen Wrote: sure I know it was more a comment to why mephiz might have heard the audio/video so much out of sync, but I realize that should not matter.
I have always had sync video to display on, along with refresh rate, was these 2 settings not combined in kodi below 17?
and then a sync display to video setting to let the audio drive the clock, perhaps that's why there is some confusion.

The two settings have always been present and are independent. Big thread about them here:
219796 (thread)
thanks popcornmix.

Quote:FernetMenta wrote:
There is no "sync playback to display" for Android because this platform lacks an implementation of video reference clock.
that explains why I did not see it through my intermediate relationship with android. Smile it could not even switch refresh rate, though the setting is there I think it works with very few lollipop devices. (shield probably)
i had both enabled and tv was switched to 50hz on the pal livetv signal - will play with what popcornmix suggested - thx Smile
AppleTV4/iPhone/iPod/iPad: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for Kodi: NFS (wiki)
HowTo configure avahi (zeroconf): Avahi_Zeroconf (wiki)
READ THE IOS FAQ!: iOS FAQ (wiki)
Having occasional Kodi GUI lockups where Estuary GUI goes blank (just the standard Estuary background colour, nothing on top), not easy to find way to repeat this lock-up.

For example #0703 and just switched now from watching a BBC Live stream to Live TV Guide and kodi GUI locked up and EPG grid never appeared kodi log

Had similar GUI lock up in #0702 yesterday too, but unfortunately don't remember exactly what i was doing and stepping through GUI at time of lock-up kodi log

When these Kodi Estuary GUI lock-up occur no amount of waiting seems to bring the GUI back to life, need to stop and restart kodi via ssh etc.

Tried to switch on debug to catch this, but problem never appears again quickly after a full reboot (reboot for example when updating to latest nightly build) etc.
rPi3B+, SanDisk Ultra 8Gb SD, Milhouse kernel_5.x LE ​Testbuild (Kodi 19 Matrix) -> Onkyo TX-SR608 AV Receiver -> Philips 42" LCD TV
KVIM2 Pro, SanDisk Ultra 8Gb SD, kernel_5.x LE Testbuild (Kodi 19 Matrix) -> LG 27UD69-W 4K Monitor -> AudioEngine A2+ Speakers
(2016-07-04, 21:06)MikeKL Wrote: Having occasional Kodi GUI lockups where Estuary GUI goes blank (just the standard Estuary background colour, nothing on top), not easy to find way to repeat this lock-up.

Remove the overclock first, just to rule that out.
Assuming kodi is still running, but hung, I think if you run:
Code:
killall -SEGV kodi.bin
You will get a backtrace in ~/kodi/temp which may have some clues in.
(2016-07-04, 21:14)popcornmix Wrote:
(2016-07-04, 21:06)MikeKL Wrote: Having occasional Kodi GUI lockups where Estuary GUI goes blank (just the standard Estuary background colour, nothing on top), not easy to find way to repeat this lock-up.
Remove the overclock first, just to rule that out. Assuming kodi is still running, but hung, I think if you run:

Code:
killall -SEGV kodi.bin
You will get a backtrace in ~/kodi/temp which may have some clues in.
Crikey, so long ago totally forgot I had overclocked Blush have commented out lines in config.txt unfortunately I had already rebooted, will keep an eye out for further lock-ups using backtrace option after grabbing standard kodi log if it happens again,
rPi3B+, SanDisk Ultra 8Gb SD, Milhouse kernel_5.x LE ​Testbuild (Kodi 19 Matrix) -> Onkyo TX-SR608 AV Receiver -> Philips 42" LCD TV
KVIM2 Pro, SanDisk Ultra 8Gb SD, kernel_5.x LE Testbuild (Kodi 19 Matrix) -> LG 27UD69-W 4K Monitor -> AudioEngine A2+ Speakers
New LibreELEC.tv Krypton build #0704: RPi / RPi2
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 4.7.0-rc6 #1 Mon Jul 4 21:08:01 BST 2016 armv6l GNU/Linux

# vcgencmd version
Jun 27 2016 17:27:06
Copyright (c) 2012 Broadcom
version 1e7b8e2c9a7319f7b22869f1334c66e2cfc99f4a (clean) (release)

# lsb_release
LibreELEC (Milhouse) - Version: devel-20160704210656-#0704-g822942e [Build #0704]

# vcdbg log msg 2>&1 | grep DTOK
002469.979: Kernel trailer DTOK property says yes

# Kernel device tree status: Enabled

Based on tip of LibreELEC.tv master (822942e1, changelog) and tip of XBMC master (7d71cb76, changelog) with the following modifications: Build Highlights:
  1. New 4.7-rc6 kernel - switching these test builds to 4.7 tree, unless there are any serious issues/regressions
  2. libbluray: bump 0.9.3 (with Nevcairiel's 3D ISO additions)
  3. PR:511: Revert "lirc: add lircd-uinput service"
Build Details:
  1. LibreELEC.tv:
    • moonlight-embedded: use gpu-viv-bin-mx6q (PR:512, 1 commit, 1 file changed)
    • scripts/image: don't copy *-update.zip to target directory (PR:513, 1 commit, 1 file changed)
  2. XBMC:
    • FFmpeg: Bump to version 3.1 (PR:10039, 1 commit, 1 file changed)
    • [eventclients] Nuke J2ME (PR:10049, 1 commit, 15 files changed)
    • [depends] libbluray 0.9.3 (PR:10056, 1 commit, 2 files changed)
    • [addons] Preserve strings which are not string ids in enum lvalues (PR:10068, 1 commit, 1 file changed)
    • [lang][kodi.core] automatic syntax corrections for the en_GB language file (956a3b83)
    • [lang] updated language files from Transifex (2f007792)
    • [lang][skin.estuary] updated language files from Transifex (2a6f4402)
    • [lang][skin.estouchy] updated language files from Transifex (a8a42b5c)
  3. pvr.dvblink:
    • [lang] updated language files from Transifex (0bf16840)
  4. pvr.hts:
    • [lang] updated language files from Transifex (856e72a4)
  5. pvr.mediaportal.tvserver:
    • [lang] updated language files from Transifex (3ba23b7b)
  6. pvr.mythtv:
    • [lang] updated language files from Transifex (02fa50d5)
  7. pvr.nextpvr:
    • [lang] updated language files from Transifex (ecbd6e5c)
  8. pvr.vbox:
    • [lang] updated language files from Transifex (36d3717b)
  9. pvr.vdr.vnsi:
    • Catch two uncaught exceptions after connection failure (PR:84, 4 commits, 2 files changed)
    • [lang] updated language files from Transifex (29449b64)
  10. pvr.vuplus:
    • [lang] updated language files from Transifex (d7f5685a)
  11. pvr.wmc:
    • [lang] updated language files from Transifex (1f3240da)
  12. newclock5:
    • Commits no longer in build:
  13. kernel 4.7.y:
    • New commits in this build:
      • Revert "ASoC: bcm2835: Add S16_LE support via packed DMA transfers" (7d8fd43e)
      • Revert "ASoC: bcm2835: setup clock only if CPU is clock master" (d6546778)
      • Revert "ASoC: bcm2835: add 24bit support" (0a516e7a)
      • Add support for Dion Audio LOCO DAC-AMP HAT (adf997c6)
    • Updated commits in this build:
    • Commits no longer in build:
      • rtc: ds1307: ensure that any pending alarm is cleared before a new alarm is enabled (fe915d32)
      • dmaengine: bcm2835: Add slave dma support (4e99035b)
      • dmaengine: bcm2835: set residue_granularity field (e3e04090)
      • bcm2835-dma: Limit cyclic transfers on lite channels to 32k (17879c9c)
      • bcm2835-dma: Fix up convert to DMA pool (b4c1abee)
      • fdt: Add support for the CONFIG_CMDLINE_EXTEND option (b12e21f4)
      • ASoC: Add support for PCM5102A codec (9d828ae8)
      • enc28j60: Add device tree compatible string and an overlay (1689900f)
      • BCM2835-V4L2: Correct handling for BGR24 vs RGB24. (e3ddcf01)
      • BCM270X_DT: Fix rpi-dac overlay (f845c10c)
      • gpio-ir overlay: gpio_pin shouldn't change pull setting (46d5da7d)
      • Implement a "wakeup-source" option for the i2c-rtc DeviceTree overlay. (8dc53ede)
      • BCM270X_DT: Make i2c-gpio usable by other overlays (88ad61a1)
      • Revert "bcm2835-dma: Fix up convert to DMA pool" (48c67a1f)
      • Revert "bcm2835-dma: Limit cyclic transfers on lite channels to 32k" (60538b1d)
      • Revert "dmaengine: bcm2835: Load driver early and support legacy API" (56252f11)
      • Revert "dmaengine: bcm2835: Add slave dma support" (1ee56fa3)
      • dmaengine: bcm2835: remove unnecessary masking of dma channels (ebb614c9)
      • dmaengine: bcm2835: add additional defines for DMA-registers (fdfa34f6)
      • dmaengine: bcm2835: move cyclic member from bcm2835_chan into bcm2835_desc (ed300507)
      • dmaengine: bcm2835: move controlblock chain generation into separate method (bba8da78)
      • dmaengine: bcm2835: limit max length based on channel type (e1510d84)
      • dmaengine: bcm2835: add slave_sg support to bcm2835-dma (d1bc02b6)
      • dmaengine: bcm2835: add dma_memcopy support to bcm2835-dma (bcb56060)
      • dmaengine: bcm2835: use platform_get_irq_byname (71073c1a)
      • dmaengine: bcm2835: Load driver early and support legacy API (d219cadf)
      • ARM: bcm270x: changed bcrm,dma-channel-mask to mask out the used channel (14d06aec)
      • ARM: bcm2835: add interrupt-names and apply correct mapping (4dd32a1f)
      • ARM: bcm2835: make dma-channel-0 available for kms setups (c48bf8b1)
      • dmaengine: bcm2835: Fix cyclic DMA period splitting (2caab8ac)
      • dmaengine: bcm2835: Avoid splitting periods into very small chunks (d6c5ec7a)
      • dmaengine: bcm2835: Fix polling for completion of DMA with interrupts masked. (3431d958)
      • dwc_otg: add FIQ latency profiling histogram (7385ae63)
      • Enable cfg80211 support (27080ee1)
      • suppress spurious messages (291fed54)
      • Add #if for 3.14 kernel change (#87) (6d603e52)
      • Set dev_type to wlan (4667944f)
      • Tentatively added support for more 8188CUS based devices. (04a721be)
      • Add support for more 8188CUS and 8192CUS devices (16b249b1)
      • Add ProductId for the Netgear N150 - WNA1000M (debe5ced)
      • Fixes CONFIG_CONCURRENT_MODE CONFIG_MULTI_VIR_IFACES (154dbfa8)
      • Fixes compatibility with 3.13 (9ad8e4cc)
      • Enables warning in the compiler and fixes some issues, reference => https://github.com/diederikdehaas/rtl8812AU (c4fd4db9)
      • Starts device in station mode instead of monitor, fixes NetworkManager issues (c4e2d567)
      • mmc: Apply ERASE_BROKEN quirks correctly (85bc78c8)
      • mm: introduce dedicated WQ_MEM_RECLAIM workqueue to do lru_add_drain_all (dc3503dc)
  14. Additional commits/pull requests/changes not yet merged upstream:
    • Added: [env] patch: libbluray: bump 0.9.3
    • Added: [env] PR:481: linux: Update to 4.7 (WIP)
    • Added: [env] PR:511: Revert "lirc: add lircd-uinput service"
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Was 0704 supposed to fix the lirc problems? My remote does not yet work to full extend, only a few buttons work. Do you want more details?

Last working build is 0618.
(2016-07-04, 23:00)jobisoft Wrote: Was 0704 supposed to fix the lirc problems? My remote does not yet work to full extend, only a few buttons work. Do you want more details?

Last working build is 0618.

I believe so, but apparently it hasn't had the desired effect.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
With this build i have both a Pi3 and a Pi2 that refuse to boot past the animated splash screen. i have narrowed it down to an issue with an Edimax Wireless AC600 USB dongle. If i remove it I can completely boot. Once booted if i plug the adapter back in Kodi locks hard and the unit becomes unresponsive.

This is the unit in question: https://www.amazon.ca/gp/product/B00FW6T...UTF8&psc=1
(2016-07-05, 02:00)jarvismeier Wrote: With this build i have both a Pi3 and a Pi2 that refuse to boot past the animated splash screen. i have narrowed it down to an issue with an Edimax Wireless AC600 USB dongle. If i remove it I can completely boot. Once booted if i plug the adapter back in Kodi locks hard and the unit becomes unresponsive.

This is the unit in question: https://www.amazon.ca/gp/product/B00FW6T...UTF8&psc=1

This would be due to the kernel switch, guess something is wrong in the driver code to your dongle.
hi guys,

Ever since build 0614, the round theme of the titan skin has not been loading. If i revert to milhouse build 0613 and below the theme will work again.
What's changed in kodi that's causing this? Took me a while go back in time and find the build that's introduced the bug.

The only thing i can see on the build notes is this:
[xbmc][cleanup] Some minor cleanup of texture handling (PR:9960, 1 commit, 5 files changed)

but i could be barking up the wrong tree here.
(2016-07-05, 08:22)loggio Wrote: hi guys,

Ever since build 0614, the round theme of the titan skin has not been loading. If i revert to milhouse build 0613 and below the theme will work again.
What's changed in kodi that's causing this? Took me a while go back in time and find the build that's introduced the bug.

The only thing i can see on the build notes is this:
[xbmc][cleanup] Some minor cleanup of texture handling (PR:9960, 1 commit, 5 files changed)

but i could be barking up the wrong tree here.
Can you post the debug log from a current build when loading this round theme.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2016-07-05, 09:52)Milhouse Wrote:
(2016-07-05, 08:22)loggio Wrote: hi guys,

Ever since build 0614, the round theme of the titan skin has not been loading. If i revert to milhouse build 0613 and below the theme will work again.
What's changed in kodi that's causing this? Took me a while go back in time and find the build that's introduced the bug.

The only thing i can see on the build notes is this:
[xbmc][cleanup] Some minor cleanup of texture handling (PR:9960, 1 commit, 5 files changed)

but i could be barking up the wrong tree here.
Can you post the debug log from a current build when loading this round theme.

here you go:
http://pastebin.com/QMzYFQk6

the texture file is called modern_rounded.xbt ... Although , there's no reference to it in the log file... only reference to Textures.xbt. After changing to the modern_rounded theme I turned off the debug log.
  •   
  • 1
  • 78
  • 79
  • 80(current)
  • 81
  • 82
  • 218
  •   
  Thread Closed
 
Thread Rating:
  • 19 Vote(s) - 4.63 Average



Logout Mark Read Team Forum Stats Members Help
LibreELEC Testbuilds for RaspberryPi (Kodi 17.0)4.6319