•   
  • 1
  • 81
  • 82
  • 83(current)
  • 84
  • 85
  • 218
  •   
  Thread Closed
v17 LibreELEC Testbuilds for RaspberryPi (Kodi 17.0)
Is there a GUI updater yet for these builds like Leopolds for OE?
https://github.com/miigotu/script.libreelec.devupdate

(2016-07-07, 13:27)nickrob84 Wrote: Is there a GUI updater yet for these builds like Leopolds for OE?
@nickrob84 or see note #7 in the first post which details the custom urls to enter for the update facility accessed via the LE Settings addon. Once the url is entered and channel selected you should be able to manually upgrade to new (or older) versions. Automatic updating will come eventually, this is still a work in progress.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Millhouse, I've said it befoe and il say it again, you are a legend Angel
(2016-07-07, 14:15)Milhouse Wrote: @nickrob84 or see note #7 in the first post which details the custom urls to enter for the update facility accessed via the LE Settings addon. Once the url is entered and channel selected you should be able to manually upgrade to new (or older) versions. Automatic updating will come eventually, this is still a work in progress.

would it be possible to start the download of the new build in LE Settings addon in background, so that I don't have to wait until download is completed or is it only possible in automatic update mode?
Why on my pi2 i see the chaptar forward button and on pi3 not?

Playing here the testBR "endless river" on both Pi's.

Do not understand that - always the #0706 build updated, hmmm ...


Harald

Edit_After restart button is visible, sorry
Don't know i overlooked it: On Intel NUC34010 with all builds starting from 0619 only a few remote buttons work.
New LibreELEC.tv Krypton build #0707: RPi / RPi2
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 4.7.0-rc6 #1 Thu Jul 7 21:07:55 BST 2016 armv6l GNU/Linux

# vcgencmd version
Jul  5 2016 21:33:41
Copyright (c) 2012 Broadcom
version 5a921d051b05efb2ce8abb0874cd44023d080d93 (clean) (release)

# lsb_release
LibreELEC (Milhouse) - Version: devel-20160707210601-#0707-g4cb4fca [Build #0707]

# vcdbg log msg 2>&1 | grep DTOK
002473.431: Kernel trailer DTOK property says yes

# Kernel device tree status: Enabled

Based on tip of LibreELEC.tv master (4cb4fca3, changelog) and tip of XBMC master (706c3344, changelog) with the following modifications: Build Highlights:
  1. Minors
Build Details:
  1. LibreELEC.tv:
    • Enable custom fonts to be installed in place of liberation fonts (PR:409, 1 commit, 2 files changed)
  2. XBMC:
    • VideoPlayer: check for duplicate filenames when opening multi source … (PR:10076, 1 commit, 1 file changed)
    • [VideoSyncD3D] CVideoSyncD3D should implement IDispResource interface… (PR:10082, 1 commit, 2 files changed)
    • [cmake] Small improvements and fixes (PR:10078, 5 commits, 6 files changed)
    • vdpau: refcount decoder with surfaces given to ffmpeg, align with vaa… (PR:10075, 1 commit, 2 files changed)
    • guilib: do not kill plugin script if we are waiting for user input (PR:10080, 1 commit, 1 file changed)
  3. pvr.stalker:
    • token cache (PR:68, 3 commits, 9 files changed)
  4. newclock5:
    • New commits in this build:
      • mmal: Include state in CMMALBuffer (363427f6)
  5. Additional commits/pull requests/changes not yet merged upstream:
    • Added: [env] patch: Bump included addon versions to prevent online updates
    • Updated: [env] patch: Enable pvr and adsp addons
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
There's an odd issue I noticed with some mkv files. When I start the playback the display will switch to 60Hz and after a couple of seconds it switch to the correct 24Hz.

Sample: https://docs.google.com/uc?id=0Bw7pv6UJO...t=download
(2016-07-08, 01:29)smp1 Wrote: There's an odd issue I noticed with some mkv files. When I start the playback the display will switch to 60Hz and after a couple of seconds it switch to the correct 24Hz.

I not noticed any abnormalities, for me works well...
[1x RPi3]#[ AV Receiver - Marantz NR1506 ]#[ TV Panasonic TX-50EXW784 ]#[ NAS @ OMV 4.1.xx (Arrakis) on NanoPI M4 ]#[ Nextcloud 16.0.4 @ ODROID C2 ]
(2016-07-07, 14:15)Milhouse Wrote: @nickrob84 or see note #7 in the first post which details the custom urls to enter for the update facility accessed via the LE Settings addon. Once the url is entered and channel selected you should be able to manually upgrade to new (or older) versions. Automatic updating will come eventually, this is still a work in progress.

Ever since this has been introduced the list of available versions for the Milhouse builds never updates, so it never looks like there are new versions - I have to switch all the update stuff off, flip the channel back the real libreelec one, refresh the list and then go back to Milhouse all over again for it to notice.

I'm assuming this isn't normal Smile What should trigger it to refreshing the lists of available versions?
(2016-07-08, 01:29)smp1 Wrote: There's an odd issue I noticed with some mkv files. When I start the playback the display will switch to 60Hz and after a couple of seconds it switch to the correct 24Hz.

There's something wrong with the encoding of this file. Run "ffmpeg -i" on it and:
Code:
Stream #0:1: Video: h264 (High), yuv420p, 1920x1080 [SAR 1:1 DAR 16:9], 47 fps, 47 tbr, 1k tbn, 47.95 tbc (default)
which is why we switch to 60fps at start. After a few seconds the correct framerate is determined and it switches to it.
Ever since the "dev update" feature was added, it hasn't been updating the "Available Versions" list, unless I reboot my RPi first. Trying to force an update by switching the "Update Channel" doesn't do the trick either. I'm now on #0705 and the problem persists.

This can't be the intended behaviour, can it? I would have expected to at least refresh when accessing the "Available Versions" list again.
MECOOL KIII Pro (S912)
Raspberry Pi 2 Model B, overclock mode: 'Pi2' (1000/500/500/2), gpu_mem_1024: '320'
The "Available versions" list really needs to update on-demand, or at least it needs a "Check now" button to avoid stale listings. This is something that needs to be added.

Edit: Toggling "Show Custom Channels", then re-applying the "Update Channel" will force refresh the "Available versions", but obviously this is not ideal...
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Libreelec on RP2 build #0706

Playing H-OU MKV and not being properly recognized as 3D (3D MVC MKV recognized fine); this is not the problem.

Subs are permanently being rendered regardless if subs turned on or off. Playing the same media in a different player has no subs (subs are not hard coded).
Never had this issue with any other media files - but seems that all recent files from this particular encoder has RP2/Libreelec rendering subs.

I tried clipping a portion of the media file and subs were not rendered on the clip (used Machete)
These files are from a torrent and I don't know if it is against the TOS to tell who the encoder is so that others could test those files.
  •   
  • 1
  • 81
  • 82
  • 83(current)
  • 84
  • 85
  • 218
  •   
  Thread Closed
 
Thread Rating:
  • 19 Vote(s) - 4.63 Average



Logout Mark Read Team Forum Stats Members Help
LibreELEC Testbuilds for RaspberryPi (Kodi 17.0)4.6319