•   
  • 1
  • 123
  • 124
  • 125(current)
  • 126
  • 127
  • 218
  •   
  Thread Closed
v17 LibreELEC Testbuilds for RaspberryPi (Kodi 17.0)
(2016-08-25, 10:55)BigNoid Wrote: I get crashes, sometimes right after boot and overnight i have a crashlog precisely every 1h23m Huh
I have a crashlog.

NPT_BsdSocket::RefreshInfo() is a UPnP/Neptune call... any idea when this started? I can get you a debug build a bit later today as that should provide a more detailed crashlog.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2016-08-25, 13:19)Milhouse Wrote:
(2016-08-25, 10:55)BigNoid Wrote: I get crashes, sometimes right after boot and overnight i have a crashlog precisely every 1h23m Huh
I have a crashlog.

NPT_BsdSocket::RefreshInfo() is a UPnP/Neptune call... any idea when this started? I can get you a debug build a bit later today as that should provide a more detailed crashlog.

I have a gap between #804 and #823, so don't know when exactly it started. Will try builds between those numbers, but as it takes an hour and half for it to crash, it might take some time Big Grin
Can also try a debug build if that would be helpful.
Already disabled everything UPnP but that didn't help.
(2016-08-25, 12:07)popcornmix Wrote:
(2016-08-25, 11:58)esco Wrote: Not sure about PLL, how can I check?
Thank you.

It is a setting in system/audio settings: "PLL adjustment to maintain audio/video sync". It defaults to disabled - what do you have it set to?

It's disabled, sorry, overlooked this setting somehow.
So I've been experimenting with ways to get the ticker on news stations like CNN to be "less stuttery" or "stutter free". I wanted to experiment with passthrough since my TV provider uses 1080i60 mpeg2. With "adjust display refresh rate" set to always, "sync playback to display" set to disabled and passthrough set to enabled, this worked quite well. Unfortunately while watching a recorded program and attempting to skip 60 seconds ahead I appear to have crashed the kodi.bin executable because it ran my PI3 out of memory:

[ 141.098732] Out of memory: Kill process 400 (kodi.bin) score 883 or sacrifice child
[ 141.098852] Killed process 400 (kodi.bin) total-vm:1171084kB, anon-rss:625456kB, file-rss:0kB, shmem-rss:0kB
[ 141.214938] oom_reaper: reaped process 400 (kodi.bin), now anon-rss:0kB, file-rss:0kB, shmem-rss:0kB
[ 141.392489] vchiq: 0: ignoring ERROR from callback to service d00c

I was using 0824 last night when that happened. Turning off passthrough and leaving "sync playback to display" set to disabled seems to still have the desired effect of a relatively stutter free news ticker but without the out of memory crash when skipping. I'd still like to try using passthrough but not if it will cause kodi to run the PI out of memory.
Seriously, where can we set the subtitles size these days? I've been looking for 6 hours straight now (and I have no idea where to look in the first place) and the subtitles are just HUGE. I want to be able to set them to my own personal taste. Help?

Edit: running the version from yesterday, #0824.
(2016-08-25, 22:37)mark_dj Wrote: Seriously, where can we set the subtitles size these days? I've been looking for 6 hours straight now (and I have no idea where to look in the first place) and the subtitles are just HUGE. I want to be able to set them to my own personal taste. Help?

Edit: running the version from yesterday, #0824.

Haha,

Settings/ player / language. Need to have settings set to expert.
(2016-08-25, 22:43)bmonster Wrote:
(2016-08-25, 22:37)mark_dj Wrote: Seriously, where can we set the subtitles size these days? I've been looking for 6 hours straight now (and I have no idea where to look in the first place) and the subtitles are just HUGE. I want to be able to set them to my own personal taste. Help?

Edit: running the version from yesterday, #0824.

Haha,

Settings/ player / language. Need to have settings set to expert.

It's set to expert, but I can't change the size there, only the position?
(2016-08-25, 22:47)mark_dj Wrote:
(2016-08-25, 22:43)bmonster Wrote:
(2016-08-25, 22:37)mark_dj Wrote: Seriously, where can we set the subtitles size these days? I've been looking for 6 hours straight now (and I have no idea where to look in the first place) and the subtitles are just HUGE. I want to be able to set them to my own personal taste. Help?

Edit: running the version from yesterday, #0824.

Haha,

Settings/ player / language. Need to have settings set to expert.

It's set to expert, but I can't change the size there, only the position?


No idea buddy, but I've checked and all my settings are there size/style/colour .

I'm using the latest build.
(2016-08-25, 22:47)mark_dj Wrote: It's set to expert, but I can't change the size there, only the position?

Make sure you're testing with Estuary. What are you seeing if it's not the same as below?

Image
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
New LibreELEC.tv Krypton build #0825: RPi / RPi2
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 4.7.2 #1 Thu Aug 25 22:13:49 BST 2016 armv6l GNU/Linux

# vcgencmd version
Aug 23 2016 15:58:54
Copyright (c) 2012 Broadcom
version f23e65aeeffca65654550c93254a0ee55f34fb07 (clean) (release)

# lsb_release
LibreELEC (Milhouse) - Version: devel-20160825234304-#0825-g20e8843 [Build #0825]

# vcdbg log msg 2>&1 | grep DTOK
002386.931: Kernel trailer DTOK property says yes

# Kernel device tree status: Enabled

Based on tip of LibreELEC.tv master (20e8843a, changelog) and tip of XBMC master (23efa213, changelog) with the following modifications: Build Highlights:
  1. AESinkPULSE: Try to resolve channel layout
  2. Deinterlace fixes
Build Details:
  1. LibreELEC.tv:
    • xf86-video-nvidia: update to 367.44 (PR:655, 1 commit, 3 files changed)
    • mono: update to 4.2.1.102 (PR:627, 4 commits, 7 files changed)
    • repository.kodinerds: initial package (PR:500, 1 commit, 4 files changed)
    • Odroid_C2: CEC/IR wake-up and boot-logo.bmp.gz support (PR:637, 8 commits, 15 files changed)
    • packages/linux-drivers/brcmap6xxx-aml: enable 40MHz channels for 2.4G (PR:656, 1 commit, 1 file changed)
    • tvheadend42: add debugging fix (PR:652, 1 commit, 4 files changed)
    • linux: update to linux-4.7.2 (PR:653, 4 commits, 30 files changed)
  2. XBMC:
    • [PVR] Recordings window: Respect setting SETTING_MYVIDEOS_SELECTACTIO… (PR:10333, 1 commit, 1 file changed)
    • [skin.estuary] Fix broken addon message (PR:10340, 1 commit, 1 file changed)
    • AESinkPULSE: Try to resolve channel layout - fallback if not possible fixes #16862 (PR:10341, 1 commit, 1 file changed)
  3. newclock5:
    • New commits in this build:
      • VideoPlayer: fix and cleanup deinterlacing methods (fde06063)
      • RBP: Add Pi specific deinterlace support reporting (e2871311)
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
In 0825, recording folders don't seem to work under liveTV or at least not using the mythtv plugin. There is also a popup when first starting kodi that says a kodi game add-on repository is not compatible and needs to be disabled. Reverting to 0824 fixes the issue with recordings in liveTV but the repository popup still happens.
(2016-08-25, 13:40)BigNoid Wrote: I have a gap between #804 and #823, so don't know when exactly it started. Will try builds between those numbers, but as it takes an hour and half for it to crash, it might take some time Big Grin
Can also try a debug build if that would be helpful.
Already disabled everything UPnP but that didn't help.

Sorry for the delay. If you have the time please test with debug-enabled build #0825x: RPi2
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2016-08-26, 02:24)zaphod24 Wrote: In 0825, recording folders don't seem to work under liveTV or at least not using the mythtv plugin. There is also a popup when first starting kodi that says a kodi game add-on repository is not compatible and needs to be disabled. Reverting to 0824 fixes the issue with recordings in liveTV but the repository popup still happens.

Popup is due to PR10335 and the Kodi game addon is noted in the changelog. It is rather annoying that it pops up every time you start Kodi, hopefully that will change.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2016-08-26, 02:46)Milhouse Wrote:
(2016-08-26, 02:24)zaphod24 Wrote: In 0825, recording folders don't seem to work under liveTV or at least not using the mythtv plugin. There is also a popup when first starting kodi that says a kodi game add-on repository is not compatible and needs to be disabled. Reverting to 0824 fixes the issue with recordings in liveTV but the repository popup still happens.

Popup is due to PR10335 and the Kodi game addon is noted in the changelog. It is rather annoying that it pops up every time you start Kodi, hopefully that will change.

Thanks Milhouse, appreciate these builds! The popup is no big deal, just figured I'd mention it. I didn't relate PR10335 and that, oops!

The recordings folder under TV not working is definitely a show-stopper for my family, but hopefully it gets sorted out quickly as it has happened before. For now 0824 works great.
(2016-08-26, 03:14)zaphod24 Wrote: The recordings folder under TV not working is definitely a show-stopper for my family, but hopefully it gets sorted out quickly as it has happened before. For now 0824 works great.

Hm, I have no issue with recording folder under TV on build #0825, both timeshift as well as recording everything in order. Attached is a SSD hard disc on USB.
[1x RPi3]#[ AV Receiver - Marantz NR1506 ]#[ TV Panasonic TX-50EXW784 ]#[ NAS @ OMV 4.1.xx (Arrakis) on Banana Pi ]#[ ODROID C2 + wrxtasy's LE 8.0 ]
  •   
  • 1
  • 123
  • 124
  • 125(current)
  • 126
  • 127
  • 218
  •   
  Thread Closed
 
Thread Rating:
  • 19 Vote(s) - 4.63 Average



Logout Mark Read Team Forum Stats Members Help
LibreELEC Testbuilds for RaspberryPi (Kodi 17.0)4.6319