•   
  • 1
  • 137
  • 138
  • 139(current)
  • 140
  • 141
  • 218
  •   
  Thread Closed
v17 LibreELEC Testbuilds for RaspberryPi (Kodi 17.0)
(2016-09-07, 22:25)meccs Wrote: Local files playback stops seemingly randomly (~30 minutes maybe) with MMAL. OMX works without problems (as usual).

Noticed a different behavior with MMAL on my P3 since several builds. All my local (played from USB disk) files, .avi .mp4. or .mkv will frieeze video after about 30min for 3-5sec. Audio and subtitles keep on playing, and video resumes after that brief freeze.
Use OMX which works OK.
i have only one problem playing tvheadend recorded files.
tvh server is capable pc, and wetek, computer, tablet doesent have any problem playing this files.

on raspi 3, starts to buffer every 5s.
live tv on rasp13 works perfect, playing tvshows and movies from remote location has no problem either.

does any one know how to fix this?
(2016-09-07, 22:47)JMRR Wrote: i have only one problem playing tvheadend recorded files.
tvh server is capable pc, and wetek, computer, tablet doesent have any problem playing this files.

on raspi 3, starts to buffer every 5s.
live tv on rasp13 works perfect, playing tvshows and movies from remote location has no problem either.

does any one know how to fix this?

Enable debug logging, play a file that demonstrates the issue, then upload your debug log (wiki) (also see note #9 in the first post).
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
New LibreELEC.tv Krypton build #0907: RPi / RPi2
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 4.7.3 #1 Wed Sep 7 22:14:49 BST 2016 armv6l GNU/Linux

# vcgencmd version
Sep  7 2016 14:50:28
Copyright (c) 2012 Broadcom
version 1f1070f16206004c8f2172144ec8f167db6c742f (clean) (release)

# lsb_release
LibreELEC (Milhouse) - Version: devel-20160907221345-#0907-gd659163 [Build #0907]

# vcdbg log msg 2>&1 | grep DTOK
002390.942: Kernel trailer DTOK property says yes

# Kernel device tree status: Enabled

Based on tip of LibreELEC.tv master (d6591638, changelog) and tip of XBMC master (7178adef, changelog) with the following modifications: Build Highlights:
  1. New firmware
  2. New 4.7.3 kernel
Build Details:
  1. Firmware (Sep 7):
    • firmware: MMAL: Support MMAL_ENCODING_xxx_SLICE formats
  2. LibreELEC.tv:
    • Update ddbridge drivers in kernel 4.7.2 (PR:703, 1 commit, 3 files changed)
  3. XBMC:
    • fix skin variable parsing: dont skip if element text is empty (PR:10395, 1 commit, 1 file changed)
    • peripheral: Add backward compatability for older settings files (PR:10393, 1 commit, 1 file changed)
    • [cmake] Fix globbing of single files on export (PR:10416, 1 commit, 1 file changed)
    • Addon alt path (PR:10419, 2 commits, 2 files changed)
    • [cmake] linux: install cmake files in arch independent dir (PR:10421, 1 commit, 2 files changed)
    • [Estuary] fix texture paths (PR:10415, 2 commits, 2 files changed)
  4. inputstream.rtmp:
    • changed: do not trust pkg-config values for librtmp (91bb3741)
  5. newclock5:
    • New commits in this build:
      • AE: make sure not to feed data into tempfilter after it got drained (d132b14e)
  6. kernel 4.7.y:
    • New commits in this build:
      • fbmem: Ensure that parameters are properly checked within fb_copyarea_user (a9d3875e)
    • Commits no longer in build:
      • Revert "ASoC: bcm2835: Add S16_LE support via packed DMA transfers" (b3b48155)
      • Revert "ASoC: bcm2835: setup clock only if CPU is clock master" (d4481e2f)
      • Revert "ASoC: bcm2835: add 24bit support" (d4c84d95)
      • Revert "ASoC: bcm2835: move to use the clock framework" (f66b42fa)
      • bcm2835-i2s: get base address for DMA from devicetree (658794c4)
      • bcm2835-i2s: add 24bit support, update bclk_ratio to more correct values (01506b75)
      • bcm2835-i2s: setup clock only if CPU is clock master (fb8d849c)
      • bcm2835-i2s: Eliminate debugfs directory error (6019d044)
      • bcm2835-i2s: Register PCM device (b99821f1)
      • bcm2835-i2s: Enable MMAP support via a DT property (224a4657)
      • bcm2835-i2s: Reduce the TX DREQ threshold (846ee110)
      • Revert "bcm2835-i2s: Reduce the TX DREQ threshold" (2341c375)
      • Revert "bcm2835-i2s: Enable MMAP support via a DT property" (f7eabb06)
      • Revert "bcm2835-i2s: Register PCM device" (3f5e417e)
      • Revert "bcm2835-i2s: Eliminate debugfs directory error" (a23e7bf0)
      • Revert "bcm2835-i2s: setup clock only if CPU is clock master" (c434816e)
      • Revert "bcm2835-i2s: add 24bit support, update bclk_ratio to more correct values" (0abba718)
      • Revert "bcm2835-i2s: get base address for DMA from devicetree" (b79165fd)
      • Revert "Revert "ASoC: bcm2835: move to use the clock framework"" (bc5f27ca)
      • Revert "Revert "ASoC: bcm2835: add 24bit support"" (02771a57)
      • Revert "Revert "ASoC: bcm2835: setup clock only if CPU is clock master"" (d53e90d6)
      • Revert "Revert "ASoC: bcm2835: Add S16_LE support via packed DMA transfers"" (70646209)
      • Revert "bcm2835-i2s: Enable MMAP support via a DT property" (edb6f75a)
      • Merge pull request #1629 from msperl/rpi-4.7.y-clock-only (8242a68a)
  7. Additional commits/pull requests/changes not yet merged upstream:
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
0907 crashed almost immediately after I installed it. After I rebooted via ssh there was only a black screen and ssh didn't work. Then rebooted by shorting the reset pins and it works ok so far.

http://sprunge.us/fYJF
(2016-09-08, 00:49)smp1 Wrote: 0907 crashed almost immediately after I installed it. After I rebooted via ssh there was only a black screen and ssh didn't work. Then rebooted by shorting the reset pins and it works ok so far.

http://sprunge.us/fYJF

The same often with different builds. It's not bad wen subsequently runs. Therefore, I have built-in a reset button ;-)
[1x RPi3]#[ AV Receiver - Marantz NR1506 ]#[ TV Panasonic TX-50EXW784 ]#[ NAS @ OMV 4.1.xx (Arrakis) on NanoPI M4 ]#[ Nextcloud 16.0.4 @ ODROID C2 ]
Yes, there's some sort of recursive add-on crash in recent (possibly just the latest) builds. It's been seen in other builds too, such as OSX. Not sure what is causing it, whether it's just at startup or when add-ons are updated.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2016-09-08, 14:26)Milhouse Wrote: Yes, there's some sort of recursive add-on crash in recent (possibly just the latest) builds. It's been seen in other builds too, such as OSX. Not sure what is causing it, whether it's just at startup or when add-ons are updated.

I'll add a "me too". Mine occurred overnight and looks like it happened while checking for add-on updates...
(2016-09-07, 22:41)Sholander Wrote:
(2016-09-07, 22:25)meccs Wrote: Local files playback stops seemingly randomly (~30 minutes maybe) with MMAL. OMX works without problems (as usual).

Noticed a different behavior with MMAL on my P3 since several builds. All my local (played from USB disk) files, .avi .mp4. or .mkv will frieeze video after about 30min for 3-5sec. Audio and subtitles keep on playing, and video resumes after that brief freeze.
Use OMX which works OK.

Thanks. Good to know it's not just me.
(2016-09-07, 12:44)popcornmix Wrote: Does adding "over_voltage=1" (or 2) fix the issue?
Added some voltage to cpu and sdram. No issues so far.
New LibreELEC.tv Krypton build #0908: RPi / RPi2
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 4.7.3 #1 Fri Sep 9 04:16:04 BST 2016 armv6l GNU/Linux

# vcgencmd version
Sep  7 2016 14:50:28
Copyright (c) 2012 Broadcom
version 1f1070f16206004c8f2172144ec8f167db6c742f (clean) (release)

# lsb_release
LibreELEC (Milhouse) - Version: devel-20160909041503-#0908-g3c47494 [Build #0908]

# vcdbg log msg 2>&1 | grep DTOK
002392.321: Kernel trailer DTOK property says yes

# Kernel device tree status: Enabled

Based on tip of LibreELEC.tv master (3c474944, changelog) and tip of XBMC master (138de509, changelog) with the following modifications: Build Highlights:
  1. More cmake fixes
  2. Revert "AE: change usage of swr_set_compensation" - fixes http://trac.kodi.tv/ticket/16887
Build Details:
  1. LibreELEC.tv:
    • packages/linux: Correctly copy Amlogic device tree binary (PR:697, 1 commit, 1 file changed)
    • system-tools: mrxvt: set terminal type to "xterm" (PR:707, 1 commit, 2 files changed)
    • system-tools: fix hddtemp (PR:706, 1 commit, 1 file changed)
    • linux: update to linux-4.7.3 (PR:710, 4 commits, 32 files changed)
    • Rsyslog: add first run wizard configuration menu (PR:712, 1 commit, 4 files changed)
    • aarch64: define CPU extensions project-wise (PR:705, 1 commit, 3 files changed)
    • system-tools: optional start mrxvt from kodi (#708) (3c474944)
  2. XBMC:
    • [cmake] Respect ENABLE_UPNP option (PR:10427, 2 commits, 5 files changed)
    • [cmake] xslt is optional (PR:10423, 1 commit, 1 file changed)
    • [autotools] Add missing APP_DATA_DIR in configure.ac (PR:10426, 1 commit, 1 file changed)
    • Added: option to pass cookies to ffmpeg connection (PR:10430, 1 commit, 1 file changed)
    • AE: make sure not to feed data into tempfilter after it got drained (PR:10425, 2 commits, 2 files changed)
    • remove window type, id and zorder defenitions (PR:10428, 1 commit, 8 files changed)
    • Revert "AE: change usage of swr_set_compensation" (PR:10435, 1 commit, 2 files changed)
    • [droid] Drop RK specific code and fix cmake AML building (PR:10417, 2 commits, 6 files changed)
    • fixed: remove accidentially added Makefile.in from header list (PR:10434, 1 commit, 1 file changed)
    • [Estuary] spaces to tabs (PR:10439, 1 commit, 3 files changed)
    • Gl: drop finishPipeline (PR:10436, 1 commit, 4 files changed)
    • [cmake] Don't allow undefined symbols in shared libraries (PR:10422, 2 commits, 3 files changed)
    • [estuary] Avoid empty variables (PR:10392, 1 commit, 1 file changed)
    • Add a numeric field type that doesn't need casting (PR:10369, 1 commit, 5 files changed)
  3. inputstream.mpd:
  4. newclock5:
    • Commits no longer in build:
      • AE: make sure not to feed data into tempfilter after it got drained (d132b14e)
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Hi,

just a question, how do you activate automatically subtitles ?
Every time I launch a video file, I have to click "activate" in order subtitles display.
I would like them to appear automatically.

Thank you for your answer.
Popcornmix i have a small issue on livetv.. If is use MMAL and there is a temporary glich (e.g .low signal) video/audio freezes but then resumes normally, but if i use OMX, on resuming audio and video are out of sync.. This has been the case for months so it is not a recent commit..what type of log can help you look in to it?
(2016-09-02, 20:40)polo_joe Wrote: I get dropouts when playing local audio file from sd card and then opening tv guide or addon browser.
http://sprunge.us/GdLQ
Anything I can do to prevent this behaviour?

anyone else having this issue?
(2016-09-09, 09:48)gendo Wrote: Popcornmix i have a small issue on livetv.. If is use MMAL and there is a temporary glich (e.g .low signal) video/audio freezes but then resumes normally, but if i use OMX, on resuming audio and video are out of sync.. This has been the case for months so it is not a recent commit..what type of log can help you look in to it?

This is a long standing issue with omxplayer and some live tv add-ons. I really need to be able to reproduce this, but so far no one has been able to provoke this from a recording - which doesn't make a lot of sense - omxplayer has no idea about the source of the video. It suggests the live tv backend does something different with timestamps in the live vs recorded cases.

Ideally find a recording that demonstrates the problem. If not then using mmal or improving TV signal strength is the best option.
  •   
  • 1
  • 137
  • 138
  • 139(current)
  • 140
  • 141
  • 218
  •   
  Thread Closed
 
Thread Rating:
  • 19 Vote(s) - 4.63 Average



Logout Mark Read Team Forum Stats Members Help
LibreELEC Testbuilds for RaspberryPi (Kodi 17.0)4.6319