20 Nov 2019 - TVDB Scraper v3.2.0 is now available which reinstates scraping. TVDB are still in the process of fixing a number of bugs so there may still be further breakages. See this post. 2901570 (post)

  •   
  • 1
  • 154
  • 155
  • 156(current)
  • 157
  • 158
  • 218
  •   
  Thread Closed
v17 LibreELEC Testbuilds for RaspberryPi (Kodi 17.0)
(2016-09-24, 08:18)Milhouse Wrote: @BigNoid, @smp1: Can you test #0923 with your game controllers, and confirm there are no crashes when a controller is connected? Also worth trying "kill -SIGSEGV $(pidof kodi.bin)" and uploading the crashlog to check that it is now sane.

running for 2+ hrs now so safe to assume that it won't crash with #923 as it would crash at every 1.5 hrs.
Hi,

Xbox 360 pad working fine, connected over night without crash.
Bring on the emulators. Big Grin
I noticed a weird issue when playing a high bitrate h264 24p blu ray videos. Sometimes I get some frame skips for no apparent reason. The frame skips are not very noticeable, 3-4 frame skips per minute.
And I have no idea how to reproduce this - it seems totally random. If I stop the video (stop button) and play again the skips are gone. The only thing I noticed is that this issue occured when I switched from Live TV to blu ray video but I'm not 100% sure that this is the cause.
(2016-09-24, 20:20)smp1 Wrote: I noticed a weird issue when playing a high bitrate h264 24p blu ray videos. Sometimes I get some frame skips for no apparent reason. The frame skips are not very noticeable, 3-4 frame skips per minute.
And I have no idea how to reproduce this - it seems totally random. If I stop the video (stop button) and play again the skips are gone. The only thing I noticed is that this issue occured when I switched from Live TV to blu ray video but I'm not 100% sure that this is the cause.

Do you see the skips reported as drop/skip on debugging overlay?
Is "sync playback to display" enabled? Any different with it flipped?

Anything appear in log at the same time as you see skips (perhaps PVR or other add-on is doing some work?)
(2016-09-24, 20:26)popcornmix Wrote: Do you see the skips reported as drop/skip on debugging overlay?
Yes.
Quote:Is "sync playback to display" enabled? Any different with it flipped?
Disabled, didn't try to enable it yet.
Quote:Anything appear in log at the same time as you see skips (perhaps PVR or other add-on is doing some work?)
Nope, nothing. I only use Tvheadend and Oscam.
(2016-09-24, 09:44)MikeKL Wrote:
(2016-09-24, 08:18)Milhouse Wrote: @MikeKL can you confirm if #0923 solves the PVR crashing issue?

@Milhouse, No PVR Crash after instal + boot of #0923

Kodi debug log

Thanks. As it happens the proposed fix (PR10544) needs more work, so the original PR10507 that introduced the problem been reverted (will be in tonight's build).

(2016-09-24, 09:44)MikeKL Wrote: Presume should continue to remove TV29.db at Pi Reboots and switch on debug before Installation of future nightly builds etc?

You shouldn't really need to remove TV29.db every time. It might be an idea to enable debug logging for tonight's upgrade, up to you if you want to delete TV29.db. I think you should stop deleting after tonight's upgrade, and if you continue to experience crashes or corrupt TV29 databases then that is something we need to look into.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2016-09-24, 10:43)BigNoid Wrote: running for 2+ hrs now so safe to assume that it won't crash with #923 as it would crash at every 1.5 hrs.

(2016-09-24, 11:21)bmonster Wrote: Hi,

Xbox 360 pad working fine, connected over night without crash.
Bring on the emulators. Big Grin

Cheers both.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
New LibreELEC.tv Krypton build #0924: RPi / RPi2
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 4.7.5 #1 Sat Sep 24 21:05:17 BST 2016 armv6l GNU/Linux

# vcgencmd version
Sep 21 2016 13:17:10
Copyright (c) 2012 Broadcom
version 2eaf52cc53435b5ce67253af1487f9a4f9f96e2d (clean) (release)

# lsb_release
LibreELEC (Milhouse) - Version: devel-20160924210416-#0924-g8a3b79d [Build #0924]

# vcdbg log msg 2>&1 | grep DTOK
002388.082: Kernel trailer DTOK property says yes

# Kernel device tree status: Enabled

Based on tip of LibreELEC.tv master (8a3b79d2, changelog) and tip of XBMC master (75547872, changelog) with the following modifications: Build Highlights:
  1. New 4.7.5 kernel
  2. ffmpeg: update to ffmpeg-3.1.3-Krypton-Beta3-2
  3. Revert PVR database fix due to crashing
  4. Partial fix for samba always enabled (still shows enabled in GUI, but services will be stopped - fixed tomorrow PR:30)
Build Details:
  1. XBMC:
    • [droid] disable libcec, libusb (PR:10227, 1 commit, 2 files changed)
    • Revert "[osx/readme] - remove KODI_HOME bits from readme (not needed … (PR:10550, 1 commit, 1 file changed)
    • Revert "Fix potential SQL constraint integrity violation in the PVR database" (PR:10551, 1 commit, 2 files changed)
    • VideoPlayer: fix wav playback on win32 (PR:10552, 1 commit, 1 file changed)
    • Fix some format warnings (PR:10549, 1 commit, 3 files changed)
    • Bump game.controller.default to v1.0.3 (PR:10555, 1 commit, 1 file changed)
    • FFmpeg: Bump to version 3.1.3-Krypton-Beta3-2 (PR:10548, 1 commit, 1 file changed)
    • [mention-bot] Correct typo (e5f5951b)
  2. kernel 4.7.y:
    • New commits in this build:
      • drm/vc4: Enable limited range RGB output with CEA modes. (6835c27a)
  3. Additional commits/pull requests/changes not yet merged upstream:
    • Added: [env] patch: ffmpeg: update to ffmpeg-3.1.3-Krypton-Beta3-2
    • Added: [env] PR:765: linux: update to linux-4.7.5
    • Added: [pkg] PR:10527: increase property and variable ranges for skins
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
problem solved...
(2016-09-25, 10:28)pstruh Wrote: Hi,
I have a problem with loading subtitles from ad-dons where they are already available. Everything works fine till build 0904 after that subtitles are not displayed. When I download them they they work, but not auto-load subtitles if available.

Here is the log from 0905 build. Same issue with all above builds. http://sprunge.us/IagF

If anyone can check or help with that I would much appreciate.

You should uninstall your banned addons, before you'll get any help here. Metal kettle and tknorris are not allowed...

Official:Forum_rules/Banned_add-ons (wiki)
Hi,

thank you guys for the hard work.
The 1080i to 720p PVR Bug is almost fixed in the latest builds.

There is one thing left that i noticed:
When i switch from a 1080i to 720p channel, then during the first aproximately 5-7s the audio is increasingly lagging.
After that i get a short audio dropout (amp loses audio shortly) and then everything is fine.

The same thing seems to happen after a reboot, when the first channel i activate is a 720p channel.

Edit:
Ok never mind.
I did another Update and tryed to get a Debug Log but this issue is now gone.
I will keep an eye on this and report back if it happens again.
New LibreELEC.tv Krypton build #0925: RPi / RPi2
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 4.7.5 #1 Sun Sep 25 21:04:48 BST 2016 armv6l GNU/Linux

# vcgencmd version
Sep 21 2016 13:17:10
Copyright (c) 2012 Broadcom
version 2eaf52cc53435b5ce67253af1487f9a4f9f96e2d (clean) (release)

# lsb_release
LibreELEC (Milhouse) - Version: devel-20160925210348-#0925-gb0a1a38 [Build #0925]

# vcdbg log msg 2>&1 | grep DTOK
002386.588: Kernel trailer DTOK property says yes

# Kernel device tree status: Enabled

Based on tip of LibreELEC.tv master (b0a1a38a, changelog) and tip of XBMC master (d51d4ae9, changelog) with the following modifications: Build Highlights:
  1. PR:10544: [pvr] attempt to fix crashing and general failure in ChannelExists() (@MikeKL please test/confirm)
Build Details:
  1. LibreELEC.tv:
    • peripheral-joystick: bump to abff316 (PR:766, 1 commit, 1 file changed)
  2. XBMC:
    • [cmake/win32] Bump minimum CMake version to 3.6 (PR:10396, 5 commits, 3 files changed)
    • [estuary] check if fanart pack is selected (PR:10556, 1 commit, 6 files changed)
    • settings: provide descriptions for color management settings (PR:10296, 2 commits, 1 file changed)
    • [paplayer] remove no more needed virtual CAEChannelInfo GetChannelInfo() (PR:10559, 1 commit, 3 files changed)
    • [epg] fix mouse focus (PR:10558, 1 commit, 1 file changed)
    • Add possibility to get information from both .nfo and scraper (PR:10259, 1 commit, 5 files changed)
    • [paplayer] fix codec deinit for audio decoder add-on (was never called) (PR:10557, 1 commit, 4 files changed)
    • Some improvements (PR:10522, 5 commits, 5 files changed)
    • Add "userrating" so Player.GetItem can return user rating value for currently playing song (#10561) (d51d4ae9)
  3. pvr.vbox:
    • attempt to fix Travis CI build (PR:134, 1 commit, 1 file changed)
    • update build instructions to account for Kodi built with CMake (dbbf8962)
  4. Additional commits/pull requests/changes not yet merged upstream:
    • Added: [pkg] PR:10543: [platform] - add unique hardware identifier as info label
    • Added: [pkg] PR:10544: [pvr] attempt to fix crashing and general failure in ChannelExists()
    • Added: [pkg] PR:10560: splash text improvements
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2016-09-25, 22:29)Milhouse Wrote: PR:10544: [pvr] attempt to fix crashing and general failure in ChannelExists() (@MikeKL please test/confirm)
@Milhouse Unfortunately, two kodi debug crashes on boot after #0925 install, before a successful start of kodi.

Kodi debug crash log 1
Kodi debug crash log 2
rPi3B+, SanDisk Ultra 8Gb SD, Milhouse kernel_5.x LE ​Testbuild (Kodi 19 Matrix) -> Onkyo TX-SR608 AV Receiver -> Philips 42" LCD TV
KVIM2 Pro, SanDisk Ultra 8Gb SD, kernel_5.x LE Testbuild (Kodi 19 Matrix) -> LG 27UD69-W 4K Monitor -> AudioEngine A2+ Speakers
0925 booted ok after install and crashed on a second reboot (before kodi started). Seems to be ok after that.
#0925 - No crashes, no RPi2 still RPi3 just after the first reboot no PVR was there to second rebot everything ok on RPi2.

Edit:

#0925 is not as good as # 0924, and arrive to picture disturbances in PVR
[1x RPi3]#[ AV Receiver - Marantz NR1506 ]#[ TV Panasonic TX-50EXW784 ]#[ NAS @ OMV 4.1.xx (Arrakis) on NanoPI M4 ]#[ Nextcloud 16.0.4 @ ODROID C2 ]
  •   
  • 1
  • 154
  • 155
  • 156(current)
  • 157
  • 158
  • 218
  •   
  Thread Closed
 
Thread Rating:
  • 19 Vote(s) - 4.63 Average



Logout Mark Read Team Forum Stats Members Help
LibreELEC Testbuilds for RaspberryPi (Kodi 17.0)4.6319