•   
  • 1
  • 169
  • 170
  • 171(current)
  • 172
  • 173
  • 218
  •   
  Thread Closed
v17 LibreELEC Testbuilds for RaspberryPi (Kodi 17.0)
Still have the run-away audio problem on recording playback, with #1014

I've tried changing audio settings like pll adjustment, passthrough, latency, no difference.
I've tried changing video settings like adjust display refresh, sync playback to display with no difference.

RPi2 with HDMI out. I don't see the problem when I go back to #0531 so it has to be some kind of software or settings issue.

Are there any AV Params that are controlled by a conf file, rather than the gui?
(2016-10-16, 02:13)mikeb8591 Wrote: Still have the run-away audio problem on recording playback, with #1014

I've tried changing audio settings like pll adjustment, passthrough, latency, no difference.
I've tried changing video settings like adjust display refresh, sync playback to display with no difference.

RPi2 with HDMI out. I don't see the problem when I go back to #0531 so it has to be some kind of software or settings issue.

Are there any AV Params that are controlled by a conf file, rather than the gui?

All 3 players have the a/v sync problem for me [audio gets progressively further ahead of video]

OMX player was good up til #0607 #0608 has the a/v sync issue.
MMAL player has bad video up til an end of august build I tried, and then has the a/v sync issue (and video isn't perfect either)
the software player had good a/v sync until the #0714 build, #0715 has the a/v sync issue.

Hopefully this will help someone figure out what's going on. I still have no idea why I'm the only one reporting this.
New LibreELEC.tv Krypton build #1015: RPi / RPi2
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 4.8.1 #1 Sun Oct 16 02:40:18 BST 2016 armv6l GNU/Linux

# vcgencmd version
Oct 13 2016 17:21:14
Copyright (c) 2012 Broadcom
version b301dbab300729c7871442ca50f65c669446af20 (clean) (release)

# lsb_release
LibreELEC (Milhouse) - Version: devel-20161016023917-#1015-ged2f577 [Build #1015]

Based on tip of LibreELEC.tv master (ed2f5777, changelog) and tip of XBMC master (63b8843a, changelog) with the following modifications: Build Highlights:
  1. Controller fixes
  2. Aspect ratio fix
  3. SQLite 3.15.0 - micro-optimizations reduce CPU usage by more than 7% on common workloads
  4. Drop lcdproc - service.lcdd add-on available (addons)
Build Details:
  1. LibreELEC.tv:
    • hardkernel reference no longer need (PR:839, 1 commit, 1 file changed)
  2. XBMC:
    • VideoPlayer: fix seek beyond eof for mp4 (PR:10705, 2 commits, 1 file changed)
    • Fix controller input on the Shield if peripheral.joystick is not present (PR:10695, 1 commit, 4 files changed)
    • Fix restart needed to enable/disable peripheral add-ons (PR:10690, 2 commits, 5 files changed)
    • Fix missing lock in CAddonButtonMap (PR:10691, 1 commit, 2 files changed)
    • [android] don't strip binaries in debug builds (PR:10683, 2 commits, 3 files changed)
    • [CryptThreading] replace hardcoded value for CRYPTO_LOCK by macro (PR:10572, 1 commit, 1 file changed)
    • [webinterface.default] tvshows: default to poster view and use sorttitle (PR:9853, 2 commits, 1 file changed)
    • [droid] force UTF8 locale (PR:10636, 1 commit, 1 file changed)
    • disable filedirectories in addonbrowser (PR:8965, 1 commit, 3 files changed)
    • VideoPlayer: drop dead code (PR:10706, 1 commit, 2 files changed)
    • SeekHandler: fix state InProgress (PR:10707, 2 commits, 6 files changed)
    • [cmake] Fix build_addon() macro (PR:10703, 1 commit, 1 file changed)
    • Changed WinEventsSDL.cpp to better support Mac Native Full Screen (PR:10681, 1 commit, 1 file changed)
    • [infomanager] add player.dbid infolabel (PR:10567, 1 commit, 2 files changed)
    • app: move first access of CPlaylistPlayer after init (PR:10709, 2 commits, 16 files changed)
    • [gitignore] add addon packages, __.SYMDEF* and certificates (PR:10566, 1 commit, 1 file changed)
  3. pvr.mythtv:
    • 4.7.3 (PR:73, 2 commits, 3 files changed)
  4. newclock5:
    • New commits in this build:
      • VideoPlayer: ffmpeg - use codec aspect ratio for stereo modes (5a98e838)
  5. kernel 4.8.y:
    • New commits in this build:
      • ARM64: Modify default config to get raspbian to boot (#1686) (214ccb22)
  6. Additional commits/pull requests/changes not yet merged upstream:
    • Added: [env] patch: sqlite: update to sqlite-3.15.0
    • Added: [env] PR:837: lcdd: initial addon
    • Added: [env] PR:838: llvm: build llvm-tblgen for host and use it for target
    • Added: [pkg] PR:33: bye bye lcdproc (service.libreelec.settings)
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
@Milhouse, Can you build transmission for RPI2/RPI3. I can´t find it in http://milhouse.libreelec.tv/builds
I see inside: http://milhouse.openelec.tv/builds/addons/RPi2/

Thanks!
popcornmix,
Hi

A small question about interlace. Here are some test videos http://www.avsforum.com/forum/26-home-th...icker.html
One (cheese slice) encoded by different codecs looks differently on RPi. Specifically h264 has ladders and double lines in motion. Mpeg2 and vc1 also not top quality, but look much better. So why? Smile
Direct links
mpeg2 http://redirect.viglink.com/?format=go&j...0(42%20MB)
vc1 http://redirect.viglink.com/?format=go&j...S%20(26MB)
h264 http://redirect.viglink.com/?format=go&j...0(36%20MB)
Thanks
Hi.I have a problem with builds #1011 #1012 #1013.When connecting my af9015 dvb-t usb tuner
in rpi3 wired network stops working,wireless is ok.With build #1010 and back usb tuner
and wired network works ok.

dmesg #1010 http://pastebin.com/9cx7vr2X
dmesg #1013 http://pastebin.com/4TnWmiwE
(2016-10-15, 10:06)Milhouse Wrote:
(2016-10-08, 12:04)camelreef Wrote:
(2016-10-08, 00:30)Milhouse Wrote:
  • Reverted: [env] PR:793: projects/*/options: disable lcdproc for all projects except Generic/Virtual (Reverted until add-on available)

Thanks again! My VFD is back!

Nico

I'm going to stop reverting the lcdproc change with tonight's build, as there will be a service.lcdd addon you can install as zip from here: http://milhouse.libreelec.tv/builds/addons

Can you give it a try with tonight's build #1015 and report any issues etc.? Thanks!

It is working fine. Once I found the proper conf file for the settings of my MtxOrb driver.

If I may offer advice... Maybe indicating somewhere in the plugin's interface that choosing the driver may not be enough, and that editing the config file for that particular driver will probably be needed. Indicating the location of the conf file would be a plus.

Other than that, I would give this a go.

Thanks for waiting for this plugin before removing LCDd from the main build!

Nico
(2016-10-16, 11:06)dias0 Wrote: Hi.I have a problem with builds #1011 #1012 #1013.When connecting my af9015 dvb-t usb tuner
in rpi3 wired network stops working,wireless is ok.With build #1010 and back usb tuner
and wired network works ok.

dmesg #1010 http://pastebin.com/9cx7vr2X
dmesg #1013 http://pastebin.com/4TnWmiwE

The second log doesn't include the start of dmesg - can you try capturing again sooner after boot, where hopefully the initial log messages are present?
(2016-10-16, 12:34)popcornmix Wrote: The second log doesn't include the start of dmesg - can you try capturing again sooner after boot, where hopefully the initial log messages are present?
dmesg #1015 with the same problem http://pastebin.com/if6UN7mB

EDIT
lsusb #1015 http://pastebin.com/EiG94KxX
(2016-10-16, 12:53)dias0 Wrote: dmesg #1015 with the same problem http://pastebin.com/if6UN7mB

Can you provide your config.txt and cmdline.txt?
(2016-10-16, 13:09)popcornmix Wrote: Can you provide your config.txt and cmdline.txt?
config.txt
Code:
gpu_mem=320

#force_turbo=0

disable_overscan=1
dtparam=sd_overclock=83
framebuffer_width=1280
framebuffer_height=720
hdmi_ignore_cec_init=0
decode_MPG2=0xe4fcbf65
decode_WVC1=0xceb36774
#hdmi_pixel_encoding=2
#hdmi_pixel_encoding=4
dtoverlay=lirc-rpi
#dtoverlay=pi3-miniuart-bt-overlay
#max_usb_current=1

cmdline.txt
Code:
boot=/dev/mmcblk0p1 disk=/dev/mmcblk0p2 quiet
(2016-10-16, 12:34)popcornmix Wrote: dmesg #1010 http://pastebin.com/9cx7vr2X
dmesg #1013 http://pastebin.com/4TnWmiwE

Can you confirm if it is a firmware or kernel change?
Start with #1010 and update to latest firmware:
https://github.com/raspberrypi/firmware/...f?raw=true
https://github.com/raspberrypi/firmware/...t?raw=true

Rename to start.elf/fixup.dat and replace the versions in /flash (or FAT partition from PC).
(2016-10-16, 08:06)ezar Wrote: @Milhouse, Can you build transmission for RPI2/RPI3. I can´t find it in http://milhouse.libreelec.tv/builds
I see inside: http://milhouse.openelec.tv/builds/addons/RPi2/

Thanks!
Transmission is no longer supported as a Kodi addon in LibreELEC. You can install it as a Docker addon - browse the LibreELEC forum for more details.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2016-10-16, 13:19)popcornmix Wrote: Can you confirm if it is a firmware or kernel change?
Start with #1010 and update to latest firmware:
https://github.com/raspberrypi/firmware/...f?raw=true
https://github.com/raspberrypi/firmware/...t?raw=true

Rename to start.elf/fixup.dat and replace the versions in /flash (or FAT partition from PC).
With your files in #1010 everything seems ok.
In #1015 same problem.
Picture (local files) stops randomly for a few seconds with #1015, audio keeps playing (Passthrough). Not sure when it started. It's pretty hard to find out since I would have to watch a movie with every build. I'll try to investigate.
  •   
  • 1
  • 169
  • 170
  • 171(current)
  • 172
  • 173
  • 218
  •   
  Thread Closed
 
Thread Rating:
  • 19 Vote(s) - 4.63 Average



Logout Mark Read Team Forum Stats Members Help
LibreELEC Testbuilds for RaspberryPi (Kodi 17.0)4.6319