TVDB are updating their site. Their site currently has a number of bugs that have broken the TVDB scraper and any add-on that relies on TVDB data. TVDB are working to rectify the problems.

  •   
  • 1
  • 177
  • 178
  • 179(current)
  • 180
  • 181
  • 218
  •   
  Thread Closed
v17 LibreELEC Testbuilds for RaspberryPi (Kodi 17.0)
(2016-10-24, 16:07)nb2a Wrote: Anyone else having issues with auto updating? I can manually update within fine but no auto updates seem to take place.

I don't think auto-update is working for custom builds.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2016-10-24, 17:49)Milhouse Wrote:
(2016-10-24, 16:07)nb2a Wrote: Anyone else having issues with auto updating? I can manually update within fine but no auto updates seem to take place.
I don't think auto-update is working for custom builds.
Following is an extract from my original post not long after devupdate was added as a LibreELEC settings feature in #0612, with ideas on useful features missing when compared to Leopold dev update add-on.
2357493 (post)
Quote:Things I really liked about Leopold addon and would like to see within minimalist LibreELEC settings build update :-
  • Ability to review complete install history and know sequence of builds (forward and back) I had installed.
  • Ability to know the current install before selecting newer or earlier build to install.
  • Ability to store nightly builds downloaded/Installed locally to speed up switch between builds at later date when issue hunting.
Thanks to team for adding capability to install nightlys via LibreELEC settings Cool
I also recollect that auto-update feature was not working for nightly builds, which in a way makes sense.
rPi3B+, SanDisk Ultra 8Gb SD, Milhouse kernel_5.x LE ​Testbuild (Kodi 19 Matrix) -> Onkyo TX-SR608 AV Receiver -> Philips 42" LCD TV
KVIM2 Pro, SanDisk Ultra 8Gb SD, kernel_5.x LE Testbuild (Kodi 19 Matrix) -> LG 27UD69-W 4K Monitor -> AudioEngine A2+ Speakers
(2016-10-19, 21:31)mezo Wrote: milhouse maybe you can help me with my question. i recently tried to run libreelec completly on usb, which the rpi3 allows. but after booting from usb i only have 120mb ram aviable... after switching back to sd card i get 753mb. i have no clue why this happen.
You'll be glad to hear that starting with tonight's build #1024 we'll be using the RPi firmware from branch=next now that it has been updated with all the recent branch=master updates. Please report if you have any memory or USB/Network booting issues with build #1024.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2016-10-24, 19:33)MikeKL Wrote: I also recollect that auto-update feature was not working for nightly builds, which in a way makes sense.

Would still be nice if it did auto-update for nightly builds, IMHO. After all, we have the auto/manual switch, so leave it up to the user how much risk they're willing to take.

The add-on still needs a little more love and it's on the list of things to be done as and when there's time (or we find the right person to make the changes!)
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
New LibreELEC.tv Krypton build #1024: RPi / RPi2
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 4.8.4 #1 Mon Oct 24 21:03:46 BST 2016 armv6l GNU/Linux

# vcgencmd version
Oct 24 2016 12:24:00
Copyright (c) 2012 Broadcom
version a37bec3ecdb7e664d1d658fb82af7d1945f5e834 (clean) (release)

# lsb_release
LibreELEC (Milhouse) - Version: devel-20161024210245-#1024-g0e328ad [Build #1024]

# Kodi version
Kodi (17.0-BETA4 Git:bd17e63). Platform: Linux ARM 32-bit

Based on tip of LibreELEC.tv master (0e328ad3, changelog) and tip of XBMC master (bd17e63c, changelog) with the following modifications: Build Highlights:
  1. New branch=next firmware. This supports USB and Network booting (documentation)
    popcornmix Wrote:I suspect if there are issues it will be with non-default config.txt options, or (slightly less likely) clocks/plls. Because USB/network is initialised by bootcode.bin in new world (when not booting from sdcard), start.elf may continue with an already initialised usb/network system in some cases. Small chance of something going wrong there (more likely if you are actually using usb/network boot).
    Known issue when network booting: Inability to reboot
  2. Updated p8-platform package
  3. Updated Database migration text - animated, and only visible when migration necessary
Build Details:
  1. Firmware (Oct 24):
    • userland: add missing libelftoolchain.so
    • next: Update to lastest master kernel and firmware
    • bootcode: Support tftp server outside local network
    • firmware: Fix fseek (for file size determination)
    • firmware: Update to latest master
    • bootcode.bin: Fix problem with overrunning filename buffer
    • firmware: Update to latest master
    • bootcode: Fix start_x.elf running See: link
    • bootcode: Adds support for Pi 3 LEDs that get controlled through a gpio expander
    • firmware/kernel: Update to latest master branch
    • firmware: Fix some broken MSD devices
    • firmware: Correctly fill allocation size for REQUEST_SENSE command
    • firmware: Make sure we retry the TEST_UNIT_READY command after the. REQUEST_SENSE command
    • firmware: Latest firmware release with additional boot modes from gordon
    • arm_loader: Add SET_SDHOST_CLOCK mailbox property
    • firmware: Rebuild with missing uart and vchiq logging commits
    • firmware: arm_loader: Use the correct UART on non-DT systems. See: link
    • Etc.
  2. LibreELEC.tv:
    • docker: update to 1.12.2 (PR:860, 3 commits, 4 files changed)
    • linux: add support for ZOTAC IR reciver (PR:874, 1 commit, 1 file changed)
  3. XBMC:
    • fix memleaks (PR:10758, 2 commits, 3 files changed)
    • [xbmc][win]Build addons with debug info on Windows (PR:10760, 1 commit, 3 files changed)
    • Simplify .codecocs config (PR:10762, 1 commit, 1 file changed)
    • FIXUP: [amcs] background video (PR:10764, 1 commit, 1 file changed)
    • [win32] .url extension is not allowed to be registered for UWP apps (9c3f2fbf)
  4. p8-platform:
    • Use standard SO versioning (PR:25, 1 commit, 1 file changed)
    • Install pkg-config and .cmake files in arch-specific libdirs (PR:26, 1 commit, 1 file changed)
    • added: support files for building on Windows (c27d06e9)
    • fixed: wrong timeout set in SocketRead() for posix. closes #27. thanks @SeppSTA (65cd6034)
    • removed: generated changelog (4a52594d)
    • bump to 2.1.0 (d7bceb64)
    • added: windows build files (missing from previous commit) (6535e48d)
  5. Additional commits/pull requests/changes not yet merged upstream:
    • Added: [pkg] PR:10731: Change splash db upgrade logic
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2016-10-21, 23:51)MikeKL Wrote:
(2016-10-14, 07:33)MikeKL Wrote: kodi crash after 1st boot of #1013 Kodi crash debug log
.
.
.
kodi always appears to crash at point when performing 1st PVR channel & epg re-fresh.
(Estuary top right hand corner of GUI revolving timer pauses/stops in mid refresh then crash)
kodi crash after 1st boot of #1021 Kodi crash debug log
kodi crash after 1st boot of #1024, Kodi crash debug log
rPi3B+, SanDisk Ultra 8Gb SD, Milhouse kernel_5.x LE ​Testbuild (Kodi 19 Matrix) -> Onkyo TX-SR608 AV Receiver -> Philips 42" LCD TV
KVIM2 Pro, SanDisk Ultra 8Gb SD, kernel_5.x LE Testbuild (Kodi 19 Matrix) -> LG 27UD69-W 4K Monitor -> AudioEngine A2+ Speakers
Has anybody else noticed that Samba wont connect to windows shares, it won't take the password that used to work. Windows can access libreelec shares.

I just noticed this on 1022.

I reverted to 1018 and samba is working.

In 1022 it is asking for username and password, it won't accept that the name and password are good.
In 1018 it does not ask for username and password; IIRC it did once and I chose remember for this share, I'm not sure of that.
Are you using IP address or hostname for your Samba share?
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
I'm using navigate/browse, I guess that would be hostname.
it gets to workgroup> computer list, then all of the computers want a name and password, including libreelec (itself). I did not try logging into libreelec though, but it did suddenly ask.

I don't have any shares mounted, I was just browsing to a downloaded zip file.
But, I also tried file manager, doesn't work there either IIRC, the hostnames did not show that way.
I went to 1024 samba works there.

I did not change any settings just used the built-in upgrade.
I think with build #1024 CEC issue has returned. If tv longer time out, CEC loses connection after power on. The connection is still about a second and then suddenly gone.
[1x RPi3]#[ AV Receiver - Marantz NR1506 ]#[ TV Panasonic TX-50EXW784 ]#[ NAS @ OMV 4.1.xx (Arrakis) on NanoPI M4 ]#[ Nextcloud 16.0.4 @ ODROID C2 ]
(2016-10-25, 09:49)Aux_ Wrote: I think with build #1024 CEC issue has returned. If tv longer time out, CEC loses connection after power on. The connection is still about a second and then suddenly gone.

Can you confirm the exact build you believe the problem started with?
i.e. does reverting to #1023 resolve the issue?
(2016-10-25, 00:55)donbrew Wrote: Has anybody else noticed that Samba wont connect to windows shares, it won't take the password that used to work. Windows can access libreelec shares.

I just noticed this on 1022.

I reverted to 1018 and samba is working.

In 1022 it is asking for username and password, it won't accept that the name and password are good.
In 1018 it does not ask for username and password; IIRC it did once and I chose remember for this share, I'm not sure of that.

The problem seems to be in the "remember" part. 1018 remembers that I had done it but 1022 didn't. 1024 remembers from when I logged in from 1018, so it is asking for login to machines that have not been logged into before.
(2016-10-25, 14:33)donbrew Wrote: The problem seems to be in the "remember" part. 1018 remembers that I had done it but 1022 didn't. 1024 remembers from when I logged in from 1018, so it is asking for login to machines that have not been logged into before.

Can you try rebooting all of your Windows machines? There is no password for the LibreELEC Samba server, you access it as the Guest user.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2016-10-25, 13:42)popcornmix Wrote:
(2016-10-25, 09:49)Aux_ Wrote: I think with build #1024 CEC issue has returned. If tv longer time out, CEC loses connection after power on. The connection is still about a second and then suddenly gone.

Can you confirm the exact build you believe the problem started with?
i.e. does reverting to #1023 resolve the issue?

I will test it with build #1023 over the night, but I'm almost sure the problem has returned with build #1024.
[1x RPi3]#[ AV Receiver - Marantz NR1506 ]#[ TV Panasonic TX-50EXW784 ]#[ NAS @ OMV 4.1.xx (Arrakis) on NanoPI M4 ]#[ Nextcloud 16.0.4 @ ODROID C2 ]
  •   
  • 1
  • 177
  • 178
  • 179(current)
  • 180
  • 181
  • 218
  •   
  Thread Closed
 
Thread Rating:
  • 19 Vote(s) - 4.63 Average



Logout Mark Read Team Forum Stats Members Help
LibreELEC Testbuilds for RaspberryPi (Kodi 17.0)4.6319