•   
  • 1
  • 181
  • 182
  • 183(current)
  • 184
  • 185
  • 218
  •   
  Thread Closed
v17 LibreELEC Testbuilds for RaspberryPi (Kodi 17.0)
(2016-10-28, 17:04)bill_orange Wrote: I have not done debug logging in a while. Does this contain what you are looking for?

That's correct. Can you provide steps to reproduce?
Sure. To find Bloomberg TV you would probably have to install one of the guides in IPTV setup. I am not sure which guide I loaded but here is one that shows Bloomberg in the index. http://pastebin.com/raw/fiMEf4Ab

In IPTV, select Bloomberg. When you try to play it, the 0% buffering starts. You will find that except for Bloomberg most of the streams do not work for reasons unrelated to KODI. I would like to get BBC but apparently you have to have an IP within GB to get it.
(2016-10-28, 18:18)bill_orange Wrote: In IPTV, select Bloomberg. When you try to play it, the 0% buffering starts. You will find that except for Bloomberg most of the streams do not work for reasons unrelated to KODI. I would like to get BBC but apparently you have to have an IP within GB to get it.

Okay, I can reproduce issue.
(2016-10-28, 16:36)bill_orange Wrote: I watch Bloomberg TV using IPTV Simple client. It is the only feed I use. It works fine on build #1024 but is broken on all subsequent builds. All I get is 0% buffering.

As a workaround, set "System/Internet Access/Internet connection bandwidth limitation" to 2048kbps and then try playing stream.
Yes, that does allow Bloomberg to play. That is certainly a workaround I would have never thought to test!. I do notice, however, that Bloomberg takes about 4 seconds to load initially. In build #1024 its start is near instantaneous.

Bill
(2016-10-28, 13:26)popcornmix Wrote: I notice you have a Pi2. One difference between Pi2 and Pi3 on GPU side is Pi3 defaults to "core_freq=400". Can you try adding that to config.txt, reboot, and then try advanced deinterlace again?

Tried it real quick, and the 'advanced' worked fine. No a/v sync issue.

Thanks!
New LibreELEC.tv Krypton build #1028: RPi / RPi2
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 4.8.4 #1 Sat Oct 29 02:45:21 BST 2016 armv6l GNU/Linux

# vcgencmd version
Oct 25 2016 17:02:22
Copyright (c) 2012 Broadcom
version cd1ab218dc23c84d9e6d984385a57f2471600300 (clean) (release)

# lsb_release
LibreELEC (Milhouse) - Version: devel-20161029024419-#1028-gd32cb9c [Build #1028]

# Kodi version
Kodi (17.0-BETA6 Git:e5cb8b0). Platform: Linux ARM 32-bit

Based on tip of LibreELEC.tv master (d32cb9c1, changelog) and tip of XBMC master (e5cb8b0e, changelog) with the following modifications: Build Highlights:
  1. Kodi 17 Beta6 development opens
  2. bcm270x: Convert to ARCH_MULTIPLATFORM (see PR:1699)
Build Details:
  1. LibreELEC.tv:
    • fix Virtual for 4.8 (PR:892, 2 commits, 4 files changed)
  2. XBMC:
    • [gui] dialogvideoinfo: show selectdialog for directorbutton if amount of directors > 1 (PR:10776, 1 commit, 1 file changed)
    • Parse the id tag only if the uniqueid tag is missing as fallback (PR:10774, 1 commit, 1 file changed)
    • [Fix] Fix two possible resource leaks (PR:10792, 2 commits, 2 files changed)
    • [linux] use appname instead of hardcoding kodi (PR:10796, 1 commit, 1 file changed)
    • [gui] - remove fallbacks for pvr next* infolabels (PR:10788, 1 commit, 1 file changed)
    • [addons] make sure temp dir exists before running CFileOperationJob (PR:10794, 1 commit, 1 file changed)
    • bump to v17.0 beta 6 (PR:10798, 1 commit, 2 files changed)
  3. libcec:
    • updated README.md to reflect the new repository changes (ff591877)
    • updated linux part in README.md (c7e56e4b)
    • fixed dead link in README.linux.md. cosmetics (575ac2d9)
    • fixed another dead link in README.linux.md (d34ea62f)
    • added logo and supported hardware list to README.md (f6fdd650)
  4. newclock5:
    • Updated commits in this build:
    • Commits no longer in build:
      • [ae] Add debug logging showing resamplerate (eb9b1f1f)
      • squash: Restructure the pll adjust code to avoid adjustment when sync display is disabled (ccc01028)
  5. kernel 4.8.y:
    • New commits in this build:
      • bcm270x: Remove bcm2708_reboot_mode parameter (ed9cd08e)
      • bcm270x: Remove NEED_MACH_IO_H (f63a922e)
      • dwc_otg: Pass struct device to dma_alloc*() (8a0e2e50)
      • mmc: bcm2835-sdhost: Pass struct device to dma_alloc*() (210b709f)
      • bcm270x: Drop NEED_MACH_MEMORY_H and use DT dma-ranges (62820516)
      • dts: Remove bcm2835-rpi-cm.dts (153cfa59)
      • bcm2708: Convert to ARCH_MULTIPLATFORM (3cd6950e)
      • bcm2709: Convert to ARCH_MULTIPLATFORM (73d6a399)
      • kconfig: Just use ARCH_BCM2835 for depends on (920ff444)
      • bcm270x: Use dma-ranges unconditionally on bcm2710 (e95a5918)
      • Merge pull request #1699 from notro/bcm270x-multi-1 (7ede3d57)
  6. Additional commits/pull requests/changes not yet merged upstream:
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
@afedchin Unfortunately the new number seek implementation doesn't support the "JumpSMSn" buttons/key codes (where n is 2-9) which makes it impossible to enter seek times from a remote control.

Here I am typing in "123" on the numeric keypad of a remote control - the only number registered on screen is "1":
Code:
04:18:00 5183.168457 T:1960579072   DEBUG: LIRC: Update - NEW at 5171458:201 0 KEY_NUMERIC_1 devinput (KEY_NUMERIC_1)
04:18:00 5183.168457 T:1960579072   DEBUG: OnKey: 206 (0xce, obc49) pressed, action is Number1
04:18:00 5183.235352 T:1960579072   DEBUG: LIRC: Update - NEW at 5171525:201 0 KEY_NUMERIC_1_UP devinput (KEY_NUMERIC_1_UP)
04:18:00 5183.568359 T:1960579072   DEBUG: LIRC: Update - NEW at 5171858:202 0 KEY_NUMERIC_2 devinput (KEY_NUMERIC_2)
04:18:00 5183.568848 T:1960579072   DEBUG: OnKey: 205 (0xcd, obc50) pressed, action is JumpSMS2
04:18:00 5183.618652 T:1960579072   DEBUG: LIRC: Update - NEW at 5171908:202 0 KEY_NUMERIC_2_UP devinput (KEY_NUMERIC_2_UP)
04:18:00 5184.101562 T:1960579072   DEBUG: LIRC: Update - NEW at 5172391:203 0 KEY_NUMERIC_3 devinput (KEY_NUMERIC_3)
04:18:00 5184.101562 T:1960579072   DEBUG: OnKey: 204 (0xcc, obc51) pressed, action is JumpSMS3
04:18:01 5184.151855 T:1960579072   DEBUG: LIRC: Update - NEW at 5172441:203 0 KEY_NUMERIC_3_UP devinput (KEY_NUMERIC_3_UP)
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Noticed with #1027 and #1028, kodi seems to hang when deleting a recording off of a remote filesystem, frequently.

restarting kodi.service gets control back, and the recording does appear to be deleted.

Anyone else notice this? (I just upgraded from a june build, so I'm not sure when this started)
remove
New LibreELEC.tv Krypton build #1029: RPi / RPi2
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 4.8.4 #1 Sat Oct 29 21:31:14 BST 2016 armv6l GNU/Linux

# vcgencmd version
Oct 25 2016 17:02:22
Copyright (c) 2012 Broadcom
version cd1ab218dc23c84d9e6d984385a57f2471600300 (clean) (release)

# lsb_release
LibreELEC (Milhouse) - Version: devel-20161029213009-#1029-gc6538f7 [Build #1029]

# Kodi version
Kodi (17.0-BETA6 Git:a0d63d1). Platform: Linux ARM 32-bit

Based on tip of LibreELEC.tv master (c6538f7e, changelog) and tip of XBMC master (a0d63d17, changelog) with the following modifications: Build Highlights:
  1. Fix Bloomberg buffering
Build Details:
  1. LibreELEC.tv:
    • patch to make ffmpeg work with tls 1.2 servers (PR:895, 1 commit, 1 file changed)
    • linux: add PL2303 serial support to Odroid_C2 (PR:858, 1 commit, 1 file changed)
    • kodi: bump to 17.0-beta5-e92818a (PR:894, 2 commits, 4 files changed)
    • settings: bump to version 0.8.4 (PR:896, 1 commit, 1 file changed)
    • RBP: Add PLL backport patch for Kodi 17 Beta 4 (PR:887, 1 commit, 2 files changed)
    • sapphire: fix build and cleanup (PR:888, 2 commits, 2 files changed)
  2. XBMC:
    • [guiinfo] Coverity: Fix CID 151032 - 151035: Control flow issues (PR:10804, 1 commit, 1 file changed)
    • Fix 1 error and 5 compiler warnings (PR:10765, 7 commits, 7 files changed)
    • AE: Drop AEBuffer (PR:10806, 1 commit, 5 files changed)
  3. pvr.mediaportal.tvserver:
    • [Live555] Android compile fix (PR:50, 2 commits, 3 files changed)
  4. newclock5:
    • New commits in this build:
      • VideoPlayer: hls, select best resolution closest to desired bandwidth (a5a0e5d0)
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
I've just seen something very strange with #1028 on my RPI B model.
When connected to my LG 3D capable TV downstairs it refuses to play last week's strictly , but plays the results show fine.
http://sprunge.us/MaiB

Disconnected, moved upstairs and connected to my DVI monitor, repeat the exact same sequence and it plays both files perfectly.
http://sprunge.us/VcSY

Seemed repeatable, so did it again with debugging on.

Basically Kodi continues to display the list of recordings with the play icon in the bottom left corner, but never switches to fullscreen playback.

Any ideas?

Edit:
This happens only with OMX enabled. File played via UPNP also shows the problem.
On starting playback position 0:00 /23:29 (or similar) increments to 0:01, then back to 0:00 and starts counting from there. When using the DVI monitor, playback starts after the counter resets to 0.
If you go fullscreen (black screen shown) then bring up the overlay it shows omx,(h264) unknown. Remove the overlay change de-interlace from 'auto' (which it defaults to on each playback) to off, the file seeks for a short period and then playback resumes properly.
Doesn't happen with MMAL on, but the PI isn't man enough for advanced de-interlace with this file.
Partial debug log showing this sequence: http://sprunge.us/aYFC
If file would be usefull l can post 1st couple of minutes via google drive. Let me know.
Bloomberg plays now. The fix worked.

Thanks,

Bill
(2016-10-26, 18:53)Aux_ Wrote:
(2016-10-25, 17:44)Aux_ Wrote:
(2016-10-25, 13:42)popcornmix Wrote: Can you confirm the exact build you believe the problem started with?
i.e. does reverting to #1023 resolve the issue?

I will test it with build #1023 over the night, but I'm almost sure the problem has returned with build #1024.

With build #1025 CEC issue was eliminated :-)

Unfortunately CEC issue with the build #1026 has returned, I had waited until now with the hope that it will be good again. It does not matter whether the TV is long time off or is switched off briefly. Had downgraded from #1028 to #1026 to test that.
[1x RPi3]#[ AV Receiver - Marantz NR1506 ]#[ TV Panasonic TX-50EXW784 ]#[ NAS @ OMV 4.1.xx (Arrakis) on Banana Pi ]#[ ODROID C2 + wrxtasy's LE 8.0 ]
(2016-10-29, 23:42)metaron Wrote: If file would be usefull l can post 1st couple of minutes via google drive. Let me know.

Can you check if problem occurs when playing the file through the file interface (not PVR)?
If you see the problem, then a sample file would be useful.
  •   
  • 1
  • 181
  • 182
  • 183(current)
  • 184
  • 185
  • 218
  •   
  Thread Closed
 
Thread Rating:
  • 19 Vote(s) - 4.63 Average



Logout Mark Read Team Forum Stats Members Help
LibreELEC Testbuilds for RaspberryPi (Kodi 17.0)4.6319