•   
  • 1
  • 182
  • 183
  • 184(current)
  • 185
  • 186
  • 218
  •   
  Thread Closed
v17 LibreELEC Testbuilds for RaspberryPi (Kodi 17.0)
(2016-10-30, 14:26)popcornmix Wrote:
(2016-10-29, 23:42)metaron Wrote: If file would be usefull l can post 1st couple of minutes via google drive. Let me know.

Can you check if problem occurs when playing the file through the file interface (not PVR)?
If you see the problem, then a sample file would be useful.

Well, I can get it to happen every time via PVR.
If I have tried to play it via PVR, trying again via UPNP is likely not to work
If this doesn't work sometimes it won't work via file (NFS mounted storage partition).

If I try directly after power on via file, it always works.

This sounds like a temperature/voltage based problem. Obviously this file does soemthing 'stressfull' but that doesn't make it the file's fault. I've always been a bit dubious about the power supplied by the LG TV anyhow...

Probably better to spend your valuable time looking at more repeatable bugs ;-)
Screensaver no longer works for me, it doesn't stay activated:

Code:
17:57:41 252.920059 T:1961280416   DEBUG: CAnnouncementManager - Announcement: OnScreensaverActivated from xbmc
17:57:41 252.920395 T:1961280416   DEBUG: GOT ANNOUNCEMENT, type: 4, from xbmc, message OnScreensaverActivated
17:57:41 252.923981 T:1961287680   DEBUG: ------ Window Init () ------
17:57:41 253.001892 T:1961287680   DEBUG: Activating window ID: 10138
17:57:41 253.002029 T:1961280416   DEBUG: CAnnouncementManager - Announcement: OnScreensaverDeactivated from xbmc
17:57:41 253.002121 T:1961287680   DEBUG: ------ Window Init (DialogBusy.xml) ------
17:57:41 253.002197 T:1961280416   DEBUG: GOT ANNOUNCEMENT, type: 4, from xbmc, message OnScreensaverDeactivated
17:57:41 253.016144 T:1961287680   DEBUG: ------ Window Deinit (DialogBusy.xml) ------
17:57:41 253.056824 T:1961287680   DEBUG: ------ Window Deinit () ------

Full Log: http://pastebin.com/sfbcQvL2
(2016-10-30, 19:00)meccs Wrote: Screensaver no longer works for me, it doesn't stay activated:

Can you reproduce with stock Estuary (I can't)? You're using a third party skin (iqconq) and a bunch of related addons (skin shortcuts, skin helper services etc.) any one of which could be responsible.

If you're sure it's not a skin/addon issue you'll need to identify the first build with the issue, then maybe we can narrow it down.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Seems there is some Buffer (?) issue with the Testbuild and Daisuki plugin (from kodinerds repo)

- LibreELEC 7.0.2 -> FHD stream works
- Auf​ v7.90.007​ -> FHD stream works
- Current Testbuild -> FHD stream lag a lot (Log: http://sprunge.us/WPbM)
(2016-10-30, 21:40)Kougami Wrote: Seems there is some Buffer (?) issue with the Testbuild and Daisuki plugin (from kodinerds repo)

- LibreELEC 7.0.2 -> FHD stream works
- Auf​ v7.90.007​ -> FHD stream works
- Current Testbuild -> FHD stream lag a lot (Log: http://sprunge.us/WPbM)

It looks like the connection to the server you are streaming from is too slow.
Are you sure this wasn't just network conditions?
Is it possible nightly builds are choosing a higher bitrate stream? (does setting a limit in "system/internet access/internet connection bandwidth limitation" help?)
Can you identify the first Milhouse nightly build with the problem?
(2016-10-30, 17:20)metaron Wrote: Well, I can get it to happen every time via PVR.
If I have tried to play it via PVR, trying again via UPNP is likely not to work
If this doesn't work sometimes it won't work via file (NFS mounted storage partition).

If I try directly after power on via file, it always works.

If you spot a repeatable pattern (e.g. perhaps playing the file a few times from file interface fails) I can investigate.
I can test with the IPTV simple PVR interface - does that fail for you?
(2016-10-30, 22:48)popcornmix Wrote:
(2016-10-30, 21:40)Kougami Wrote: Seems there is some Buffer (?) issue with the Testbuild and Daisuki plugin (from kodinerds repo)

- LibreELEC 7.0.2 -> FHD stream works
- Auf​ v7.90.007​ -> FHD stream works
- Current Testbuild -> FHD stream lag a lot (Log: http://sprunge.us/WPbM)

It looks like the connection to the server you are streaming from is too slow.
Are you sure this wasn't just network conditions?
Is it possible nightly builds are choosing a higher bitrate stream? (does setting a limit in "system/internet access/internet connection bandwidth limitation" help?)
Can you identify the first Milhouse nightly build with the problem?

Thanks for the answer Wink .

SD-Card with fresh installed LibreELEC v7.90.007​ (RPi wired connected) -> FHD stream with no lags, no problems (Log: http://sprunge.us/fLMK ).
After this test, i directly updated to the current Testbuild. Set bandwidth limitation to 512kbps and watched the same episode with lags (resolution was 640x360 !!!) (Log: http://sprunge.us/fFdM ). I don’t thing this is an network problem, crunchyroll as example works on both versions fine.
New LibreELEC.tv Krypton build #1030: RPi / RPi2
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 4.8.4 #1 Sun Oct 30 22:26:52 GMT 2016 armv6l GNU/Linux

# vcgencmd version
Oct 25 2016 17:02:22
Copyright (c) 2012 Broadcom
version cd1ab218dc23c84d9e6d984385a57f2471600300 (clean) (release)

# lsb_release
LibreELEC (Milhouse) - Version: devel-20161030222550-#1030-gae704a7 [Build #1030]

# Kodi version
Kodi (17.0-BETA6 Git:a08a5e3). Platform: Linux ARM 32-bit

Based on tip of LibreELEC.tv master (ae704a71, changelog) and tip of XBMC master (a08a5e3f, changelog) with the following modifications: Build Highlights:
  1. PR:10819: fix hash checking in addon installer
  2. Revert kernel 4.8.y PR:1700 - breaks USB
  3. MemoryAlignment: Fixes
Build Details:
  1. LibreELEC.tv:
    • i.MX6 4.4 kernel: update the patches set to all known in the wild (PR:883, 1 commit, 22 files changed)
  2. XBMC:
    • FIX: [amc] Multiple fixes (PR:10779, 5 commits, 2 files changed)
    • Coverity: Initialize videoinfotag rating and uniqueid ids (PR:10812, 1 commit, 1 file changed)
    • [cmake] Debug binary-addon packaging issues on android (PR:10803, 2 commits, 2 files changed)
    • deprecate autotools (PR:10797, 1 commit, 1 file changed)
    • Bunch of SPMC jni backports (PR:10808, 26 commits, 76 files changed)
    • MemoryAlignment: Fixes (PR:10810, 4 commits, 5 files changed)
    • [skins] seeknumeric - use hh:mm:ss format (PR:10816, 1 commit, 2 files changed)
    • FFmpeg: Bump to 3.1.5-Krypton-Beta5-1 (PR:10746, 1 commit, 1 file changed)
    • allow settings.xml.in (PR:10815, 1 commit, 1 file changed)
    • Fixed: RTMP swfvfy also accepts 1 instead of just true (PR:10820, 1 commit, 1 file changed)
  3. kernel 4.8.y:
    • New commits in this build:
      • BCM270X_DT: Use raspberrypi-power to turn on USB power (0bf264c2)
      • firmware: bcm2835: Don't turn on USB power (9fdbef16)
      • Merge pull request #1700 from notro/raspberrypi-power-1 (d8f7c2da)
  4. Additional commits/pull requests/changes not yet merged upstream:
    • Added: [pkg] PR:10819: fix hash checking in addon installer
    • Reverted: [pkg] PR:1700: #Use raspberrypi-power to turn on USB power (Reason: RPi1 fails to initialise USB) (linux)
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Addons menu no longer works, as soon as I with the remote control on Addon menu down scrol crashes kodi and reboot. Addons icons are also not visible.

http://pastebin.com/0A324M3f
http://pastebin.com/k9tG23E3
[1x RPi3]#[ AV Receiver - Marantz NR1506 ]#[ TV Panasonic TX-50EXW784 ]#[ NAS @ OMV 4.1.xx (Arrakis) on Banana Pi ]#[ ODROID C2 + wrxtasy's LE 8.0 ]
(2016-10-31, 16:46)Aux_ Wrote: Addons menu no longer works, as soon as I with the remote control on Addon menu down scrol crashes kodi and reboot. Addons icons are also not visible.

I think this crash is fixed here: 10828 (PR)
(2016-10-31, 16:51)popcornmix Wrote:
(2016-10-31, 16:46)Aux_ Wrote: Addons menu no longer works, as soon as I with the remote control on Addon menu down scrol crashes kodi and reboot. Addons icons are also not visible.

I think this crash is fixed here: 10828 (PR)

@popcornmix

Could this also fix the crashes I saw last night on two different RPI3s when navigating the TV Library? Some shows would cause it to crash but some would be fine.

http://sprunge.us/ZhQU
http://sprunge.us/Oaih
http://sprunge.us/AGEF
http://sprunge.us/KeQd
HTPC(s): All running LibreELEC
  • AMD 2200G APU on Gigabyte AB350N-Gaming WIFI-CF
  • RPI3 x2 | RPI2 x2
NAS: FreeNAS (Latest Stable) | NFS/CIFS
Also a little more explanation in 10826 (PR)

Should be fixed in tonight's build (thanks @fritsch & @notspiff)
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2016-10-31, 16:55)pyrodex Wrote: Could this also fix the crashes I saw last night on two different RPI3s when navigating the TV Library? Some shows would cause it to crash but some would be fine.

Yes, all those crashes look like they may be caused by invalid image buffer allocations, so were likely caused by #10810 and should be addressed by #10828
(2016-10-31, 17:00)popcornmix Wrote:
(2016-10-31, 16:55)pyrodex Wrote: Could this also fix the crashes I saw last night on two different RPI3s when navigating the TV Library? Some shows would cause it to crash but some would be fine.

Yes, all those crashes look like they may be caused by invalid image buffer allocations, so were likely caused by #10810 and should be addressed by #10828

Thanks! I will test tonight's build if this is pushed into it and report back.
HTPC(s): All running LibreELEC
  • AMD 2200G APU on Gigabyte AB350N-Gaming WIFI-CF
  • RPI3 x2 | RPI2 x2
NAS: FreeNAS (Latest Stable) | NFS/CIFS
@devs

Hi,
since 3D playback of MVC streams are already working beautifully from MKVs and ISOs, is there any chance for a setting to switch left eye and right eye channel? Several movies have left and right eye swapped (i.e. The Hobbit, Edge of Tomorrow) so one has to wear the glasses wrongly. Big Grin

ps: congrats to libreELEC. I just recently tried it and I am very impressed. Excellent job.
  •   
  • 1
  • 182
  • 183
  • 184(current)
  • 185
  • 186
  • 218
  •   
  Thread Closed
 
Thread Rating:
  • 19 Vote(s) - 4.63 Average



Logout Mark Read Team Forum Stats Members Help
LibreELEC Testbuilds for RaspberryPi (Kodi 17.0)4.6319