•   
  • 1
  • 184
  • 185
  • 186(current)
  • 187
  • 188
  • 218
  •   
  Thread Closed
v17 LibreELEC Testbuilds for RaspberryPi (Kodi 17.0)
(2016-11-01, 14:27)origpumu Wrote: Amazon Prime Video works so far, but some movies doesn't show video, there is just the sound to hear. What can I do to correctly this error?

This is unfortunately a known issue. Amazon changed their encryption a few weeks ago and many videos will no longer play correctly - all you have is audio. It's being worked on, but currently their is no solution.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2016-11-01, 14:09)popcornmix Wrote:
(2016-11-01, 13:01)Aux_ Wrote: Hi Milhouse, the problem occurs when TV is off and I turn it back on, then goes the CEC connection lost and I must on the TV the KODI (RPi) source again select.
The RPi3 is connected to the TV via AV receiver and the AV receiver Is also connected via CEC so I can switch everything with one remote control.

I use master-slave power strip, the TV is master therefore when I turn off the TV then the AV receiver is also off but RPi is not, RPi is connected via extra current source

I would try to generate a log but what should I turn on?
Thanks for your attention!

Enable debug logging and "libCEC" in component specific logging. Reboot pi.
Reproduce problem (e.g. switch TV off and then on and try to use CEC buttons).

I'd suggest you create an issue here: https://github.com/Pulse-Eight/libcec/issues
(including a link to the log) where the right developer will see.

Hi @popcornmix

Have done as suggested, this is a time window of about 20 seconds TV off and on again.

http://pastebin.com/EkLyLmMm
[1x RPi3]#[ AV Receiver - Marantz NR1506 ]#[ TV Panasonic TX-50EXW784 ]#[ NAS @ OMV 4.1.xx (Arrakis) on Banana Pi ]#[ ODROID C2 + wrxtasy's LE 8.0 ]
i don't understand why, but on my rpi3 i have a random reboot.

I update from KODI 14 Helix from KODI 17.

Kodi 16 ( last milhouse builds ) is already in beta and i don't know how is possible that there is kodi 17 and 16 in in beta...

anyway with this, i have a black screen when i leave it untouched for some hours and needed to turn off and on rpi.

Someone can help me? i need to attach logs?
(2016-11-01, 21:15)robertus Wrote: i don't understand why, but on my rpi3 i have a random reboot.

I update from KODI 14 Helix from KODI 17.

Kodi 16 ( last milhouse builds ) is already in beta and i don't know how is possible that there is kodi 17 and 16 in in beta...

The latest LibreELEC builds here are based on Kodi 17 Beta 6, as this is the version at the tip of the Kodi master tree.

Kodi 16 has reached end of line status and is no longer actively developed.

(2016-11-01, 21:15)robertus Wrote: anyway with this, i have a black screen when i leave it untouched for some hours and needed to turn off and on rpi.

Someone can help me? i need to attach logs?

I would suggest a clean install rather than upgrades, particularly when upgrading from such an old version as Kodi 14.

You can find official LibreELEC 7 images (Kodi 16 based) on the LibreELEC download page, and use to create a clean install.

There are also official LibreELEC 8 Alpha builds (Kodi 17 based) available from here which you can install as an image (ie clean install).

Once you are running either LibreELEC 7 or LibreELEC 8 Alpha, you should be able to upgrade without any issues to the latest of these test builds.

As for logs, just the usual - see note #9 in the first post.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2016-11-01, 21:42)Milhouse Wrote:
(2016-11-01, 21:15)robertus Wrote: i don't understand why, but on my rpi3 i have a random reboot.

I update from KODI 14 Helix from KODI 17.

Kodi 16 ( last milhouse builds ) is already in beta and i don't know how is possible that there is kodi 17 and 16 in in beta...

The latest LibreELEC builds here are based on Kodi 17 Beta 6, as this is the version at the tip of the Kodi master tree.

Kodi 16 has reached end of line status and is no longer actively developed.

(2016-11-01, 21:15)robertus Wrote: anyway with this, i have a black screen when i leave it untouched for some hours and needed to turn off and on rpi.

Someone can help me? i need to attach logs?

I would suggest a clean install rather than upgrades, particularly when upgrading from such an old version as Kodi 14.

You can find official LibreELEC 7 images (Kodi 16 based) on the LibreELEC download page, and use to create a clean install.

There are also official LibreELEC 8 Alpha builds (Kodi 17 based) available from here which you can install as an image (ie clean install).

Once you are running either LibreELEC 7 or LibreELEC 8 Alpha, you should be able to upgrade without any issues to the latest of these test builds.

As for logs, just the usual - see note #9 in the first post.

i tried to install libreelec 7.0.2, and iptv open channel is slow, i don't know how in your version are very fast, so i was frustrate and i put in update folder last kodi 17 ( LibreELEC-RPi2.arm-8.0-Milhouse-20161030222550-#1030-gae704a7 ) and i leave estuary skin that i hate but to have a good support need it.
I tried to install two addons and when i only get the cursor under the addon, i have a reboot.
Unortunally i can't get crash logs because now when i reboot i have a black screen, so tomorrow i reinstall one more time and i'll try to attach logs to have a better support.

Kodi 15 works fine, but iptv have a slow open channel, so i want to upgrade. ( i guess that newer version doesn't have features that i can see with my eyes, or not ? )

thanks and please wait my another reply with logs
Install PuTTY (on Windows) and use it to connect to the RPi using ssh (username: root, password: libreelec). Just because you have a black screen doesn't mean you can't connect with ssh and upload your log. If you didn't enable ssh in the LE Settings add-on/first run Wizard then you'll need to add "ssh" to the end of your kernel command line in the file cmdline.txt.

There is a bug in #1030 that causes a crash when caching images - this is probably the issue you experienced and is already fixed in #1031.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
New LibreELEC.tv Krypton build #1101: RPi / RPi2
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 4.8.6 #1 Tue Nov 1 22:49:52 GMT 2016 armv6l GNU/Linux

# vcgencmd version
Oct 25 2016 17:02:22
Copyright (c) 2012 Broadcom
version cd1ab218dc23c84d9e6d984385a57f2471600300 (clean) (release)

# lsb_release
LibreELEC (Milhouse) - Version: devel-20161101224848-#1101-g61cb0dc [Build #1101]

# Kodi version
Kodi (17.0-BETA6 Git:5855cfe). Platform: Linux ARM 32-bit

Based on tip of LibreELEC.tv master (61cb0dcb, changelog) and tip of XBMC master (5855cfe6, changelog) with the following modifications: Build Highlights:
  1. Restore raspberrypi-power PR:1700
  2. (Clean build)
Build Details:
  1. LibreELEC.tv:
    • systemd: machine-id.service is required for systemd-tmpfiles-setup-de… (PR:898, 1 commit, 1 file changed)
  2. XBMC:
    • ListItem.Year - prefer to use the year value from the firstaired date (PR:10770, 1 commit, 2 files changed)
    • [python] add xbmcgui.ListItem.setCast() (PR:10619, 1 commit, 2 files changed)
    • [python] add xbmcgui.Dialog().videoinfo() and .musicinfo() (PR:10616, 1 commit, 2 files changed)
    • [python] fix pydocs after a2f675e04b8e4c8dab2cf1398bcd2be2e3d8e98f (PR:10833, 1 commit, 1 file changed)
    • [PVR] Fix local art lookup log spam. pvr recordings never have local art. (PR:10832, 1 commit, 1 file changed)
    • [xbmc][fix] Don't try to index outside our lookup table and crash (PR:10831, 1 commit, 2 files changed)
    • Subtitles: allow self-closing br and html escape characters (PR:10813, 2 commits, 1 file changed)
    • slideshow: only stop video player, keep background music playing (PR:10835, 1 commit, 1 file changed)
    • Fixed OnPlayBackResumed not getting fired anymore. (PR:10739, 1 commit, 1 file changed)
    • DVDDemuxFFmpeg: Fix whitespace (PR:10821, 1 commit, 1 file changed)
    • VideoPlayer: hls, select best resolution closest to desired bandwidth (PR:10801, 1 commit, 2 files changed)
    • VideoPlayer: add user name and password back to url after testing for… (PR:10799, 1 commit, 1 file changed)
    • fix streaminfo set by python (PR:10824, 1 commit, 1 file changed)
    • [cmake] add our own FindLibXml2.cmake, needed for static libs (PR:10829, 1 commit, 1 file changed)
  3. libcec:
    • changed: renamed 'libcec-dev' to 'libcec4-dev' (81fe5bc0)
  4. inputstream.rtmp:
    • [depends] fix openssl install when INSTALL_PREFIX env var is set (PR:9, 1 commit, 1 file changed)
  5. pvr.vbox:
    • Genre mapping for programs, using mapping XML (PR:146, 8 commits, 7 files changed)
    • Added version check for VBox databases (channels & EPG) before fetch (a34454c4)
    • Added version check for VBox databases (channels & EPG) before fetch (8e496578)
  6. newclock5:
    • Commits no longer in build:
      • VideoPlayer: cleanup VideoCodec interface, SetDropState (fac2d4f4)
      • MMAL: Update to new dropping scheme (181f3058)
      • VideoPlayer: hls, select best resolution closest to desired bandwidth (c57fdc4d)
  7. Additional commits/pull requests/changes not yet merged upstream:
    • Added: [env] 881901c6: Mako: initial commit
    • Added: [env] patch: mesa: update to mesa-13.0.0
    • Added: [env] patch: visualization.shadertoy: update to 1.1.4
    • Added: [env] PR:900: linux: update to linux-4.8.6
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Hello.
Addon PVR IPTV Simple does not recognize the group of channels in the playlist. Tested on the LibreELEC (Krypton) v7.90.008 ALPHA at Raspberry Pi3. LibreELEC Kodi 16.1 - Jarvis works similarly.
Channel groups can be seen on OSMС builds with the same playlist.
What am I doing wrong?
I posted a few days ago but no one replied so I'm not sure if someone noticed that "Enable Standby" on Bluetooth devices disables it and vice versa?
Enable Standby also prevents the Kodi Screensaver from working.

Tested with Fire TV Stick remote. I can't find out when it started because repairing the device is a pain and takes forever. Sorry.
(2016-10-31, 00:13)Kougami Wrote:
(2016-10-30, 22:48)popcornmix Wrote:
(2016-10-30, 21:40)Kougami Wrote: Seems there is some Buffer (?) issue with the Testbuild and Daisuki plugin (from kodinerds repo)

- LibreELEC 7.0.2 -> FHD stream works
- Auf​ v7.90.007​ -> FHD stream works
- Current Testbuild -> FHD stream lag a lot (Log: http://sprunge.us/WPbM)

It looks like the connection to the server you are streaming from is too slow.
Are you sure this wasn't just network conditions?
Is it possible nightly builds are choosing a higher bitrate stream? (does setting a limit in "system/internet access/internet connection bandwidth limitation" help?)
Can you identify the first Milhouse nightly build with the problem?

Thanks for the answer Wink .

SD-Card with fresh installed LibreELEC v7.90.007​ (RPi wired connected) -> FHD stream with no lags, no problems (Log: http://sprunge.us/fLMK ).
After this test, i directly updated to the current Testbuild. Set bandwidth limitation to 512kbps and watched the same episode with lags (resolution was 640x360 !!!) (Log: http://sprunge.us/fFdM ). I don’t thing this is an network problem, crunchyroll as example works on both versions fine.

Seems the issue starts with #1025, but not sure what exactly caused the problem or why only the daisuki plugin is affected .

- Open daisuki
- All Series -> Magic of Stella -> Episode 1
- Played the first 2-3min

-> #1024 no buffering/lag , #1025 a lot of buffering/lags

Set bandwidth limitation for #1025, but still same problem.
(2016-11-02, 15:55)Kougami Wrote: - Open daisuki
- All Series -> Magic of Stella -> Episode 1
- Played the first 2-3min

-> #1024 no buffering/lag , #1025 a lot of buffering/lags

Set bandwidth limitation for #1025, but still same problem.

I've watched first 5 minutes and no buffering/lags.
What does the video bitrate and resolution show as for #1024 and #1025?
I see 1920x1080 and ~5Mb/s with latest version (and no internet bandwidth limit).
first test with #1101: RPi2 on RPi3 after long time ago Angel

i see if playing DTS music two progressbars and stuttering bar-curser, also time-display does not run smothly -> staccato.
The mouse is frozen after some time: Logitech k400 and also a seperate mouse.If stopp playing - mouse works.

This happens only if i play from Folder - playing particular a dts song like:

https://drive.google.com/file/d/0B2rgZ0B...sp=sharing

[Attention! without dts-capable equipment you only hear very loud pink noise]

...the mouse will work, only one progressbar appears but stuttering time and bar cursor.


Playing DVD rip-mkv with dts sound all works fine - no Problem with k400/mouse and progressbar,
playing mp3 also ok

BluRay Menue works perfekt, with dts, no Prob.


Thanks
i try last version and works for me at the moment, but i have an addon that doesn't work for this version of kodi (17).

So i want to downgrade to kodi 16, but is slow at change iptv channel.

You know how to fix it in kodi 16 ? (because last testbuilds of this version have some issue for me like black screen when in idle for a while)

@milhouse: infact i didn't attach log, like you told my some posts ago, because this issue if with kodi 16 testbuilds, that i guess isn't supported anymore )
(2016-11-01, 21:15)robertus Wrote: i don't understand why, but on my rpi3 i have a random reboot.

I update from KODI 14 Helix from KODI 17.

Kodi 16 ( last milhouse builds ) is already in beta and i don't know how is possible that there is kodi 17 and 16 in in beta...

anyway with this, i have a black screen when i leave it untouched for some hours and needed to turn off and on rpi.

Someone can help me? i need to attach logs?

I had/have the exact same problem regardless if its a mere update or clean install. However after some fiddling with the cdc adapter in system input then peripherals and pulse cdc adapter i think i manage to solve it. Especially check the part "when the tv is turned off"
(2016-11-02, 19:31)robertus Wrote: i try last version and works for me at the moment, but i have an addon that doesn't work for this version of kodi (17).

So i want to downgrade to kodi 16, but is slow at change iptv channel.

You know how to fix it in kodi 16 ? (because last testbuilds of this version have some issue for me like black screen when in idle for a while)

@milhouse: infact i didn't attach log, like you told my some posts ago, because this issue if with kodi 16 testbuilds, that i guess isn't supported anymore )

You should contact the add-on developer for a Kodi 17 compatible update. There will be no further Kodi 16 development.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
  •   
  • 1
  • 184
  • 185
  • 186(current)
  • 187
  • 188
  • 218
  •   
  Thread Closed
 
Thread Rating:
  • 19 Vote(s) - 4.63 Average



Logout Mark Read Team Forum Stats Members Help
LibreELEC Testbuilds for RaspberryPi (Kodi 17.0)4.6319