The TVDB scraper is currently broken due to upgrade works at TheTVDB site. We hope this issue will be resolved quickly.

  •   
  • 1
  • 204
  • 205
  • 206(current)
  • 207
  • 208
  • 218
  •   
  Thread Closed
v17 LibreELEC Testbuilds for RaspberryPi (Kodi 17.0)
(2016-11-24, 01:26)Aux_ Wrote: New skin, as I click the main window -> Addons -> Install from zip nothing happens


This is a known issue. => https://github.com/phil65/skin.estuary/issues/9
(2016-11-24, 08:43)ksooo Wrote: @grisia how do you rename the folders? Ofc you know that it's not enough to just rename them on the disk and that you additionally have to manually edit tvheadend's internal dvr database (a set of json files)? And after this you have to restart tvheadend.

@ksooo Yes that's what i've done. Otherwise tvheadend would show them as deleted. That's why I delete all recordings, so there is just one json file to edit.
I have a few problems with the sound.
At Livestreams, the sound will turn off for a few seconds.
Can someone help me?

Code:
12:50:08.718 T:1001386912   ERROR: CVideoPlayerAudio::DecodeFrame - Decode Error. Skipping audio packet (-1094995529)
12:50:34.164 T:1923085216   ERROR: Previous line repeats 2 times.

Code:
12:29:03.866 T:1700938656  NOTICE: VideoInfoScanner: Finished scan. Scanning for video info took 00:33
12:30:05.729 T:1961603072  NOTICE: NFS is idle. Closing the remaining connections.
12:30:40.440 T:1961603072  NOTICE: Samba is idle. Closing the remaining connections
12:33:47.433 T:1254990752  NOTICE: AddOnLog: PVR IPTV Simple Client: EPG Loaded.
12:38:26.694 T:1709327264 WARNING: CSkinInfo: failed to load skin settings
12:38:26.760 T:1961603072   ERROR: Window Translator: Can't find window videolibrary
12:38:26.761 T:1961603072 WARNING: Label Formating: $VAR[GlobalFanartVar] is not defined
12:38:26.843 T:1961603072   ERROR: Control 1000 in window 13001 has been asked to focus, but it can't
12:38:26.846 T:1961603072   ERROR: CGUITextureManager::GetTexturePath: could not find texture 'default/bg.jpg'
12:38:33.199 T:1923085216  NOTICE: CAESinkPi:AddPackets Underrun (delay:0.00 frames:1102)
12:38:51.403 T:1254990752  NOTICE: AddOnLog: PVR IPTV Simple Client: EPG Loaded.
12:40:43.745 T:1961603072  NOTICE: VideoPlayer: Opening: pvr://channels/tv/Alle Kanäle/pvr.iptvsimple_1262629749.pvr
12:40:43.745 T:1961603072 WARNING: CDVDMessageQueue(player)::Put MSGQ_NOT_INITIALIZED
12:40:43.747 T:1127216032  NOTICE: Creating InputStream
12:40:45.849 T:1127216032  NOTICE: Creating Demuxer
12:40:45.961 T:1127216032  NOTICE: Opening stream: 1 source: 256
12:40:45.962 T:1127216032  NOTICE: Creating video codec with codec id: 28
12:40:45.962 T:1127216032  NOTICE: CDVDVideoCodecFFmpeg::Open() Using codec: H.264 / AVC / MPEG-4 AVC / MPEG-4 part 10
12:40:45.963 T:1127216032  NOTICE: Creating video thread
12:40:45.963 T:1055462304  NOTICE: running thread: video_thread
12:40:45.963 T:1127216032  NOTICE: Opening stream: 4 source: 256
12:40:45.963 T:1127216032  NOTICE: Finding audio codec for: 86019
12:40:45.964 T:1127216032  NOTICE: Creating audio thread
12:40:45.965 T:1127216032  NOTICE: Opening stream: 0 source: 256
12:40:45.965 T:1001386912  NOTICE: running thread: CVideoPlayerAudio::Process()
12:40:45.965 T:1127216032  NOTICE: waiting for teletext data thread to exit
12:40:45.967 T:1127216032  NOTICE: Creating teletext data thread
12:40:45.967 T:992998304  NOTICE: running thread: CDVDTeletextData
12:40:45.993 T:1127216032  NOTICE: Opening stream: 1 source: 256
12:40:45.993 T:1127216032  NOTICE: Creating video codec with codec id: 28
12:40:46.004 T:1127216032  NOTICE: Opening stream: 4 source: 256
12:40:46.004 T:1127216032  NOTICE: Opening stream: 0 source: 256
12:40:46.026 T:1001386912  NOTICE: Creating audio stream (codec id: 86019, channels: 6, sample rate: 48000, no pass-through)
12:40:46.253 T:1961603072  NOTICE: Display resolution ADJUST : 1920x1080 (1920x1080) @ 50.00 - Full Screen (52) (weight: 0.000)
12:40:47.287 T:1055462304 WARNING: CRenderManager::WaitForBuffer - timeout waiting for buffer
12:40:54.547 T:1961603072 WARNING: Previous line repeats 2 times.
12:40:54.547 T:1961603072  NOTICE: Display resolution ADJUST : 1920x1080 (1920x1080) @ 50.00 - Full Screen (52) (weight: 0.000)
12:42:14.288 T:1961603072  NOTICE: Samba is idle. Closing the remaining connections
12:46:23.050 T:1923085216  NOTICE: CAESinkPi:AddPackets Underrun (delay:0.00 frames:1200)
12:50:08.717 T:1001386912  NOTICE: Previous line repeats 1 times.
12:50:08.718 T:1001386912   ERROR: CVideoPlayerAudio::DecodeFrame - Decode Error. Skipping audio packet (-1094995529)
12:50:34.164 T:1923085216   ERROR: Previous line repeats 2 times.
12:50:34.165 T:1923085216  NOTICE: CAESinkPi:AddPackets Underrun (delay:0.00 frames:1200)
12:58:49.099 T:1961603072  NOTICE: Previous line repeats 1 times.
12:58:49.099 T:1961603072  NOTICE: CVideoPlayer::CloseFile()
12:58:49.099 T:1961603072  NOTICE: VideoPlayer: waiting for threads to exit
12:58:49.541 T:1127216032  NOTICE: CVideoPlayer::OnExit()
12:58:49.541 T:1127216032  NOTICE: Closing stream player 1
12:58:49.541 T:1127216032  NOTICE: Waiting for audio thread to exit
12:58:49.602 T:1001386912  NOTICE: thread end: CVideoPlayerAudio::OnExit()
12:58:49.603 T:1127216032  NOTICE: Closing audio device
12:58:49.668 T:1055462304 WARNING: CRenderManager::WaitForBuffer - timeout waiting for buffer
12:58:50.081 T:1127216032 WARNING: Previous line repeats 2 times.
12:58:50.081 T:1127216032  NOTICE: Deleting audio codec
12:58:50.081 T:1127216032  NOTICE: Closing stream player 2
12:58:50.081 T:1127216032  NOTICE: waiting for video thread to exit
12:58:50.082 T:1055462304  NOTICE: thread end: video_thread
12:58:50.083 T:1127216032  NOTICE: deleting video codec
12:58:50.088 T:1127216032  NOTICE: Closing stream player 4
12:58:50.088 T:1127216032  NOTICE: waiting for teletext data thread to exit
12:58:50.088 T:992998304   ERROR: Got MSGQ_ABORT or MSGO_IS_ERROR return true (-1)
12:58:50.088 T:992998304  NOTICE: thread end: data_thread
12:58:50.655 T:1961603072  NOTICE: VideoPlayer: finished waiting
12:58:50.831 T:1961603072  NOTICE: CVideoPlayer::CloseFile()
12:58:50.831 T:1961603072  NOTICE: VideoPlayer: waiting for threads to exit
12:58:50.831 T:1961603072  NOTICE: VideoPlayer: finished waiting
12:58:50.831 T:1961603072  NOTICE: CVideoPlayer::CloseFile()
12:58:50.831 T:1961603072  NOTICE: VideoPlayer: waiting for threads to exit
12:58:50.831 T:1961603072  NOTICE: VideoPlayer: finished waiting
12:58:54.289 T:1254990752  NOTICE: AddOnLog: PVR IPTV Simple Client: EPG Loaded.
12:58:57.950 T:992998304 WARNING: CSkinInfo: failed to load skin settings
12:58:58.016 T:1961603072   ERROR: Window Translator: Can't find window videolibrary
12:58:58.016 T:1961603072 WARNING: Label Formating: $VAR[GlobalFanartVar] is not defined
12:58:58.094 T:1961603072   ERROR: Control 1000 in window 13000 has been asked to focus, but it can't
12:58:58.096 T:1961603072   ERROR: CGUITextureManager::GetTexturePath: could not find texture 'default/bg.jpg'
12:59:02.533 T:1923085216  NOTICE: CAESinkPi:AddPackets Underrun (delay:0.00 frames:1102)
(2016-11-23, 18:05)popcornmix Wrote:
(2016-11-23, 18:01)hanspeter Wrote: same behavior also with the bootcode.bin from #1119, freezes with 614M. Is this expected, or is the memtester freezing with a large value already a symptom of this problem...?

I think the freezing is something else. memtester locks the memory and if there is too little remaining linux struggles to run.
I believe I got that and did a control-c and left it for a while it response did return.

I'm more interested in using a lower number such that the test does run, but reports corruption.

Ran for >12hrs, no errors. I also could not find any way to provoke the crash... Do you have any ideas what the root-cause could be? If you suspect a (hardware) memory problem, would overclocking the memory to an unstable value maybe provoke it...? Or what about running memtester while kodi is running?
(2016-11-24, 01:50)Milhouse Wrote:
(2016-11-23, 21:34)doldi Wrote: But with mouse i can not handle my files in a folder - if there are more than 20 single files i have no chance for a selection - scroll down or up is to fast :-)

Do you still have this mouse problem with tonight's #1123 build (in case it's a kernel 4.9-rc6 related issue)? Assuming you do, then it's probably best to report it in the Estuary forum as a usability issue.

Hello Milhouse indeed - now updated Rpi2 and the Rpi3 on TV. Scrolling and parallel working backround is to fast for mouse -handling,
i think.
I make a report in the Estuary forum.

Thanks
(2016-11-24, 15:40)hanspeter Wrote: Ran for >12hrs, no errors. I also could not find any way to provoke the crash... Do you have any ideas what the root-cause could be? If you suspect a (hardware) memory problem, would overclocking the memory to an unstable value maybe provoke it...? Or what about running memtester while kodi is running?

I hardware issue seemed possible when only you had a problem. As gendo also saw a similar crash, then a hardware issue is less likely.
Most likely the arm is trying to access memory in the top 16M of address space. This should be used by the GPU but there may be a situation I'm missing,
If I could reproduce this then diagnosing it would be easier.

As total_mem=1008 works and total_mem=1024 (the default if unspecified) doesn't work, it may be interesting to see what the threshold is.
E.g. Try total_mem=1016. If that seems good try total_mem=1020, and if not try total_mem=1012.

If you get a crash where ssh still works, then dmesg output may be useful.
After a reboot then .kodi/temp/kodi.old.log may be useful if it shows what was going on from just before the crash.
(2016-11-24, 17:59)popcornmix Wrote:
(2016-11-24, 15:40)hanspeter Wrote: Ran for >12hrs, no errors. I also could not find any way to provoke the crash... Do you have any ideas what the root-cause could be? If you suspect a (hardware) memory problem, would overclocking the memory to an unstable value maybe provoke it...? Or what about running memtester while kodi is running?

I hardware issue seemed possible when only you had a problem. As gendo also saw a similar crash, then a hardware issue is less likely.
Most likely the arm is trying to access memory in the top 16M of address space. This should be used by the GPU but there may be a situation I'm missing,
If I could reproduce this then diagnosing it would be easier.

As total_mem=1008 works and total_mem=1024 (the default if unspecified) doesn't work, it may be interesting to see what the threshold is.
E.g. Try total_mem=1016. If that seems good try total_mem=1020, and if not try total_mem=1012.

If you get a crash where ssh still works, then dmesg output may be useful.
After a reboot then .kodi/temp/kodi.old.log may be useful if it shows what was going on from just before the crash.

Nothing in old log.. funny thing is i have 2 x RPi2 1 hangs 3 -4 times a day whilst the other one is rock solid.. both have libreelec on usb drive... but the one that crashes has a usb DVB-t tuner and runs at 720p resolution

both are Pi2 Model B rev 1.1, BCM2836 SoC with 1GB RAM by Sony (reported by bcmstat)
(2016-11-24, 19:08)gendo Wrote: Nothing in old log.. funny thing is i have 2 x RPi2 1 hangs 3 -4 times a day whilst the other one is rock solid.. both have libreelec on usb drive... but the one that crashes has a usb DVB-t tuner and runs at 720p resolution

both are Pi2 Model B rev 1.1, BCM2836 SoC with 1GB RAM by Sony (reported by bcmstat)

That's the sort of information that could be interesting.
I can't currently think of a reason why the DVB tuner or 720p resolution would cause the crash.
However if you were to report, say, that switching the good Pi to 720p made it unreliable then that would be even more interesting.
For some reason I get screen resolution with big icons and fonts and it looks scaled out.
Hello, together.

First i have to appreciate your work, Millhouse. Very nice Kodi Distibution. Big Grin

I have a little problem since the last 5 or 6 Builds:

I have a playlist with some Online Radio Channels in it, its played automatically when i come home. So problems with this. But there's one Radio channel which causes Kodi to crash, when its played.

This one: http://relay1.hirschmilch.de:7100/chillout.mp3

I've already tested different cases with audio buffer in advancedsettings (old and new format)

Here my advancedsettings.xml:

Code:
<advancedsettings>


  
<pvr>
    <!-- <minvideocachelevel>40</minvideocachelevel> -->
    <!-- <minaudiocachelevel>40</minaudiocachelevel> -->
</pvr>
  
<network>
   <disableipv6>true</disableipv6>
</network>

<cache>
    <buffermode>1</buffermode>
    <memorysize>157286400</memorysize>
    <readfactor>10</readfactor>
</cache>
  
  <videolibrary>
   <cleanonupdate>true</cleanonupdate> <!-- Also clean library during library update -->
   <importwatchedstate>true</importwatchedstate>
   <importresumepoint>true</importresumepoint>
</videolibrary>

<videoscanner>
   <ignoreerrors>true</ignoreerrors> <!-- Silently ignore errors while scanning videos. -->
</videoscanner>

<video>
   <timeseekforward>15</timeseekforward> <!-- Skip back time 15 s -->
   <timeseekbackward>-15</timeseekbackward> <!-- Skip forward time 15 s -->
</video>

</advancedsettings>


Damn cant choose an own background wallpaper anymore with the new skin
Not a big problem, just for infomation. Groove Music app on Win10 no longer plays tracks from RPi via sharing. #1123 (maybe 2-3 builds earlier). WMP or Kodi play fine.
(2016-11-24, 19:23)popcornmix Wrote:
(2016-11-24, 19:08)gendo Wrote: Nothing in old log.. funny thing is i have 2 x RPi2 1 hangs 3 -4 times a day whilst the other one is rock solid.. both have libreelec on usb drive... but the one that crashes has a usb DVB-t tuner and runs at 720p resolution

both are Pi2 Model B rev 1.1, BCM2836 SoC with 1GB RAM by Sony (reported by bcmstat)

That's the sort of information that could be interesting.
I can't currently think of a reason why the DVB tuner or 720p resolution would cause the crash.
However if you were to report, say, that switching the good Pi to 720p made it unreliable then that would be even more interesting.

I also experience a similar issue after I updated. The sound loops for a few seconds, image color goes to green scrambled and then turns black. I'm on rPi3 (special build with the new skin, came from a build about 3 weeks old), high oc'ed. I was watching live TV from a DVB-C USB stick. Interface is on 1080p and the channel playing was 1080p h264.

I will try to help out. I'm now checking if it was a one-time-thing before changing anything about my config.
Just crashed again also after about 90 minutes. I've enabled debugging now as there was nothing logged. Also SSH freezes immediately, had it open while it happened but was unable to execute any commands.
(2016-11-24, 19:43)SpokV Wrote: For some reason I get screen resolution with big icons and fonts and it looks scaled out.

Can you post a screen shot? It might be how it's supposed to look...
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2016-11-24, 23:47)Milhouse Wrote:
(2016-11-24, 19:43)SpokV Wrote: For some reason I get screen resolution with big icons and fonts and it looks scaled out.

Can you post a screen shot? It might be how it's supposed to look...

I think thats how it was made as Milhouse suggests, it is pretty big..
  •   
  • 1
  • 204
  • 205
  • 206(current)
  • 207
  • 208
  • 218
  •   
  Thread Closed
 
Thread Rating:
  • 19 Vote(s) - 4.63 Average



Logout Mark Read Team Forum Stats Members Help
LibreELEC Testbuilds for RaspberryPi (Kodi 17.0)4.6319